Opened 11 years ago

Closed 10 years ago

#3737 closed defect (fixed)

[close once the ReST patches are in] backslash in verbatim environment in tut.tex breaks doctest

Reported by: jhpalmieri Owned by: mhansen
Priority: minor Milestone: sage-3.4
Component: doctest coverage Keywords: latex, verbatim, backslash
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I would like to include lines like these in tut.tex:

\begin{verbatim}
sage: A = Matrix([[1,2,3],[3,2,1],[1,1,1]])
sage: Y = vector([0,-4,-1])
sage: A \ Y
(-2, 1, 0)
\end{verbatim}

When I include these, doctesting fails on tut.tex, giving an error about something 500 lines away, and giving an error after half a second, whereas if these lines are removed, doctesting finishes successfully in about 30 seconds.

I would guess that the problem is the backslash in the verbatim environment.

Change History (7)

comment:1 Changed 11 years ago by jhpalmieri

  • Milestone changed from sage-3.1 to sage-3.1.1

comment:2 Changed 11 years ago by mhansen

  • Owner changed from failure to mhansen
  • Status changed from new to assigned

comment:3 Changed 11 years ago by jhpalmieri

This might become moot with the Sphinx versions of the documentation -- I noticed that the new version of the tutorial at http://sage.math.washington.edu/home/mhansen/doc-sphinx/ includes an example like the one above, so if doctesting and the live version work, then once the Sphinx versions are the official documentation for the distribution, we can consider this issue solved.

comment:4 Changed 10 years ago by mhansen

  • Milestone changed from sage-3.4.1 to sage-3.4

Yep, this is fine in the Sphinx documentation.

comment:5 Changed 10 years ago by jhpalmieri

This can be closed.

comment:6 Changed 10 years ago by mabshoff

  • Summary changed from backslash in verbatim environment in tut.tex breaks doctest to [close once the ReST patches are in] backslash in verbatim environment in tut.tex breaks doctest

comment:7 Changed 10 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by the ReST merge in 3.4.alpha0.

Cheers,

Michael

Note: See TracTickets for help on using tickets.