Opened 13 years ago

Closed 8 years ago

#3723 closed defect (duplicate)

alarm() doesn't work with the factor() command

Reported by: was Owned by: cwitty
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: misc Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

teragon-2:~ was$ sage
----------------------------------------------------------------------
| SAGE Version 3.0.5, Release Date: 2008-07-11                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
Loading SAGE library. Current Mercurial branch is: review
sage: alarm(3); factor(2^997-1) 

#
# and I wait 10 seconds then hit control c
#

^C---------------------------------------------------------------------------
KeyboardInterrupt                         Traceback (most recent call last)

/Users/was/s/local/lib/python2.5/site-packages/sage/misc/misc.py in __mysig(a, b)
   1343 __alarm_time=0
   1344 def __mysig(a,b):
-> 1345     raise KeyboardInterrupt, "computation timed out because alarm was set for %s seconds"%__alarm_time
   1346 
   1347 def alarm(seconds):

KeyboardInterrupt: computation timed out because alarm was set for 3 seconds
sage: 

Change History (4)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.10 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Clearly duplicate of #13311.

comment:2 Changed 8 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:3 Changed 8 years ago by jdemeyer

  • Summary changed from alarm doesn't work with the factor command on os x (but control c does) to alarm() doesn't work with the factor() command

comment:4 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.