Opened 13 years ago

Closed 13 years ago

#3720 closed defect (duplicate)

[with patch; needs review] stupid bug in elliptic curves caused by refactoring

Reported by: was Owned by: was
Priority: major Milestone: sage-3.0.6
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: EllipticCurve([0,0,0,-193^2,0]).sha().an()
---------------------------------------------------------------------------
NameError                                 Traceback (most recent call last)

/Users/was/<ipython console> in <module>()

/Users/was/s/local/lib/python2.5/site-packages/sage/schemes/elliptic_curves/sha.py in an(self, use_database)
    157         eps = E.root_number()
    158         if eps == 1:
--> 159             L1_over_omega = E.lseries().L_ratio()
    160             if L1_over_omega == 0:
    161                 return self.an_numerical(use_database=use_database)

/Users/was/s/local/lib/python2.5/site-packages/sage/schemes/elliptic_curves/lseries_ell.py in L_ratio(self)
    695                 quo = Q(n) / Q(C)
    696                 self.__lratio = quo / self.__E.real_components()
    697                 return self.__lratio
    698             k += sqrtN
--> 699             misc.verbose("Increasing precision to %s terms."%k)

NameError: global name 'misc' is not defined

this was reported by Nils Bruin and John Cremona.

Attachments (1)

sage-3720.patch (1.4 KB) - added by was 13 years ago.

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by was

comment:1 Changed 13 years ago by was

  • Summary changed from stupid bug in elliptic curves caused by refactoring to [with patch; needs review] stupid bug in elliptic curves caused by refactoring

comment:2 Changed 13 years ago by cremona

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3651 which has already been fixed in 3.0.6.rc0, hence this one can be closed as a duplicate.

Note: See TracTickets for help on using tickets.