Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#3710 closed defect (fixed)

[with spkg, positive review] Segfault in Tachyon on some latest GCC versions

Reported by: aginiewicz Owned by: aginiewicz
Priority: minor Milestone: sage-3.1.2
Component: graphics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Segfault confirmed on 32 bit linux with GCC 4.3.1 and GCC 4.2.4, versions prior to GCC 4.2.3 including should work, status of version 4.3.0 is still not known, also status of 64 bit builds is not known. This bug is bug in gcc or bug in Tachyon that showed up after some changes to GCC somewhere in between 2008-02-01 and 2008-05-19. Status of 64 bit version is unknown because I have no access to hardware with those compile versions.

When 32 bit threaded version of Tachyon is built using "make linux-thr" and used to render attached scene, it segfaults around 59%. Non threaded version works (one built with "make linux"), threaded version works when -fno-crossjumping -fno-reorder-blocks compilation flags are added.

Still working to get smaller test case and informations on gcc 4.3.0, there will hopefully be patch/spkg soon.

This ticket is follow-up of report from "Sage 3.0.6.alpha0 released" sage-devel thread.

Attachments (1)

test.dat (796 bytes) - added by aginiewicz 14 years ago.
testcase made from simplified doctest example that was found to segfault

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by aginiewicz

testcase made from simplified doctest example that was found to segfault

comment:1 Changed 14 years ago by aginiewicz

  • Owner changed from was to aginiewicz
  • Status changed from new to assigned

comment:2 Changed 14 years ago by aginiewicz

  • Summary changed from Segfault in Tachyon on some latest GCC versions to [with spkg, needs review] Segfault in Tachyon on some latest GCC versions

There's what I did to fix it: I added gcc version check and set GCCFIX variable to flags needed to fix the issue for gcc 4.2.4 and all 4.3.* (I wasn't able to test 4.3.0), also added simple patch that adds it to src/unix/Make-arch... I put it into patches directory and spkg-install, basing how it's done with some other packages

I hope all is ok because that's my only second fix but first tracked from start and with own ticket... if anything would look better other way I'd be happy to know

comment:3 Changed 14 years ago by aginiewicz

  • Milestone changed from sage-3.1.1 to sage-3.1

btw, as this is segfault fix only I guess it could go to 3.1 so I reassign it to 3.1 as I don't know if before release tickets ready to review from next milestone are searched for... are there reasons for it to not make in for 3.1?

cheers, Andrzej.

comment:4 Changed 14 years ago by aginiewicz

Changed spkg along with information from #3882 - there are both patch (to generate new file if new version of Tachyon will come out) and patched file that is copied over.

comment:5 Changed 14 years ago by mabshoff

  • Summary changed from [with spkg, needs review] Segfault in Tachyon on some latest GCC versions to [with spkg, positive review] Segfault in Tachyon on some latest GCC versions

Hi Andrzej,

a couple remarks:

  • You deleted the hg history of the spkg - that is not good :)
  • Instead of the construct using "gcc -v ..." it is much easier to use "gcc -dumpversion". I did that in the updated spkg.
  • Please do not attach spkgs to tickets. Put them up somewhere and post a link.

I am giving the spkg with the changes I made a positive review.

Cheers,

Michael

comment:7 Changed 14 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in Sage 3.1.2.alpha0

comment:8 Changed 14 years ago by aginiewicz

will know next time, thanks for pointing all this out!

Note: See TracTickets for help on using tickets.