Opened 9 years ago

Closed 9 years ago

#3675 closed enhancement (fixed)

[with spkg, positive review] upgrade optinal valgrind.spkg to the 3.3.1 release

Reported by: rlm Owned by: mabshoff
Priority: major Milestone: sage-3.1.2
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by rlm)

[12:50pm] rlm: __Pyx_ImportType?
[12:51pm] rlm: sound familiar? i'm valgrinding, and this
seems to be many of 13,030 loss records...
[12:51pm] mabshoff: Yes.
[12:51pm] mabshoff: It is Cython dictionaries and I plan
to suppress them in the future.
...
[12:52pm] mabshoff: Can you make a ticket for it? I also
want to upgrade the optional valgrind.spkg to 3.3.1 and
also change some of the default options, i.e. no more
--follow-children
...
[1:06pm] mabshoff: Re #3675: I can do some env option
that would build python specifically for valgrind/debugging.

Change History (5)

comment:1 Changed 9 years ago by rlm

  • Description modified (diff)

comment:2 Changed 9 years ago by rlm

  • Description modified (diff)

comment:3 Changed 9 years ago by mabshoff

  • Milestone changed from sage-3.1.3 to sage-3.1.2
  • Status changed from new to assigned
  • Summary changed from upgrade to valgrind 3.3.1 to [with spkg, needs review] upgrade optinal valgrind.spkg to the 3.3.1 release

comment:4 Changed 9 years ago by rlm

  • Summary changed from [with spkg, needs review] upgrade optinal valgrind.spkg to the 3.3.1 release to [with spkg, positive review] upgrade optinal valgrind.spkg to the 3.3.1 release

Suppression good!

comment:5 Changed 9 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in the optional spkg repo in Sage 3.1.2.rc4.

Note: See TracTickets for help on using tickets.