Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#3663 closed enhancement (fixed)

add support for affine crystals

Reported by: mhansen Owned by: aschilling
Priority: major Milestone: sage-4.3
Component: combinatorics Keywords: affine crystals
Cc: sage-combinat, bump@… Merged in: sage-4.3.alpha0
Authors: Anne Schilling, Brant Jones Reviewers: Dan Bump
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by aschilling)

Implementation of affine crystals from classical crystals:

  • input is a classical crystal
  • an affine crystal can be constructed by providing the methods e0 and f0

Implementation of affine crystals from classical crystal and promotion:

  • input is a classical crystal and a promotion operators which corresponds to a Dynkin diagram automorphism
  • the methods e0 and f0 are computed using the promotion operator

Implementation of Kirillov Reshetikhin crystals:

  • Type A_n{(1)} KR crystals are implemented.
  • Type D_n{(1)}, B_n{(1)}, A_{2n-1}{(2)} KR crystals are implemented using plus-minus diagrams to construct the promotion operator which corresponds to interchanging nodes 0 and 1
  • Type C_n{(1)} KR crystals are implemented; the methods e0 and f0 are constructed using an embedding into the ambient crystal of type A_{2n+1}{(2)}
  • Type A_{2n}{(2)}, D_{n+1}{(2)} KR crystals are implemented; the methods e0 and f0 are constructed using an embedding into the ambient crystal of type C_n{(1)} via a similarity of crystals

Some documentation links improvements.

Depends on trac ticket #4326 on root systems.

This patch is authored by Brant Jones and Anne Schilling.

Attachments (5)

affine-crystal-3663-as.2.patch (43.5 KB) - added by aschilling 8 years ago.
affine-crystal-3663-as.3.patch (64.3 KB) - added by aschilling 8 years ago.
affine-crystal-3663-as.4.patch (71.7 KB) - added by aschilling 8 years ago.
affine-crystal-3663-as.5.patch (72.9 KB) - added by aschilling 8 years ago.
improved documentation links added
affine-crystal-3663-as.6.patch (72.9 KB) - added by aschilling 8 years ago.
corrected problems with documentation in crystal_morphism

Download all attachments as: .zip

Change History (18)

comment:1 Changed 8 years ago by nthiery

  • Cc sage-combinat added

Changed 8 years ago by aschilling

comment:2 Changed 8 years ago by aschilling

  • Description modified (diff)
  • Keywords affine crystals added
  • Owner changed from mhansen to aschilling

comment:3 Changed 8 years ago by aschilling

  • Description modified (diff)

Changed 8 years ago by aschilling

comment:4 Changed 8 years ago by aschilling

  • Description modified (diff)

comment:5 Changed 8 years ago by aschilling

  • Description modified (diff)

Changed 8 years ago by aschilling

comment:6 Changed 8 years ago by aschilling

  • Authors set to Anne Schilling, Brant Jones
  • Cc bump@… added
  • Reviewers set to Dan Bump

Changed 8 years ago by aschilling

improved documentation links added

comment:7 Changed 8 years ago by aschilling

  • Description modified (diff)

Changed 8 years ago by aschilling

corrected problems with documentation in crystal_morphism

comment:8 Changed 8 years ago by bump

  • Summary changed from add support for affine crystals to add support for affine crystals [with patch, positive review]

I am reviewing the version of the patch that is in the combinat queue, running under sage 4.1.1.

I ran sage -testall. The patch introduces no new failures. (Where it appears in the queue there are some failures, but the same failures still occur if you qpop the patch, rebuild and run testall again, so they are not caused by this patch.)

All new methods have docstrings and tests.

Kirillov-Reshetikhin crystals for are crystal bases on modules of quantized enveloping algebras of affine Kac-Moody Lie algebras. They had their origin in the observation that it was sometimes possible to define crystal bases on the data parametrizing the eigenstates in the Bethe Ansatz. Beyond that, they tend to be perfect crystals, from which all integrable modules of the quantum group can be constructed. There is one Kirillov-Reshetikhin crystal B(r,s) based on tableaux of rectangular shape s^r for every positive integer s and index r of the underlying classical crystal.

Constructions of all for the classical untwisted and untwisted types are summarized in Fourier, Schilling and Okado http://front.math.ucdavis.edu/0811.1604. Most but all of these are implemented in sage by this patch.

The unimplemented crystals are listed here: http://groups.google.com/group/sage-combinat-devel/msg/9571cf3991bca4db?hl=en

I generated quite a few of these and ran C.check() on them. I looked at a few of them more closely. I am confident that the patch is correct. It is also an important advance to have these affine crystals in sage.

Some useful functionality is also added in crystals.py. Namely, morphisms of crystals and some root string operations.

comment:9 Changed 7 years ago by mhansen

  • Status changed from new to needs_review

comment:10 Changed 7 years ago by mhansen

  • Status changed from needs_review to positive_review

comment:11 Changed 7 years ago by mhansen

  • Merged in set to sage-4.3.alpha0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:12 Changed 7 years ago by mvngu

  • Milestone changed from sage-combinat to sage-4.3

comment:13 Changed 7 years ago by mvngu

  • Report Upstream set to N/A
  • Summary changed from add support for affine crystals [with patch, positive review] to add support for affine crystals
Note: See TracTickets for help on using tickets.