Opened 13 years ago

Closed 11 years ago

#3465 closed defect (wontfix)

Number Field base rings for NumberFieldTower

Reported by: roed Owned by: davidloeffler
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: relative number fields
Cc: craigcitro Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by robertwb)

When creating towers of number fields, the base rings don't behave as I think they should. The following is from the coercion branch (the opposite problem exists in the normal branch).

sage: sage: L.<cuberoot2, zeta3> = CyclotomicField(3).extension(x^3 - 2)
sage: type(L)
<class 'sage.rings.number_field.number_field.NumberField_relative'>
sage: L.ngens()
1 (2 in current Sage, I think it should be 1)
sage: L.base_ring()
Cyclotomic Field of order 3 and degree 2 (I agree)
sage: L.base_field()
Cyclotomic Field of order 3 and degree 2 (I agree)
sage: L.base()
Rational Field (I think it should be Cyclotomic Field of order 3 and degree 2)
sage: K.<a, b> = NumberField( [x^2 + x + 1, x^3 + 2] )
sage: K.ngens()
1 (2 in current Sage, I think it should be 2)sage: type(K)
<class 'sage.rings.number_field.number_field.NumberField_relative'>  
sage: K.base_ring()
Number Field in b with defining polynomial x^3 + 2 (I think it should be Rational Field)
sage: K.base_field()
Number Field in b with defining polynomial x^3 + 2 (I think it should be Rational Field)
sage: K.base()
Rational Field (um... ok, I agree)

Change History (7)

comment:1 Changed 13 years ago by robertwb

  • Description modified (diff)

comment:2 Changed 13 years ago by roed

Note that this affects the doctests for sage.rings.number_field.RelativeNumberFieldHomset?.list

comment:3 Changed 13 years ago by craigcitro

  • Cc craigcitro added

comment:4 Changed 12 years ago by davidloeffler

  • Component changed from number theory to number fields
  • Owner changed from was to davidloeffler

comment:5 Changed 11 years ago by davidloeffler

  • Report Upstream set to N/A
  • Status changed from new to needs_review

This ticket has been idle for nearly two years, and moreover it's not really clear to me exactly what the reporter considers to be a bug. Is the suggestion that the objects created via the NumberFieldTower constructor should somehow behave differently from ones created via the extension() method? That sounds like a bad idea to me.

I suggest closing this as wontfix. I'm setting this to "needs review" in order to request a second opinion on my proposal not to fix this.

comment:6 Changed 11 years ago by lftabera

  • Status changed from needs_review to positive_review

I agree, the result should be homogenenous no matter how you have constructed the field.

I think that the problem is that base had no documentation.

comment:7 Changed 11 years ago by mpatel

  • Milestone changed from sage-4.5.2 to sage-duplicate/invalid/wontfix
  • Resolution set to wontfix
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.