Opened 5 months ago

Closed 4 months ago

#34496 closed defect (fixed)

disallow PARI 2.15 from the system, until giac is fixed

Reported by: slelievre Owned by:
Priority: critical Milestone: sage-9.8
Component: packages: standard Keywords: upgrade, pari
Cc: arojas, fbissey, mkoeppe Merged in:
Authors: Dima Pasechnik Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 1e2f16b (Commits, GitHub, GitLab) Commit: 1e2f16b63fc7620e15166893ee369ca3e0d937b3
Dependencies: Stopgaps:

GitHub link to the corresponding issue

Description (last modified by dimpase)

disallow PARI 2.15 from the system, until giac is fixed

--- Was: Upgrade to PARI 2.15. (dupe of #34537)

Change History (7)

comment:1 Changed 5 months ago by slelievre

A first prerelease of PARI 2.15.0 has been made available.

comment:2 Changed 4 months ago by dimpase

Cc: mkoeppe added
Description: modified (diff)
Summary: Upgrade: PARI 2.15disallow PARI 2.15 from the system, until giac is fixed
Type: enhancementdefect

duplicate of #34537

let's re-purpose it to disallow system Pari 2.15.* until we have a fix for giac.

comment:3 Changed 4 months ago by dimpase

Authors: Dima Pasechnik
Branch: u/dimpase/packages/pari/fobid215_forthetimebeing
Commit: 1e2f16b63fc7620e15166893ee369ca3e0d937b3
Status: newneeds_review

New commits:

1e2f16bforbid pari 2.15.* and higher from the system: #34496

comment:4 Changed 4 months ago by vdelecroix

Could we close this ticket and proceed with #34537?

comment:5 Changed 4 months ago by dimpase

I'd say #34496 should depend on this one. In the branch of #34496 you can just increase the value of SAGE_PARI_MAXVER. (the latter might be useful later on, with emergence of yet another incompatible pari version)

comment:6 Changed 4 months ago by mkoeppe

Priority: majorcritical
Reviewers: Matthias Koeppe
Status: needs_reviewpositive_review

This works well.

comment:7 Changed 4 months ago by vbraun

Branch: u/dimpase/packages/pari/fobid215_forthetimebeing1e2f16b63fc7620e15166893ee369ca3e0d937b3
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.