Opened 6 months ago

Closed 5 weeks ago

#33671 closed enhancement (fixed)

Add devcontainer.json for development with VS Code in a Docker container

Reported by: Matthias Köppe Owned by:
Priority: major Milestone: sage-9.7
Component: user interface Keywords:
Cc: Tobias Diez, Dima Pasechnik, William Stein, Marc Culler, Julian Rüth, Kwankyu Lee Merged in:
Authors: Tobias Diez, Matthias Koeppe, Kwankyu Lee Reviewers: Kwankyu Lee, Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 4affef2 (Commits, GitHub, GitLab) Commit: 4affef24a703a5c9f2cd7dfc008637b57e04dade
Dependencies: #33873, #34352 Stopgaps:

Status badges

Description (last modified by Matthias Köppe)

https://code.visualstudio.com/docs/remote/containers

We add two new sections in the developer's guide: https://47f8b984ef964a5aa34147393fbdc32e0dde88ad--sagemath-tobias.netlify.app/developer/portability_testing.html#using-our-pre-built-docker-images-published-on-ghcr-io

We also set up devcontainer configurations for the CoCalc and computop/sage Docker images, as well as downstream distribution packaging of Sage.

Tested devcontainer.json of

  • portability-ubuntu-jammy-standard: builds well; runs well
  • develop-docker-computop: builds well; runs well
  • downstream-docker-cocalc: builds well; runs well (except machines with the issue #32434)
  • downstream-docker-computop: builds well; runs well
  • downstream-archlinux-latest: builds well; runs well
  • downstream-conda-forge-latest: builds well; runs well

Follow-ups:

Attachments (1)

codespaces.jpg (44.0 KB) - added by Tobias Diez 3 months ago.

Download all attachments as: .zip

Change History (306)

comment:1 Changed 6 months ago by Matthias Köppe

Description: modified (diff)

comment:2 Changed 6 months ago by Matthias Köppe

Description: modified (diff)

comment:3 Changed 6 months ago by Matthias Köppe

Milestone: sage-9.6sage-9.7

comment:4 Changed 5 months ago by Matthias Köppe

Dependencies: #29536

comment:5 Changed 5 months ago by Tobias Diez

Authors: Tobias Diez
Branch: public/build/devcontainer
Commit: 85a71000ebc615391199152e1627335519a660ec
Dependencies: #29536
Status: newneeds_review

A basic devcontainer definition is now added for ubuntu systems.


New commits:

85a7100Add devcontainer for ubuntu

comment:6 Changed 5 months ago by git

Commit: 85a71000ebc615391199152e1627335519a660ec11110ae08511896111a907537e3acf755c0132ee

Branch pushed to git repo; I updated commit sha1. New commits:

11110aeAdd bootstrap

comment:7 Changed 5 months ago by git

Commit: 11110ae08511896111a907537e3acf755c0132eec5295e3defd3cbb4c40d2ec110d55fe74edccb7d

Branch pushed to git repo; I updated commit sha1. New commits:

c5295e3enable-build-as-root

comment:8 Changed 5 months ago by Tobias Diez

Description: modified (diff)

comment:9 Changed 5 months ago by Matthias Köppe

Thanks! That's a beginning. Why do you not use the full build (-with-targets)?

comment:10 Changed 5 months ago by git

Commit: c5295e3defd3cbb4c40d2ec110d55fe74edccb7d872c0c82aca9fd1619aa9ccab819f3f764fa85f9

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

58e112abootstrap-conda: Use script package _develop instead of hardcoded list of dev tools; remove unused RECOMMENDED
21e06c5bootstrap-conda: Write an additional comment
4290b11Add pytest-xdist package
a365828build/pkgs/pytest/dependencies: Add missing dep
a2e396bbuild/pkgs/pytest_xdist/dependencies: Add missing dep
2ec0061Merge #33825
5857902build/pkgs/_develop/dependencies: Add pytest, pytest_xdist
2368adcbootstrap-conda: Write an additional comment (fixup)
0df31a9bootstrap-conda: Rewrite using fewer redirects
872c0c8.devcontainer: Generalize to other distros

comment:11 Changed 5 months ago by Matthias Köppe

Authors: Tobias DiezTobias Diez, Matthias Koeppe
Dependencies: #33825

comment:12 Changed 5 months ago by Matthias Köppe

Dependencies: #33825#33851

comment:13 Changed 5 months ago by git

Commit: 872c0c82aca9fd1619aa9ccab819f3f764fa85f996bb5ad7bb30d4696b78ed2216789d5b3a72d13e

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

8d7f7abMerge #33851
96bb5ad.devcontainer: Generalize to other distros

comment:14 in reply to:  9 Changed 5 months ago by Tobias Diez

Replying to mkoeppe:

Thanks! That's a beginning. Why do you not use the full build (-with-targets)?

I didn't saw the point in that. In contrast to gitpod you don't know which version of sage the developer will use in the devcontainer, especially since devcontainer are cached by vscode until they are manually rebuild.

comment:15 Changed 5 months ago by Matthias Köppe

You also don't know that on gitpod, as I've explained in https://trac.sagemath.org/ticket/33113#comment:18

comment:16 Changed 5 months ago by Matthias Köppe

Anyway, I've made it configurable

comment:17 Changed 5 months ago by Matthias Köppe

There are some problems when running this from a locally configured source tree, I'll try to find a solution for this.

comment:18 Changed 5 months ago by git

Commit: 96bb5ad7bb30d4696b78ed2216789d5b3a72d13e02f246016578f8aec429cb5f7a7d4d4c4b03810c

Branch pushed to git repo; I updated commit sha1. New commits:

765dff7Merge #33740
ccbc21abootstrap, bootstrap-conda, src/doc/bootstrap: Use build/bin/sage-package directly
4560895src/doc/Makefile: Remove explicit use of SAGE_ROOT and the top-level sage script
7759f3cGenerate en/reference/repl/options.txt at build time, not bootstrap time
58ab878bootstrap-conda: Fix typo, generate->generating to match messages from bootstrap
02f2460Merge #33851

comment:19 in reply to:  17 Changed 5 months ago by Matthias Köppe

Replying to mkoeppe:

There are some problems when running this from a locally configured source tree, I'll try to find a solution for this.

Fixed in #33852, merged via #33851

comment:20 Changed 5 months ago by git

Commit: 02f246016578f8aec429cb5f7a7d4d4c4b03810cd08ff6f82368862c447ae89109fcb42a7ccf2bb9

Branch pushed to git repo; I updated commit sha1. New commits:

d08ff6f.devcontainer/devcontainer.json: Use configure --prefix

comment:21 Changed 5 months ago by git

Commit: d08ff6f82368862c447ae89109fcb42a7ccf2bb9a36721ea45da7237680be017af8e7cabcdde58b5

Branch pushed to git repo; I updated commit sha1. New commits:

bea9a69.devcontainer/devcontainer.json: Use make build V=0
a36721e.devcontainer/devcontainer.json: Use with-targets

comment:22 Changed 5 months ago by git

Commit: a36721ea45da7237680be017af8e7cabcdde58b5eb52e2530f41524db73bcc8ad1a7d9cfddffd695

Branch pushed to git repo; I updated commit sha1. New commits:

eb52e25.devcontainer/devcontainer.json: Install python extension

comment:23 Changed 5 months ago by Tobias Diez

Status: needs_reviewneeds_work

I doesn't make sense to add those two packages to the _develop package. They are not needed to create a devcontainer, but have to be installed into the devcontainer to work with vscode. Thus they should only be listed in the devcontainer/Dockerfile.

Moreover, git should be installed (and configured) through the "feature" flag: https://code.visualstudio.com/docs/remote/containers#_dev-container-features-preview

comment:24 in reply to:  23 ; Changed 5 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

I doesn't make sense to add those two packages to the _develop package. They are not needed to create a devcontainer, but have to be installed into the devcontainer to work with vscode.

Hm? That's exactly what is done.

comment:25 Changed 5 months ago by Matthias Köppe

Yes, git is still missing.

comment:26 Changed 5 months ago by git

Commit: eb52e2530f41524db73bcc8ad1a7d9cfddffd695a6777bc4c92e5a9256adb90934e5ba8985ba14a9

Branch pushed to git repo; I updated commit sha1. New commits:

a6777bcbuild/pkgs/_develop/distros/debian.txt: Add git here for now

comment:27 Changed 5 months ago by Matthias Köppe

Status: needs_workneeds_review

comment:28 Changed 5 months ago by Matthias Köppe

I haven't tested other distros yet. Need to add corresponding .txt files.

comment:29 in reply to:  24 ; Changed 5 months ago by Tobias Diez

Replying to mkoeppe:

Replying to gh-tobiasdiez:

I doesn't make sense to add those two packages to the _develop package. They are not needed to create a devcontainer, but have to be installed into the devcontainer to work with vscode.

Hm? That's exactly what is done.

They are now added to this virtual develop package, which is meant for "useful stuff for developers". But these two packages are needed by vscode and thus should *only* be mentioned in the corresponding dockerfile, and not in the virtual develop package.

comment:30 in reply to:  29 ; Changed 5 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

They are now added to this virtual develop package, which is meant for "useful stuff for developers". But these two packages are needed by vscode and thus should *only* be mentioned in the corresponding dockerfile, and not in the virtual develop package.

I don't want to go back to maintaining separate Dockerfiles for the various distributions.

I can of course create a separate script package "_devcontainer" for this purpose. Not sure if it really has to be so fine-grained.

comment:31 Changed 5 months ago by git

Commit: a6777bc4c92e5a9256adb90934e5ba8985ba14a95daaa9a4f1211615390cf346d85d79b86aa81aaf

Branch pushed to git repo; I updated commit sha1. New commits:

12ea8cebuild/pkgs/_develop/distros: Add packages providing gpgconf
238b7bbbuild/pkgs/_develop/distros: Add packages providing ssh
5daaa9aMerge #33851

comment:32 Changed 5 months ago by git

Commit: 5daaa9a4f1211615390cf346d85d79b86aa81aaf4831977d52d1d9738195e63c7e9132e108633ea5

Branch pushed to git repo; I updated commit sha1. New commits:

6699fb3.devcontainer/devcontainer.json: Also install packages from build/pkgs/_develop/dependencies
4831977.devcontainer: Fix use of sage-print-system-package-command

comment:33 Changed 5 months ago by git

Commit: 4831977d52d1d9738195e63c7e9132e108633ea544493f0420ec43c8c1ec30d5eae2d2c74faf2071

Branch pushed to git repo; I updated commit sha1. New commits:

44493f0.vscode/extensions.json: Recommend extension 'Remote - Containers'

comment:34 in reply to:  30 Changed 5 months ago by Tobias Diez

Status: needs_reviewneeds_work

Replying to mkoeppe:

Replying to gh-tobiasdiez:

They are now added to this virtual develop package, which is meant for "useful stuff for developers". But these two packages are needed by vscode and thus should *only* be mentioned in the corresponding dockerfile, and not in the virtual develop package.

I don't want to go back to maintaining separate Dockerfiles for the various distributions.

I can of course create a separate script package "_devcontainer" for this purpose. Not sure if it really has to be so fine-grained.

There is no need for a new package, just put it in a switch/if statement for the different systems in the devcontainer dockerfile.

comment:35 Changed 5 months ago by Matthias Köppe

Status: needs_workneeds_review

I have built this reusable infrastructure so that it can be reused. It's OK if you don't like it, but that does not make it "needs_work".

comment:36 Changed 5 months ago by Tobias Diez

Reviewers: Tobias Diez (-1), ...

You created a reusable infrastructure for something that is needed in one place and thus doesn't have to be reused. For this abstraction you are paying the usual costs that come with an additional level of indirection in terms of simplicity, discoverability, maintainability etc. I think its fair to criticize this as part of a review. So -1 from my side for the current solution to install gpgconf into the devcontainer.

comment:37 Changed 5 months ago by Matthias Köppe

There is always a trade off. I made the abstraction in full awareness of the indirection costs, and it has served the project well. Keeping the system package data in a central place goes a long way for maintainability and discoverability.

comment:38 in reply to:  36 ; Changed 5 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

You created a reusable infrastructure for something that is needed in one place and thus doesn't have to be reused.

The package scripts are used for informing the user, for provisioning environments, and for generating documentation. Multiple uses, guaranteeing that things don't fall out of sync.

comment:39 in reply to:  38 ; Changed 5 months ago by Tobias Diez

Replying to mkoeppe:

Replying to gh-tobiasdiez:

You created a reusable infrastructure for something that is needed in one place and thus doesn't have to be reused.

The package scripts are used for informing the user, for provisioning environments, and for generating documentation. Multiple uses, guaranteeing that things don't fall out of sync.

I don't mean the general package infrastructure, but the _develop package and in particular that gpgconf is installed there. Your advantages don't apply there: its not used to inform the user, its only used for the devcontainer, it is not displayed in the documentation, has only a single use and thus cannot fall out of sync. If in the future there might be the need to reuse it somewhere else then given the usecase one could decide about the right form of abstraction (e.g. bundling with other "devtools" or as an ordinary optional package or ...).

comment:40 in reply to:  39 Changed 5 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

it is not displayed in the documentation

Yes it is, it's automatic.

comment:41 in reply to:  39 Changed 5 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

If in the future [...] decide about the right form of abstraction (e.g. bundling with other "devtools" or as an ordinary optional package or ...).

It's not like these packages are mysterious VS Code-specific requirements. gpg is a typical dev tool that people use for signing commits, and ssh is also what trac users need to push.

Actually, from my use of repology for finding the gpgconf it seems that Debian is the only distro family that has it as a separate package. So one could consider to also package the full gpg in the case of Debian. That's a possible refinement.

comment:42 Changed 5 months ago by git

Commit: 44493f0420ec43c8c1ec30d5eae2d2c74faf207147f8b984ef964a5aa34147393fbdc32e0dde88ad

Branch pushed to git repo; I updated commit sha1. New commits:

9e674ca.devcontainer/Dockerfile: Add argument DOCKER_TAG
d59144csrc/doc/en/developer/portability_testing.rst: Add section 'Using our pre-built Docker images published on ghcr.io'
47f8b98src/doc/en/developer/portability_testing.rst: Add section 'Developing with our pre-built Docker images as devcontainers in VS Code'

comment:43 Changed 5 months ago by Matthias Köppe

Given that we ask users to edit the devcontainer.json file, perhaps we should only check in a template to avoid merge conflicts?

comment:44 Changed 5 months ago by Matthias Köppe

Description: modified (diff)

comment:45 Changed 5 months ago by Matthias Köppe

Cc: William Stein added

Perhaps it would also make sense to include another sample configuration for using sagemathinc/cocalc as a devcontainer?

comment:46 Changed 5 months ago by git

Commit: 47f8b984ef964a5aa34147393fbdc32e0dde88ada7a8d664f3a3572db43f615f6f88e3b162486101

Branch pushed to git repo; I updated commit sha1. New commits:

fc19e7adevcontainer-ubuntu-jammy-standard.json: Renamed from devcontainer.json
f3cbc53.devcontainer: Factor out script post_create.sh
a7a8d66.devcontainer/devcontainer-cocalc.json: New

comment:47 Changed 5 months ago by git

Commit: a7a8d664f3a3572db43f615f6f88e3b1624861010d573da876dde5e88c97840444f93d9b94ad78d8

Branch pushed to git repo; I updated commit sha1. New commits:

0d573dasrc/doc/en/developer/portability_testing.rst: Copy or symlink the devcontainer.json sample file

comment:48 Changed 5 months ago by git

Commit: 0d573da876dde5e88c97840444f93d9b94ad78d8be191a155e775e2bd4e036e3531153f8ed010055

Branch pushed to git repo; I updated commit sha1. New commits:

aea8531build/pkgs/_develop/dependencies: Add _bootstrap
be191a1.devcontainer/devcontainer: Use MAKE='make -j12'

comment:49 Changed 5 months ago by Matthias Köppe

This works, but getting /usr/local/sage/local/lib/libgmp.a: error adding symbols: archive has no index; run ranlib to add one on cocalc

comment:50 Changed 5 months ago by git

Commit: be191a155e775e2bd4e036e3531153f8ed010055c23008b1985fc4f0d58c30799ae9522d9b2bb224

Branch pushed to git repo; I updated commit sha1. New commits:

b863c5c.devcontainer/post_create.sh: Handle option --sudo
c23008b.devcontainer/devcontainer-computop-sage.json: New

comment:51 Changed 5 months ago by Matthias Köppe

Dependencies: #33851#33851, #33786

computop/sage has SAGE_ROOT set in the global environment. So this needs #33786.

comment:52 Changed 5 months ago by git

Commit: c23008b1985fc4f0d58c30799ae9522d9b2bb2249cd17f9fa93c9e7c83cf862d04742f778a39b89d

Branch pushed to git repo; I updated commit sha1. New commits:

60bcbecREADME.md, src/doc/en/installation/source.rst: Update multi-user install
2116f9fREADME.md: Update final step 'symlink sage', add jupyter kernel step
5c68335Merge #33787
252372dSAGE_ROOT/sage: Unconditionally determine SAGE_ROOT from $0; no longer invite to edit this file
01caa38SAGE_ROOT/sage: Actually unconditionally determine SAGE_ROOT from $0
b9c9764Merge #33786
9cd17f9.devcontainer/devcontainer-computop-sage.json: Stop it from injecting old SAGE_ROOT into every shell

comment:53 Changed 5 months ago by git

Commit: 9cd17f9fa93c9e7c83cf862d04742f778a39b89dc25bd9d7fdeb37efbd237ff3426cc0e8fe00cb8f

Branch pushed to git repo; I updated commit sha1. New commits:

530eaacsrc/bin/sage-env: Key SAGE_ENV_SOURCED also to SAGE_SRC because the PATH setting depends on it
c25bd9dbuild/make/Makefile.in: Put SAGE_SRC/bin in front of SAGE_VENV/bin so that sage-env-config is sourced from SAGE_SRC

comment:54 Changed 5 months ago by git

Commit: c25bd9d7fdeb37efbd237ff3426cc0e8fe00cb8f9195e152e8a72582c57946e04f90a5f183c6494b

Branch pushed to git repo; I updated commit sha1. New commits:

9195e15.devcontainer/devcontainer-computop-sage.json: More workarounds

comment:55 Changed 5 months ago by Matthias Köppe

Description: modified (diff)

comment:56 Changed 5 months ago by Matthias Köppe

Cc: Nathan Dunfield Marc Culler added

comment:57 Changed 5 months ago by git

Commit: 9195e152e8a72582c57946e04f90a5f183c6494bc173378da3232986186d4a37694b4d0a4a271501

Branch pushed to git repo; I updated commit sha1. New commits:

2edf926.devcontainer/post_create.sh: First update package lists, also install _prereq
c173378.devcontainer/devcontainer-sagemath-sagemath.json: New

comment:58 Changed 5 months ago by Matthias Köppe

Cc: Julian Rüth added
Description: modified (diff)
Last edited 5 months ago by Matthias Köppe (previous) (diff)

comment:59 Changed 5 months ago by git

Commit: c173378da3232986186d4a37694b4d0a4a2715013c7f6bd2403a5786a3bf9973f667f5fe6cf33ed0

Branch pushed to git repo; I updated commit sha1. New commits:

b1dd79d.devcontainer/devcontainer-archlinux-latest-downstream.json: New
3c7f6bdbuild/pkgs/_develop/dependencies: Add python3, tox

comment:60 Changed 5 months ago by git

Commit: 3c7f6bd2403a5786a3bf9973f667f5fe6cf33ed016fd4af4803a2032b9ce1e89cdc3caff1c821abd

Branch pushed to git repo; I updated commit sha1. New commits:

16fd4af.devcontainer/devcontainer-archlinux-latest-downstream.json: Install pip, notebook

comment:61 Changed 5 months ago by git

Commit: 16fd4af4803a2032b9ce1e89cdc3caff1c821abd3c4929e9ab4c0bf265535d537a236a7ed1bd1c23

Branch pushed to git repo; I updated commit sha1. New commits:

3c4929e.devcontainer/devcontainer-conda-forge-latest-downstream.json: New

comment:62 Changed 5 months ago by Matthias Köppe

Dependencies: #33851, #33786#33851, #33786, #33870
Status: needs_reviewneeds_work

comment:63 Changed 5 months ago by Matthias Köppe

Work issues: merge #33870, use _sagemath script package

comment:64 Changed 5 months ago by Matthias Köppe

Dependencies: #33851, #33786, #33870#33851, #33786, #33870, #33873

comment:65 Changed 5 months ago by git

Commit: 3c4929e9ab4c0bf265535d537a236a7ed1bd1c23df2216b249bcab09832dd1ca843b52a3c8109815

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

a2557d4build/pkgs/_sagemath/distros/debian.txt: Move debian info here from src/doc/en/installation/linux.rst
3dd0d18build/pkgs/_sagemath/type: New
f45f500Merge #33870
ab5a4f1build/bin/sage-get-system-packages: If system=auto, use sage-guess-package-system
798f4d3build/bin/sage-print-system-package-command: If system=auto, use sage-guess-package-system
ef249ccbuild/bin/sage-print-system-package-command: New option --spkg
d75da7etox.ini: Simplify using new options of sage-print-system-package-command
780e747Merge #33873
d27f5e2.devcontainer/post_create.sh: Simplify using new options of sage-print-system-package-command
df2216b.devcontainer/devcontainer-archlinux-latest-downstream.json: Use spkg _sagemath

comment:66 Changed 5 months ago by Matthias Köppe

Status: needs_workneeds_review
Work issues: merge #33870, use _sagemath script package

comment:67 Changed 4 months ago by Tobias Diez

Status: needs_reviewneeds_work

Codespaces are not working as the devcontainer file is not recognized. According to https://github.blog/2022-04-20-codespaces-multi-repository-monorepo-scenarios/:

Codespaces now supports multiple devcontainer.json files inside of your .devcontainer directory, as long as they follow the pattern of .devcontainer/${DIR}/devcontainer.json

comment:68 Changed 4 months ago by Matthias Köppe

Interesting

comment:69 Changed 4 months ago by Matthias Köppe

I was looking for this feature in VS Code...

comment:70 Changed 4 months ago by git

Commit: df2216b249bcab09832dd1ca843b52a3c8109815bcf4302ebd715da6fe7d1798ff7eff0d2f6170ee

Branch pushed to git repo; I updated commit sha1. New commits:

bcf4302.devcontainer: Move devcontainer.json files to separate directories for Codespaces

comment:71 Changed 4 months ago by Matthias Köppe

like this?

comment:72 Changed 4 months ago by git

Commit: bcf4302ebd715da6fe7d1798ff7eff0d2f6170eee0ae39f4af5cf5ca6386ef8619d3bd5182f1167d

Branch pushed to git repo; I updated commit sha1. New commits:

e0ae39fsrc/doc/en/developer/portability_testing.rst: Update

comment:73 Changed 4 months ago by Matthias Köppe

Do you have access to Codespaces? This appears to be a paid service.

comment:74 Changed 4 months ago by git

Commit: e0ae39f4af5cf5ca6386ef8619d3bd5182f1167d8befa1c592fd662581ac69c4c714143badca1513

Branch pushed to git repo; I updated commit sha1. New commits:

8befa1csrc/doc/en/developer/portability_testing.rst: Add link to GitHub devcontainer doc

comment:75 Changed 4 months ago by Matthias Köppe

Status: needs_workneeds_review

comment:76 Changed 4 months ago by git

Commit: 8befa1c592fd662581ac69c4c714143badca151316d925d73b0ffc5ad45c2291b32562f687578324

Branch pushed to git repo; I updated commit sha1. New commits:

16d925dsrc/doc/en/developer/portability_testing.rst: Fix rst

comment:77 Changed 4 months ago by git

Commit: 16d925d73b0ffc5ad45c2291b32562f6875783241712a3e25702ae46c32b2e40c3fa0195242e2259

Branch pushed to git repo; I updated commit sha1. New commits:

1712a3e.devcontainer/*/devcontainer.json: Use 'make configure' instead of './bootstrap' to match instructions in README

comment:78 Changed 4 months ago by Tobias Diez

Yes, I have access to codespaces as I've been in the beta program. I think you can also enable them on the sagemath org (with a billing limit of say 1 dollar).

It's partly working. Only archlinux-latest-downstream, conda-forge-latest-downstream and ubuntu-jammy-standard are shown in the dropdown box. Any idea why? Moreover, there is a "Default codespace configuration" which is the default github image. If I read the docs about multiple devcontainer files correctly, I think one needs a ".devcontainer/devcontainer.json" file that serves as the default config (I guess that would be ubuntu-jammy-standard in our case). I would also suggest to prefix the other devcontainer names by their function (portability-testing?) since they are not really meant as a platform for development, right?

comment:79 in reply to:  78 ; Changed 4 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

I think one needs a ".devcontainer/devcontainer.json" file that serves as the default config

I have not created this file in the repository because in VS Code users have to edit this file to make changes - and then the worktree would be dirty.

comment:80 in reply to:  78 Changed 4 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

I would also suggest to prefix the other devcontainer names by their function (portability-testing?) since they are not really meant as a platform for development, right?

Good idea, will do

comment:81 Changed 4 months ago by git

Commit: 1712a3e25702ae46c32b2e40c3fa0195242e225973110b633c46e0b555bf003405f74f3c479f96b0

Branch pushed to git repo; I updated commit sha1. New commits:

73110b6.devcontainer: Use prefixes 'downstream-', 'portability-'

comment:82 in reply to:  79 ; Changed 4 months ago by Tobias Diez

Replying to mkoeppe:

Replying to gh-tobiasdiez:

I think one needs a ".devcontainer/devcontainer.json" file that serves as the default config

I have not created this file in the repository because in VS Code users have to edit this file to make changes - and then the worktree would be dirty.

Since the idea of the dev container is to provide a container for the development, I think this should be the main and default config. If someone temporarily wants to investigate some issues using one of the other images, then its okay to have an uncommited change dangling around. I would also suggest you open an issue at the vscode repo to support multiple devcontainers.

comment:83 in reply to:  82 ; Changed 4 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

Since the idea of the dev container is to provide a container for the development, I think this should be the main and default config.

But I would think most people who want to use VS Code will want to do dev locally, not in the container. It's pretty annoying to be asked to reopen it in the devcontainer.

comment:84 in reply to:  82 Changed 4 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

If someone temporarily wants to investigate some issues using one of the other images, then its okay to have an uncommited change dangling around.

No, I wouldn't like that

comment:85 in reply to:  83 ; Changed 4 months ago by Tobias Diez

Replying to mkoeppe:

Replying to gh-tobiasdiez:

Since the idea of the dev container is to provide a container for the development, I think this should be the main and default config.

But I would think most people who want to use VS Code will want to do dev locally, not in the container. It's pretty annoying to be asked to reopen it in the devcontainer.

If you have the remote container extension installed, then its fair to assume you may also want to use it.

By the way, please remove the extension from the recommended list. I think its to situational to recommend to everyone.

comment:86 Changed 4 months ago by git

Commit: 73110b633c46e0b555bf003405f74f3c479f96b023d62231a563029b60336ebe51ec97bfe152fc1b

Branch pushed to git repo; I updated commit sha1. New commits:

23d6223Revert ".vscode/extensions.json: Recommend extension 'Remote - Containers'"

comment:87 in reply to:  85 ; Changed 4 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

If you have the remote container extension installed, then its fair to assume you may also want to use it.

Hardly. What extension is installed is not specific to a project.

comment:88 in reply to:  87 ; Changed 4 months ago by Tobias Diez

Replying to mkoeppe:

Replying to gh-tobiasdiez:

If you have the remote container extension installed, then its fair to assume you may also want to use it.

Hardly. What extension is installed is not specific to a project.

Yes it is, you can disable/enable extensions for a specific workspace. https://code.visualstudio.com/docs/editor/extension-marketplace#_disable-an-extension

comment:89 in reply to:  88 Changed 4 months ago by Matthias Köppe

Replying to gh-tobiasdiez:

you can disable/enable extensions for a specific workspace. https://code.visualstudio.com/docs/editor/extension-marketplace#_disable-an-extension

Thanks, that's good to know

comment:90 Changed 3 months ago by git

Commit: 23d62231a563029b60336ebe51ec97bfe152fc1ba8a902d403c05a37f1e1d9ac6ff626809782cb5c

Branch pushed to git repo; I updated commit sha1. This was a forced push. Last 10 new commits:

93fabf8.devcontainer/devcontainer-archlinux-latest-downstream.json: Install pip, notebook
928cd43.devcontainer/devcontainer-conda-forge-latest-downstream.json: New
b11ae77.devcontainer/post_create.sh: Simplify using new options of sage-print-system-package-command
33dc4eb.devcontainer/devcontainer-archlinux-latest-downstream.json: Use spkg _sagemath
c9e52c5.devcontainer: Move devcontainer.json files to separate directories for Codespaces
863e24dsrc/doc/en/developer/portability_testing.rst: Update
0fae3d8src/doc/en/developer/portability_testing.rst: Add link to GitHub devcontainer doc
98204aesrc/doc/en/developer/portability_testing.rst: Fix rst
07e8495.devcontainer/*/devcontainer.json: Use 'make configure' instead of './bootstrap' to match instructions in README
a8a902d.devcontainer: Use prefixes 'downstream-', 'portability-'

comment:91 Changed 3 months ago by Matthias Köppe

Dependencies: #33851, #33786, #33870, #33873#33786, #33870, #33873
Reviewers: Tobias Diez (-1), ...

comment:92 Changed 3 months ago by Matthias Köppe

Description: modified (diff)

comment:93 Changed 3 months ago by Matthias Köppe

Dependencies: #33786, #33870, #33873
Status: needs_reviewneeds_work

comment:94 Changed 3 months ago by git

Commit: a8a902d403c05a37f1e1d9ac6ff626809782cb5c17922881e1f198ab7ad145d8f0608ecfdb874d60

Branch pushed to git repo; I updated commit sha1. This was a forced push. Last 10 new commits:

5380a51.devcontainer/devcontainer-archlinux-latest-downstream.json: Install pip, notebook
ece0fde.devcontainer/devcontainer-conda-forge-latest-downstream.json: New
9772b1c.devcontainer/post_create.sh: Simplify using new options of sage-print-system-package-command
b44280c.devcontainer/devcontainer-archlinux-latest-downstream.json: Use spkg _sagemath
64ad9d0.devcontainer: Move devcontainer.json files to separate directories for Codespaces
a813a75src/doc/en/developer/portability_testing.rst: Update
60e58d3src/doc/en/developer/portability_testing.rst: Add link to GitHub devcontainer doc
6137928src/doc/en/developer/portability_testing.rst: Fix rst
0b9fc68.devcontainer/*/devcontainer.json: Use 'make configure' instead of './bootstrap' to match instructions in README
1792288.devcontainer: Use prefixes 'downstream-', 'portability-'

comment:95 Changed 3 months ago by git

Commit: 17922881e1f198ab7ad145d8f0608ecfdb874d60b828e559e1851f7ab4c1cdcc851701561bd01bb7

Branch pushed to git repo; I updated commit sha1. New commits:

b828e55Remove use of _develop package

comment:96 Changed 3 months ago by git

Commit: b828e559e1851f7ab4c1cdcc851701561bd01bb7425f51f764959ab9fb1d05c8e003e2f7f5ed13d4

Branch pushed to git repo; I updated commit sha1. New commits:

ab5a4f1build/bin/sage-get-system-packages: If system=auto, use sage-guess-package-system
798f4d3build/bin/sage-print-system-package-command: If system=auto, use sage-guess-package-system
ef249ccbuild/bin/sage-print-system-package-command: New option --spkg
d75da7etox.ini: Simplify using new options of sage-print-system-package-command
425f51fMerge #33873

comment:97 Changed 3 months ago by Matthias Köppe

Dependencies: #33873

comment:98 Changed 3 months ago by git

Commit: 425f51f764959ab9fb1d05c8e003e2f7f5ed13d4e12ca6cf399c6898873de5ebbc363a7e7e442d0e

Branch pushed to git repo; I updated commit sha1. New commits:

e12ca6c.devcontainer: Install git

comment:99 Changed 3 months ago by git

Commit: e12ca6cf399c6898873de5ebbc363a7e7e442d0e6a6ce788c8de36347a10ad431387fc29b3895b38

Branch pushed to git repo; I updated commit sha1. New commits:

6a6ce78src/doc/en/developer/portability_testing.rst: Fix markup

comment:100 Changed 3 months ago by Matthias Köppe

Status: needs_workneeds_review

Here's a version with fewer dependencies.

Changed 3 months ago by Tobias Diez

Attachment: codespaces.jpg added

comment:101 Changed 3 months ago by Tobias Diez

It's still not working on github's workspaces (see attached screenshot). The default config (which is used if you use the direct link without manual config) just starts github's default (= almost empty) workspace, and thus is not useful for sage development. Moreover, only a few of the added dev containers are actually appearing in the dropdown menu (maybe some parsing issues?).

Codespaces are now included in the educational program of github, so you might be able to test it yourself.

Moreover, some of the container names are a bit confusing (e.g. sagemath-sagemath). Could this be improved? In either case, I would welcome if each one is shortly explained in the docs.

comment:102 Changed 3 months ago by Matthias Köppe

I still don't have access to codespaces. So I'd say let's defer codespaces to a follow up (unless you have time to work on it for this ticket).

Last edited 3 months ago by Matthias Köppe (previous) (diff)

comment:103 Changed 2 months ago by git

Commit: 6a6ce788c8de36347a10ad431387fc29b3895b38029c9a08ca06efd08ff10fc3952453b4ad3c2bbb

Branch pushed to git repo; I updated commit sha1. New commits:

029c9a0.devcontainer/post_create.sh: Install python3 so that python3-venv is available on Debian

comment:104 Changed 2 months ago by git

Commit: 029c9a08ca06efd08ff10fc3952453b4ad3c2bbb23b4cc506141c3214ef596f6ccb1d8bd0e496cba

Branch pushed to git repo; I updated commit sha1. New commits:

23b4cc5Merge tag '9.7.beta7' into t/33671/public/build/devcontainer

comment:105 Changed 2 months ago by Matthias Köppe

Cc: Kwankyu Lee added

comment:106 Changed 8 weeks ago by Matthias Köppe

Description: modified (diff)

comment:107 Changed 8 weeks ago by git

Commit: 23b4cc506141c3214ef596f6ccb1d8bd0e496cbad798acc3e7210d2f25f82c4981214afc11169f3a

Branch pushed to git repo; I updated commit sha1. New commits:

d798accMerge branch 'develop' into t/33671/public/build/devcontainer

comment:108 Changed 7 weeks ago by Kwankyu Lee

First some questions from a person just initiated to these devcontainer things:

  1. What does the name of a directory in .devcontainer indicate? Does it indicate the platform where the devcontainer.json file is used? So for example, downstream-archlinux-latest/devcontainer.json is used if you use VSCode on archlinux? What does downstream and latest then mean?
  1. What is the relationship between the container image specified in the Dockerfile and the container image in a devcontainer.json?
Last edited 7 weeks ago by Kwankyu Lee (previous) (diff)

comment:109 in reply to:  108 ; Changed 7 weeks ago by Kwankyu Lee

Replying to klee:

  1. What is the relationship between the container image specified in the Dockerfile and the container image in a devcontainer.json?

Perhaps the Dockerfile is used when there is no image specified in devcontainer.json?

comment:110 Changed 7 weeks ago by git

Commit: d798acc3e7210d2f25f82c4981214afc11169f3a132083f3450318a09d23352f9fce9d7c75333612

Branch pushed to git repo; I updated commit sha1. New commits:

132083fsrc/doc/en/developer/portability_testing.rst: Explain the downstream-... devcontainers

comment:111 in reply to:  108 Changed 7 weeks ago by Kwankyu Lee

Replying to klee:

  1. What does the name of a directory in .devcontainer indicate? Does it indicate the platform where the devcontainer.json file is used? So for example, downstream-archlinux-latest/devcontainer.json is used if you use VSCode on archlinux? What does downstream and latest then mean?

No, according to the last commit... The directory name indicates which container image is used.

comment:112 Changed 7 weeks ago by git

Commit: 132083f3450318a09d23352f9fce9d7c75333612d0790b4b33b427493dd99c1b29cc4cb27e56f6f7

Branch pushed to git repo; I updated commit sha1. New commits:

d0790b4src/doc/en/developer/portability_testing.rst: Explain more about devcontainers

comment:113 in reply to:  109 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

Replying to klee:

  1. What is the relationship between the container image specified in the Dockerfile and the container image in a devcontainer.json?

Perhaps the Dockerfile is used when there is no image specified in devcontainer.json?

It is only used when specified in "build" -> "dockerfile". Only the portability-... devcontainer.json uses it.

comment:114 Changed 7 weeks ago by git

Commit: d0790b4b33b427493dd99c1b29cc4cb27e56f6f7a9f37fa8f1ecaf7b3181c71a6da75197905b3e92

Branch pushed to git repo; I updated commit sha1. New commits:

a9f37fa.devcontainer/Dockerfile: Add comment

comment:115 Changed 7 weeks ago by git

Commit: a9f37fa8f1ecaf7b3181c71a6da75197905b3e925a3b07220b1e6dc816de6348f29342e97d40967f

Branch pushed to git repo; I updated commit sha1. New commits:

5a3b072.devcontainer/: Add two more portability-... configurations

comment:116 Changed 7 weeks ago by Kwankyu Lee

How about putting the Dockerfile and other auxiliary into “common/“ directory so that they are not mixed with the copied “devcontainer.json”?

comment:117 Changed 7 weeks ago by git

Commit: 5a3b07220b1e6dc816de6348f29342e97d40967f355abedb9aa18361af9e6bbaf15660c91e304215

Branch pushed to git repo; I updated commit sha1. New commits:

355abedSome edits

comment:118 Changed 7 weeks ago by Kwankyu Lee

Actually, I could not finish following the guide, as VS code hangs at "Installing VS Code server ...".

comment:119 Changed 7 weeks ago by git

Commit: 355abedb9aa18361af9e6bbaf15660c91e3042150e1542b3a43d155565519dd0d3b08cbcf40b648b

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

0e1542b.devcontainer/: Add two more portability-... configurations

comment:120 Changed 7 weeks ago by git

Commit: 0e1542b3a43d155565519dd0d3b08cbcf40b648b8a8eb96727e0f4810032362cf31ceff1bb15ea5e

Branch pushed to git repo; I updated commit sha1. New commits:

8a8eb96src/doc/en/developer/portability_testing.rst: Expand on using the VS Code remote containers extension

comment:121 Changed 7 weeks ago by git

Commit: 8a8eb96727e0f4810032362cf31ceff1bb15ea5e5cde5fe8c2b58d7d914318dccfdbf06385c77481

Branch pushed to git repo; I updated commit sha1. New commits:

b78da73.devcontainer/portability-Dockerfile: Rename from Dockerfile
5cde5fesrc/doc/en/developer/portability_testing.rst: Expand on the devcontainer build

comment:122 Changed 7 weeks ago by Nathan Dunfield

Cc: Nathan Dunfield removed

comment:123 Changed 7 weeks ago by git

Commit: 5cde5fe8c2b58d7d914318dccfdbf06385c77481bc0198af8d65b2d72c6ca7e9d2b70202e945e516

Branch pushed to git repo; I updated commit sha1. New commits:

bc0198a.devcontainer/portability-post_start.sh: New, use it to simplify portability-.../devcontainer.json

comment:124 Changed 7 weeks ago by git

Commit: bc0198af8d65b2d72c6ca7e9d2b70202e945e516869f6e2eec454da74899394e5feb0f5222311a5c

Branch pushed to git repo; I updated commit sha1. New commits:

869f6e2.devcontainer/portability-post_start.sh: If upstream is a symlink, remove it; keep logs in container if possible

comment:125 Changed 7 weeks ago by Kwankyu Lee

You abandoned my commit in comment:117.

comment:126 Changed 7 weeks ago by Matthias Köppe

Sorry! I'll cherry-pick it

comment:127 Changed 7 weeks ago by Kwankyu Lee

There may be conflicts. Needs merge.

If you may wonder, I rephrased the section title not to start with "Developing" since the section is in "Testing on multiple platforms".

comment:128 Changed 7 weeks ago by git

Commit: 869f6e2eec454da74899394e5feb0f5222311a5c8bd20238d836a14dfde9a3a49d28abfe44768f21

Branch pushed to git repo; I updated commit sha1. New commits:

8bd2023Some edits

comment:129 Changed 7 weeks ago by Matthias Köppe

I've merged it, please take a look.

comment:130 Changed 7 weeks ago by git

Commit: 8bd20238d836a14dfde9a3a49d28abfe44768f219439ce6966629e20ac118fa92649dcf13d7c8f14

Branch pushed to git repo; I updated commit sha1. New commits:

9439ce6More edits

comment:131 Changed 7 weeks ago by Kwankyu Lee

For my case code . does not work, so I added a paragraph for this.

comment:132 Changed 7 weeks ago by git

Commit: 9439ce6966629e20ac118fa92649dcf13d7c8f144bd8169eb26349b8a0f64cb03c983e0adfe8f8ff

Branch pushed to git repo; I updated commit sha1. New commits:

4bd8169A typo

comment:133 Changed 7 weeks ago by git

Commit: 4bd8169eb26349b8a0f64cb03c983e0adfe8f8ff1bad4cab778c109dfe3c89130804d6429a366431

Branch pushed to git repo; I updated commit sha1. New commits:

1bad4caSome tiny edits

comment:134 Changed 7 weeks ago by Kwankyu Lee

I used "dev container" instead of "devcontainer".

comment:135 in reply to:  118 Changed 7 weeks ago by Kwankyu Lee

Replying to klee:

Actually, I could not finish following the guide, as VS code hangs at "Installing VS Code server ...".

Now it proceeded beyond that. (It seems there was a network problem on the vscode side (azure ?) But eventually the build (with the default configuration) failed.

I will try again later.

comment:136 Changed 7 weeks ago by Kwankyu Lee

It now works.

comment:137 Changed 7 weeks ago by Kwankyu Lee

You define "MAKE": "make -j12" for containerEnv. The value 12 seems too many for a typical developer machine. No?

comment:138 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:139 Changed 7 weeks ago by Matthias Köppe

Dependencies: #33873#33873, #34352

comment:140 Changed 7 weeks ago by git

Commit: 1bad4cab778c109dfe3c89130804d6429a3664316838f995fbbe62e12d755e9ccff8f221f0db99ce

Branch pushed to git repo; I updated commit sha1. New commits:

3a58015settings.json: add missing comma
6838f99Merge #34352

comment:141 Changed 7 weeks ago by Matthias Köppe

I'll check if I can fix the portability-centos-7-devtoolset-gcc_11-standard, or I'll replace it by something that works

comment:142 Changed 7 weeks ago by git

Commit: 6838f995fbbe62e12d755e9ccff8f221f0db99cec06132dd7c7d7af1cdf1146fd189424c9bb7006e

Branch pushed to git repo; I updated commit sha1. New commits:

85fa6ad.devcontainer/portability-centos-7-devtoolset-gcc_11-standard/devcontainer.json: Enable the devtoolset
7f9ba98.devcontainer/portability-post_start.sh: Fix up logs symlinkery
c06132d.devcontainer/portability-post_start.sh: Pick up configuration from image

comment:143 in reply to:  141 Changed 7 weeks ago by Matthias Köppe

Replying to mkoeppe:

I'll check if I can fix the portability-centos-7-devtoolset-gcc_11-standard

It works now

comment:144 Changed 7 weeks ago by Matthias Köppe

However, portability-debian-buster-i386-standard does not work for me, the log ends with "userEnvProbe is taking longer than 10 seconds."

comment:145 Changed 7 weeks ago by git

Commit: c06132dd7c7d7af1cdf1146fd189424c9bb7006e1355787df880d72dfaae58f3c62ace0cbdb82a9f

Branch pushed to git repo; I updated commit sha1. New commits:

1355787Add note

comment:146 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:147 Changed 7 weeks ago by git

Commit: 1355787df880d72dfaae58f3c62ace0cbdb82a9fa9ba6d276336fbded0ee6fc9bb25893c141a0a8c

Branch pushed to git repo; I updated commit sha1. New commits:

a9ba6d2.devcontainer/portability-debian-buster-i386-standard: Remove (does not work)

comment:148 Changed 7 weeks ago by git

Commit: a9ba6d276336fbded0ee6fc9bb25893c141a0a8cafe62c2902db425e494b55f474ba70f11e14e300

Branch pushed to git repo; I updated commit sha1. New commits:

afe62c2src/doc/en/developer/portability_testing.rst: Expand note on going back to local

comment:149 Changed 7 weeks ago by Matthias Köppe

Authors: Tobias Diez, Matthias KoeppeTobias Diez, Matthias Koeppe, Kwankyu Lee

comment:150 in reply to:  137 ; Changed 7 weeks ago by Matthias Köppe

Replying to klee:

You define "MAKE": "make -j12" for containerEnv. The value 12 seems too many for a typical developer machine. No?

Probably. Though on macOS, the actual number of processors used is determined by the Docker configuration. If you are testing on Windows (using the Docker WSL backend), does it make full use of the CPU?

comment:151 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:152 in reply to:  150 ; Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

... If you are testing on Windows (using the Docker WSL backend), does it make full use of the CPU?

Yes, upto 100% of all 4 cores on my windows machine. Docker says the number of cores used is dictated by the configuration of WSL, which by default seems the full use of all available cores. I think requiring the user to do the necessary configuration adds another to the heap of hassles in using vs code with containers...

comment:153 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:154 in reply to:  description ; Changed 7 weeks ago by Matthias Köppe

  • cocalc: not working

I see:

  [ecm-7.0.5]   checking for recent GMP... yes
  [ecm-7.0.5]   checking if GMP is MPIR... no
  [ecm-7.0.5]   checking whether we can link against GMP... no
  [ecm-7.0.5]   configure: error: Could not link against GMP library.
  [ecm-7.0.5]   

Is this the failure that you encountered?

comment:155 in reply to:  152 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

I think requiring the user to do the necessary configuration adds another to the heap of hassles in using vs code with containers...

I agree, I'll find a better solution.

comment:156 Changed 7 weeks ago by git

Commit: afe62c2902db425e494b55f474ba70f11e14e30086876262faffac5f3fed12e08b0cf0b45e3e216c

Branch pushed to git repo; I updated commit sha1. New commits:

8687626.devcontainer/cocalc/devcontainer.json: Fix ecm build

comment:157 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:158 in reply to:  154 ; Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

  • cocalc: not working

I see:

  [ecm-7.0.5]   checking for recent GMP... yes
  [ecm-7.0.5]   checking if GMP is MPIR... no
  [ecm-7.0.5]   checking whether we can link against GMP... no
  [ecm-7.0.5]   configure: error: Could not link against GMP library.
  [ecm-7.0.5]   

Is this the failure that you encountered?

I don't remember. I am testing again with your patch.

As far as I understand from the above message and your comment "// libgmp.a is broken and leads to a build failure of ecm.", it seems a genuine problem of the combination of the cocalc image and the devel branch. No? If yes, then should we fix the problem in the devcontainer.json? The purpose of the dev container is to reveal such a problem. No?

comment:159 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:160 Changed 7 weeks ago by Kwankyu Lee

downstream-conda-forge-latest dev container seems working. It "seems" because I don't use conda, and don't know what to do with the conda environment to invoke sage.

comment:161 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

For sagemath-sagemath, I got

Running the postStartCommand from devcontainer.json...

[222822 ms] Start: Run in container: /bin/sh -c make configure && (export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin && unset CFLAGS LDFLAGS CXXFLAGS CPATH LIBRARY_PATH && ./configure --prefix=/home/sage/sage/local --with-sage-venv) && make build V=0
/bin/sh: 1: make: not found
[223443 ms] postStartCommand failed with exit code 127. Skipping any further user-provided commands.
Done. Press any key to close the terminal.

comment:162 in reply to:  158 ; Changed 7 weeks ago by Matthias Köppe

Replying to klee:

As far as I understand from the above message and your comment "// libgmp.a is broken and leads to a build failure of ecm.", it seems a genuine problem of the combination of the cocalc image and the devel branch. No?

Yes, this is broken in the CoCalc Docker image. But rebuilding Sage on top of the CoCalc Docker image is not exactly a documented use case of that Docker image, as far as I know. (For that matter, I also don't know if the CoCalc service supports or documents doing Sage development.)

If yes, then should we fix the problem in the devcontainer.json? The purpose of the dev container is to reveal such a problem. No?

And it just did! So now we don't need it to continue revealing the same problem. Hence the workaround, which allows us to catch other problems that we don't know about yet.

comment:163 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:164 Changed 7 weeks ago by git

Commit: 86876262faffac5f3fed12e08b0cf0b45e3e216c0ea8654bbd60b4bae5f1dc63c1494466d53473f1

Branch pushed to git repo; I updated commit sha1. New commits:

0ea8654.devcontainer/computop-sage/devcontainer.json: Fix ecm build

comment:165 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:166 Changed 7 weeks ago by git

Commit: 0ea8654bbd60b4bae5f1dc63c1494466d53473f1b8784a039f7f365874507f752c202ae56f13a62c

Branch pushed to git repo; I updated commit sha1. New commits:

b8784a0.devcontainer/develop-docker-{cocalc,computop,sagemath}/: Rename from cocalc, computop-sage, sagemath-sagemath

comment:167 Changed 7 weeks ago by git

Commit: b8784a039f7f365874507f752c202ae56f13a62c822d9d1e4ad254ab7284828655747c177eeac1cb

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

822d9d1.devcontainer/develop-docker-{cocalc,computop}/, .devcontainer/downstream-docker-{cocalc,computop,sagemath}: Rename/specialize from cocalc, computop-sage, sagemath-sagemath

comment:168 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:169 in reply to:  162 ; Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Yes, this is broken in the CoCalc Docker image. But rebuilding Sage on top of the CoCalc Docker image is not exactly a documented use case of that Docker image, as far as I know. (For that matter, I also don't know if the CoCalc service supports or documents doing Sage development.)

Then why do we keep the devcontainer.json for cocalc (taking the burden of fixing its problem like the broken libgmp.a)? What is the benefit for sage developers?

comment:170 Changed 7 weeks ago by Kwankyu Lee

About naming. Presently prefixes for the directory names are "develop", "portability", and "" (None). I think these prefixes are useless. A developer may use one for either development, or for portability check. We don't need to attach these to the directory name.

comment:171 in reply to:  169 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

Replying to mkoeppe:

Yes, this is broken in the CoCalc Docker image. But rebuilding Sage on top of the CoCalc Docker image is not exactly a documented use case of that Docker image, as far as I know. (For that matter, I also don't know if the CoCalc service supports or documents doing Sage development.)

Then why do we keep the devcontainer.json for cocalc (taking the burden of fixing its problem like the broken libgmp.a)? What is the benefit for sage developers?

I think it's too early to evaluate cost vs benefit for our project. My hope would be that the downstream maintainer fixes the cocalc installation scripts so that we don't have to work around it. Here I built it to demonstrate a way of using the CoCalc Docker image; we will have to see if downstream is sufficiently interested in it to fix the issues.

comment:172 in reply to:  170 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

About naming. Presently prefixes for the directory names are "develop", "portability", and "" (None).

After 822d9d1, None is gone. It's "develop", "portability", and "downstream".

I think these prefixes are useless. A developer may use one for either development, or for portability check. We don't need to attach these to the directory name.

Tobias suggested it in comment:78, and I think, if properly explained, it is useful. I'll expand the documentation.

comment:173 Changed 7 weeks ago by git

Commit: 822d9d1e4ad254ab7284828655747c177eeac1cbcf27a5ecf82f203ba92e0bc4d84f4ff48d627ea9

Branch pushed to git repo; I updated commit sha1. New commits:

cf27a5e.devcontainer/downstream-docker-cocalc/devcontainer.json: Only run Sage config when in a Sage source tree

comment:174 Changed 7 weeks ago by git

Commit: cf27a5ecf82f203ba92e0bc4d84f4ff48d627ea97ea06b3cecc6b841b6f20a56626efc7ae80dd654

Branch pushed to git repo; I updated commit sha1. New commits:

7ea06b3src/doc/en/developer/portability_testing.rst: Expand on devcontainer directory prefixes

comment:175 Changed 7 weeks ago by Kwankyu Lee

First sorry for complaining about the names without good understanding of the purposes of each of the devcontainer.json. Put up with me as I am trying :)

Do we need the middle part -docker-? They are all based on docker images. I don't understand what meaning the middle part conveys...

comment:176 in reply to:  175 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

First sorry for complaining about the names without good understanding of the purposes of each of the devcontainer.json. Put up with me as I am trying :)

To the contrary -- I really appreciate it! Your feedback has already led to many important improvements.

comment:177 in reply to:  175 ; Changed 7 weeks ago by Matthias Köppe

Replying to klee:

Do we need the middle part -docker-? They are all based on docker images. I don't understand what meaning the middle part conveys...

The ones with "docker" in it are pre-made Docker images that include Sage. The others are Docker images of minimal distribution installations, and we are then testing the downstream package providing Sage.

comment:178 Changed 7 weeks ago by git

Commit: 7ea06b3cecc6b841b6f20a56626efc7ae80dd654cb64abccfbb7e19e498d932fb7b17d5e7c675371

Branch pushed to git repo; I updated commit sha1. New commits:

c8b59ec.devcontainer/downstream-conda-forge-latest/devcontainer.json: Only run Sage config when in a Sage source tree
cb64abc.devcontainer/downstream-docker-sagemath/devcontainer.json: Do not try to bootstrap/configure/build; only set synlinks when in a Sage source tree

comment:179 Changed 7 weeks ago by git

Commit: cb64abccfbb7e19e498d932fb7b17d5e7c675371bb9ff58f60af07a4e15e8d667428ada9793237c9

Branch pushed to git repo; I updated commit sha1. New commits:

bb9ff58src/doc/en/developer/portability_testing.rst: Add link to _sagemath dummy package

comment:180 Changed 7 weeks ago by git

Commit: bb9ff58f60af07a4e15e8d667428ada9793237c96592b7d635fea77e407632b2060c02577cab36be

Branch pushed to git repo; I updated commit sha1. New commits:

6592b7d.devcontainer/downstream-docker-sagemath/devcontainer.json: Fixup

comment:181 in reply to:  177 ; Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

The ones with "docker" in it are pre-made Docker images that include Sage. The others are Docker images of minimal distribution installations, and we are then testing the downstream package providing Sage.

This distinction should be (and is already, perhaps) explained in the documentation for "cocalc", "computop", and "sagemath", and already conveyed by the fact that "cocalc", "computop", and "sagemath" are not os names. I think "docker" in the name does not explain anything, and redundant. But I would not insist if you decide to keep them.

comment:182 Changed 7 weeks ago by git

Commit: 6592b7d635fea77e407632b2060c02577cab36bec5d883c7e24f0c7eef4f49bf2adf645248fb392b

Branch pushed to git repo; I updated commit sha1. New commits:

c5d883csrc/doc/en/developer/portability_testing.rst: Explain the devcontainer name prefix downstream-docker-...

comment:183 in reply to:  181 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

This distinction should be [...] already conveyed by the fact that "cocalc", "computop", and "sagemath" are not os names.

I think this will not be so clear for the casual observer; after all, there are hundreds of Linux distributions...

I'm keeping it and have expanded the documentation to explain it better

Last edited 7 weeks ago by Matthias Köppe (previous) (diff)

comment:184 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:185 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:186 Changed 7 weeks ago by git

Commit: c5d883c7e24f0c7eef4f49bf2adf645248fb392b84a5e13bd2d17cfb27ac93ab0177193d5a0917db

Branch pushed to git repo; I updated commit sha1. New commits:

3016ce9build/bin/sage-print-system-package-command (conda): Actually include options in command
84a5e13.devcontainer/downstream-conda-forge-latest/devcontainer.json: Do not use .devcontainer/post_create.sh

comment:187 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:188 Changed 7 weeks ago by Tobias Diez

The handling of multiple devcontainer definition files is discussed in the following issues:

Summary: the implementation that Github's codespaces uses is the defacto standard, and vscode is expected to follow suit in the future (however, without a clear timeline).

Thus, in order to be future proof, I would say we should have a default devcontainer file that vscode and github codespaces uses if no other devcontainer is specified. vscode users then have the option to either change that default devcontainer config or use the devcontainer cli (https://github.com/devcontainers/cli). This would also reduce the step necessary for using devcontainers for actual development.

Moreover, I suggest you add github workflows that verify that sage is at least compiling in these containers. That should be relatively straightforward using https://github.com/devcontainers/ci

comment:189 Changed 7 weeks ago by Matthias Köppe

No, I'm still -1 on including a default because there is no agreement on the right default. We support multiple use cases, and it is extremely annoying and a Bad Idea to do configuration by overwriting a file under version control.

comment:190 in reply to:  188 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

Replying to gh-tobiasdiez:

I suggest you add github workflows that verify that sage is at least compiling in these containers. That should be relatively straightforward using https://github.com/devcontainers/ci

That's a good idea for a follow-up ticket. I've added it to the ticket description.

comment:191 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:192 Changed 7 weeks ago by Kwankyu Lee

computop still fails for me:

libtool: compile:  g++ -std=gnu++11 -std=c++11 -DHAVE_CONFIG_H -I. -I.. -DFPLLL_DEFAULT_STRATEGY_PATH=\"/sage/local/sh
are/fplll/strategies\" -DFPLLL_DEFAULT_STRATEGY=\"/sage/local/share/fplll/strategies/default.json\" -I./.. -I/sage/loc
al/include/ -pthread -g -O2 -fPIC -I/sage/local/include/ -L/sage/local/lib -c enum-parallel/enumlib_dim.80.cpp  -fPIC 
-DPIC -o enum-parallel/.libs/libfplll_la-enumlib_dim.80.o
/usr/bin/bash ../libtool  --tag=CXX   --mode=compile g++ -std=gnu++11 -std=c++11 -DHAVE_CONFIG_H -I. -I..  -DFPLLL_DEF
AULT_STRATEGY_PATH=\"/sage/local/share/fplll/strategies\" -DFPLLL_DEFAULT_STRATEGY=\"/sage/local/share/fplll/strategie
s/default.json\" -I./.. -I/sage/local/include/ -pthread -g -O2 -fPIC -I/sage/local/include/ -L/sage/local/lib -c -o en
um-parallel/libfplll_la-enumlib_dim.70.lo `test -f 'enum-parallel/enumlib_dim.70.cpp' || echo './'`enum-parallel/enuml
ib_dim.70.cpp
libtool: compile:  g++ -std=gnu++11 -std=c++11 -DHAVE_CONFIG_H -I. -I.. -DFPLLL_DEFAULT_STRATEGY_PATH=\"/sage/local/share/fplll/strategies\" -DFPLLL_DEFAULT_STRATEGY=\"/sage/local/share/fplll/strategies/default.json\" -I./.. -I/sage/local/include/ -pthread -g -O2 -fPIC -I/sage/local/include/ -L/sage/local/lib -c enum-parallel/enumlib_dim.70.cpp  -fPIC -DPIC -o enum-parallel/.libs/libfplll_la-enumlib_dim.70.o
g++: fatal error: Killed signal terminated program cc1plus
compilation terminated.
make[8]: *** [Makefile:1647: enum-parallel/libfplll_la-enumlib_dim.120.lo] Error 1
make[8]: *** Waiting for unfinished jobs....
g++: fatal error: Killed signal terminated program cc1plus
compilation terminated.
make[8]: *** [Makefile:1661: enum-parallel/libfplll_la-enumlib_dim.100.lo] Error 1
make[7]: *** [Makefile:858: all] Error 2
make[6]: *** [Makefile:506: all-recursive] Error 1
make[5]: *** [Makefile:394: all] Error 2
**********************************************************************************************************************************
Error building fplll-5.4.2
**********************************************************************************************************************************

comment:193 Changed 7 weeks ago by Matthias Köppe

comment:194 Changed 7 weeks ago by git

Commit: 84a5e13bd2d17cfb27ac93ab0177193d5a0917db945de29b5be9c7bb3da86b306e36f284bae11103

Branch pushed to git repo; I updated commit sha1. New commits:

945de29.devcontainer: Reduce parallelism to 4

comment:195 Changed 7 weeks ago by Matthias Köppe

This change also reduces the memory pressure, so it may help

comment:196 in reply to:  189 ; Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

No, I'm still -1 on including a default because there is no agreement on the right default.

+1. The present design is to have a developer user choose the default for him/her.

Last edited 7 weeks ago by Kwankyu Lee (previous) (diff)

comment:197 in reply to:  193 Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Perhaps it has run out of memory? https://docs.microsoft.com/en-us/windows/wsl/wsl-config#example-wslconfig-file

This is on my mac. I will try again with -j4.

comment:198 Changed 7 weeks ago by Kwankyu Lee

For downstream-docker-sagemath, the build ended with

...
[06:59:26] Extension installed successfully: ms-toolsai.jupyter-renderers
[06:59:26] Extension installed successfully: ms-toolsai.jupyter
[27620 ms] [06:59:26] Extension installed successfully: ms-python.python
[27620 ms] [06:59:26] Extension installed successfully: ms-python.vscode-pylance
[27640 ms] Extension 'ms-python.python' v2022.12.0 was successfully installed.
[28147 ms] Port forwarding connection from 50847 > 41575 > 41575 in the container.
[28148 ms] Start: Run in container: /home/sage/.vscode-server/bin/6d9b74a70ca9c7733b29f0456fd8195364076dda/node -e 
[28160 ms] Port forwarding connection from 50848 > 41575 > 41575 in the container.
[28161 ms] Start: Run in container: /home/sage/.vscode-server/bin/6d9b74a70ca9c7733b29f0456fd8195364076dda/node -e 
[28533 ms] Port forwarding 50847 > 41575 > 41575 stderr: Connection established
[28628 ms] Port forwarding 50848 > 41575 > 41575 stderr: Connection established
[33560 ms] Port forwarding 50847 > 41575 > 41575 stderr: Remote close
[33579 ms] Port forwarding 50847 > 41575 > 41575 terminated with code 0 and signal null.
[33636 ms] Port forwarding 50848 > 41575 > 41575 stderr: Remote close
[33661 ms] Port forwarding 50848 > 41575 > 41575 terminated with code 0 and signal null.
[1493722 ms] Start: Run in container: cat /proc/4150/environ
[1495541 ms] Port forwarding 50847 > 41575 > 41575: Local close
[1495541 ms] Port forwarding 50848 > 41575 > 41575: Local close

(there is not "Done ..." message). And I get from a new terminal

sage@81d51a468975:/workspaces/sage-dev$ ./sage
************************************************************************
It seems that you are attempting to run Sage from an unpacked source
tarball, but you have not compiled it yet (or maybe the build has not
finished). You should run `make` in the Sage root directory first.
If you did not intend to build Sage from source, you should download
a binary tarball instead. Read README.txt for more information.
************************************************************************

comment:199 Changed 7 weeks ago by git

Commit: 945de29b5be9c7bb3da86b306e36f284bae11103b29dfa784916838ec3f21ad26db340bf5602b190

Branch pushed to git repo; I updated commit sha1. New commits:

b29dfa7.devcontainer/downstream-docker-sagemath: Remove

comment:200 Changed 7 weeks ago by Matthias Köppe

Indeed. This looks hopeless until after the sagemath/sage image has been fixed (#34242). I've removed it.

comment:201 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:202 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:203 Changed 7 weeks ago by Kwankyu Lee

Last edited 7 weeks ago by Kwankyu Lee (previous) (diff)

comment:204 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:205 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)
Status: needs_reviewneeds_work

I will recheck all devcontainers.

comment:206 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

portability-centos-7-devtoolset-gcc_11-standard builds well, but

[root@974c41aebd4e sage-dev]# ./sage
------------------------------------------------------------------------
/sage/local/var/lib/sage/venv-python3.10.5/lib/python3.10/site-packages/cysignals/signals.cpython-310-x86_64-linux-gnu.so(+0x7d08)[0x7fc373db3d08]
/sage/local/var/lib/sage/venv-python3.10.5/lib/python3.10/site-packages/cysignals/signals.cpython-310-x86_64-linux-gnu.so(+0x7da9)[0x7fc373db3da9]
/sage/local/var/lib/sage/venv-python3.10.5/lib/python3.10/site-packages/cysignals/signals.cpython-310-x86_64-linux-gnu.so(+0xa0ce)[0x7fc373db60ce]
/lib64/libpthread.so.0(+0xf630)[0x7fc37536d630]
/sage/local/lib/libgmp.so.10(__gmpz_import+0x144)[0x7fc373412984]
/workspaces/sage-dev/src/sage/libs/gmp/pylong.cpython-310-x86_64-linux-gnu.so(+0x2e9b)[0x7fc370f15e9b]
/workspaces/sage-dev/src/sage/misc/randstate.cpython-310-x86_64-linux-gnu.so(+0x1063d)[0x7fc3707ee63d]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(+0x109e1e)
...
...
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(+0x1b5013)[0x7fc375966013]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(+0x1b5217)[0x7fc375966217]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(+0x1b52ff)[0x7fc3759662ff]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(_PyRun_SimpleFileObject+0x111)[0x7fc375968231]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(_PyRun_AnyFileObject+0x3b)[0x7fc37596871b]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(Py_RunMain+0x406)[0x7fc375984036]
/sage/local/var/lib/sage/venv-python3.10.5/lib/libpython3.10.so.1.0(Py_BytesMain+0x47)[0x7fc375984867]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x7fc3748a9555]
python3[0x40108e]
------------------------------------------------------------------------
Attaching gdb to process id 69929.
Cannot find gdb installed
GDB is not installed.
Install gdb for enhanced tracebacks.
------------------------------------------------------------------------
Unhandled SIGILL: An illegal instruction occurred.
This probably occurred because a *compiled* module has a bug
in it and is not properly wrapped with sig_on(), sig_off().
Python will now terminate.
------------------------------------------------------------------------
/workspaces/sage-dev/src/bin/sage-python: line 2: 69929 Illegal instruction     sage -python "$@"
[root@974c41aebd4e sage-dev]# 

comment:207 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

develop-docker-cocalc builds well, but

root@2c9e7b96f2da:/workspaces/sage-dev# ./sage
------------------------------------------------------------------------
/usr/local/sage/local/var/lib/sage/venv-python3.8/lib/python3.8/site-packages/cysignals/signals.cpython-38-x86_64-linux-gnu.so(+0x7e64)[0x7fb671bfde64]
/usr/local/sage/local/var/lib/sage/venv-python3.8/lib/python3.8/site-packages/cysignals/signals.cpython-38-x86_64-linux-gnu.so(+0x8039)[0x7fb671bfe039]
/usr/local/sage/local/var/lib/sage/venv-python3.8/lib/python3.8/site-packages/cysignals/signals.cpython-38-x86_64-linux-gnu.so(+0xa583)[0x7fb671c00583]
/lib/x86_64-linux-gnu/libc.so.6(+0x43090)[0x7fb6725a4090]
/usr/local/sage/local/lib/libgmp.so.10(__gmpz_n_pow_ui+0xa4)[0x7fb6711af024]
/usr/local/sage/local/lib/libgmp.so.10(__gmpz_ui_pow_ui+0x22)[0x7fb6711b5b32]
/workspaces/sage-dev/src/sage/rings/integer.cpython-38-x86_64-linux-gnu.so(+0x13641)[0x7fb6698eb641]
python3(PyModule_ExecDef+0x4c)[0x6a946c]
...
...
python3(_PyObject_CallMethodIdObjArgs+0x198)[0x5f5128]
python3(PyImport_ImportModuleLevelObject+0x7c2)[0x553bb2]
python3(_PyEval_EvalFrameDefault+0x2a2d)[0x56ddcd]
python3(_PyEval_EvalCodeWithName+0x26a)[0x569dba]
python3(_PyFunction_Vectorcall+0x393)[0x5f6eb3]
python3(_PyEval_EvalFrameDefault+0x187f)[0x56cc1f]
python3(_PyFunction_Vectorcall+0x1b6)[0x5f6cd6]
python3(_PyEval_EvalFrameDefault+0x72d)[0x56bacd]
python3(_PyEval_EvalCodeWithName+0x26a)[0x569dba]
python3(PyEval_EvalCode+0x27)[0x6902a7]
python3[0x67f951]
python3[0x67f9cf]
python3[0x67fa71]
python3(PyRun_SimpleFileExFlags+0x197)[0x681b97]
python3(Py_RunMain+0x212)[0x6b9d32]
python3(Py_BytesMain+0x2d)[0x6ba0bd]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0x7fb672585083]
python3(_start+0x2e)[0x5fc5fe]
------------------------------------------------------------------------
Attaching gdb to process id 30116.
Cannot find gdb installed
GDB is not installed.
Install gdb for enhanced tracebacks.
------------------------------------------------------------------------
Unhandled SIGILL: An illegal instruction occurred.
This probably occurred because a *compiled* module has a bug
in it and is not properly wrapped with sig_on(), sig_off().
Python will now terminate.
------------------------------------------------------------------------
/workspaces/sage-dev/src/bin/sage-python: line 2: 30116 Illegal instruction     sage -python "$@"
root@2c9e7b96f2da:/workspaces/sage-dev# 

I get the same with

root@2c9e7b96f2da:/workspaces/sage-dev# /usr/local/sage/sage

comment:208 Changed 7 weeks ago by Matthias Köppe

Is this on the same machines where you tested earlier, or a different one?

Does downstream-docker-cocalc work OK on this machine?

comment:209 in reply to:  208 Changed 7 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Is this on the same machines where you tested earlier, or a different one?

I tested mostly on my mac pro, sometimes on windows. I don't remember which is on which. That is one reason why I am testing all again, on mac.

Would it dependent on the platform where docker runs?

Does downstream-docker-cocalc work OK on this machine?

Not tested yet. Soon I will report.

comment:210 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:211 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

downstream-docker-cocals fails to run similarly

oot@c52fbbb6d2cf:/workspaces/sage-dev# ./sage
┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 9.6, Release Date: 2022-05-15                     │
│ Using Python 3.8.10. Type "help()" for help.                       │
└────────────────────────────────────────────────────────────────────┘
------------------------------------------------------------------------
/usr/local/sage/local/var/lib/sage/venv-python3.8/lib/python3.8/site-packages/cysignals/signals.cpython-38-x86_64-linux-gnu.so(+0x7e24)[0x7f7258b64e24]
/usr/local/sage/local/var/lib/sage/venv-python3.8/lib/python3.8/site-packages/cysignals/signals.cpython-38-x86_64-linux-gnu.so(+0x7ff9)[0x7f7258b64ff9]
/usr/local/sage/local/var/lib/sage/venv-python3.8/lib/python3.8/site-packages/cysignals/signals.cpython-38-x86_64-linux-gnu.so(+0xa5e3)[0x7f7258b675e3]
/lib/x86_64-linux-gnu/libc.so.6(+0x43090)[0x7f725b72d090]
...
...
python3(_PyEval_EvalFrameDefault+0x85a)[0x56bbfa]
python3(_PyEval_EvalCodeWithName+0x26a)[0x569dba]
python3(PyEval_EvalCode+0x27)[0x6902a7]
python3[0x67f951]
python3[0x67f9cf]
python3[0x67fa71]
python3(PyRun_SimpleFileExFlags+0x197)[0x681b97]
python3(Py_RunMain+0x212)[0x6b9d32]
python3(Py_BytesMain+0x2d)[0x6ba0bd]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0x7f725b70e083]
python3(_start+0x2e)[0x5fc5fe]
------------------------------------------------------------------------
Attaching gdb to process id 8400.
Cannot find gdb installed
GDB is not installed.
Install gdb for enhanced tracebacks.
------------------------------------------------------------------------
Unhandled SIGILL: An illegal instruction occurred.
This probably occurred because a *compiled* module has a bug
in it and is not properly wrapped with sig_on(), sig_off().
Python will now terminate.
------------------------------------------------------------------------
/workspaces/sage-dev/src/bin/sage-python: line 2:  8400 Illegal instruction     sage -python "$@"

comment:212 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:213 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

downstream-archlinux-latest builds well, but in a new termianl, I get

bash: /root/.bashrc: No such file or directory
[root@d05614ceb461 sage-dev]# ./sage
************************************************************************
It seems that you are attempting to run Sage from an unpacked source
tarball, but you have not compiled it yet (or maybe the build has not
finished). You should run `make` in the Sage root directory first.
If you did not intend to build Sage from source, you should download
a binary tarball instead. Read README.txt for more information.
************************************************************************
[root@d05614ceb461 sage-dev]# ls -l
total 4204
-rw-r--r--   1 root root     356 Apr 13 23:54 AUTHORS.md
-rw-r--r--   1 root root     361 Jan 19  2022 CITATION.cff
-rw-r--r--   1 root root    2320 Apr 13 23:54 CODE_OF_CONDUCT.md
-rw-r--r--   1 root root    1490 Apr 13 23:54 CONTRIBUTING.md
-rw-r--r--   1 root root   66314 Mar 14 08:35 COPYING.txt
-rw-r--r--   1 root root   14023 Aug  3 11:24 Makefile
-rw-r--r--   1 root root     769 Aug 14 04:17 Pipfile
-rw-r--r--   1 root root    2043 Dec 30  2021 Pipfile.m4
-rw-r--r--   1 root root   27792 Aug  3 11:24 README.md
-rw-r--r--   1 root root      53 Aug  9 03:14 VERSION.txt
-rw-r--r--   1 root root  129771 Aug 14 04:19 aclocal.m4
drwxr-xr-x  15 root root     480 Aug 14 04:19 autom4te.cache
-rwxr-xr-x   1 root root   11134 Aug  9 03:14 bootstrap
-rwxr-xr-x   1 root root    3184 Jul 28 23:04 bootstrap-conda
drwxr-xr-x  11 root root     352 Jul  6 11:15 build
-rw-r--r--   1 root root     223 Dec 30  2021 condarc.yml
drwxr-xr-x   8 root root     256 Aug 14 04:19 config
-rw-r--r--   1 root root  229949 Aug 16 06:41 config.log
-rwxr-xr-x   1 root root  121354 Aug 16 06:41 config.status
-rwxr-xr-x   1 root root 3528718 Aug 14 04:19 configure
-rw-r--r--   1 root root   21961 Aug  9 11:16 configure.ac
drwxr-xr-x   9 root root     288 Aug  3 11:24 docker
-rw-r--r--   1 root root    1445 Aug 14 04:18 environment-optional.yml
-rw-r--r--   1 root root    1172 Aug 14 04:18 environment.yml
drwxr-xr-x  10 root root     320 Aug  9 21:45 local
drwxr-xr-x   5 root root     160 Aug 12 12:42 logs
drwxr-xr-x  31 root root     992 Aug 14 04:17 m4
drwxr-xr-x  13 root root     416 Jul 12 04:45 pkgs
lrwxr-xr-x   1 root root      21 Aug 16 06:41 prefix -> /usr/local/sage/local
-rw-r--r--   1 root root     628 Jun 14 04:05 pyrightconfig.json
-rwxr-xr-x   1 root root    4893 Jun  5 23:19 sage
drwxr-xr-x  36 root root    1152 Aug 14 04:18 src
-rw-r--r--   1 root root   40355 Aug  3 11:24 tox.ini
drwxr-xr-x 252 root root    8064 Aug 14 13:14 upstream
lrwxr-xr-x   1 root root       4 Aug 16 06:50 venv -> /usr
[root@d05614ceb461 sage-dev]# /usr/loacl/sage/sage
bash: /usr/loacl/sage/sage: No such file or directory

comment:214 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:215 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

downstream-conda-forge-latest builds well; then I did

mamba create -n sage sage
...
mamba init
... (whatever I was requested to do)
(base) root@c81bcba95c83:/workspaces# mamba activate sage
(sage) root@c81bcba95c83:/workspaces# sage
┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 9.6, Release Date: 2022-05-15                     │
│ Using Python 3.10.5. Type "help()" for help.                       │
└────────────────────────────────────────────────────────────────────┘
sage: 

comment:216 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

downstream-docker-computop builds and runs well:

sage@a17bf8c87254:/workspaces/sage-dev$ ./sage
************************************************************************
It seems that you are attempting to run Sage from an unpacked source
tarball, but you have not compiled it yet (or maybe the build has not
finished). You should run `make` in the Sage root directory first.
If you did not intend to build Sage from source, you should download
a binary tarball instead. Read README.txt for more information.
************************************************************************
sage@a17bf8c87254:/workspaces/sage-dev$ /sage/sage
SageMath version 9.6, Release Date: 2022-05-15
sage: 

comment:217 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

downstream-docker-sagemath seems to have failed to build, according to

Running the postCreateCommand from devcontainer.json...

[7625 ms] Start: Run in container: /bin/sh -c .devcontainer/post_create.sh --sudo
Ign:1 http://archive.ubuntu.com/ubuntu impish InRelease
Ign:2 http://security.ubuntu.com/ubuntu impish-security InRelease
Ign:3 http://archive.ubuntu.com/ubuntu impish-updates InRelease
Err:4 http://security.ubuntu.com/ubuntu impish-security Release
  404  Not Found [IP: 91.189.91.39 80]
Ign:5 http://archive.ubuntu.com/ubuntu impish-backports InRelease
Err:6 http://archive.ubuntu.com/ubuntu impish Release
  404  Not Found [IP: 91.189.91.38 80]
Err:7 http://archive.ubuntu.com/ubuntu impish-updates Release
  404  Not Found [IP: 91.189.91.38 80]
Err:8 http://archive.ubuntu.com/ubuntu impish-backports Release
  404  Not Found [IP: 91.189.91.38 80]
Reading package lists... Done
E: The repository 'http://security.ubuntu.com/ubuntu impish-security Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://archive.ubuntu.com/ubuntu impish Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://archive.ubuntu.com/ubuntu impish-updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://archive.ubuntu.com/ubuntu impish-backports Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  perl-base

Package ca-certificates is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package make is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'make' has no installation candidate
E: Unable to locate package m4
E: Package 'perl' has no installation candidate
E: Unable to locate package python3
E: Unable to locate package bc
E: Package 'ca-certificates' has no installation candidate
E: Unable to locate package python3
E: Unable to locate package libpython3-dev
E: Unable to locate package python3-distutils
E: Unable to locate package python3-venv
E: Unable to locate package git

Running the postStartCommand from devcontainer.json...

[11202 ms] Start: Run in container: /bin/sh -c if [ -d pkgs/sagemath-standard ]; then ln -sf /home/sage/sage/venv venv && ln -sf /home/sage/sage/local prefix; else echo 'Edit .devcontainer/devcontainer.json (postStartCommand) to run project-specific startup commands'; fi

Done. Press any key to close the terminal.

comment:218 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:219 in reply to:  217 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

downstream-docker-sagemath seems to have failed to build

Yes, that's why I have removed it. (this is https://trac.sagemath.org/ticket/33274#comment:7)

comment:220 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:221 Changed 7 weeks ago by Kwankyu Lee

Do those with "fails to run" fail with you too?

If so, I suggest to create a separate ticket for a branch that contains only those devcontainers.json that "builds well; runs well", and keep this ticket to fix other failing devcontainers.json.

It would also be good to include in the manual how and where to start sage for each dev containers. For example, in downstream-docker-computop, it is /sage/sage.

comment:222 in reply to:  213 Changed 7 weeks ago by Matthias Köppe

I'll check now

comment:223 in reply to:  213 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

downstream-archlinux-latest builds well, but in a new termianl, I get

bash: /root/.bashrc: No such file or directory
[root@d05614ceb461 sage-dev]# ./sage
************************************************************************
It seems that you are attempting to run Sage from an unpacked source

This one is expected

[...] lrwxr-xr-x 1 root root 21 Aug 16 06:41 prefix -> /usr/local/sage/local

This symbolic link is from your computer's file system, I think. I'll add a command to the devcontainer script to remove this confusing symlink.

[root@d05614ceb461 sage-dev]# /usr/loacl/sage/sage bash: /usr/loacl/sage/sage: No such file or directory }}}

Overall that location /usr/local/sage is not present on archlinux (also there's a typo loacl -> local)

It should just work by typing sage (that's /usr/bin/sage), but I'll check again now.

Yes, we should mention how to launch the downstream sage in the documentation

comment:224 Changed 7 weeks ago by git

Commit: b29dfa784916838ec3f21ad26db340bf5602b190b72ff17c346b2f64849a45400a226b74dc2f10f8

Branch pushed to git repo; I updated commit sha1. New commits:

b09e6d1.devcontainer/downstream-archlinux-latest/devcontainer.json: Remove a 'prefix' symlink if present
f99f09f.devcontainer/downstream-archlinux-latest/devcontainer.json: No need to bootstrap
b72ff17Refinements for downstream-archlinux-latest

comment:225 Changed 7 weeks ago by git

Commit: b72ff17c346b2f64849a45400a226b74dc2f10f89215621a6fa51b9cb914fc91fb25ac6c82ccdbef

Branch pushed to git repo; I updated commit sha1. New commits:

9215621Copy instructions for downstream-conda-latest

comment:226 Changed 7 weeks ago by git

Commit: 9215621a6fa51b9cb914fc91fb25ac6c82ccdbefde05f69712024a42b171e76ba378761ba8c0d998

Branch pushed to git repo; I updated commit sha1. New commits:

de05f69Copy instructions for downstream-*

comment:227 Changed 7 weeks ago by git

Commit: de05f69712024a42b171e76ba378761ba8c0d99843abc572dca5342919c34406b3691d4cb67fe929

Branch pushed to git repo; I updated commit sha1. New commits:

43abc57.devcontainer/develop-docker-cocalc, portability-centos-7-devtoolset-gcc_11-standard: Remove

comment:228 Changed 7 weeks ago by Matthias Köppe

Description: modified (diff)

comment:229 Changed 7 weeks ago by Matthias Köppe

Status: needs_workneeds_review

comment:230 in reply to:  221 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

I suggest to create a separate ticket for a branch that contains only those devcontainers.json that "builds well; runs well", and keep this ticket to fix other failing devcontainers.json.

I've just removed them here on the branch. Easy to revert on follow-up tickets that fix it.

It would also be good to include in the manual how and where to start sage for each dev containers.

Done

comment:231 Changed 7 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:232 Changed 7 weeks ago by Kwankyu Lee

downstream-docker-cocalc: still the same as in comment:211, with

root@bec4edc3fcf6:/workspaces/sage-dev# sage
Last edited 7 weeks ago by Kwankyu Lee (previous) (diff)

comment:233 Changed 7 weeks ago by Kwankyu Lee

It seems that a devcontainer.json might not build if the source tree is in a "dirty state", like just after building another devcontainer.json. It seems ./bootstrap in the source tree fixes this.

I don't know if this should be documented...

comment:234 in reply to:  232 ; Changed 7 weeks ago by Matthias Köppe

Replying to klee:

downstream-docker-cocalc: still the same as in comment:211, with

root@bec4edc3fcf6:/workspaces/sage-dev# sage

Is this on your Mac? Can you reproduce it with just docker run -it sagemathinc/cocalc bash from the command line?

In the container where Sage crashes, could you run cat /proc/cpuinfo?

comment:235 in reply to:  233 Changed 7 weeks ago by Matthias Köppe

Replying to klee:

It seems that a devcontainer.json might not build if the source tree is in a "dirty state", like just after building another devcontainer.json. It seems ./bootstrap in the source tree fixes this.

Yes, that's a helpful observation. I'll make it more robust by including the bootstrapping prerequisites in all containers

comment:236 Changed 7 weeks ago by git

Commit: 43abc572dca5342919c34406b3691d4cb67fe929bad3c162dbffb22c7367d9ebf585b340d4fe9485

Branch pushed to git repo; I updated commit sha1. New commits:

bad3c16.devcontainer/post_create.sh: Install bootstrapping prerequisites

comment:237 in reply to:  196 Changed 7 weeks ago by Tobias Diez

Replying to klee:

Replying to mkoeppe:

No, I'm still -1 on including a default because there is no agreement on the right default.

+1. The present design is to have a developer user choose the default for him/her.

The problem is that Github codespaces will just use Github's default image (which does not work with sage) if there is no default devcontainer config.

comment:238 Changed 7 weeks ago by Matthias Köppe

I don't think GitHub codespaces will have much relevance for our project because the project won't be able to pay for them.

comment:239 in reply to:  188 Changed 7 weeks ago by Matthias Köppe

In any case:

Replying to gh-tobiasdiez:

Thus, in order to be future proof, [...]

We have already set up the structure of the file in a way that is compatible. So I don't think anything needs to be changed here on this ticket.

comment:240 in reply to:  234 ; Changed 6 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Replying to klee:

downstream-docker-cocalc: still the same as in comment:211, with

root@bec4edc3fcf6:/workspaces/sage-dev# sage

Is this on your Mac?

Yes. I could not run it on windows. It takes too long(or hangs?) while it downloads docker image files.

Can you reproduce it with just docker run -it sagemathinc/cocalc bash from the command line?

With root@bd6485e9bc61:/usr/local/sage# ./sage, I get the same failure.

In the container where Sage crashes, could you run cat /proc/cpuinfo?

root@bd6485e9bc61:/# cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 0
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 6994.74
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 1
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 6836.50
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

processor	: 2
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 2
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 2
initial apicid	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 6918.23
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 3
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 7096.50
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

processor	: 4
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 4
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 4
initial apicid	: 4
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 7001.61
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

processor	: 5
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 5
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 5
initial apicid	: 5
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 6933.10
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

comment:241 in reply to:  234 ; Changed 6 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Can you reproduce it with just docker run -it sagemathinc/cocalc bash from the command line?

The devcontainer.json only "./configure" the source tree. Doesn't it need to make?

comment:242 Changed 6 weeks ago by Matthias Köppe

No, the downstream-... devcontainer.json do not build Sage

comment:243 in reply to:  240 Changed 6 weeks ago by Matthias Köppe

@was: sagemathinc/cocalc gives Unhandled SIGILL: An illegal instruction occurred. on a mac with this CPU

Replying to klee:

Replying to mkoeppe:

Can you reproduce it with just docker run -it sagemathinc/cocalc bash from the command line?

With root@bd6485e9bc61:/usr/local/sage# ./sage, I get the same failure.

In the container where Sage crashes, could you run cat /proc/cpuinfo?

root@bd6485e9bc61:/# cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-1650 v2 @ 3.50GHz
stepping	: 4
cpu MHz		: 3497.372
cache size	: 12288 KB
physical id	: 0
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht pbe syscall nx pdpe1gb lm constant_tsc rep_good nopl xtopology nonstop_tsc cpuid pni pclmulqdq dtes64 ds_cpl ssse3 cx16 xtpr pcid dca sse4_1 sse4_2 popcnt aes xsave avx f16c rdrand hypervisor lahf_lm fsgsbase erms xsaveopt arat
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 6994.74
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

comment:244 in reply to:  241 Changed 6 weeks ago by Kwankyu Lee

Replying to klee:

Replying to mkoeppe:

Can you reproduce it with just docker run -it sagemathinc/cocalc bash from the command line?

The devcontainer.json only "./configure" the source tree. Doesn't it need to make?

I now understand better. /usr/local/sage/sage should run without any configuration.

comment:245 Changed 6 weeks ago by Kwankyu Lee

Description: modified (diff)

It seems that it is a problem of my mac pro (late 2013).

With macbook pro (2019), downstream-docker-cocalc runs just fine!

comment:246 Changed 6 weeks ago by Matthias Köppe

See #32434 for this issue

comment:247 Changed 6 weeks ago by git

Commit: bad3c162dbffb22c7367d9ebf585b340d4fe9485ab79e40b1b93f50fa091403103336dc5c981675f

Branch pushed to git repo; I updated commit sha1. New commits:

ab79e40Edit duplicates

comment:248 Changed 6 weeks ago by Kwankyu Lee

Reviewers: Kwankyu Lee

I am positive with the branch.

comment:249 Changed 6 weeks ago by Kwankyu Lee

Description: modified (diff)

comment:250 Changed 6 weeks ago by git

Commit: ab79e40b1b93f50fa091403103336dc5c981675f5ca1db842c5b5038dd20a214cfb41f9c3a3c60c9

Branch pushed to git repo; I updated commit sha1. New commits:

5ca1db8Note for reusing a dev container

comment:251 Changed 6 weeks ago by git

Commit: 5ca1db842c5b5038dd20a214cfb41f9c3a3c60c9f48d9111f944483334aecbf98f42c4e41e457d75

Branch pushed to git repo; I updated commit sha1. New commits:

f48d911Correct the new note

comment:252 Changed 6 weeks ago by Tobias Diez

Status: needs_reviewneeds_work

The main build should happen in the onCreateCommand or updateContentCommand and not in postCreateCommand and definitely not in postStartCommand (which is meant for something like starting a dev server). This is a general recommendation, but particular relevant for prebuilds:

When a prebuild configuration workflow runs, GitHub creates a temporary codespace, performing setup operations up to and including any onCreateCommand and updateContentCommand commands in the devcontainer.json file. No postCreateCommand commands are run during the creation of a prebuild. For more information about these commands, see the devcontainer.json reference in the VS Code documentation. A snapshot of the generated container is then taken and stored.

This should also help with the strange behavior when restarting vscode, which shouldn't rebuild but only restart the container.

comment:253 Changed 6 weeks ago by Matthias Köppe

Do you plan to work on this?

comment:254 Changed 6 weeks ago by Tobias Diez

No, I sadly don't the time for this atm.

comment:255 in reply to:  252 Changed 6 weeks ago by Matthias Köppe

Replying to gh-tobiasdiez:

The main build should happen in the onCreateCommand or updateContentCommand and not in postCreateCommand and definitely not in postStartCommand (which is meant for something like starting a dev server).

Thanks for the pointer. It looks like this will give an improvement

Last edited 6 weeks ago by Matthias Köppe (previous) (diff)

comment:256 Changed 6 weeks ago by git

Commit: f48d9111f944483334aecbf98f42c4e41e457d7579c3bcb261834938f8c0fff1f404ae7aecbc4ee7

Branch pushed to git repo; I updated commit sha1. New commits:

79c3bcb.devcontainer/downstream-docker-cocalc/devcontainer.json: Use onCreateCommand, updateContentCommand

comment:257 Changed 6 weeks ago by Kwankyu Lee

The new downstream-docker-cocalc/devcontainer.json works well.

I cm curious why updateContentCommand but not postCreateCommand should be used.

I also tested after replacing updateContentCommand with postCreateCommand. It seems postCreateCommand works equally well...

comment:258 Changed 6 weeks ago by Matthias Köppe

The documentation is not very detailed, but it seems that some of the distinctions are for GitHub Codespaces only. I do not have access to those, and we shouldn't worry too much about them.

comment:259 Changed 6 weeks ago by git

Commit: 79c3bcb261834938f8c0fff1f404ae7aecbc4ee7fbfab5e4d5bc6c0c90d30f527c159ecb638c8782

Branch pushed to git repo; I updated commit sha1. New commits:

fbfab5e.devcontainer/downstream-docker-computop/devcontainer.json: Use onCreateCommand, updateContentCommand

comment:260 Changed 6 weeks ago by git

Commit: fbfab5e4d5bc6c0c90d30f527c159ecb638c878209289e5418e448bc0421a8bf4208930cd7a4dad5

Branch pushed to git repo; I updated commit sha1. New commits:

09289e5.devcontainer/downstream-archlinux-latest/devcontainer.json: Use onCreateCommand, updateContentCommand

comment:261 Changed 6 weeks ago by git

Commit: 09289e5418e448bc0421a8bf4208930cd7a4dad57c22fd77a9c7b709c3824e8b00a84a40f2a34288

Branch pushed to git repo; I updated commit sha1. New commits:

7c22fd7.devcontainer/downstream-conda-forge-latest/devcontainer.json: Use onCreateCommand, updateContentCommand

comment:262 Changed 6 weeks ago by git

Commit: 7c22fd77a9c7b709c3824e8b00a84a40f2a34288968ec531a406c0fe1b938c8e37a10097505ac8df

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

968ec53.devcontainer/downstream-conda-forge-latest/devcontainer.json: Use onCreateCommand, updateContentCommand

comment:263 Changed 6 weeks ago by git

Commit: 968ec531a406c0fe1b938c8e37a10097505ac8df1ab9559726239ed4196d26fa0d836ce6fda0799f

Branch pushed to git repo; I updated commit sha1. New commits:

1ab9559.devcontainer/*/devcontainer.json: Use onCreateCommand, updateContentCommand

comment:264 Changed 6 weeks ago by Matthias Köppe

Status: needs_workneeds_review

comment:265 Changed 6 weeks ago by git

Commit: 1ab9559726239ed4196d26fa0d836ce6fda0799f3ba737b841647ee112b2f01b5c54e3024baa8c65

Branch pushed to git repo; I updated commit sha1. New commits:

3ba737bMinor edits

comment:266 Changed 6 weeks ago by git

Commit: 3ba737b841647ee112b2f01b5c54e3024baa8c6530f345364611205d3c8c6b9347a6f569e553d8ea

Branch pushed to git repo; I updated commit sha1. New commits:

30f3453Small edits

comment:267 Changed 6 weeks ago by Kwankyu Lee

I tested all devcontainers.json files again. They all work well.

So I am positive with the branch again.

comment:268 Changed 6 weeks ago by Matthias Köppe

Reviewers: Kwankyu LeeKwankyu Lee, Matthias Koeppe

comment:269 Changed 6 weeks ago by Matthias Köppe

Is the guidance to use ""Remote-Containers: Attach to Running Container" still needed?

comment:270 Changed 6 weeks ago by Matthias Köppe

(Is "Remote-Containers: Reopen in Container" not enough now?)

comment:271 Changed 6 weeks ago by Tobias Diez

Status: needs_reviewneeds_work

On codespaces one gets the following error:

2022-08-20 21:48:06.646Z: Configuration starting...
2022-08-20 21:48:06.735Z: $ git -C "/var/lib/docker/codespacemount/workspace" clone --branch public/build/devcontainer --depth 1 https://github.com/sagemath/sagetrac-mirror "/var/lib/docker/codespacemount/workspace/sagetrac-mirror"
2022-08-20 21:48:06.757Z: Cloning into '/var/lib/docker/codespacemount/workspace/sagetrac-mirror'...
2022-08-20 21:48:21.250Z: git process exited with exit code 0
2022-08-20 21:48:21.332Z: $ git -C "/var/lib/docker/codespacemount/workspace/sagetrac-mirror" config --local remote.origin.fetch +refs/heads/*:refs/remotes/origin/*
2022-08-20 21:48:21.354Z: git process exited with exit code 0
2022-08-20 21:48:23.167Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-20 21:48:23.194Z: Start: Resolving Remote
2022-08-20 21:48:23.213Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-20 21:48:23.232Z: Stop (49 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-20 21:48:23.253Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-20 21:48:23.332Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-20 21:48:23.361Z: $ docker buildx version
2022-08-20 21:48:23.499Z: Stop (160 ms): Run: docker buildx version
2022-08-20 21:48:23.520Z: Start: Resolving Remote
2022-08-20 21:48:23.538Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-20 21:48:23.560Z: Stop (43 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-20 21:48:23.577Z: Error: ENOENT: no such file or directory, open '/var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile'
2022-08-20 21:48:23.599Z: Stop (328 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-20 21:48:23.617Z: Exit code 1
2022-08-20 21:48:23.641Z: Failed to create container.
2022-08-20 21:48:23.681Z: Error: Command failed: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-20 21:48:23.724Z: Error Code: 1302
2022-08-20 21:48:23.766Z: Container creation failed.
2022-08-20 21:48:23.807Z: 
2022-08-20 21:48:23.847Z: Creating recovery container.

Looks like the path to the dockerfile needs to be corrected.

comment:272 Changed 6 weeks ago by git

Commit: 30f345364611205d3c8c6b9347a6f569e553d8eaf1f38b144836995613caae929a7eaebd2f83ea4d

Branch pushed to git repo; I updated commit sha1. New commits:

f1f38b1.devcontainer/portability-ubuntu-jammy-standard: Add symlink to portability-Dockerfile

comment:273 Changed 6 weeks ago by Matthias Köppe

Thanks for testing! Please try with this change

comment:274 Changed 6 weeks ago by git

Commit: f1f38b144836995613caae929a7eaebd2f83ea4d37eb95dcb3e68c19092c38cb49c9a75c5da35154

Branch pushed to git repo; I updated commit sha1. New commits:

37eb95dRemove the note for starting configured dev container

comment:275 in reply to:  269 Changed 6 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Is the guidance to use ""Remote-Containers: Attach to Running Container" still needed?

No. Removed.

comment:276 in reply to:  270 Changed 6 weeks ago by Kwankyu Lee

Replying to mkoeppe:

(Is "Remote-Containers: Reopen in Container" not enough now?)

I don't see this command. I do "Remote-Containers: Open Folder in Container" to restart the container.

comment:277 Changed 6 weeks ago by Matthias Köppe

comment:278 in reply to:  277 Changed 6 weeks ago by Kwankyu Lee

Replying to mkoeppe:

Strange. It's documented here: https://code.visualstudio.com/docs/remote/create-dev-container

The command palettes seems adjusted to the environment. If I open a folder in vscode, there is the command. Before that, it is not there.

comment:279 Changed 6 weeks ago by Matthias Köppe

That makes sense. So "Reopen" only works if the folder is already "open".

comment:280 in reply to:  273 Changed 6 weeks ago by Tobias Diez

Replying to mkoeppe:

Thanks for testing! Please try with this change

Thanks, that helped in fixing the original issue. But now I get

2022-08-21 09:38:37.529Z: Configuration starting...
2022-08-21 09:38:37.557Z: $ git -C "/var/lib/docker/codespacemount/workspace" clone --branch public/build/devcontainer --depth 1 https://github.com/sagemath/sagetrac-mirror "/var/lib/docker/codespacemount/workspace/sagetrac-mirror"
2022-08-21 09:38:37.584Z: Cloning into '/var/lib/docker/codespacemount/workspace/sagetrac-mirror'...
2022-08-21 09:38:47.403Z: git process exited with exit code 0
2022-08-21 09:38:47.461Z: $ git -C "/var/lib/docker/codespacemount/workspace/sagetrac-mirror" config --local remote.origin.fetch +refs/heads/*:refs/remotes/origin/*
2022-08-21 09:38:47.477Z: git process exited with exit code 0
2022-08-21 09:38:49.532Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 09:38:49.551Z: Start: Resolving Remote
2022-08-21 09:38:49.564Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 09:38:49.579Z: Stop (33 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 09:38:49.592Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 09:38:49.608Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 09:38:49.625Z: $ docker buildx version
2022-08-21 09:38:49.649Z: Stop (195 ms): Run: docker buildx version
2022-08-21 09:38:49.671Z: Start: Resolving Remote
2022-08-21 09:38:49.691Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 09:38:49.706Z: Stop (29 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 09:38:49.724Z: local container features stored at: /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/node_modules/vscode-dev-containers/container-features
2022-08-21 09:38:49.741Z: $ tar --no-same-owner -x -f -
2022-08-21 09:38:49.762Z: Stop (22 ms): Run: tar --no-same-owner -x -f -
2022-08-21 09:38:49.777Z: $ docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 09:38:50.006Z: #1 [internal] load build definition from portability-Dockerfile
2022-08-21 09:38:50.146Z: #1 transferring dockerfile:
2022-08-21 09:38:50.286Z: #1 transferring dockerfile: 72B done
2022-08-21 09:38:50.397Z: #1 DONE 0.4s
2022-08-21 09:38:50.421Z: 
2022-08-21 09:38:50.442Z: 
2022-08-21 09:38:50.458Z: #2 [internal] load .dockerignore
2022-08-21 09:38:50.477Z: #2 transferring context: 2B done
2022-08-21 09:38:50.496Z: #2 DONE 0.4s
2022-08-21 09:38:50.523Z: error: failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: failed to read dockerfile: too many links
2022-08-21 09:38:50.550Z: Stop (869 ms): Run: docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 09:38:50.573Z: Error: Command failed: docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 09:38:50.605Z:     at HS (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:255:1454)
2022-08-21 09:38:50.628Z:     at processTicksAndRejections (internal/process/task_queues.js:95:5)
2022-08-21 09:38:50.668Z:     at async bu (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:254:2801)
2022-08-21 09:38:50.702Z:     at async Jw (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:254:1779)
2022-08-21 09:38:50.733Z:     at async KS (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:260:2006)
2022-08-21 09:38:50.768Z:     at async co (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:260:3110)
2022-08-21 09:38:50.795Z:     at async LP (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:359:9352)
2022-08-21 09:38:50.813Z:     at async DP (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:359:9108)
2022-08-21 09:38:50.831Z: Stop (1225 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 09:38:50.856Z: Exit code 1
2022-08-21 09:38:50.874Z: Failed to create container.
2022-08-21 09:38:50.896Z: Error: Command failed: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 09:38:50.916Z: Error Code: 1302
2022-08-21 09:38:50.939Z: Container creation failed.
2022-08-21 09:38:50.959Z: 
2022-08-21 09:38:50.980Z: Creating recovery container.

Looking at the output, github codespaces uses the devcontainer cli so you probably can reproduce this issue locally using https://code.visualstudio.com/docs/remote/devcontainer-cli.

comment:281 Changed 6 weeks ago by Matthias Köppe

That will have to happen on a follow-up ticket.

comment:282 Changed 6 weeks ago by Matthias Köppe

Status: needs_workneeds_review

comment:283 in reply to:  267 Changed 6 weeks ago by Matthias Köppe

Status: needs_reviewpositive_review

Replying to klee:

I tested all devcontainers.json files again. They all work well.

So I am positive with the branch again.

And I approve your edits.

comment:284 Changed 6 weeks ago by git

Commit: 37eb95dcb3e68c19092c38cb49c9a75c5da3515459f4ac12b1b7c2dffe85d8ce1a9bca22d74f2c0d
Status: positive_reviewneeds_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

8fd3ea4Delete symlink again
59f4ac1And simply move the dockerfile

comment:285 Changed 6 weeks ago by Matthias Köppe

No, that's not a good idea, because the Dockerfile is meant to be shared between different portability-... configurations.

comment:286 Changed 6 weeks ago by Tobias Diez

Status: needs_reviewneeds_work

There is only one portability config as of now.

Its still not completely working:

2022-08-21 20:49:43.997Z: #5 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 45.5s
2022-08-21 20:49:49.011Z: #5 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 50.5s
2022-08-21 20:49:54.193Z: #5 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 55.7s
2022-08-21 20:49:59.932Z: #5 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 61.4s
2022-08-21 20:50:01.305Z: #5 ERROR: failed to register layer: ApplyLayer exit status 1 stdout:  stderr: write /sage/upstream/cvxopt-1.3.0.tar.gz: no space left on device
2022-08-21 20:50:01.579Z: ------
2022-08-21 20:50:01.672Z:  > [1/1] FROM ghcr.io/sagemath/sage/sage-docker-ubuntu-jammy-standard-with-targets:dev@sha256:99664006e200e598940648fd313e953fb7e83890fffd25898ac0d0032b49ee95:
2022-08-21 20:50:01.738Z: ------
2022-08-21 20:50:01.772Z: error: failed to solve: failed to register layer: ApplyLayer exit status 1 stdout:  stderr: write /sage/upstream/cvxopt-1.3.0.tar.gz: no space left on device
2022-08-21 20:50:01.803Z: Stop (148413 ms): Run: docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 20:50:01.858Z: Error: Command failed: docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 20:50:01.919Z:     at HS (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:255:1454)
2022-08-21 20:50:01.983Z:     at processTicksAndRejections (internal/process/task_queues.js:95:5)
2022-08-21 20:50:02.045Z:     at async bu (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:254:2801)
2022-08-21 20:50:02.094Z:     at async Jw (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:254:1779)
2022-08-21 20:50:02.160Z:     at async KS (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:260:2006)
2022-08-21 20:50:02.190Z:     at async co (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:260:3110)
2022-08-21 20:50:02.216Z:     at async LP (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:359:9352)
2022-08-21 20:50:02.264Z:     at async DP (/usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js:359:9108)
2022-08-21 20:50:02.296Z: Stop (148752 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 20:50:02.322Z: Exit code 1
2022-08-21 20:50:02.349Z: Failed to create container.
2022-08-21 20:50:02.380Z: Error: Command failed: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 20:50:02.412Z: Error Code: 1302
2022-08-21 20:50:02.453Z: Container creation failed.

The "out of space" error is confusing. The problem is actually that it conflicts with the sage executable in the root. If I delete this file, the container builds successful. But then there are more issues:

./sage
Traceback (most recent call last):
  File "/workspaces/sagetrac-mirror/src/bin/sage-ipython", line 9, in <module>
    from sage.misc.banner import banner
ModuleNotFoundError: No module named 'sage'

I have to run make build manually, although this should be part of the creation cmd, right? According to the log it is run, but doesn't detect any changes. Could it be that the docker container contains the sage code which confuses make/devcontainer?

Don't you have the same issues with vscode locally?

Full creation log:

2022-08-21 20:53:42.991Z: Configuration starting...
2022-08-21 20:53:44.111Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 20:53:44.149Z: Start: Resolving Remote
2022-08-21 20:53:44.168Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:53:44.186Z: Stop (41 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:53:44.211Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --remove-existing-container --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 20:53:44.230Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 20:53:44.250Z: $ docker buildx version
2022-08-21 20:53:44.268Z: Stop (163 ms): Run: docker buildx version
2022-08-21 20:53:45.148Z: Start: Resolving Remote
2022-08-21 20:53:45.168Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:53:45.199Z: Stop (75 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:53:45.226Z: local container features stored at: /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/node_modules/vscode-dev-containers/container-features
2022-08-21 20:53:45.252Z: $ tar --no-same-owner -x -f -
2022-08-21 20:53:45.271Z: Stop (42 ms): Run: tar --no-same-owner -x -f -
2022-08-21 20:53:45.291Z: $ docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 20:53:45.310Z: #1 [internal] load build definition from portability-Dockerfile
2022-08-21 20:53:45.330Z: 
2022-08-21 20:53:45.349Z: #1 transferring dockerfile:
2022-08-21 20:53:45.367Z: #1 transferring dockerfile: 500B done
2022-08-21 20:53:45.387Z: #1 DONE 0.3s
2022-08-21 20:53:45.407Z: 
2022-08-21 20:53:45.428Z: #2 [internal] load .dockerignore
2022-08-21 20:53:45.471Z: #2 transferring context: 2B done
2022-08-21 20:53:45.525Z: #2 DONE 0.4s
2022-08-21 20:53:45.550Z: 
2022-08-21 20:53:45.569Z: #3 [internal] load metadata for ghcr.io/sagemath/sage/sage-docker-ubuntu-jammy-standard-with-targets:dev
2022-08-21 20:53:45.588Z: 
2022-08-21 20:53:46.285Z: #3 DONE 1.0s
2022-08-21 20:53:46.318Z: 
2022-08-21 20:53:46.363Z: #4 [1/1] FROM ghcr.io/sagemath/sage/sage-docker-ubuntu-jammy-standard-with-targets:dev@sha256:99664006e200e598940648fd313e953fb7e83890fffd25898ac0d0032b49ee95
2022-08-21 20:53:46.402Z: #4 resolve ghcr.io/sagemath/sage/sage-docker-ubuntu-jammy-standard-with-targets:dev@sha256:99664006e200e598940648fd313e953fb7e83890fffd25898ac0d0032b49ee95 0.1s done
2022-08-21 20:53:46.453Z: #4 sha256:99664006e200e598940648fd313e953fb7e83890fffd25898ac0d0032b49ee95 4.31kB / 4.31kB done
2022-08-21 20:53:46.500Z: #4 sha256:854dcfff88485eec8787ff844bab8bad0480c9b34a1270948fc597272e53aba8 16.86kB / 16.86kB done
2022-08-21 20:53:46.565Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 0B / 32.53MB 0.3s
2022-08-21 20:53:46.597Z: #4 sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 0B / 30.43MB 0.3s
2022-08-21 20:53:46.676Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 0B / 586.19MB 0.4s
2022-08-21 20:53:46.959Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 3.15MB / 32.53MB 0.7s
2022-08-21 20:53:47.128Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 5.24MB / 32.53MB 0.8s
2022-08-21 20:53:47.267Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 10.49MB / 32.53MB 1.0s
2022-08-21 20:53:47.287Z: 
2022-08-21 20:53:47.306Z: #4 sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 11.53MB / 30.43MB 1.0s
2022-08-21 20:53:47.386Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 12.58MB / 32.53MB 1.1s
2022-08-21 20:53:47.405Z: #4 sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 16.78MB / 30.43MB 1.1s
2022-08-21 20:53:47.527Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 15.73MB / 32.53MB 1.2s
2022-08-21 20:53:47.545Z: #4 sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 20.97MB / 30.43MB 1.2s
2022-08-21 20:53:47.673Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 22.02MB / 32.53MB 1.4s
2022-08-21 20:53:47.819Z: #4 sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 29.36MB / 30.43MB 1.4s
2022-08-21 20:53:47.842Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 31.46MB / 586.19MB 1.4s
2022-08-21 20:53:47.876Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 25.17MB / 32.53MB 1.5s
2022-08-21 20:53:47.926Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 29.36MB / 32.53MB 1.6s
2022-08-21 20:53:48.108Z: #4 sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 30.43MB / 30.43MB 1.5s done
2022-08-21 20:53:48.153Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 32.53MB / 32.53MB 1.8s
2022-08-21 20:53:48.185Z: #4 sha256:27782e898ee11a1c3c324c54c547be9cab2373629fe435f4cc784a43cf314f06 0B / 93B 1.8s
2022-08-21 20:53:48.225Z: #4 extracting sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d
2022-08-21 20:53:48.266Z: #4 sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 32.53MB / 32.53MB 1.8s done
2022-08-21 20:53:48.299Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 63.96MB / 586.19MB 2.0s
2022-08-21 20:53:48.339Z: #4 sha256:27782e898ee11a1c3c324c54c547be9cab2373629fe435f4cc784a43cf314f06 93B / 93B 2.0s
2022-08-21 20:53:48.407Z: #4 sha256:27782e898ee11a1c3c324c54c547be9cab2373629fe435f4cc784a43cf314f06 93B / 93B 2.0s done
2022-08-21 20:53:48.446Z: #4 sha256:091fd60a25cb05119bd3931d4783425b189c77306de4af960ab827ee00e487f8 0B / 57.84kB 2.1s
2022-08-21 20:53:48.520Z: #4 sha256:90dc587b3c2513899bb997509148df4e201d51513840744c9b6cf7533195cad4 0B / 4.87kB 2.2s
2022-08-21 20:53:48.855Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 95.42MB / 586.19MB 2.6s
2022-08-21 20:53:48.892Z: #4 sha256:091fd60a25cb05119bd3931d4783425b189c77306de4af960ab827ee00e487f8 57.84kB / 57.84kB 2.3s done
2022-08-21 20:53:48.933Z: #4 sha256:90dc587b3c2513899bb997509148df4e201d51513840744c9b6cf7533195cad4 4.87kB / 4.87kB 2.5s done
2022-08-21 20:53:48.954Z: #4 sha256:5a50adec57df3aca1fa7336a8548b0e04b0e5fda1456360b002c5d22b4e7b667 0B / 1.81kB 2.6s
2022-08-21 20:53:48.984Z: #4 sha256:dd94103c9405f111d83aab38ea06d53c95977698c0e6d94fad8dce62d606c2d2 0B / 46.45kB 2.7s
2022-08-21 20:53:49.211Z: #4 extracting sha256:d19f32bd9e4106d487f1a703fc2f09c8edadd92db4405d477978e8e466ab290d 1.2s done
2022-08-21 20:53:49.233Z: #4 sha256:5a50adec57df3aca1fa7336a8548b0e04b0e5fda1456360b002c5d22b4e7b667 1.81kB / 1.81kB 2.8s done
2022-08-21 20:53:49.353Z: #4 sha256:0b8574558a8f619b7acf46defc7a408fd9c6eebdee6399a0eb107d8b4953c221 0B / 3.08kB 3.1s
2022-08-21 20:53:49.467Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 128.97MB / 586.19MB 3.2s
2022-08-21 20:53:49.499Z: #4 sha256:dd94103c9405f111d83aab38ea06d53c95977698c0e6d94fad8dce62d606c2d2 46.45kB / 46.45kB 3.2s
2022-08-21 20:53:49.582Z: #4 sha256:dd94103c9405f111d83aab38ea06d53c95977698c0e6d94fad8dce62d606c2d2 46.45kB / 46.45kB 3.2s done
2022-08-21 20:53:49.609Z: #4 sha256:0b8574558a8f619b7acf46defc7a408fd9c6eebdee6399a0eb107d8b4953c221 3.08kB / 3.08kB 3.3s
2022-08-21 20:53:49.642Z: #4 extracting sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75
2022-08-21 20:53:49.692Z: #4 sha256:0b8574558a8f619b7acf46defc7a408fd9c6eebdee6399a0eb107d8b4953c221 3.08kB / 3.08kB 3.3s done
2022-08-21 20:53:49.732Z: #4 sha256:df34989ca33f2b624e39bd7afc6e3d97202576022464ef00b26f1cee4291e502 0B / 39.13kB 3.4s
2022-08-21 20:53:49.804Z: #4 sha256:221958f57eea077c3ca6533df00daec091409a9533ce970a472ba1afa101e213 0B / 342.71kB 3.5s
2022-08-21 20:53:50.000Z: #4 sha256:df34989ca33f2b624e39bd7afc6e3d97202576022464ef00b26f1cee4291e502 39.13kB / 39.13kB 3.6s done
2022-08-21 20:53:50.111Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 161.71MB / 586.19MB 3.8s
2022-08-21 20:53:50.131Z: #4 sha256:e20260c12bf17b43999e51629030cfc081f5210c054e26d0256b37927568b252 0B / 2.80MB 3.8s
2022-08-21 20:53:50.225Z: #4 sha256:221958f57eea077c3ca6533df00daec091409a9533ce970a472ba1afa101e213 342.71kB / 342.71kB 3.9s
2022-08-21 20:53:50.373Z: #4 extracting sha256:170cd1be70a47ac4f969025a98386ba7cdc21f139fa15275dfb518674eeaaa75 0.8s done
2022-08-21 20:53:50.947Z: 
2022-08-21 20:53:51.257Z: #4 sha256:221958f57eea077c3ca6533df00daec091409a9533ce970a472ba1afa101e213 342.71kB / 342.71kB 3.9s done
2022-08-21 20:53:51.393Z: #4 sha256:5deec403a9280d099b31923d05d0cf7a658ab22f6b836ee92705ae269f11d072 0B / 1.39MB 4.2s
2022-08-21 20:53:51.661Z: #4 sha256:e20260c12bf17b43999e51629030cfc081f5210c054e26d0256b37927568b252 2.80MB / 2.80MB 4.3s
2022-08-21 20:53:51.731Z: 
2022-08-21 20:53:51.850Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 203.42MB / 586.19MB 4.5s
2022-08-21 20:53:51.934Z: #4 sha256:5deec403a9280d099b31923d05d0cf7a658ab22f6b836ee92705ae269f11d072 1.39MB / 1.39MB 4.5s
2022-08-21 20:53:51.993Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 236.98MB / 586.19MB 5.1s
2022-08-21 20:53:52.223Z: 
2022-08-21 20:53:52.298Z: #4 sha256:e20260c12bf17b43999e51629030cfc081f5210c054e26d0256b37927568b252 2.80MB / 2.80MB 4.9s done
2022-08-21 20:53:52.424Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 267.39MB / 586.19MB 5.6s
2022-08-21 20:53:53.045Z: 
2022-08-21 20:53:53.102Z: #4 sha256:1ff42478180f1776b67288595f3b4d885fba33604bb599ad0347f564e1a841a3 0B / 163B 5.6s
2022-08-21 20:53:53.153Z: #4 sha256:5deec403a9280d099b31923d05d0cf7a658ab22f6b836ee92705ae269f11d072 1.39MB / 1.39MB 5.5s done
2022-08-21 20:53:53.215Z: #4 sha256:1ff42478180f1776b67288595f3b4d885fba33604bb599ad0347f564e1a841a3 163B / 163B 5.9s
2022-08-21 20:53:53.261Z: #4 sha256:1ff42478180f1776b67288595f3b4d885fba33604bb599ad0347f564e1a841a3 163B / 163B 6.0s done
2022-08-21 20:53:53.308Z: #4 sha256:89ed0b628b705fed9bf38fdd582a6d548c07278d1ed17ac05405def5d24dbc2e 0B / 401.06kB 6.0s
2022-08-21 20:53:53.355Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 300.94MB / 586.19MB 6.2s
2022-08-21 20:53:53.400Z: #4 sha256:89ed0b628b705fed9bf38fdd582a6d548c07278d1ed17ac05405def5d24dbc2e 401.06kB / 401.06kB 6.5s
2022-08-21 20:53:53.440Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 338.69MB / 586.19MB 6.8s
2022-08-21 20:53:53.492Z: #4 sha256:1a6513998b39bb26953b08d6542141b5a48ae12069cda071e587f1327ae038e7 0B / 1.85kB 6.9s
2022-08-21 20:53:53.521Z: #4 sha256:89ed0b628b705fed9bf38fdd582a6d548c07278d1ed17ac05405def5d24dbc2e 401.06kB / 401.06kB 6.8s done
2022-08-21 20:53:53.569Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 0B / 1.00GB 7.1s
2022-08-21 20:53:53.603Z: #4 sha256:1a6513998b39bb26953b08d6542141b5a48ae12069cda071e587f1327ae038e7 1.85kB / 1.85kB 7.2s
2022-08-21 20:53:53.627Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 368.05MB / 586.19MB 7.3s
2022-08-21 20:53:53.652Z: 
2022-08-21 20:53:53.673Z: #4 sha256:1a6513998b39bb26953b08d6542141b5a48ae12069cda071e587f1327ae038e7 1.85kB / 1.85kB 7.2s done
2022-08-21 20:53:53.785Z: #4 sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 0B / 25.56MB 7.4s
2022-08-21 20:53:54.067Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 397.41MB / 586.19MB 7.8s
2022-08-21 20:53:54.093Z: 
2022-08-21 20:53:54.178Z: #4 sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 4.19MB / 25.56MB 7.9s
2022-08-21 20:53:54.272Z: #4 sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 10.49MB / 25.56MB 8.0s
2022-08-21 20:53:54.415Z: #4 sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 15.73MB / 25.56MB 8.1s
2022-08-21 20:53:54.436Z: 
2022-08-21 20:53:54.554Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 428.87MB / 586.19MB 8.3s
2022-08-21 20:53:54.687Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 50.33MB / 1.00GB 8.3s
2022-08-21 20:53:54.713Z: #4 sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 25.56MB / 25.56MB 8.3s
2022-08-21 20:53:54.839Z: #4 sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 25.56MB / 25.56MB 8.4s done
2022-08-21 20:53:54.974Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 0B / 1.70GB 8.7s
2022-08-21 20:53:55.111Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 460.32MB / 586.19MB 8.8s
2022-08-21 20:53:55.576Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 491.78MB / 586.19MB 9.3s
2022-08-21 20:53:55.596Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 106.95MB / 1.00GB 9.3s
2022-08-21 20:53:56.104Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 523.24MB / 586.19MB 9.8s
2022-08-21 20:53:56.595Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 556.79MB / 586.19MB 10.3s
2022-08-21 20:53:56.614Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 164.63MB / 1.00GB 10.3s
2022-08-21 20:53:56.878Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 94.37MB / 1.70GB 10.6s
2022-08-21 20:53:57.156Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 586.19MB / 586.19MB 10.9s
2022-08-21 20:53:58.318Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 214.96MB / 1.00GB 11.1s
2022-08-21 20:53:58.376Z: #4 sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 586.19MB / 586.19MB 12.0s done
2022-08-21 20:53:58.398Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 275.78MB / 1.00GB 12.1s
2022-08-21 20:53:58.419Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 184.55MB / 1.70GB 12.1s
2022-08-21 20:53:58.493Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa
2022-08-21 20:53:59.326Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 333.45MB / 1.00GB 13.0s
2022-08-21 20:53:59.772Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 270.53MB / 1.70GB 13.5s
2022-08-21 20:54:01.719Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 396.36MB / 1.00GB 14.0s
2022-08-21 20:54:01.753Z: 
2022-08-21 20:54:01.793Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 360.71MB / 1.70GB 14.7s
2022-08-21 20:54:01.817Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 448.79MB / 1.00GB 14.8s
2022-08-21 20:54:01.874Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 502.27MB / 1.00GB 15.6s
2022-08-21 20:54:02.333Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 458.23MB / 1.70GB 16.0s
2022-08-21 20:54:02.897Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 552.60MB / 1.00GB 16.3s
2022-08-21 20:54:03.387Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 610.27MB / 1.00GB 17.1s
2022-08-21 20:54:04.698Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 545.26MB / 1.70GB 17.1s
2022-08-21 20:54:04.733Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 5.0s
2022-08-21 20:54:04.865Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 662.70MB / 1.00GB 17.8s
2022-08-21 20:54:05.021Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 635.44MB / 1.70GB 18.1s
2022-08-21 20:54:05.176Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 714.08MB / 1.00GB 18.5s
2022-08-21 20:54:05.721Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 778.04MB / 1.00GB 19.3s
2022-08-21 20:54:05.817Z: 
2022-08-21 20:54:05.845Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 746.59MB / 1.70GB 19.3s
2022-08-21 20:54:05.869Z: 
2022-08-21 20:54:06.285Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 829.42MB / 1.00GB 20.0s
2022-08-21 20:54:07.835Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 832.57MB / 1.70GB 20.4s
2022-08-21 20:54:07.890Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 882.90MB / 1.00GB 20.6s
2022-08-21 20:54:07.981Z: 
2022-08-21 20:54:08.053Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 923.80MB / 1.70GB 21.1s
2022-08-21 20:54:08.174Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 950.76MB / 1.00GB 21.4s
2022-08-21 20:54:08.381Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 1.00GB / 1.00GB 22.1s
2022-08-21 20:54:08.987Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.02GB / 1.70GB 22.1s
2022-08-21 20:54:09.212Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 10.5s
2022-08-21 20:54:09.538Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.12GB / 1.70GB 23.1s
2022-08-21 20:54:10.280Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.22GB / 1.70GB 24.0s
2022-08-21 20:54:10.629Z: #4 sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 1.00GB / 1.00GB 24.2s done
2022-08-21 20:54:11.279Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.31GB / 1.70GB 25.0s
2022-08-21 20:54:12.766Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.40GB / 1.70GB 25.8s
2022-08-21 20:54:12.977Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.49GB / 1.70GB 26.7s
2022-08-21 20:54:13.884Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.58GB / 1.70GB 27.6s
2022-08-21 20:54:14.023Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 15.5s
2022-08-21 20:54:14.816Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.67GB / 1.70GB 28.5s
2022-08-21 20:54:17.072Z: #4 sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 1.70GB / 1.70GB 30.7s done
2022-08-21 20:54:19.018Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 20.5s
2022-08-21 20:54:24.035Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 25.6s
2022-08-21 20:54:29.128Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 30.6s
2022-08-21 20:54:34.184Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 35.7s
2022-08-21 20:54:35.699Z: #4 extracting sha256:06c38813aa6b32a65bcc7996a0cc868ca3be8f71b4348e7b914adce0e6a3faaa 37.1s done
2022-08-21 20:54:37.352Z: #4 extracting sha256:27782e898ee11a1c3c324c54c547be9cab2373629fe435f4cc784a43cf314f06 done
2022-08-21 20:54:37.659Z: #4 extracting sha256:091fd60a25cb05119bd3931d4783425b189c77306de4af960ab827ee00e487f8 done
2022-08-21 20:54:37.799Z: #4 extracting sha256:90dc587b3c2513899bb997509148df4e201d51513840744c9b6cf7533195cad4
2022-08-21 20:54:37.829Z: 
2022-08-21 20:54:37.968Z: #4 extracting sha256:90dc587b3c2513899bb997509148df4e201d51513840744c9b6cf7533195cad4 done
2022-08-21 20:54:38.107Z: #4 extracting sha256:5a50adec57df3aca1fa7336a8548b0e04b0e5fda1456360b002c5d22b4e7b667
2022-08-21 20:54:38.128Z: 
2022-08-21 20:54:38.247Z: #4 extracting sha256:5a50adec57df3aca1fa7336a8548b0e04b0e5fda1456360b002c5d22b4e7b667 done
2022-08-21 20:54:38.360Z: #4 extracting sha256:dd94103c9405f111d83aab38ea06d53c95977698c0e6d94fad8dce62d606c2d2
2022-08-21 20:54:38.527Z: #4 extracting sha256:dd94103c9405f111d83aab38ea06d53c95977698c0e6d94fad8dce62d606c2d2 done
2022-08-21 20:54:38.618Z: #4 extracting sha256:0b8574558a8f619b7acf46defc7a408fd9c6eebdee6399a0eb107d8b4953c221
2022-08-21 20:54:38.641Z: 
2022-08-21 20:54:38.756Z: #4 extracting sha256:0b8574558a8f619b7acf46defc7a408fd9c6eebdee6399a0eb107d8b4953c221 done
2022-08-21 20:54:38.895Z: #4 extracting sha256:df34989ca33f2b624e39bd7afc6e3d97202576022464ef00b26f1cee4291e502
2022-08-21 20:54:39.039Z: #4 extracting sha256:df34989ca33f2b624e39bd7afc6e3d97202576022464ef00b26f1cee4291e502 done
2022-08-21 20:54:39.179Z: #4 extracting sha256:221958f57eea077c3ca6533df00daec091409a9533ce970a472ba1afa101e213
2022-08-21 20:54:39.319Z: #4 extracting sha256:221958f57eea077c3ca6533df00daec091409a9533ce970a472ba1afa101e213 0.1s done
2022-08-21 20:54:39.460Z: #4 extracting sha256:e20260c12bf17b43999e51629030cfc081f5210c054e26d0256b37927568b252
2022-08-21 20:54:40.133Z: #4 extracting sha256:e20260c12bf17b43999e51629030cfc081f5210c054e26d0256b37927568b252 0.6s done
2022-08-21 20:54:40.581Z: #4 extracting sha256:5deec403a9280d099b31923d05d0cf7a658ab22f6b836ee92705ae269f11d072
2022-08-21 20:54:40.833Z: #4 extracting sha256:5deec403a9280d099b31923d05d0cf7a658ab22f6b836ee92705ae269f11d072 0.2s done
2022-08-21 20:54:41.088Z: #4 extracting sha256:1ff42478180f1776b67288595f3b4d885fba33604bb599ad0347f564e1a841a3
2022-08-21 20:54:41.253Z: #4 extracting sha256:1ff42478180f1776b67288595f3b4d885fba33604bb599ad0347f564e1a841a3 done
2022-08-21 20:54:41.366Z: #4 extracting sha256:89ed0b628b705fed9bf38fdd582a6d548c07278d1ed17ac05405def5d24dbc2e
2022-08-21 20:54:41.505Z: #4 extracting sha256:89ed0b628b705fed9bf38fdd582a6d548c07278d1ed17ac05405def5d24dbc2e 0.1s done
2022-08-21 20:54:41.645Z: #4 extracting sha256:1a6513998b39bb26953b08d6542141b5a48ae12069cda071e587f1327ae038e7
2022-08-21 20:54:41.784Z: #4 extracting sha256:1a6513998b39bb26953b08d6542141b5a48ae12069cda071e587f1327ae038e7 done
2022-08-21 20:54:42.071Z: #4 extracting sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 0.1s
2022-08-21 20:54:47.161Z: #4 extracting sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 5.2s
2022-08-21 20:54:52.218Z: #4 extracting sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 10.2s
2022-08-21 20:54:57.405Z: #4 extracting sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 15.4s
2022-08-21 20:55:02.569Z: #4 extracting sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 20.6s
2022-08-21 20:55:06.761Z: #4 extracting sha256:149b0e49ed91abdf6c833200f1c3a9215201479d42fc619d145cb09bb4457769 24.7s done
2022-08-21 20:55:08.720Z: #4 extracting sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43
2022-08-21 20:55:10.263Z: #4 extracting sha256:a9802ac3c7a2b17639283e9047468f73a9f7a8c2e9d431bb20776d90886fda43 1.4s done
2022-08-21 20:55:11.160Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 0.1s
2022-08-21 20:55:16.276Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 5.2s
2022-08-21 20:55:21.299Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 10.2s
2022-08-21 20:55:26.399Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 15.3s
2022-08-21 20:55:31.413Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 20.4s
2022-08-21 20:55:36.433Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 25.4s
2022-08-21 20:55:41.432Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 30.4s
2022-08-21 20:55:46.588Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 35.5s
2022-08-21 20:55:51.665Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 40.6s
2022-08-21 20:55:56.687Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 45.6s
2022-08-21 20:56:01.744Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 50.7s
2022-08-21 20:56:06.792Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 55.7s
2022-08-21 20:56:11.856Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 60.8s
2022-08-21 20:56:15.200Z: #4 extracting sha256:3b1e60273ffaa3ed8e4b40305896268d5f89779173b4431ffdff1219f8bfe952 64.1s done
2022-08-21 20:56:23.465Z: #4 ...
2022-08-21 20:56:23.505Z: 
2022-08-21 20:56:23.534Z: #5 exporting to image
2022-08-21 20:56:23.564Z: #5 exporting layers done
2022-08-21 20:56:23.876Z: #5 writing image sha256:05758e709ba75d931c0f0db9d148400bc5c62cb0d8e9849b42b711af8df0e9f6 0.0s done
2022-08-21 20:56:23.920Z: #5 naming to docker.io/library/vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 0.0s done
2022-08-21 20:56:23.961Z: #5 DONE 0.5s
2022-08-21 20:56:23.988Z: 
2022-08-21 20:56:24.026Z: #4 [1/1] FROM ghcr.io/sagemath/sage/sage-docker-ubuntu-jammy-standard-with-targets:dev@sha256:99664006e200e598940648fd313e953fb7e83890fffd25898ac0d0032b49ee95
2022-08-21 20:56:24.063Z: #4 ...
2022-08-21 20:56:24.095Z: 
2022-08-21 20:56:24.128Z: #6 exporting cache
2022-08-21 20:56:24.158Z: #6 preparing build cache for export done
2022-08-21 20:56:24.186Z: #6 DONE 0.0s
2022-08-21 20:56:24.215Z: Stop (159582 ms): Run: docker buildx build --load --build-arg BUILDKIT_INLINE_CACHE=1 -f /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/portability-Dockerfile -t vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 --build-arg SYSTEM_FACTOR=ubuntu-jammy --build-arg PACKAGE_FACTOR=standard --build-arg DOCKER_TARGET=with-targets --build-arg DOCKER_TAG=dev /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard
2022-08-21 20:56:24.257Z: $ docker -v
2022-08-21 20:56:24.298Z: Stop (38 ms): Run: docker -v
2022-08-21 20:56:24.342Z: $ docker events --format {{json .}} --filter event=start
2022-08-21 20:56:24.386Z: Start: Starting container
2022-08-21 20:56:24.429Z: $127.0.0.1 --cap-add sys_nice --network host --entrypoint /bin/sh vsc-sagetrac-mirror-75078c9b69c284c8b1e1c83da9ecd534 -c echo Container started
2022-08-21 20:56:24.967Z: Stop (1019 ms): Starting container
2022-08-21 20:56:24.995Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:56:25.018Z: Stop (1026 ms): Run: docker events --format {{json .}} --filter event=start
2022-08-21 20:56:25.060Z: Stop (43 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:56:25.090Z: $ docker inspect --type container 52218116cc3e
2022-08-21 20:56:25.122Z: Container started
2022-08-21 20:56:25.140Z: 
2022-08-21 20:56:25.158Z: Stop (36 ms): Run: docker inspect --type container 52218116cc3e
2022-08-21 20:56:25.181Z: Start: Inspecting container
2022-08-21 20:56:25.208Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:25.257Z: Stop (40 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:25.280Z: Stop (40 ms): Inspecting container
2022-08-21 20:56:25.334Z: $ /bin/sh
2022-08-21 20:56:25.379Z: $ uname -m
2022-08-21 20:56:25.421Z: x86_64
2022-08-21 20:56:25.461Z: 
2022-08-21 20:56:25.512Z: Stop (144 ms): Run in container: uname -m
2022-08-21 20:56:25.557Z: $ (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:25.588Z: PRETTY_NAME="Ubuntu 22.04.1 LTS"
2022-08-21 20:56:25.611Z: NAME="Ubuntu"
2022-08-21 20:56:25.636Z: VERSION_ID="22.04"
2022-08-21 20:56:25.656Z: VERSION="22.04.1 LTS (Jammy Jellyfish)"
2022-08-21 20:56:25.676Z: VERSION_CODENAME=jammy
2022-08-21 20:56:25.703Z: ID=ubuntu
2022-08-21 20:56:25.745Z: ID_LIKE=debian
2022-08-21 20:56:25.771Z: HOME_URL="https://www.ubuntu.com/"
2022-08-21 20:56:25.800Z: SUPPORT_URL="https://help.ubuntu.com/"
2022-08-21 20:56:25.824Z: BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
2022-08-21 20:56:25.844Z: PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
2022-08-21 20:56:25.868Z: UBUNTU_CODENAME=jammy
2022-08-21 20:56:25.887Z: 
2022-08-21 20:56:25.907Z: Stop (63 ms): Run in container: (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:25.928Z: $ cat /etc/passwd
2022-08-21 20:56:25.947Z: Stop (1 ms): Run in container: cat /etc/passwd
2022-08-21 20:56:25.978Z: $ test -f '/var/vscode-remote/.patchEtcEnvironmentMarker'
2022-08-21 20:56:26.022Z: 
2022-08-21 20:56:26.049Z: 
2022-08-21 20:56:26.070Z: Exit code 1
2022-08-21 20:56:26.101Z: Stop (1 ms): Run in container: test -f '/var/vscode-remote/.patchEtcEnvironmentMarker'
2022-08-21 20:56:26.126Z: $ test ! -f '/var/vscode-remote/.patchEtcEnvironmentMarker' && set -o noclobber && mkdir -p '/var/vscode-remote' && { > '/var/vscode-remote/.patchEtcEnvironmentMarker' ; } 2> /dev/null
2022-08-21 20:56:26.145Z: 
2022-08-21 20:56:26.165Z: 
2022-08-21 20:56:26.184Z: Stop (160 ms): Run in container: test ! -f '/var/vscode-remote/.patchEtcEnvironmentMarker' && set -o noclobber && mkdir -p '/var/vscode-remote' && { > '/var/vscode-remote/.patchEtcEnvironmentMarker' ; } 2> /dev/null
2022-08-21 20:56:26.208Z: $ cat >> /etc/environment <<'etcEnvrionmentEOF'
2022-08-21 20:56:26.235Z: 
2022-08-21 20:56:26.260Z: 
2022-08-21 20:56:26.281Z: Stop (48 ms): Run in container: cat >> /etc/environment <<'etcEnvrionmentEOF'
2022-08-21 20:56:26.300Z: $ test -f '/var/vscode-remote/.patchEtcProfileMarker'
2022-08-21 20:56:26.320Z: 
2022-08-21 20:56:26.339Z: 
2022-08-21 20:56:26.358Z: Exit code 1
2022-08-21 20:56:26.377Z: Stop (1 ms): Run in container: test -f '/var/vscode-remote/.patchEtcProfileMarker'
2022-08-21 20:56:26.396Z: $ test ! -f '/var/vscode-remote/.patchEtcProfileMarker' && set -o noclobber && mkdir -p '/var/vscode-remote' && { > '/var/vscode-remote/.patchEtcProfileMarker' ; } 2> /dev/null
2022-08-21 20:56:26.421Z: 
2022-08-21 20:56:26.448Z: 
2022-08-21 20:56:26.470Z: Stop (2 ms): Run in container: test ! -f '/var/vscode-remote/.patchEtcProfileMarker' && set -o noclobber && mkdir -p '/var/vscode-remote' && { > '/var/vscode-remote/.patchEtcProfileMarker' ; } 2> /dev/null
2022-08-21 20:56:26.494Z: $-\3}/g' /etc/profile || true
2022-08-21 20:56:26.513Z: 
2022-08-21 20:56:26.531Z: 
2022-08-21 20:56:26.552Z: Stop (104 ms): Run in container: sed -i -E 's/((^|\s)PATH=)([^\$]*)$/\1${PATH:-\3}/g' /etc/profile || true
2022-08-21 20:56:26.578Z: Stop (161429 ms): Resolving Remote
2022-08-21 20:56:26.597Z: Stop (161715 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /var/lib/docker/codespacemount/.persistedshare --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --remove-existing-container --mount type=bind,source=/.codespaces/agent/mount/cache,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 20:56:26.615Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:26.639Z: Stop (43 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:26.659Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js read-configuration --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --mount-workspace-git-root false
2022-08-21 20:56:26.688Z: Stop (171 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js read-configuration --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --mount-workspace-git-root false
2022-08-21 20:56:26.718Z: Start: Inspecting container
2022-08-21 20:56:26.741Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:26.761Z: Stop (38 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:26.781Z: Stop (39 ms): Inspecting container
2022-08-21 20:56:26.803Z: $ /bin/sh
2022-08-21 20:56:26.854Z: $ uname -m
2022-08-21 20:56:26.882Z: x86_64
2022-08-21 20:56:26.909Z: 
2022-08-21 20:56:26.929Z: Stop (96 ms): Run in container: uname -m
2022-08-21 20:56:26.949Z: $ (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:26.972Z: PRETTY_NAME="Ubuntu 22.04.1 LTS"
2022-08-21 20:56:26.995Z: NAME="Ubuntu"
2022-08-21 20:56:27.023Z: VERSION_ID="22.04"
2022-08-21 20:56:27.041Z: VERSION="22.04.1 LTS (Jammy Jellyfish)"
2022-08-21 20:56:27.062Z: VERSION_CODENAME=jammy
2022-08-21 20:56:27.090Z: ID=ubuntu
2022-08-21 20:56:27.119Z: ID_LIKE=debian
2022-08-21 20:56:27.149Z: HOME_URL="https://www.ubuntu.com/"
2022-08-21 20:56:27.172Z: SUPPORT_URL="https://help.ubuntu.com/"
2022-08-21 20:56:27.201Z: BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
2022-08-21 20:56:27.225Z: PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
2022-08-21 20:56:27.244Z: UBUNTU_CODENAME=jammy
2022-08-21 20:56:27.263Z: 
2022-08-21 20:56:27.293Z: Stop (2 ms): Run in container: (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:27.318Z: $ cat /etc/passwd
2022-08-21 20:56:27.345Z: Stop (2 ms): Run in container: cat /etc/passwd
2022-08-21 20:56:27.365Z: Start: Updating configuration state
2022-08-21 20:56:27.386Z: Stop (64 ms): Updating configuration state
2022-08-21 20:56:27.406Z: $ test -d /root/.vscode-remote
2022-08-21 20:56:27.428Z: 
2022-08-21 20:56:27.455Z: 
2022-08-21 20:56:27.478Z: Exit code 1
2022-08-21 20:56:27.497Z: Stop (1 ms): Run in container: test -d /root/.vscode-remote
2022-08-21 20:56:27.516Z: $ test -d /root/.vscode-remote
2022-08-21 20:56:27.535Z: 
2022-08-21 20:56:27.554Z: 
2022-08-21 20:56:27.573Z: Exit code 1
2022-08-21 20:56:27.592Z: Stop (1 ms): Run in container: test -d /root/.vscode-remote
2022-08-21 20:56:27.611Z: $ test ! -f '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' && set -o noclobber && mkdir -p '/root/.vscode-remote/data/Machine' && { > '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' ; } 2> /dev/null
2022-08-21 20:56:27.633Z: 
2022-08-21 20:56:27.652Z: 
2022-08-21 20:56:27.677Z: Stop (2 ms): Run in container: test ! -f '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' && set -o noclobber && mkdir -p '/root/.vscode-remote/data/Machine' && { > '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' ; } 2> /dev/null
2022-08-21 20:56:27.696Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js read-configuration --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --include-features-configuration --mount-workspace-git-root false
2022-08-21 20:56:27.715Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 20:56:27.734Z: Stop (160 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js read-configuration --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --include-features-configuration --mount-workspace-git-root false
2022-08-21 20:56:27.754Z: $ cat /root/.vscode-remote/data/Machine/settings.json
2022-08-21 20:56:27.773Z: 
2022-08-21 20:56:27.792Z: cat: /root/.vscode-remote/data/Machine/settings.json: No such file or directory
2022-08-21 20:56:27.810Z: Exit code 1
2022-08-21 20:56:27.829Z: Stop (2 ms): Run in container: cat /root/.vscode-remote/data/Machine/settings.json
2022-08-21 20:56:27.848Z: Stop (162357 ms): Resolving Remote
2022-08-21 20:56:28.715Z: $ cp -r /root/.docker /var/lib/docker/codespacemount/.persistedshare
2022-08-21 20:56:28.747Z: cp process exited with exit code 0
2022-08-21 20:56:28.770Z: $ rm -rf /root/.docker
2022-08-21 20:56:28.873Z: rm process exited with exit code 0
2022-08-21 20:56:28.894Z: $ ln -sfn /workspaces/.codespaces/.persistedshare/.docker /root/.docker
2022-08-21 20:56:29.006Z: ln process exited with exit code 0
2022-08-21 20:56:29.026Z: $ chown -R root /workspaces/.codespaces/.persistedshare/.docker
2022-08-21 20:56:29.119Z: chown process exited with exit code 0
2022-08-21 20:56:29.448Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 20:56:29.475Z: Start: Resolving Remote
2022-08-21 20:56:29.495Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:56:29.514Z: Stop (41 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:56:29.533Z: $ docker inspect --type container 52218116cc3e
2022-08-21 20:56:29.552Z: Stop (37 ms): Run: docker inspect --type container 52218116cc3e
2022-08-21 20:56:29.573Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /tmp --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --expect-existing-container --mount type=bind,source=/tmp/vsch-root,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 20:56:29.643Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 20:56:29.664Z: $ docker buildx version
2022-08-21 20:56:29.839Z: Stop (192 ms): Run: docker buildx version
2022-08-21 20:56:29.859Z: Start: Resolving Remote
2022-08-21 20:56:29.878Z: $ docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:56:29.898Z: Stop (37 ms): Run: docker ps -q -a --filter label=Type=codespaces
2022-08-21 20:56:29.918Z: $ docker inspect --type container 52218116cc3e
2022-08-21 20:56:29.937Z: Stop (35 ms): Run: docker inspect --type container 52218116cc3e
2022-08-21 20:56:29.956Z: Start: Inspecting container
2022-08-21 20:56:29.979Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:30.001Z: Stop (35 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:30.024Z: Stop (35 ms): Inspecting container
2022-08-21 20:56:30.043Z: $ /bin/sh
2022-08-21 20:56:30.066Z: $ uname -m
2022-08-21 20:56:30.086Z: x86_64
2022-08-21 20:56:30.105Z: 
2022-08-21 20:56:30.124Z: Stop (102 ms): Run in container: uname -m
2022-08-21 20:56:30.143Z: $ (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:30.162Z: PRETTY_NAME="Ubuntu 22.04.1 LTS"
2022-08-21 20:56:30.184Z: NAME="Ubuntu"
2022-08-21 20:56:30.202Z: VERSION_ID="22.04"
2022-08-21 20:56:30.221Z: VERSION="22.04.1 LTS (Jammy Jellyfish)"
2022-08-21 20:56:30.240Z: VERSION_CODENAME=jammy
2022-08-21 20:56:30.259Z: ID=ubuntu
2022-08-21 20:56:30.279Z: ID_LIKE=debian
2022-08-21 20:56:30.302Z: HOME_URL="https://www.ubuntu.com/"
2022-08-21 20:56:30.324Z: SUPPORT_URL="https://help.ubuntu.com/"
2022-08-21 20:56:30.345Z: BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
2022-08-21 20:56:30.365Z: PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
2022-08-21 20:56:30.385Z: UBUNTU_CODENAME=jammy
2022-08-21 20:56:30.404Z: 
2022-08-21 20:56:30.424Z: Stop (2 ms): Run in container: (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:30.445Z: $ cat /etc/passwd
2022-08-21 20:56:30.464Z: Stop (2 ms): Run in container: cat /etc/passwd
2022-08-21 20:56:30.487Z: $ test -f '/var/vscode-remote/.patchEtcEnvironmentMarker'
2022-08-21 20:56:30.506Z: 
2022-08-21 20:56:30.526Z: 
2022-08-21 20:56:30.544Z: Stop (1 ms): Run in container: test -f '/var/vscode-remote/.patchEtcEnvironmentMarker'
2022-08-21 20:56:30.573Z: $ test -f '/var/vscode-remote/.patchEtcProfileMarker'
2022-08-21 20:56:30.591Z: 
2022-08-21 20:56:30.610Z: 
2022-08-21 20:56:30.630Z: Stop (0 ms): Run in container: test -f '/var/vscode-remote/.patchEtcProfileMarker'
2022-08-21 20:56:30.669Z: Stop (227 ms): Resolving Remote
2022-08-21 20:56:30.696Z: Stop (529 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js up --user-data-folder /tmp --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --id-label Type=codespaces --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --expect-existing-container --mount type=bind,source=/tmp/vsch-root,target=/vscode --skip-post-create --update-remote-user-uid-default never --mount-workspace-git-root false
2022-08-21 20:56:30.737Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:30.782Z: Stop (55 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:30.812Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js read-configuration --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --mount-workspace-git-root false
2022-08-21 20:56:30.852Z: Stop (184 ms): Run: /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js read-configuration --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --mount-workspace-git-root false
2022-08-21 20:56:30.875Z: Start: Inspecting container
2022-08-21 20:56:30.905Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:30.925Z: Stop (44 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:30.946Z: Stop (44 ms): Inspecting container
2022-08-21 20:56:30.967Z: $ /bin/sh
2022-08-21 20:56:30.986Z: $ uname -m
2022-08-21 20:56:31.007Z: x86_64
2022-08-21 20:56:31.026Z: 
2022-08-21 20:56:31.051Z: Stop (107 ms): Run in container: uname -m
2022-08-21 20:56:31.079Z: $ (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:31.108Z: PRETTY_NAME="Ubuntu 22.04.1 LTS"
2022-08-21 20:56:31.128Z: NAME="Ubuntu"
2022-08-21 20:56:31.149Z: VERSION_ID="22.04"
2022-08-21 20:56:31.171Z: VERSION="22.04.1 LTS (Jammy Jellyfish)"
2022-08-21 20:56:31.191Z: VERSION_CODENAME=jammy
2022-08-21 20:56:31.211Z: ID=ubuntu
2022-08-21 20:56:31.231Z: ID_LIKE=debian
2022-08-21 20:56:31.251Z: HOME_URL="https://www.ubuntu.com/"
2022-08-21 20:56:31.269Z: SUPPORT_URL="https://help.ubuntu.com/"
2022-08-21 20:56:31.289Z: BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
2022-08-21 20:56:31.311Z: PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
2022-08-21 20:56:31.329Z: UBUNTU_CODENAME=jammy
2022-08-21 20:56:31.349Z: 
2022-08-21 20:56:31.368Z: Stop (9 ms): Run in container: (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:31.387Z: $ cat /etc/passwd
2022-08-21 20:56:31.410Z: Stop (3 ms): Run in container: cat /etc/passwd
2022-08-21 20:56:31.430Z: $ test -d /root/.vscode-remote
2022-08-21 20:56:31.453Z: 
2022-08-21 20:56:31.473Z: 
2022-08-21 20:56:31.499Z: Stop (1 ms): Run in container: test -d /root/.vscode-remote
2022-08-21 20:56:31.531Z: $ test ! -f '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' && set -o noclobber && mkdir -p '/root/.vscode-remote/data/Machine' && { > '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' ; } 2> /dev/null
2022-08-21 20:56:31.558Z: 
2022-08-21 20:56:31.588Z: 
2022-08-21 20:56:31.627Z: Exit code 1
2022-08-21 20:56:31.663Z: Stop (1 ms): Run in container: test ! -f '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' && set -o noclobber && mkdir -p '/root/.vscode-remote/data/Machine' && { > '/root/.vscode-remote/data/Machine/.writeMachineSettingsMarker' ; } 2> /dev/null
2022-08-21 20:56:31.706Z: $ cat /root/.vscode-remote/data/Machine/settings.json
2022-08-21 20:56:31.763Z: 
2022-08-21 20:56:31.809Z: cat: /root/.vscode-remote/data/Machine/settings.json: No such file or directory
2022-08-21 20:56:31.877Z: Exit code 1
2022-08-21 20:56:31.918Z: Stop (2 ms): Run in container: cat /root/.vscode-remote/data/Machine/settings.json
2022-08-21 20:56:31.961Z: userEnvProbe: loginInteractiveShell (default)
2022-08-21 20:56:32.008Z: $ /usr/bin/node /usr/lib/node_modules/@microsoft/vscode-dev-containers-cli/dist/spec-node/devContainersSpecCLI.js run-user-commands --user-data-folder /tmp --container-data-folder .vscode-remote/data/Machine --container-system-data-folder /var/vscode-remote --workspace-folder /var/lib/docker/codespacemount/workspace/sagetrac-mirror --container-id 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210 --log-level info --log-format json --config /var/lib/docker/codespacemount/workspace/sagetrac-mirror/.devcontainer/portability-ubuntu-jammy-standard/devcontainer.json --override-config /root/.codespaces/shared/merged_devcontainer.json --default-user-env-probe loginInteractiveShell --skip-non-blocking-commands true --prebuild false --stop-for-personalization true --mount-workspace-git-root false
2022-08-21 20:56:32.029Z: userEnvProbe shell: /bin/bash
2022-08-21 20:56:32.066Z: $ /bin/bash -lic echo -n 083debc4be67035e0f5cbf44ca808fb8; cat /proc/self/environ; echo -n 083debc4be67035e0f5cbf44ca808fb8
2022-08-21 20:56:32.104Z: @microsoft/vscode-dev-containers-cli 0.66.0.
2022-08-21 20:56:32.132Z: $ docker buildx version
2022-08-21 20:56:32.195Z: Stop (166 ms): Run: docker buildx version
2022-08-21 20:56:32.216Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:32.243Z: Stop (57 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:32.265Z: Start: Inspecting container
2022-08-21 20:56:32.291Z: $ docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:32.309Z: Stop (59 ms): Run: docker inspect --type container 52218116cc3ee79e6543e92e5f20d4574d43ab6bd4dced86ca976c452a4ee210
2022-08-21 20:56:32.328Z: Stop (60 ms): Inspecting container
2022-08-21 20:56:32.355Z: $ /bin/sh
2022-08-21 20:56:32.387Z: $ uname -m
2022-08-21 20:56:32.419Z: Stop (625 ms): Run in container: /bin/bash -lic echo -n 083debc4be67035e0f5cbf44ca808fb8; cat /proc/self/environ; echo -n 083debc4be67035e0f5cbf44ca808fb8
2022-08-21 20:56:32.449Z: userEnvProbe PATHs:
2022-08-21 20:56:32.496Z: Probe:     '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
2022-08-21 20:56:32.538Z: Container: '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
2022-08-21 20:56:32.588Z: x86_64
2022-08-21 20:56:32.613Z: 
2022-08-21 20:56:32.665Z: Stop (168 ms): Run in container: uname -m
2022-08-21 20:56:32.740Z: $ (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:32.766Z: PRETTY_NAME="Ubuntu 22.04.1 LTS"
2022-08-21 20:56:32.832Z: NAME="Ubuntu"
2022-08-21 20:56:32.872Z: VERSION_ID="22.04"
2022-08-21 20:56:32.921Z: VERSION="22.04.1 LTS (Jammy Jellyfish)"
2022-08-21 20:56:32.998Z: VERSION_CODENAME=jammy
2022-08-21 20:56:33.043Z: ID=ubuntu
2022-08-21 20:56:33.079Z: ID_LIKE=debian
2022-08-21 20:56:33.131Z: HOME_URL="https://www.ubuntu.com/"
2022-08-21 20:56:33.166Z: SUPPORT_URL="https://help.ubuntu.com/"
2022-08-21 20:56:33.207Z: BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
2022-08-21 20:56:33.230Z: PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
2022-08-21 20:56:33.249Z: UBUNTU_CODENAME=jammy
2022-08-21 20:56:33.269Z: 
2022-08-21 20:56:33.289Z: Stop (3 ms): Run in container: (cat /etc/os-release || cat /usr/lib/os-release) 2>/dev/null
2022-08-21 20:56:33.308Z: $ cat /etc/passwd
2022-08-21 20:56:33.351Z: Stop (2 ms): Run in container: cat /etc/passwd
2022-08-21 20:56:33.369Z: userEnvProbe: loginInteractiveShell (default)
2022-08-21 20:56:33.403Z: $23.980394847Z' > '/root/.vscode-remote/data/Machine/.onCreateCommandMarker'
2022-08-21 20:56:33.425Z: userEnvProbe shell: /bin/bash
2022-08-21 20:56:33.444Z: $ /bin/bash -lic echo -n 1c5891524b4aae6a549b7afb73fe2f98; cat /proc/self/environ; echo -n 1c5891524b4aae6a549b7afb73fe2f98
2022-08-21 20:56:33.463Z: 
2022-08-21 20:56:33.483Z: 
2022-08-21 20:56:33.505Z: && echo '2022-08-21T20:56:23.980394847Z' > '/root/.vscode-remote/data/Machine/.onCreateCommandMarker'
2022-08-21 20:56:33.535Z: Running the onCreateCommand from devcontainer.json...
2022-08-21 20:56:33.554Z: 
2022-08-21 20:56:33.581Z: Stop (260 ms): Run in container: /bin/bash -lic echo -n 1c5891524b4aae6a549b7afb73fe2f98; cat /proc/self/environ; echo -n 1c5891524b4aae6a549b7afb73fe2f98
2022-08-21 20:56:33.602Z: userEnvProbe PATHs:
2022-08-21 20:56:33.643Z: Probe:     '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
2022-08-21 20:56:33.667Z: Container: '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
2022-08-21 20:56:33.685Z: $ /bin/sh -c .devcontainer/post_create.sh
2022-08-21 20:56:33.708Z: 
2022-08-21 20:56:33.746Z: 0% [Working]
2022-08-21 20:56:33.772Z: 
2022-08-21 20:56:33.799Z:             
2022-08-21 20:56:33.818Z: Hit:1 http://archive.ubuntu.com/ubuntu jammy InRelease
2022-08-21 20:56:33.837Z: 
2022-08-21 20:56:33.865Z: 0% [Waiting for headers] [Connecting to security.ubuntu.com (91.189.91.38)]
2022-08-21 20:56:33.903Z:                                                                            
2022-08-21 20:56:33.923Z: Get:2 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]
2022-08-21 20:56:33.942Z: 
2022-08-21 20:56:33.961Z:                                                                            
2022-08-21 20:56:33.980Z: Get:3 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [99.8 kB]
2022-08-21 20:56:34.001Z: 
2022-08-21 20:56:34.019Z:                                                                            
2022-08-21 20:56:34.041Z: 0% [Waiting for headers]
2022-08-21 20:56:34.071Z: 
2022-08-21 20:56:34.108Z:                         
2022-08-21 20:56:34.135Z: Get:4 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
2022-08-21 20:56:34.155Z: 
2022-08-21 20:56:34.177Z: 0% [4 InRelease 12.3 kB/110 kB 11%]
2022-08-21 20:56:34.199Z: 
2022-08-21 20:56:34.231Z:                                    
2022-08-21 20:56:34.250Z: 0% [Working]
2022-08-21 20:56:34.280Z: 
2022-08-21 20:56:34.303Z: 0% [Working]
2022-08-21 20:56:34.322Z: 
2022-08-21 20:56:34.341Z: 0% [Working]
2022-08-21 20:56:34.366Z: 
2022-08-21 20:56:34.384Z:             
2022-08-21 20:56:34.404Z: Get:5 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 Packages [354 kB]
2022-08-21 20:56:34.425Z: 
2022-08-21 20:56:34.451Z: 0% [5 Packages 91.2 kB/354 kB 26%]
2022-08-21 20:56:34.471Z: 
2022-08-21 20:56:34.490Z:                                   
2022-08-21 20:56:34.509Z: 0% [Working]
2022-08-21 20:56:34.529Z: 0% [5 Packages store 0 B]
2022-08-21 20:56:34.550Z: 
2022-08-21 20:56:34.570Z:                          
2022-08-21 20:56:34.589Z: Get:6 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 Packages [264 kB]
2022-08-21 20:56:34.611Z: 
2022-08-21 20:56:34.630Z: 0% [5 Packages store 0 B] [6 Packages 20.7 kB/264 kB 8%]
2022-08-21 20:56:34.650Z: 
2022-08-21 20:56:34.676Z:                                                         
2022-08-21 20:56:34.698Z: 0% [5 Packages store 0 B]
2022-08-21 20:56:34.722Z:                          
2022-08-21 20:56:34.742Z: Get:7 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages [641 kB]
2022-08-21 20:56:34.761Z: 
2022-08-21 20:56:34.783Z: 0% [5 Packages store 0 B] [7 Packages 0 B/641 kB 0%]
2022-08-21 20:56:34.801Z: 
2022-08-21 20:56:34.821Z:                                                     
2022-08-21 20:56:34.851Z: 0% [5 Packages store 0 B]
2022-08-21 20:56:34.899Z: 
2022-08-21 20:56:34.934Z:                          
2022-08-21 20:56:34.970Z: 0% [Working]
2022-08-21 20:56:35.009Z: 0% [6 Packages store 0 B]
2022-08-21 20:56:35.045Z: 
2022-08-21 20:56:35.071Z:                          
2022-08-21 20:56:35.096Z: 0% [Working]
2022-08-21 20:56:35.139Z: 
2022-08-21 20:56:35.165Z: 0% [7 Packages store 0 B]
2022-08-21 20:56:35.188Z: 
2022-08-21 20:56:35.227Z:                          
2022-08-21 20:56:35.252Z: 0% [Working]
2022-08-21 20:56:35.275Z: 
2022-08-21 20:56:35.313Z: 0% [Working]
2022-08-21 20:56:35.337Z: 
2022-08-21 20:56:35.370Z:             
2022-08-21 20:56:35.392Z: Get:8 http://archive.ubuntu.com/ubuntu jammy-backports/universe amd64 Packages [6909 B]
2022-08-21 20:56:35.418Z: 
2022-08-21 20:56:35.438Z: 0% [Working]
2022-08-21 20:56:35.463Z: 
2022-08-21 20:56:35.485Z: 0% [8 Packages store 0 B]
2022-08-21 20:56:35.505Z: 
2022-08-21 20:56:35.534Z:                          
2022-08-21 20:56:35.556Z: 0% [Working]
2022-08-21 20:56:35.589Z: 
2022-08-21 20:56:35.638Z: 72% [Working]
2022-08-21 20:56:35.671Z: 
2022-08-21 20:56:35.708Z:              
2022-08-21 20:56:35.728Z: Get:9 http://security.ubuntu.com/ubuntu jammy-security/main amd64 Packages [333 kB]
2022-08-21 20:56:35.753Z: 
2022-08-21 20:56:35.776Z: 72% [9 Packages 2647 B/333 kB 1%]
2022-08-21 20:56:35.799Z: 
2022-08-21 20:56:35.867Z:                                  
2022-08-21 20:56:35.892Z: 83% [Working]
2022-08-21 20:56:35.918Z: 
2022-08-21 20:56:35.939Z: 83% [9 Packages store 0 B] [Waiting for headers]
2022-08-21 20:56:35.959Z: 
2022-08-21 20:56:35.978Z:                                                 
2022-08-21 20:56:36.006Z: 84% [Waiting for headers]
2022-08-21 20:56:36.045Z: 
2022-08-21 20:56:36.068Z:                          
2022-08-21 20:56:36.088Z: Get:10 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 Packages [132 kB]
2022-08-21 20:56:36.125Z: 
2022-08-21 20:56:36.149Z: 84% [10 Packages 11.2 kB/132 kB 8%]
2022-08-21 20:56:36.168Z: 
2022-08-21 20:56:36.231Z:                                    
2022-08-21 20:56:36.273Z: Get:11 http://security.ubuntu.com/ubuntu jammy-security/restricted amd64 Packages [313 kB]
2022-08-21 20:56:36.312Z: 
2022-08-21 20:56:36.333Z:                                    
2022-08-21 20:56:36.360Z: 88% [11 Packages 394 B/313 kB 0%]
2022-08-21 20:56:36.389Z: 
2022-08-21 20:56:36.418Z: 90% [10 Packages store 0 B] [11 Packages 36.1 kB/313 kB 12%]
2022-08-21 20:56:36.438Z: 
2022-08-21 20:56:36.460Z:                                                             
2022-08-21 20:56:36.483Z: 91% [11 Packages 53.2 kB/313 kB 17%]
2022-08-21 20:56:36.505Z: 
2022-08-21 20:56:36.526Z:                                     
2022-08-21 20:56:36.565Z: 99% [Working]
2022-08-21 20:56:36.587Z: 99% [11 Packages store 0 B]
2022-08-21 20:56:36.612Z: 
2022-08-21 20:56:36.630Z:                            
2022-08-21 20:56:36.655Z: 100% [Working]
2022-08-21 20:56:36.674Z:               
2022-08-21 20:56:36.694Z: Fetched 2368 kB in 2s (1446 kB/s)
2022-08-21 20:56:36.714Z: 
2022-08-21 20:56:36.734Z: Reading package lists... 0%
2022-08-21 20:56:36.758Z: 
2022-08-21 20:56:36.789Z: Reading package lists... 0%
2022-08-21 20:56:36.809Z: 
2022-08-21 20:56:36.829Z: Reading package lists... 0%
2022-08-21 20:56:36.874Z: 
2022-08-21 20:56:36.893Z: Reading package lists... 8%
2022-08-21 20:56:36.912Z: 
2022-08-21 20:56:36.970Z: Reading package lists... 8%
2022-08-21 20:56:36.990Z: 
2022-08-21 20:56:37.013Z: Reading package lists... 9%
2022-08-21 20:56:37.040Z: 
2022-08-21 20:56:37.060Z: Reading package lists... 9%
2022-08-21 20:56:37.079Z: 
2022-08-21 20:56:37.098Z: Reading package lists... 74%
2022-08-21 20:56:37.138Z: 
2022-08-21 20:56:37.180Z: Reading package lists... 87%
2022-08-21 20:56:37.207Z: 
2022-08-21 20:56:37.255Z: Reading package lists... 87%
2022-08-21 20:56:37.275Z: 
2022-08-21 20:56:37.295Z: Reading package lists... 88%
2022-08-21 20:56:37.315Z: 
2022-08-21 20:56:37.336Z: Reading package lists... 88%
2022-08-21 20:56:37.359Z: 
2022-08-21 20:56:37.380Z: Reading package lists... 91%
2022-08-21 20:56:37.399Z: 
2022-08-21 20:56:37.419Z: Reading package lists... 91%
2022-08-21 20:56:37.438Z: 
2022-08-21 20:56:37.459Z: Reading package lists... 93%
2022-08-21 20:56:37.484Z: 
2022-08-21 20:56:37.503Z: Reading package lists... 93%
2022-08-21 20:56:37.522Z: 
2022-08-21 20:56:37.542Z: Reading package lists... 94%
2022-08-21 20:56:37.566Z: 
2022-08-21 20:56:37.589Z: Reading package lists... 94%
2022-08-21 20:56:37.614Z: 
2022-08-21 20:56:37.640Z: Reading package lists... 95%
2022-08-21 20:56:37.664Z: 
2022-08-21 20:56:37.693Z: Reading package lists... 95%
2022-08-21 20:56:37.714Z: 
2022-08-21 20:56:37.735Z: Reading package lists... 95%
2022-08-21 20:56:37.755Z: 
2022-08-21 20:56:37.783Z: Reading package lists... 95%
2022-08-21 20:56:37.802Z: 
2022-08-21 20:56:37.822Z: Reading package lists... 96%
2022-08-21 20:56:37.842Z: 
2022-08-21 20:56:37.861Z: Reading package lists... 96%
2022-08-21 20:56:37.880Z: 
2022-08-21 20:56:37.899Z: Reading package lists... 98%
2022-08-21 20:56:37.920Z: 
2022-08-21 20:56:37.938Z: Reading package lists... 98%
2022-08-21 20:56:37.956Z: 
2022-08-21 20:56:37.977Z: Reading package lists... 99%
2022-08-21 20:56:37.996Z: 
2022-08-21 20:56:38.016Z: Reading package lists... 99%
2022-08-21 20:56:38.036Z: 
2022-08-21 20:56:38.056Z: Reading package lists... 99%
2022-08-21 20:56:38.075Z: 
2022-08-21 20:56:38.094Z: Reading package lists... 99%
2022-08-21 20:56:38.114Z: 
2022-08-21 20:56:38.133Z: Reading package lists... Done
2022-08-21 20:56:38.159Z: 
2022-08-21 20:56:38.180Z: Reading package lists... 0%
2022-08-21 20:56:38.199Z: 
2022-08-21 20:56:38.217Z: Reading package lists... 0%
2022-08-21 20:56:38.237Z: 
2022-08-21 20:56:38.257Z: Reading package lists... 0%
2022-08-21 20:56:38.285Z: 
2022-08-21 20:56:38.304Z: Reading package lists... 8%
2022-08-21 20:56:38.323Z: 
2022-08-21 20:56:38.345Z: Reading package lists... 8%
2022-08-21 20:56:38.366Z: 
2022-08-21 20:56:38.390Z: Reading package lists... 9%
2022-08-21 20:56:38.410Z: 
2022-08-21 20:56:38.430Z: Reading package lists... 9%
2022-08-21 20:56:38.454Z: 
2022-08-21 20:56:38.481Z: Reading package lists... 87%
2022-08-21 20:56:38.507Z: 
2022-08-21 20:56:38.527Z: Reading package lists... 87%
2022-08-21 20:56:38.547Z: 
2022-08-21 20:56:38.584Z: Reading package lists... 87%
2022-08-21 20:56:38.606Z: 
2022-08-21 20:56:38.626Z: Reading package lists... 88%
2022-08-21 20:56:38.653Z: 
2022-08-21 20:56:38.703Z: Reading package lists... 88%
2022-08-21 20:56:38.736Z: 
2022-08-21 20:56:38.770Z: Reading package lists... 91%
2022-08-21 20:56:38.820Z: 
2022-08-21 20:56:38.843Z: Reading package lists... 91%
2022-08-21 20:56:38.867Z: 
2022-08-21 20:56:38.888Z: Reading package lists... 93%
2022-08-21 20:56:38.909Z: 
2022-08-21 20:56:38.932Z: Reading package lists... 93%
2022-08-21 20:56:38.958Z: 
2022-08-21 20:56:38.977Z: Reading package lists... 94%
2022-08-21 20:56:39.000Z: 
2022-08-21 20:56:39.020Z: Reading package lists... 94%
2022-08-21 20:56:39.047Z: 
2022-08-21 20:56:39.104Z: Reading package lists... 95%
2022-08-21 20:56:39.145Z: 
2022-08-21 20:56:39.185Z: Reading package lists... 95%
2022-08-21 20:56:39.231Z: 
2022-08-21 20:56:39.284Z: Reading package lists... 95%
2022-08-21 20:56:39.307Z: 
2022-08-21 20:56:39.352Z: Reading package lists... 95%
2022-08-21 20:56:39.403Z: 
2022-08-21 20:56:39.428Z: Reading package lists... 96%
2022-08-21 20:56:39.457Z: 
2022-08-21 20:56:39.481Z: Reading package lists... 96%
2022-08-21 20:56:39.505Z: 
2022-08-21 20:56:39.532Z: Reading package lists... 98%
2022-08-21 20:56:39.555Z: 
2022-08-21 20:56:39.579Z: Reading package lists... 98%
2022-08-21 20:56:39.600Z: 
2022-08-21 20:56:39.619Z: Reading package lists... 99%
2022-08-21 20:56:39.642Z: 
2022-08-21 20:56:39.666Z: Reading package lists... 99%
2022-08-21 20:56:39.711Z: 
2022-08-21 20:56:39.735Z: Reading package lists... 99%
2022-08-21 20:56:39.758Z: 
2022-08-21 20:56:39.778Z: Reading package lists... 99%
2022-08-21 20:56:39.802Z: 
2022-08-21 20:56:39.821Z: Reading package lists... Done
2022-08-21 20:56:39.889Z: 
2022-08-21 20:56:39.915Z: Building dependency tree... 0%
2022-08-21 20:56:39.934Z: 
2022-08-21 20:56:39.954Z: Building dependency tree... 0%
2022-08-21 20:56:39.978Z: 
2022-08-21 20:56:40.010Z: Building dependency tree... 50%
2022-08-21 20:56:40.033Z: 
2022-08-21 20:56:40.052Z: Building dependency tree... 50%
2022-08-21 20:56:40.085Z: 
2022-08-21 20:56:40.112Z: Building dependency tree... Done
2022-08-21 20:56:40.135Z: 
2022-08-21 20:56:40.158Z: 
2022-08-21 20:56:40.210Z: Reading state information... 0% 
2022-08-21 20:56:40.239Z: 
2022-08-21 20:56:40.269Z: Reading state information... 0%
2022-08-21 20:56:40.296Z: 
2022-08-21 20:56:40.319Z: Reading state information... Done
2022-08-21 20:56:40.346Z: 
2022-08-21 20:56:40.366Z: autoconf is already the newest version (2.71-2).
2022-08-21 20:56:40.393Z: automake is already the newest version (1:1.16.5-1.3).
2022-08-21 20:56:40.435Z: 
2022-08-21 20:56:40.472Z: bc is already the newest version (1.07.1-3build1).
2022-08-21 20:56:40.491Z: 
2022-08-21 20:56:40.511Z: binutils is already the newest version (2.38-3ubuntu1).
2022-08-21 20:56:40.533Z: 
2022-08-21 20:56:40.554Z: ca-certificates is already the newest version (20211016).
2022-08-21 20:56:40.578Z: 
2022-08-21 20:56:40.598Z: g++ is already the newest version (4:11.2.0-1ubuntu1).
2022-08-21 20:56:40.618Z: 
2022-08-21 20:56:40.638Z: gcc is already the newest version (4:11.2.0-1ubuntu1).
2022-08-21 20:56:40.659Z: gettext is already the newest version (0.21-4ubuntu4).
2022-08-21 20:56:40.684Z: libpython3-dev is already the newest version (3.10.4-0ubuntu2).
2022-08-21 20:56:40.704Z: libtool is already the newest version (2.4.6-15build2).
2022-08-21 20:56:40.726Z: 
2022-08-21 20:56:40.779Z: m4 is already the newest version (1.4.18-5ubuntu2).
2022-08-21 20:56:40.818Z: 
2022-08-21 20:56:40.857Z: make is already the newest version (4.3-4.1build1).
2022-08-21 20:56:40.897Z: 
2022-08-21 20:56:40.935Z: perl is already the newest version (5.34.0-3ubuntu1).
2022-08-21 20:56:40.976Z: pkg-config is already the newest version (0.29.2-1ubuntu3).
2022-08-21 20:56:41.027Z: python3 is already the newest version (3.10.4-0ubuntu2).
2022-08-21 20:56:41.057Z: python3-distutils is already the newest version (3.10.4-0ubuntu1).
2022-08-21 20:56:41.087Z: 
2022-08-21 20:56:41.113Z: tar is already the newest version (1.34+dfsg-1build3).
2022-08-21 20:56:41.150Z: 
2022-08-21 20:56:41.180Z: python3-venv is already the newest version (3.10.4-0ubuntu2).
2022-08-21 20:56:41.211Z: 
2022-08-21 20:56:41.243Z: The following additional packages will be installed:
2022-08-21 20:56:41.268Z:   git-man less libcbor0.8 libcurl3-gnutls liberror-perl libfido2-1
2022-08-21 20:56:41.301Z:   openssh-client
2022-08-21 20:56:41.329Z: Suggested packages:
2022-08-21 20:56:41.350Z:   git-daemon-run | git-daemon-sysvinit git-doc git-email git-gui gitk gitweb
2022-08-21 20:56:41.374Z:   git-cvs git-mediawiki git-svn keychain libpam-ssh monkeysphere ssh-askpass
2022-08-21 20:56:41.398Z: The following NEW packages will be installed:
2022-08-21 20:56:41.426Z:   git git-man less libcbor0.8 libcurl3-gnutls liberror-perl libfido2-1
2022-08-21 20:56:41.460Z:   openssh-client
2022-08-21 20:56:41.486Z: 0 upgraded, 8 newly installed, 0 to remove and 3 not upgraded.
2022-08-21 20:56:41.518Z: Need to get 5552 kB of archives.
2022-08-21 20:56:41.550Z: After this operation, 25.5 MB of additional disk space will be used.
2022-08-21 20:56:41.579Z: 
2022-08-21 20:56:41.610Z: 0% [Working]
2022-08-21 20:56:41.645Z: 
2022-08-21 20:56:41.671Z:             
2022-08-21 20:56:41.707Z: Get:1 http://archive.ubuntu.com/ubuntu jammy/main amd64 less amd64 590-1build1 [143 kB]
2022-08-21 20:56:41.726Z: 
2022-08-21 20:56:41.755Z: 0% [1 less 0 B/143 kB 0%]
2022-08-21 20:56:41.791Z: 
2022-08-21 20:56:41.817Z:                          
2022-08-21 20:56:41.854Z: 5% [Working]
2022-08-21 20:56:41.890Z: 
2022-08-21 20:56:41.916Z:             
2022-08-21 20:56:41.935Z: Get:2 http://archive.ubuntu.com/ubuntu jammy/main amd64 libcbor0.8 amd64 0.8.0-2ubuntu1 [24.6 kB]
2022-08-21 20:56:41.964Z: 
2022-08-21 20:56:41.998Z: 5% [2 libcbor0.8 24.6 kB/24.6 kB 100%]
2022-08-21 20:56:42.026Z:                                       
2022-08-21 20:56:42.056Z: 7% [Waiting for headers]
2022-08-21 20:56:42.086Z:                         
2022-08-21 20:56:42.128Z: Get:3 http://archive.ubuntu.com/ubuntu jammy/main amd64 libfido2-1 amd64 1.10.0-1 [82.8 kB]
2022-08-21 20:56:42.158Z: 
2022-08-21 20:56:42.184Z: 8% [3 libfido2-1 22.6 kB/82.8 kB 27%]
2022-08-21 20:56:42.203Z: 
2022-08-21 20:56:42.222Z:                                      
2022-08-21 20:56:42.245Z: 11% [Waiting for headers]
2022-08-21 20:56:42.265Z:                          
2022-08-21 20:56:42.286Z: Get:4 http://archive.ubuntu.com/ubuntu jammy/main amd64 openssh-client amd64 1:8.9p1-3 [909 kB]
2022-08-21 20:56:42.307Z: 
2022-08-21 20:56:42.334Z: 11% [4 openssh-client 8055 B/909 kB 1%]
2022-08-21 20:56:42.370Z: 
2022-08-21 20:56:42.408Z:                                        
2022-08-21 20:56:42.432Z: 27% [Working]
2022-08-21 20:56:42.468Z: 
2022-08-21 20:56:42.487Z:              
2022-08-21 20:56:42.505Z: Get:5 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libcurl3-gnutls amd64 7.81.0-1ubuntu1.3 [284 kB]
2022-08-21 20:56:42.525Z: 
2022-08-21 20:56:42.548Z: 27% [5 libcurl3-gnutls 0 B/284 kB 0%]
2022-08-21 20:56:42.574Z: 
2022-08-21 20:56:42.621Z:                                      
2022-08-21 20:56:42.642Z: 33% [Working]
2022-08-21 20:56:42.671Z:              
2022-08-21 20:56:42.696Z: Get:6 http://archive.ubuntu.com/ubuntu jammy/main amd64 liberror-perl all 0.17029-1 [26.5 kB]
2022-08-21 20:56:42.716Z: 
2022-08-21 20:56:42.737Z: 33% [6 liberror-perl 0 B/26.5 kB 0%]
2022-08-21 20:56:42.770Z: 
2022-08-21 20:56:42.798Z:                                     
2022-08-21 20:56:42.830Z: 36% [Working]
2022-08-21 20:56:42.858Z:              
2022-08-21 20:56:42.878Z: Get:7 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 git-man all 1:2.34.1-1ubuntu1.4 [952 kB]
2022-08-21 20:56:42.897Z: 
2022-08-21 20:56:42.918Z: 36% [7 git-man 0 B/952 kB 0%]
2022-08-21 20:56:42.954Z: 
2022-08-21 20:56:42.983Z:                              
2022-08-21 20:56:43.011Z: 52% [Working]
2022-08-21 20:56:43.039Z: 
2022-08-21 20:56:43.072Z:              
2022-08-21 20:56:43.104Z: Get:8 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 git amd64 1:2.34.1-1ubuntu1.4 [3131 kB]
2022-08-21 20:56:43.134Z: 
2022-08-21 20:56:43.168Z: 52% [8 git 0 B/3131 kB 0%]
2022-08-21 20:56:43.202Z: 
2022-08-21 20:56:43.228Z:                           
2022-08-21 20:56:43.256Z: 100% [Working]
2022-08-21 20:56:43.284Z:               
2022-08-21 20:56:43.312Z: Fetched 5552 kB in 0s (27.3 MB/s)
2022-08-21 20:56:43.342Z: debconf: delaying package configuration, since apt-utils is not installed
2022-08-21 20:56:43.377Z: Selecting previously unselected package less.
2022-08-21 20:56:43.408Z: (Reading database ... 
2022-08-21 20:56:43.438Z: (Reading database ... 5%
2022-08-21 20:56:43.470Z: (Reading database ... 10%
2022-08-21 20:56:43.504Z: (Reading database ... 15%
2022-08-21 20:56:43.537Z: (Reading database ... 20%
2022-08-21 20:56:43.565Z: (Reading database ... 25%
2022-08-21 20:56:43.601Z: (Reading database ... 30%
2022-08-21 20:56:43.620Z: (Reading database ... 35%
2022-08-21 20:56:43.639Z: (Reading database ... 40%
2022-08-21 20:56:43.661Z: (Reading database ... 45%
2022-08-21 20:56:43.681Z: (Reading database ... 50%
2022-08-21 20:56:43.702Z: (Reading database ... 55%
2022-08-21 20:56:43.723Z: (Reading database ... 60%
2022-08-21 20:56:43.757Z: (Reading database ... 65%
2022-08-21 20:56:43.798Z: (Reading database ... 70%
2022-08-21 20:56:43.856Z: (Reading database ... 75%
2022-08-21 20:56:43.897Z: (Reading database ... 80%
2022-08-21 20:56:43.941Z: (Reading database ... 85%
2022-08-21 20:56:43.983Z: (Reading database ... 90%
2022-08-21 20:56:44.022Z: (Reading database ... 95%
2022-08-21 20:56:44.067Z: (Reading database ... 100%
2022-08-21 20:56:44.121Z: (Reading database ... 68886 files and directories currently installed.)
2022-08-21 20:56:44.299Z: Preparing to unpack .../0-less_590-1build1_amd64.deb ...
2022-08-21 20:56:44.326Z: Unpacking less (590-1build1) ...
2022-08-21 20:56:44.451Z: Selecting previously unselected package libcbor0.8:amd64.
2022-08-21 20:56:44.477Z: Preparing to unpack .../1-libcbor0.8_0.8.0-2ubuntu1_amd64.deb ...
2022-08-21 20:56:44.564Z: Unpacking libcbor0.8:amd64 (0.8.0-2ubuntu1) ...
2022-08-21 20:56:44.873Z: Selecting previously unselected package libfido2-1:amd64.
2022-08-21 20:56:44.899Z: Preparing to unpack .../2-libfido2-1_1.10.0-1_amd64.deb ...
2022-08-21 20:56:44.941Z: Unpacking libfido2-1:amd64 (1.10.0-1) ...
2022-08-21 20:56:45.292Z: Selecting previously unselected package openssh-client.
2022-08-21 20:56:45.326Z: Preparing to unpack .../3-openssh-client_1%3a8.9p1-3_amd64.deb ...
2022-08-21 20:56:45.405Z: Unpacking openssh-client (1:8.9p1-3) ...
2022-08-21 20:56:45.741Z: Selecting previously unselected package libcurl3-gnutls:amd64.
2022-08-21 20:56:45.770Z: Preparing to unpack .../4-libcurl3-gnutls_7.81.0-1ubuntu1.3_amd64.deb ...
2022-08-21 20:56:45.816Z: Unpacking libcurl3-gnutls:amd64 (7.81.0-1ubuntu1.3) ...
2022-08-21 20:56:46.080Z: Selecting previously unselected package liberror-perl.
2022-08-21 20:56:46.104Z: Preparing to unpack .../5-liberror-perl_0.17029-1_all.deb ...
2022-08-21 20:56:46.130Z: Unpacking liberror-perl (0.17029-1) ...
2022-08-21 20:56:46.367Z: Selecting previously unselected package git-man.
2022-08-21 20:56:46.410Z: Preparing to unpack .../6-git-man_1%3a2.34.1-1ubuntu1.4_all.deb ...
2022-08-21 20:56:46.455Z: Unpacking git-man (1:2.34.1-1ubuntu1.4) ...
2022-08-21 20:56:46.847Z: Selecting previously unselected package git.
2022-08-21 20:56:46.889Z: Preparing to unpack .../7-git_1%3a2.34.1-1ubuntu1.4_amd64.deb ...
2022-08-21 20:56:46.918Z: Unpacking git (1:2.34.1-1ubuntu1.4) ...
2022-08-21 20:56:47.383Z: Setting up libcbor0.8:amd64 (0.8.0-2ubuntu1) ...
2022-08-21 20:56:47.552Z: Setting up less (590-1build1) ...
2022-08-21 20:56:47.747Z: Setting up libcurl3-gnutls:amd64 (7.81.0-1ubuntu1.3) ...
2022-08-21 20:56:47.887Z: Setting up liberror-perl (0.17029-1) ...
2022-08-21 20:56:48.055Z: Setting up git-man (1:2.34.1-1ubuntu1.4) ...
2022-08-21 20:56:48.223Z: Setting up libfido2-1:amd64 (1.10.0-1) ...
2022-08-21 20:56:48.363Z: Setting up openssh-client (1:8.9p1-3) ...
2022-08-21 20:56:48.755Z: update-alternatives: using /usr/bin/ssh to provide /usr/bin/rsh (rsh) in auto mode
2022-08-21 20:56:48.802Z: update-alternatives: using /usr/bin/slogin to provide /usr/bin/rlogin (rlogin) in auto mode
2022-08-21 20:56:48.852Z: update-alternatives: using /usr/bin/scp to provide /usr/bin/rcp (rcp) in auto mode
2022-08-21 20:56:48.951Z: Setting up git (1:2.34.1-1ubuntu1.4) ...
2022-08-21 20:56:49.120Z: Processing triggers for libc-bin (2.35-0ubuntu3.1) ...
2022-08-21 20:56:54.683Z: Stop (23282 ms): Run in container: /bin/sh -c .devcontainer/post_create.sh
2022-08-21 20:56:54.707Z: 
2022-08-21 20:56:54.731Z: $23.980394847Z' > '/root/.vscode-remote/data/Machine/.updateContentCommandMarker'
2022-08-21 20:56:54.751Z: 
2022-08-21 20:56:54.770Z: 
2022-08-21 20:56:54.790Z: && echo '2022-08-21T20:56:23.980394847Z' > '/root/.vscode-remote/data/Machine/.updateContentCommandMarker'
2022-08-21 20:56:54.844Z: Running the updateContentCommand from devcontainer.json...
2022-08-21 20:56:54.871Z: 
2022-08-21 20:56:54.916Z: $ /bin/sh -c .devcontainer/portability-post_start.sh
2022-08-21 20:56:54.937Z: + make configure
2022-08-21 20:56:54.978Z: ./bootstrap -d
2022-08-21 20:56:55.025Z: make[1]: Entering directory '/workspaces/sagetrac-mirror'
2022-08-21 20:56:55.095Z: rm -rf config/install-sh config/compile config/config.guess config/config.sub config/missing configure build/make/Makefile-auto.in
2022-08-21 20:56:55.151Z: rm -f src/doc/en/installation/*.txt
2022-08-21 20:56:55.207Z: rm -rf src/doc/en/reference/spkg/*.rst
2022-08-21 20:56:55.246Z: rm -f environment.yml
2022-08-21 20:56:55.269Z: rm -f src/environment.yml
2022-08-21 20:56:55.289Z: rm -f src/environment-dev.yml
2022-08-21 20:56:55.309Z: rm -f environment-optional.yml
2022-08-21 20:56:55.353Z: rm -f src/environment-optional.yml
2022-08-21 20:56:55.387Z: rm -f src/Pipfile
2022-08-21 20:56:55.419Z: rm -f src/pyproject.toml
2022-08-21 20:56:55.459Z: rm -f src/requirements.txt
2022-08-21 20:56:55.486Z: rm -f src/setup.cfg
2022-08-21 20:56:55.525Z: make[1]: Leaving directory '/workspaces/sagetrac-mirror'
2022-08-21 20:56:55.548Z: bootstrap:: installing 'm4/sage_spkg_configures.m4'
2022-08-21 20:56:58.101Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_environment/src/pyproject.toml
2022-08-21 20:56:58.157Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_environment/src/requirements.txt
2022-08-21 20:56:58.182Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_environment/src/setup.cfg
2022-08-21 20:56:58.202Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_repl/src/pyproject.toml
2022-08-21 20:56:58.223Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_repl/src/requirements.txt
2022-08-21 20:56:58.244Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_repl/src/setup.cfg
2022-08-21 20:56:58.267Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagelib/src/Pipfile-dist
2022-08-21 20:56:58.292Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagelib/src/Pipfile
2022-08-21 20:56:58.311Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagelib/src/pyproject.toml
2022-08-21 20:56:58.335Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagelib/src/requirements.txt
2022-08-21 20:56:58.355Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagelib/src/setup.cfg
2022-08-21 20:56:58.377Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_objects/src/pyproject.toml
2022-08-21 20:56:58.397Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_objects/src/requirements.txt
2022-08-21 20:56:58.418Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_objects/src/setup.cfg
2022-08-21 20:56:58.438Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_categories/src/MANIFEST.in
2022-08-21 20:56:58.458Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_categories/src/pyproject.toml
2022-08-21 20:56:58.478Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_categories/src/requirements.txt
2022-08-21 20:56:58.501Z: ./bootstrap: installing /workspaces/sagetrac-mirror/build/pkgs/sagemath_categories/src/setup.cfg
2022-08-21 20:56:59.109Z: ./bootstrap-conda:48: generate conda environment files
2022-08-21 20:56:59.504Z: src/doc/bootstrap:68: installing src/doc/en/installation/arch*.txt
2022-08-21 20:56:59.980Z: src/doc/bootstrap:68: installing src/doc/en/installation/debian*.txt
2022-08-21 20:57:00.513Z: src/doc/bootstrap:68: installing src/doc/en/installation/fedora*.txt
2022-08-21 20:57:01.016Z: src/doc/bootstrap:68: installing src/doc/en/installation/cygwin*.txt
2022-08-21 20:57:01.550Z: src/doc/bootstrap:68: installing src/doc/en/installation/homebrew*.txt
2022-08-21 20:57:01.616Z: src/doc/bootstrap:78: installing src/doc/en/reference/spkg/*.rst
2022-08-21 20:57:17.436Z: configure.ac:57: installing 'config/compile'
2022-08-21 20:57:17.868Z: configure.ac:57: installing 'config/config.guess'
2022-08-21 20:57:17.900Z: configure.ac:57: installing 'config/config.sub'
2022-08-21 20:57:17.920Z: configure.ac:43: installing 'config/install-sh'
2022-08-21 20:57:17.947Z: configure.ac:43: installing 'config/missing'
2022-08-21 20:57:20.348Z: + [ -x /sage/config.status ]
2022-08-21 20:57:20.379Z: + 
2022-08-21 20:57:20.405Z: /sage/config.status --config
2022-08-21 20:57:20.434Z: + eval ./configure --enable-build-as-root --enable-option-checking --with-system-primesieve=yes --with-system-mpfr=yes --with-system-fflas_ffpack=yes --with-system-readline=yes --with-system-fplll=yes --with-system-ncurses=yes --with-system-m4rie=yes --with-system-liblzma=yes --with-system-bzip2=yes --with-system-openssl=yes --with-system-lcalc=yes --with-system-xz=yes --with-system-gfortran=yes --with-system-cliquer=yes --with-system-gsl=yes --with-system-pkgconf=yes --with-system-symmetrica=yes --with-system-patch=yes --with-system-libbraiding=yes --with-system-rw=yes --with-system-m4ri=yes --with-system-gc=yes --with-system-giac=yes --with-system-gfan=yes --with-system-curl=yes --with-system-gf2x=yes --with-system-palp=yes --with-system-brial=yes --with-system-givaro=yes --with-system-qhull=yes --with-system-ntl=yes --with-system-linbox=yes --with-system-zeromq=yes --with-system-arb=yes --with-system-pari=yes --with-system-cddlib=yes --with-system-boost_cropped=yes --with-system-freetype=yes --with-system-zlib=yes --with-system-libatomic_ops=yes --with-system-cmake=yes --with-system-openblas=yes --with-system-planarity=yes --with-system-eclib=yes --with-system-singular=yes --with-system-tachyon=yes --with-system-libgd=yes --with-system-sqlite=yes --with-system-lrcalc=yes --with-system-ppl=yes --with-system-gengetopt=yes --with-system-libhomfly=yes --with-system-gmp=yes --with-system-sympow=yes --with-system-iml=yes --with-system-ecm=yes --with-system-pcre=yes --with-system-nauty=yes --with-system-suitesparse=yes --with-system-gcc=yes --with-system-mpfi=yes --with-system-flint=yes --with-system-mpc=yes --with-system-libffi=yes --with-system-flintqs=yes --with-system-ecl=yes --with-system-r=yes --with-system-_prereq=yes --with-system-zn_poly=yes --with-system-tox=yes --with-system-glpk=yes --enable-experimental-packages --enable-download-from-upstream-url --with-system-python3=yes --enable-build-as-root --prefix=/sage/local --with-sage-venv
2022-08-21 20:57:20.454Z: + ./configure --enable-build-as-root --enable-option-checking --with-system-primesieve=yes --with-system-mpfr=yes --with-system-fflas_ffpack=yes --with-system-readline=yes --with-system-fplll=yes --with-system-ncurses=yes --with-system-m4rie=yes --with-system-liblzma=yes --with-system-bzip2=yes --with-system-openssl=yes --with-system-lcalc=yes --with-system-xz=yes --with-system-gfortran=yes --with-system-cliquer=yes --with-system-gsl=yes --with-system-pkgconf=yes --with-system-symmetrica=yes --with-system-patch=yes --with-system-libbraiding=yes --with-system-rw=yes --with-system-m4ri=yes --with-system-gc=yes --with-system-giac=yes --with-system-gfan=yes --with-system-curl=yes --with-system-gf2x=yes --with-system-palp=yes --with-system-brial=yes --with-system-givaro=yes --with-system-qhull=yes --with-system-ntl=yes --with-system-linbox=yes --with-system-zeromq=yes --with-system-arb=yes --with-system-pari=yes --with-system-cddlib=yes --with-system-boost_cropped=yes --with-system-freetype=yes --with-system-zlib=yes --with-system-libatomic_ops=yes --with-system-cmake=yes --with-system-openblas=yes --with-system-planarity=yes --with-system-eclib=yes --with-system-singular=yes --with-system-tachyon=yes --with-system-libgd=yes --with-system-sqlite=yes --with-system-lrcalc=yes --with-system-ppl=yes --with-system-gengetopt=yes --with-system-libhomfly=yes --with-system-gmp=yes --with-system-sympow=yes --with-system-iml=yes --with-system-ecm=yes --with-system-pcre=yes --with-system-nauty=yes --with-system-suitesparse=yes --with-system-gcc=yes --with-system-mpfi=yes --with-system-flint=yes --with-system-mpc=yes --with-system-libffi=yes --with-system-flintqs=yes --with-system-ecl=yes --with-system-r=yes --with-system-_prereq=yes --with-system-zn_poly=yes --with-system-tox=yes --with-system-glpk=yes --enable-experimental-packages --enable-download-from-upstream-url --with-system-python3=yes --enable-build-as-root --prefix=/sage/local --with-sage-venv
2022-08-21 20:57:21.000Z: checking for a BSD-compatible install... 
2022-08-21 20:57:21.020Z: /usr/bin/install -c
2022-08-21 20:57:21.040Z: checking whether build environment is sane... 
2022-08-21 20:57:21.088Z: yes
2022-08-21 20:57:21.123Z: checking for a race-free mkdir -p... 
2022-08-21 20:57:21.150Z: /usr/bin/mkdir -p
2022-08-21 20:57:21.170Z: checking for gawk... 
2022-08-21 20:57:21.212Z: no
2022-08-21 20:57:21.260Z: checking for mawk... mawk
2022-08-21 20:57:21.399Z: checking whether make -j4 sets $(MAKE)... 
2022-08-21 20:57:21.517Z: yes
2022-08-21 20:57:21.597Z: checking whether make -j4 supports nested variables... 
2022-08-21 20:57:21.667Z: yes
2022-08-21 20:57:21.724Z: checking whether to enable maintainer-specific portions of Makefiles... 
2022-08-21 20:57:21.749Z: yes
2022-08-21 20:57:21.792Z: checking whether make -j4 supports the include directive... 
2022-08-21 20:57:21.879Z: yes (GNU style)
2022-08-21 20:57:21.927Z: checking for gcc... 
2022-08-21 20:57:21.952Z: gcc
2022-08-21 20:57:21.983Z: checking whether the C compiler works... 
2022-08-21 20:57:22.484Z: yes
2022-08-21 20:57:22.505Z: checking for C compiler default output file name... a.out
2022-08-21 20:57:22.526Z: checking for suffix of executables... 
2022-08-21 20:57:22.569Z: 
2022-08-21 20:57:22.601Z: checking whether we are cross compiling... 
2022-08-21 20:57:22.764Z: no
2022-08-21 20:57:22.785Z: checking for suffix of object files... 
2022-08-21 20:57:22.807Z: o
2022-08-21 20:57:22.828Z: checking whether the compiler supports GNU C... 
2022-08-21 20:57:22.852Z: yes
2022-08-21 20:57:22.875Z: checking whether gcc accepts -g... 
2022-08-21 20:57:22.916Z: yes
2022-08-21 20:57:22.939Z: checking for gcc option to enable C11 features... 
2022-08-21 20:57:23.155Z: none needed
2022-08-21 20:57:23.176Z: checking whether gcc understands -c and -o together... 
2022-08-21 20:57:23.199Z: yes
2022-08-21 20:57:23.229Z: checking dependency style of gcc... 
2022-08-21 20:57:23.249Z: none
2022-08-21 20:57:23.269Z: checking build system type... 
2022-08-21 20:57:23.299Z: x86_64-pc-linux-gnu
2022-08-21 20:57:23.336Z: checking host system type... 
2022-08-21 20:57:23.357Z: x86_64-pc-linux-gnu
2022-08-21 20:57:23.378Z: checking for ld used by gcc... 
2022-08-21 20:57:23.400Z: /usr/bin/ld
2022-08-21 20:57:23.420Z: checking if the linker (/usr/bin/ld) is GNU ld... 
2022-08-21 20:57:23.441Z: yes
2022-08-21 20:57:23.470Z: checking for shared library run path origin... 
2022-08-21 20:57:23.511Z: done
2022-08-21 20:57:23.538Z: checking for a sed that does not truncate output... 
2022-08-21 20:57:23.566Z: /usr/bin/sed
2022-08-21 20:57:23.595Z: checking for ar... 
2022-08-21 20:57:23.617Z: yes
2022-08-21 20:57:23.639Z: checking for m4... 
2022-08-21 20:57:23.701Z: yes
2022-08-21 20:57:23.722Z: checking for pkg-config... 
2022-08-21 20:57:23.744Z: /usr/bin/pkg-config
2022-08-21 20:57:23.797Z: checking pkg-config is at least version 0.29... 
2022-08-21 20:57:23.841Z: yes
2022-08-21 20:57:23.905Z: checking for ranlib... 
2022-08-21 20:57:23.991Z: yes
2022-08-21 20:57:24.076Z: checking for strip... 
2022-08-21 20:57:24.157Z: yes
2022-08-21 20:57:24.215Z: checking for GNU or BSD tar... 
2022-08-21 20:57:24.265Z: /usr/bin/tar
2022-08-21 20:57:24.289Z: checking for Python... 
2022-08-21 20:57:24.322Z: /usr/bin/python3
2022-08-21 20:57:24.379Z: checking for latex... 
2022-08-21 20:57:24.401Z: no
2022-08-21 20:57:24.443Z: configure: You do not have 'latex', which is recommended, but not
2022-08-21 20:57:24.472Z: configure: required. Latex is only really used for building pdf
2022-08-21 20:57:24.495Z: configure: documents and for %latex mode in the Sage notebook.
2022-08-21 20:57:24.516Z: checking for perl... 
2022-08-21 20:57:24.547Z: /usr/bin/perl
2022-08-21 20:57:24.573Z: checking for Perl version 5.8.0 or later... 
2022-08-21 20:57:24.599Z: yes
2022-08-21 20:57:24.622Z: checking whether a conda environment is active... no
2022-08-21 20:57:24.647Z: checking for gcc... (cached) gcc
2022-08-21 20:57:24.670Z: checking whether the compiler supports GNU C... (cached) yes
2022-08-21 20:57:24.692Z: checking whether gcc accepts -g... (cached) yes
2022-08-21 20:57:24.718Z: checking for gcc option to enable C11 features... (cached) none needed
2022-08-21 20:57:24.737Z: checking whether gcc understands -c and -o together... (cached) 
2022-08-21 20:57:24.758Z: yes
2022-08-21 20:57:24.778Z: checking dependency style of gcc... 
2022-08-21 20:57:24.819Z: (cached) none
2022-08-21 20:57:24.840Z: checking how to run the C preprocessor... 
2022-08-21 20:57:24.865Z: gcc -E
2022-08-21 20:57:24.887Z: checking for g++... 
2022-08-21 20:57:24.940Z: g++
2022-08-21 20:57:24.966Z: checking whether the compiler supports GNU C++... 
2022-08-21 20:57:24.993Z: yes
2022-08-21 20:57:25.017Z: checking whether g++ accepts -g... 
2022-08-21 20:57:25.045Z: yes
2022-08-21 20:57:25.071Z: checking for g++ option to enable C++11 features... 
2022-08-21 20:57:25.340Z: none needed
2022-08-21 20:57:25.387Z: checking dependency style of g++... 
2022-08-21 20:57:25.405Z: none
2022-08-21 20:57:25.433Z: checking for gfortran... 
2022-08-21 20:57:25.485Z: gfortran
2022-08-21 20:57:25.532Z: checking whether the compiler supports GNU Fortran... 
2022-08-21 20:57:26.207Z: yes
2022-08-21 20:57:26.231Z: checking whether gfortran accepts -g... 
2022-08-21 20:57:26.256Z: yes
2022-08-21 20:57:26.278Z: checking for gcc... 
2022-08-21 20:57:26.301Z: gcc
2022-08-21 20:57:26.334Z: checking whether the compiler supports GNU Objective C... 
2022-08-21 20:57:26.359Z: no
2022-08-21 20:57:26.382Z: checking whether gcc accepts -g... 
2022-08-21 20:57:26.407Z: no
2022-08-21 20:57:26.427Z: checking dependency style of gcc... 
2022-08-21 20:57:26.451Z: none
2022-08-21 20:57:26.470Z: checking for g++... 
2022-08-21 20:57:26.491Z: g++
2022-08-21 20:57:26.519Z: checking whether the compiler supports GNU Objective C++... 
2022-08-21 20:57:26.539Z: no
2022-08-21 20:57:26.565Z: checking whether g++ accepts -g... 
2022-08-21 20:57:26.593Z: no
2022-08-21 20:57:26.613Z: checking dependency style of g++... none
2022-08-21 20:57:26.631Z: checking for stdio.h... 
2022-08-21 20:57:26.654Z: yes
2022-08-21 20:57:26.674Z: checking for stdlib.h... 
2022-08-21 20:57:26.699Z: yes
2022-08-21 20:57:26.718Z: checking for string.h... 
2022-08-21 20:57:26.747Z: yes
2022-08-21 20:57:26.771Z: checking for inttypes.h... 
2022-08-21 20:57:26.799Z: yes
2022-08-21 20:57:26.825Z: checking for stdint.h... 
2022-08-21 20:57:26.852Z: yes
2022-08-21 20:57:26.877Z: checking for strings.h... 
2022-08-21 20:57:26.907Z: yes
2022-08-21 20:57:26.933Z: checking for sys/stat.h... 
2022-08-21 20:57:26.964Z: yes
2022-08-21 20:57:26.985Z: checking for sys/types.h... 
2022-08-21 20:57:27.006Z: yes
2022-08-21 20:57:27.025Z: checking for unistd.h... 
2022-08-21 20:57:27.103Z: yes
2022-08-21 20:57:27.127Z: checking for complex.h... 
2022-08-21 20:57:28.140Z: yes
2022-08-21 20:57:28.161Z: checking for sqrt in -lm... 
2022-08-21 20:57:28.207Z: yes
2022-08-21 20:57:28.227Z: -----------------------------------------------------------------------------
2022-08-21 20:57:28.250Z: Checking whether SageMath should install SPKG gcc...
2022-08-21 20:57:28.271Z: checking whether gcc is already installed in SAGE_LOCAL... no
2022-08-21 20:57:28.292Z: checking for C compiler vendor... 
2022-08-21 20:57:28.364Z: gnu
2022-08-21 20:57:28.383Z: checking whether g++ supports C++11 features with -std=gnu++11... 
2022-08-21 20:57:28.475Z: yes
2022-08-21 20:57:28.494Z: checking if gcc accepts -dumpversion option... 
2022-08-21 20:57:28.514Z: yes
2022-08-21 20:57:28.578Z: checking gcc version... 
2022-08-21 20:57:28.613Z: 11
2022-08-21 20:57:28.666Z: 
2022-08-21 20:57:28.711Z: checking if g++ accepts -dumpversion option... 
2022-08-21 20:57:28.737Z: yes
2022-08-21 20:57:28.780Z: checking g++ version... 
2022-08-21 20:57:28.800Z: 11
2022-08-21 20:57:28.820Z: checking whether C++ compiler accepts "-march=native"... 
2022-08-21 20:57:28.849Z: yes
2022-08-21 20:57:28.868Z: checking for OpenMP flag of C compiler... 
2022-08-21 20:57:28.896Z: -fopenmp
2022-08-21 20:57:28.935Z: checking for OpenMP flag of C++ compiler... 
2022-08-21 20:57:29.094Z: -fopenmp
2022-08-21 20:57:29.114Z: configure: will use system package and not install SPKG gcc
2022-08-21 20:57:29.133Z: checking for the location of crti.o... 
2022-08-21 20:57:29.158Z: /usr/lib/gcc/x86_64-linux-gnu/11/../../../x86_64-linux-gnu
2022-08-21 20:57:29.178Z: checking how to run the C++ preprocessor... 
2022-08-21 20:57:29.200Z: g++ -std=gnu++11 -E
2022-08-21 20:57:29.227Z: -----------------------------------------------------------------------------
2022-08-21 20:57:29.246Z: Checking whether SageMath should install SPKG gmp...
2022-08-21 20:57:29.282Z: checking for gmp.h... 
2022-08-21 20:57:29.303Z: yes
2022-08-21 20:57:29.336Z: checking for gmpxx.h... 
2022-08-21 20:57:29.652Z: yes
2022-08-21 20:57:29.673Z: checking for library containing __gmpq_cmp_z... 
2022-08-21 20:57:29.763Z: -lgmp
2022-08-21 20:57:29.784Z: configure: will use system package and not install SPKG gmp
2022-08-21 20:57:29.803Z: checking absolute name of <gmp.h>... checking for gmp.h... (cached) yes
2022-08-21 20:57:29.825Z: ///usr/include/x86_64-linux-gnu/gmp.h
2022-08-21 20:57:29.844Z: -----------------------------------------------------------------------------
2022-08-21 20:57:29.867Z: Checking whether SageMath should install SPKG zlib...
2022-08-21 20:57:29.901Z: checking for inflateEnd in -lz... 
2022-08-21 20:57:29.925Z: yes
2022-08-21 20:57:29.952Z: checking for zlib.h... 
2022-08-21 20:57:29.984Z: yes
2022-08-21 20:57:30.014Z: checking for libpng >= 1.2... 
2022-08-21 20:57:30.036Z: yes
2022-08-21 20:57:30.071Z: configure: will use system package and not install SPKG zlib
2022-08-21 20:57:30.090Z: -----------------------------------------------------------------------------
2022-08-21 20:57:30.109Z: Checking whether SageMath should install SPKG glpk...
2022-08-21 20:57:30.129Z: checking whether any of gmp zlib is installed as or will be installed as SPKG... no
2022-08-21 20:57:30.149Z: checking for glpsol... 
2022-08-21 20:57:30.168Z: /usr/bin/glpsol
2022-08-21 20:57:30.190Z: checking for glpk.h... 
2022-08-21 20:57:30.212Z: yes
2022-08-21 20:57:30.234Z: checking for library containing glp_config... 
2022-08-21 20:57:30.258Z: -lglpk
2022-08-21 20:57:30.282Z: yes. Use system's glpk
2022-08-21 20:57:30.305Z: configure: will use system package and not install SPKG glpk
2022-08-21 20:57:30.338Z: using glpk from the system
2022-08-21 20:57:30.358Z: -----------------------------------------------------------------------------
2022-08-21 20:57:30.399Z: Checking whether SageMath should install SPKG 4ti2...
2022-08-21 20:57:30.436Z: checking whether any of gmp glpk zlib is installed as or will be installed as SPKG... no
2022-08-21 20:57:30.454Z: checking for hilbert... 
2022-08-21 20:57:30.476Z: no
2022-08-21 20:57:30.517Z: checking for 4ti2-hilbert... 
2022-08-21 20:57:30.537Z: no
2022-08-21 20:57:30.563Z: checking for 4ti2_hilbert... 
2022-08-21 20:57:30.598Z: no
2022-08-21 20:57:30.624Z: checking for markov... 
2022-08-21 20:57:30.645Z: no
2022-08-21 20:57:30.674Z: checking for 4ti2-markov... 
2022-08-21 20:57:30.702Z: no
2022-08-21 20:57:30.744Z: checking for 4ti2_markov... 
2022-08-21 20:57:30.763Z: no
2022-08-21 20:57:30.797Z: checking for graver... 
2022-08-21 20:57:30.826Z: no
2022-08-21 20:57:30.853Z: checking for 4ti2-graver... 
2022-08-21 20:57:30.873Z: no
2022-08-21 20:57:30.899Z: checking for 4ti2_graver... 
2022-08-21 20:57:30.923Z: no
2022-08-21 20:57:30.949Z: checking for zsolve... no
2022-08-21 20:57:30.980Z: checking for 4ti2-zsolve... 
2022-08-21 20:57:31.010Z: no
2022-08-21 20:57:31.036Z: checking for 4ti2_zsolve... 
2022-08-21 20:57:31.062Z: no
2022-08-21 20:57:31.084Z: checking for qsolve... 
2022-08-21 20:57:31.106Z: no
2022-08-21 20:57:31.137Z: checking for 4ti2-qsolve... no
2022-08-21 20:57:31.164Z: checking for 4ti2_qsolve... no
2022-08-21 20:57:31.191Z: checking for rays... 
2022-08-21 20:57:31.218Z: no
2022-08-21 20:57:31.249Z: checking for 4ti2-rays... no
2022-08-21 20:57:31.277Z: checking for 4ti2_rays... no
2022-08-21 20:57:31.299Z: checking for ppi... no
2022-08-21 20:57:31.318Z: checking for 4ti2-ppi... 
2022-08-21 20:57:31.359Z: no
2022-08-21 20:57:31.393Z: checking for 4ti2_ppi... 
2022-08-21 20:57:31.447Z: no
2022-08-21 20:57:31.483Z: checking for circuits... no
2022-08-21 20:57:31.506Z: checking for 4ti2-circuits... no
2022-08-21 20:57:31.533Z: checking for 4ti2_circuits... 
2022-08-21 20:57:31.578Z: no
2022-08-21 20:57:31.596Z: checking for groebner... no
2022-08-21 20:57:31.637Z: checking for 4ti2-groebner... 
2022-08-21 20:57:31.676Z: no
2022-08-21 20:57:31.696Z: checking for 4ti2_groebner... no
2022-08-21 20:57:31.717Z: checking for library 4ti2gmp... 
2022-08-21 20:57:31.751Z: no
2022-08-21 20:57:31.785Z: configure: no suitable system package found for SPKG 4ti2
2022-08-21 20:57:31.810Z: -----------------------------------------------------------------------------
2022-08-21 20:57:31.831Z: Checking whether SageMath should install SPKG _prereq...
2022-08-21 20:57:31.851Z: configure: will use system package and not install SPKG _prereq
2022-08-21 20:57:31.871Z: -----------------------------------------------------------------------------
2022-08-21 20:57:31.918Z: Checking whether SageMath should install SPKG _recommended...
2022-08-21 20:57:31.938Z: configure: no suitable system package found for SPKG _recommended
2022-08-21 20:57:31.957Z: -----------------------------------------------------------------------------
2022-08-21 20:57:31.979Z: Checking whether SageMath should install SPKG tox...
2022-08-21 20:57:32.003Z: checking for tox >= 3.21.4... 
2022-08-21 20:57:32.128Z: /usr/bin/tox
2022-08-21 20:57:32.149Z: configure: will use system package and not install SPKG tox
2022-08-21 20:57:32.179Z: -----------------------------------------------------------------------------
2022-08-21 20:57:32.198Z: Checking whether SageMath should install SPKG virtualenv...
2022-08-21 20:57:32.221Z: configure: SPKG virtualenv is not required on this system
2022-08-21 20:57:32.241Z: -----------------------------------------------------------------------------
2022-08-21 20:57:32.260Z: Checking whether SageMath should install SPKG appdirs...
2022-08-21 20:57:32.280Z: configure: SPKG appdirs is not required on this system
2022-08-21 20:57:32.299Z: -----------------------------------------------------------------------------
2022-08-21 20:57:32.318Z: Checking whether SageMath should install SPKG mpfr...
2022-08-21 20:57:32.350Z: checking whether any of gmp is installed as or will be installed as SPKG... no
2022-08-21 20:57:32.380Z: checking for mpfr.h... 
2022-08-21 20:57:32.420Z: yes
2022-08-21 20:57:32.446Z: checking for library containing mpfr_free_pool... 
2022-08-21 20:57:32.477Z: -lmpfr
2022-08-21 20:57:32.503Z: configure: will use system package and not install SPKG mpfr
2022-08-21 20:57:32.530Z: using mpfr library from the system
2022-08-21 20:57:32.556Z: -----------------------------------------------------------------------------
2022-08-21 20:57:32.580Z: Checking whether SageMath should install SPKG ntl...
2022-08-21 20:57:32.600Z: checking whether any of gmp gcc is installed as or will be installed as SPKG... no
2022-08-21 20:57:32.623Z: checking for NTL/ZZ.h... 
2022-08-21 20:57:33.051Z: yes
2022-08-21 20:57:33.072Z: checking whether we can link a program using NTL... 
2022-08-21 20:57:33.528Z: yes
2022-08-21 20:57:33.549Z: checking NTL version >= 10.3... 
2022-08-21 20:57:33.614Z: yes
2022-08-21 20:57:33.637Z: configure: will use system package and not install SPKG ntl
2022-08-21 20:57:33.658Z: checking absolute name of <NTL/ZZ.h>... 
2022-08-21 20:57:33.695Z: checking for NTL/ZZ.h... (cached) yes
2022-08-21 20:57:33.717Z: ///usr/include/NTL/ZZ.h
2022-08-21 20:57:33.739Z: -----------------------------------------------------------------------------
2022-08-21 20:57:33.761Z: Checking whether SageMath should install SPKG flint...
2022-08-21 20:57:33.786Z: checking whether any of mpfr ntl is installed as or will be installed as SPKG... 
2022-08-21 20:57:33.816Z: no
2022-08-21 20:57:33.897Z: checking for flint/flint.h... 
2022-08-21 20:57:33.980Z: yes
2022-08-21 20:57:34.000Z: checking for library containing fmpz_mod_ctx_init... 
2022-08-21 20:57:34.148Z: -lflint
2022-08-21 20:57:34.180Z: checking for library containing fmpz_poly_get_ZZX... 
2022-08-21 20:57:34.260Z: none required
2022-08-21 20:57:34.284Z: checking that GC is not enabled in Flint... ... 
2022-08-21 20:57:34.372Z: GC not enabled. Good.
2022-08-21 20:57:34.394Z: configure: will use system package and not install SPKG flint
2022-08-21 20:57:34.477Z: -----------------------------------------------------------------------------
2022-08-21 20:57:34.504Z: Checking whether SageMath should install SPKG arb...
2022-08-21 20:57:34.538Z: checking installing flint? ... 
2022-08-21 20:57:34.578Z: checking for arb.h... 
2022-08-21 20:57:34.763Z: yes
2022-08-21 20:57:34.786Z: checking for acb_mat_eig_simple in -larb... 
2022-08-21 20:57:34.849Z: no
2022-08-21 20:57:34.868Z: 
2022-08-21 20:57:34.888Z: checking for acb_mat_eig_simple in -lflint-arb... 
2022-08-21 20:57:34.966Z: yes
2022-08-21 20:57:34.989Z: 
2022-08-21 20:57:35.049Z: configure: will use system package and not install SPKG arb
2022-08-21 20:57:35.069Z: -----------------------------------------------------------------------------
2022-08-21 20:57:35.097Z: Checking whether SageMath should install SPKG boost_cropped...
2022-08-21 20:57:35.125Z: checking for boostlib >= 1.66.0 (106600)... 
2022-08-21 20:57:35.166Z: yes
2022-08-21 20:57:35.186Z: configure: will use system package and not install SPKG boost_cropped
2022-08-21 20:57:35.205Z: -----------------------------------------------------------------------------
2022-08-21 20:57:35.249Z: Checking whether SageMath should install SPKG libpng...
2022-08-21 20:57:35.289Z: checking installing zlib? ... no
2022-08-21 20:57:35.320Z: checking for libpng >= 1.2... yes
2022-08-21 20:57:35.349Z: configure: will use system package and not install SPKG libpng
2022-08-21 20:57:35.388Z: -----------------------------------------------------------------------------
2022-08-21 20:57:35.415Z: Checking whether SageMath should install SPKG m4ri...
2022-08-21 20:57:35.435Z: checking whether any of libpng is installed as or will be installed as SPKG... 
2022-08-21 20:57:35.470Z: no
2022-08-21 20:57:35.507Z: checking for m4ri >= 20140914... 
2022-08-21 20:57:35.544Z: yes
2022-08-21 20:57:35.584Z: 
2022-08-21 20:57:35.620Z: configure: will use system package and not install SPKG m4ri
2022-08-21 20:57:35.646Z: -----------------------------------------------------------------------------
2022-08-21 20:57:35.682Z: 
2022-08-21 20:57:35.714Z: Checking whether SageMath should install SPKG brial...
2022-08-21 20:57:35.744Z: checking whether any of gcc boost_cropped m4ri is installed as or will be installed as SPKG... 
2022-08-21 20:57:35.780Z: no
2022-08-21 20:57:35.806Z: checking if we can link against brial libraries and run... 
2022-08-21 20:57:38.690Z: checking version not equal to 1.2.5... 
2022-08-21 20:57:39.625Z: yes
2022-08-21 20:57:39.646Z: configure: will use system package and not install SPKG brial
2022-08-21 20:57:39.700Z: -----------------------------------------------------------------------------
2022-08-21 20:57:39.719Z: Checking whether SageMath should install SPKG bzip2...
2022-08-21 20:57:39.744Z: checking for bzlib.h... 
2022-08-21 20:57:39.768Z: yes
2022-08-21 20:57:39.787Z: checking for library containing BZ2_bzCompress... 
2022-08-21 20:57:39.852Z: -lbz2
2022-08-21 20:57:39.873Z: checking for bzip2... /usr/bin/bzip2
2022-08-21 20:57:39.893Z: configure: will use system package and not install SPKG bzip2
2022-08-21 20:57:39.914Z: checking for Fortran flag needed to accept free-form source... 
2022-08-21 20:57:39.939Z: -ffree-form
2022-08-21 20:57:39.961Z: -----------------------------------------------------------------------------
2022-08-21 20:57:39.982Z: Checking whether SageMath should install SPKG gfortran...
2022-08-21 20:57:40.003Z: checking the version of gfortran... 
2022-08-21 20:57:40.063Z: 11
2022-08-21 20:57:40.083Z: configure: will use system package and not install SPKG gfortran
2022-08-21 20:57:40.104Z: -----------------------------------------------------------------------------
2022-08-21 20:57:40.123Z: Checking whether SageMath should install SPKG openblas...
2022-08-21 20:57:40.145Z: checking whether any of gfortran is installed as or will be installed as SPKG... no
2022-08-21 20:57:40.164Z: checking for openblas >= 0.2.20... 
2022-08-21 20:57:40.187Z: yes
2022-08-21 20:57:40.206Z: checking for cblas_dgemm... 
2022-08-21 20:57:40.228Z: yes
2022-08-21 20:57:40.247Z: checking for dgeqrf... 
2022-08-21 20:57:40.268Z: no
2022-08-21 20:57:40.288Z: checking for dgeqrf_... 
2022-08-21 20:57:40.353Z: yes
2022-08-21 20:57:40.378Z: checking for DGEQRF... 
2022-08-21 20:57:40.435Z: no
2022-08-21 20:57:40.457Z: checking for DGEQRF_... 
2022-08-21 20:57:40.521Z: no
2022-08-21 20:57:40.585Z: configure: will use system package and not install SPKG openblas
2022-08-21 20:57:40.613Z: -----------------------------------------------------------------------------
2022-08-21 20:57:40.646Z: Checking whether SageMath should install SPKG cbc...
2022-08-21 20:57:40.667Z: checking whether any of openblas zlib bzip2 is installed as or will be installed as SPKG... no
2022-08-21 20:57:40.686Z: checking for cbc >= 2.9.4... 
2022-08-21 20:57:40.707Z: no
2022-08-21 20:57:40.731Z: configure: no suitable system package found for SPKG cbc
2022-08-21 20:57:40.750Z: -----------------------------------------------------------------------------
2022-08-21 20:57:40.770Z: Checking whether SageMath should install SPKG cddlib...
2022-08-21 20:57:40.789Z: checking whether any of gmp is installed as or will be installed as SPKG... no
2022-08-21 20:57:40.808Z: checking for cddexec... 
2022-08-21 20:57:40.830Z: cddexec
2022-08-21 20:57:40.849Z: checking for cddexec_gmp... 
2022-08-21 20:57:40.868Z: cddexec_gmp
2022-08-21 20:57:40.890Z: checking for redcheck_gmp... redcheck_gmp
2022-08-21 20:57:40.911Z: checking for scdd_gmp... scdd_gmp
2022-08-21 20:57:40.932Z: checking whether cddexec --redcheck works correctly for real input... 
2022-08-21 20:57:40.954Z: yes
2022-08-21 20:57:40.976Z: checking for cddlib/cdd.h... 
2022-08-21 20:57:41.002Z: yes
2022-08-21 20:57:41.023Z: checking for library containing dd_abs... 
2022-08-21 20:57:41.053Z: -lcddgmp
2022-08-21 20:57:41.075Z: configure: will use system package and not install SPKG cddlib
2022-08-21 20:57:41.097Z: -----------------------------------------------------------------------------
2022-08-21 20:57:41.139Z: Checking whether SageMath should install SPKG cliquer...
2022-08-21 20:57:41.163Z: checking for library containing clique_unweighted_max_weight... 
2022-08-21 20:57:41.197Z: -lcliquer
2022-08-21 20:57:41.221Z: checking for cliquer/cliquer.h... 
2022-08-21 20:57:41.262Z: yes
2022-08-21 20:57:41.352Z: checking for cl... 
2022-08-21 20:57:41.394Z: no
2022-08-21 20:57:41.427Z: configure: cl (cliquer's CLI) is not found.
2022-08-21 20:57:41.486Z: configure: No action, as Sage does not need it. cl might be named cliquer on this system.
2022-08-21 20:57:41.557Z: configure: will use system package and not install SPKG cliquer
2022-08-21 20:57:41.607Z: -----------------------------------------------------------------------------
2022-08-21 20:57:41.629Z: Checking whether SageMath should install SPKG cmake...
2022-08-21 20:57:41.667Z: checking for cmake >= 3.4... 
2022-08-21 20:57:41.723Z: /usr/bin/cmake
2022-08-21 20:57:41.743Z: configure: will use system package and not install SPKG cmake
2022-08-21 20:57:41.771Z: -----------------------------------------------------------------------------
2022-08-21 20:57:41.792Z: Checking whether SageMath should install SPKG coxeter3...
2022-08-21 20:57:41.811Z: checking for library coxeter3... 
2022-08-21 20:57:41.838Z: no
2022-08-21 20:57:41.866Z: configure: no suitable system package found for SPKG coxeter3
2022-08-21 20:57:41.896Z: -----------------------------------------------------------------------------
2022-08-21 20:57:41.923Z: Checking whether SageMath should install SPKG curl...
2022-08-21 20:57:41.946Z: checking for curl 7.22... 
2022-08-21 20:57:41.970Z: /usr/bin/curl
2022-08-21 20:57:41.992Z: checking for gawk... (cached) mawk
2022-08-21 20:57:42.011Z: checking for curl-config... 
2022-08-21 20:57:42.035Z: /usr/bin/curl-config
2022-08-21 20:57:42.056Z: checking for the version of libcurl... 
2022-08-21 20:57:42.080Z: 7.81.0
2022-08-21 20:57:42.100Z: checking for libcurl >= version 7.22... 
2022-08-21 20:57:42.120Z: yes
2022-08-21 20:57:42.140Z: checking whether libcurl is usable... 
2022-08-21 20:57:42.162Z: yes
2022-08-21 20:57:42.181Z: checking for curl_free... 
2022-08-21 20:57:42.231Z: yes
2022-08-21 20:57:42.604Z: checking whether programs linking to libcurl can be executed... 
2022-08-21 20:57:42.719Z: yes
2022-08-21 20:57:42.743Z: configure: will use system package and not install SPKG curl
2022-08-21 20:57:42.765Z: -----------------------------------------------------------------------------
2022-08-21 20:57:42.796Z: Checking whether SageMath should install SPKG distlib...
2022-08-21 20:57:42.839Z: configure: SPKG distlib is not required on this system
2022-08-21 20:57:42.858Z: -----------------------------------------------------------------------------
2022-08-21 20:57:42.880Z: Checking whether SageMath should install SPKG libatomic_ops...
2022-08-21 20:57:42.901Z: checking for atomic_ops >= 7.6.2... 
2022-08-21 20:57:42.927Z: yes
2022-08-21 20:57:42.950Z: configure: will use system package and not install SPKG libatomic_ops
2022-08-21 20:57:42.974Z: -----------------------------------------------------------------------------
2022-08-21 20:57:43.001Z: Checking whether SageMath should install SPKG gc...
2022-08-21 20:57:43.024Z: checking whether any of libatomic_ops is installed as or will be installed as SPKG... 
2022-08-21 20:57:43.059Z: no
2022-08-21 20:57:43.112Z: checking whether we run on WSL... 
2022-08-21 20:57:43.152Z: no
2022-08-21 20:57:43.209Z: checking for bdw-gc-threaded >= 7.6.4... 
2022-08-21 20:57:43.241Z: no
2022-08-21 20:57:43.316Z: checking for bdw-gc >= 7.6.4... 
2022-08-21 20:57:43.372Z: yes
2022-08-21 20:57:43.413Z: configure: will use system package and not install SPKG gc
2022-08-21 20:57:43.465Z: -----------------------------------------------------------------------------
2022-08-21 20:57:43.485Z: Checking whether SageMath should install SPKG ecl...
2022-08-21 20:57:43.506Z: checking whether any of gcc gc gmp is installed as or will be installed as SPKG... 
2022-08-21 20:57:43.533Z: no
2022-08-21 20:57:43.567Z: checking for ecl-config... 
2022-08-21 20:57:43.586Z: /usr/bin/ecl-config
2022-08-21 20:57:43.627Z: 
2022-08-21 20:57:43.654Z: configure: will use system package and not install SPKG ecl
2022-08-21 20:57:43.704Z: -----------------------------------------------------------------------------
2022-08-21 20:57:43.749Z: Checking whether SageMath should install SPKG ncurses...
2022-08-21 20:57:43.809Z: checking for ncurses >= 6.0... 
2022-08-21 20:57:43.836Z: yes
2022-08-21 20:57:43.860Z: configure: will use system package and not install SPKG ncurses
2022-08-21 20:57:43.886Z: -----------------------------------------------------------------------------
2022-08-21 20:57:43.916Z: Checking whether SageMath should install SPKG readline...
2022-08-21 20:57:43.942Z: checking Installing ncurses? ... No.
2022-08-21 20:57:43.967Z: checking for readline >= 6.0... 
2022-08-21 20:57:43.993Z: yes
2022-08-21 20:57:44.017Z: configure: will use system package and not install SPKG readline
2022-08-21 20:57:44.043Z: -----------------------------------------------------------------------------
2022-08-21 20:57:44.069Z: Checking whether SageMath should install SPKG pari...
2022-08-21 20:57:44.105Z: checking whether any of gmp readline is installed as or will be installed as SPKG... no
2022-08-21 20:57:44.130Z: checking for gp... 
2022-08-21 20:57:44.156Z: /usr/bin/gp
2022-08-21 20:57:44.186Z: checking for gphelp... 
2022-08-21 20:57:44.214Z: /usr/bin/gphelp
2022-08-21 20:57:44.237Z: checking whether gphelp has access to the documentation... 
2022-08-21 20:57:44.291Z: yes
2022-08-21 20:57:44.316Z: checking is pari_elldata installed? ... 
2022-08-21 20:57:44.336Z: yes
2022-08-21 20:57:44.355Z: checking is pari_galdata installed? ... 
2022-08-21 20:57:44.378Z: yes
2022-08-21 20:57:44.398Z: checking is pari_galpol installed? ... 
2022-08-21 20:57:44.418Z: yes
2022-08-21 20:57:44.437Z: checking is pari_seadata installed? ... 
2022-08-21 20:57:44.460Z: yes
2022-08-21 20:57:44.480Z: checking whether rnfdisc bug of pari 2.13.1 is fixed... 
2022-08-21 20:57:44.510Z: yes
2022-08-21 20:57:44.530Z: checking for pari/pari.h... 
2022-08-21 20:57:44.684Z: yes
2022-08-21 20:57:44.705Z: checking for library containing matpermanent... 
2022-08-21 20:57:44.823Z: -lpari
2022-08-21 20:57:44.841Z: checking getting GP's version ... 
2022-08-21 20:57:44.859Z: 134403
2022-08-21 20:57:44.879Z: checking comparing GP and libpari versions... 
2022-08-21 20:57:45.299Z: libpari's and GP's versions match. Good
2022-08-21 20:57:45.328Z: checking is GP's version good enough? ... 
2022-08-21 20:57:45.349Z: yes
2022-08-21 20:57:45.369Z: checking getting GP's datadir... 
2022-08-21 20:57:45.389Z: "/usr/share/pari"
2022-08-21 20:57:45.408Z: checking comparing GP's and libpari's datadirs... 
2022-08-21 20:57:45.496Z: libpari's and GP's datadirs match. Good
2022-08-21 20:57:45.516Z: checking whether pari is configured with pthreads... 
2022-08-21 20:57:45.635Z: yes. Good
2022-08-21 20:57:45.656Z: configure: will use system package and not install SPKG pari
2022-08-21 20:57:45.675Z: -----------------------------------------------------------------------------
2022-08-21 20:57:45.695Z: Checking whether SageMath should install SPKG eclib...
2022-08-21 20:57:45.715Z: configure: eclib has already been installed by SageMath
2022-08-21 20:57:45.734Z: -----------------------------------------------------------------------------
2022-08-21 20:57:45.753Z: Checking whether SageMath should install SPKG ecm...
2022-08-21 20:57:45.772Z: checking whether any of gmp is installed as or will be installed as SPKG... no
2022-08-21 20:57:45.793Z: checking for ecm.h... 
2022-08-21 20:57:45.815Z: yes
2022-08-21 20:57:45.836Z: checking absolute name of <ecm.h>... 
2022-08-21 20:57:45.855Z: checking for ecm.h... 
2022-08-21 20:57:45.875Z: (cached) yes
2022-08-21 20:57:45.904Z: ///usr/include/ecm.h
2022-08-21 20:57:45.945Z: 
2022-08-21 20:57:45.966Z: checking for library containing ecm_factor... 
2022-08-21 20:57:45.986Z: -lecm
2022-08-21 20:57:46.004Z: checking for ecm... 
2022-08-21 20:57:46.023Z: /usr/bin/ecm
2022-08-21 20:57:46.049Z: configure: will use system package and not install SPKG ecm
2022-08-21 20:57:46.073Z: -----------------------------------------------------------------------------
2022-08-21 20:57:46.097Z: Checking whether SageMath should install SPKG givaro...
2022-08-21 20:57:46.120Z: configure: givaro has already been installed by SageMath
2022-08-21 20:57:46.151Z: -----------------------------------------------------------------------------
2022-08-21 20:57:46.184Z: Checking whether SageMath should install SPKG fflas_ffpack...
2022-08-21 20:57:46.227Z: configure: fflas_ffpack has already been installed by SageMath
2022-08-21 20:57:46.267Z: checking whether C++ compiler accepts -mavx512f -mavx512vl -mavx512dq... 
2022-08-21 20:57:46.310Z: yes
2022-08-21 20:57:46.330Z: checking whether C++ compiler accepts -mfma... 
2022-08-21 20:57:46.364Z: yes
2022-08-21 20:57:46.386Z: checking whether C++ compiler accepts -mfma4... 
2022-08-21 20:57:46.426Z: yes
2022-08-21 20:57:46.465Z: -----------------------------------------------------------------------------
2022-08-21 20:57:46.485Z: Checking whether SageMath should install SPKG ffmpeg...
2022-08-21 20:57:46.535Z: checking for ffmpeg... 
2022-08-21 20:57:46.601Z: no
2022-08-21 20:57:46.677Z: configure: no suitable system package found for SPKG ffmpeg
2022-08-21 20:57:46.772Z: -----------------------------------------------------------------------------
2022-08-21 20:57:46.860Z: Checking whether SageMath should install SPKG filelock...
2022-08-21 20:57:46.929Z: configure: SPKG filelock is not required on this system
2022-08-21 20:57:46.971Z: -----------------------------------------------------------------------------
2022-08-21 20:57:47.013Z: Checking whether SageMath should install SPKG flintqs...
2022-08-21 20:57:47.079Z: checking for QuadraticSieve... 
2022-08-21 20:57:47.158Z: yes
2022-08-21 20:57:47.195Z: configure: will use system package and not install SPKG flintqs
2022-08-21 20:57:47.214Z: -----------------------------------------------------------------------------
2022-08-21 20:57:47.253Z: Checking whether SageMath should install SPKG fplll...
2022-08-21 20:57:47.292Z: configure: fplll has already been installed by SageMath
2022-08-21 20:57:47.325Z: -----------------------------------------------------------------------------
2022-08-21 20:57:47.364Z: Checking whether SageMath should install SPKG freetype...
2022-08-21 20:57:47.400Z: checking whether any of gcc libpng is installed as or will be installed as SPKG... no
2022-08-21 20:57:47.446Z: checking for freetype2 >= 20.0... 
2022-08-21 20:57:47.470Z: yes
2022-08-21 20:57:47.496Z: configure: will use system package and not install SPKG freetype
2022-08-21 20:57:47.522Z: -----------------------------------------------------------------------------
2022-08-21 20:57:47.561Z: Checking whether SageMath should install SPKG gengetopt...
2022-08-21 20:57:47.631Z: checking for gengetopt... 
2022-08-21 20:57:47.661Z: /usr/bin/gengetopt
2022-08-21 20:57:47.696Z: configure: will use system package and not install SPKG gengetopt
2022-08-21 20:57:47.732Z: -----------------------------------------------------------------------------
2022-08-21 20:57:47.769Z: Checking whether SageMath should install SPKG gf2x...
2022-08-21 20:57:47.801Z: checking for gf2x >= 1.2... 
2022-08-21 20:57:47.821Z: yes
2022-08-21 20:57:47.840Z: configure: will use system package and not install SPKG gf2x
2022-08-21 20:57:47.880Z: -----------------------------------------------------------------------------
2022-08-21 20:57:47.909Z: Checking whether SageMath should install SPKG gfan...
2022-08-21 20:57:47.935Z: checking for gfan >= 0.6.2... 
2022-08-21 20:57:47.960Z: 
2022-08-21 20:57:47.988Z: configure: will use system package and not install SPKG gfan
2022-08-21 20:57:48.008Z: -----------------------------------------------------------------------------
2022-08-21 20:57:48.035Z: Checking whether SageMath should install SPKG giac...
2022-08-21 20:57:48.059Z: checking whether any of pari is installed as or will be installed as SPKG... no
2022-08-21 20:57:48.079Z: checking for giac >= 1.5.0, <= 1.9.999... 
2022-08-21 20:57:48.102Z: /usr/bin/giac
2022-08-21 20:57:48.121Z: checking for giac/giac.h... 
2022-08-21 20:57:48.668Z: yes
2022-08-21 20:57:48.689Z: checking for library containing ConvertUTF16toUTF8... 
2022-08-21 20:57:48.872Z: -lgiac
2022-08-21 20:57:48.922Z: configure: will use system package and not install SPKG giac
2022-08-21 20:57:48.962Z: -----------------------------------------------------------------------------
2022-08-21 20:57:48.982Z: Checking whether SageMath should install SPKG git...
2022-08-21 20:57:49.001Z: checking for git... 
2022-08-21 20:57:49.033Z: /usr/bin/git
2022-08-21 20:57:49.052Z: configure: will use system package and not install SPKG git
2022-08-21 20:57:49.074Z: -----------------------------------------------------------------------------
2022-08-21 20:57:49.094Z: Checking whether SageMath should install SPKG gp2c...
2022-08-21 20:57:49.114Z: checking whether any of pari is installed as or will be installed as SPKG... no
2022-08-21 20:57:49.135Z: checking for gp2c... 
2022-08-21 20:57:49.156Z: /usr/bin/gp2c
2022-08-21 20:57:49.178Z: configure: will use system package and not install SPKG gp2c
2022-08-21 20:57:49.199Z: -----------------------------------------------------------------------------
2022-08-21 20:57:49.221Z: Checking whether SageMath should install SPKG graphviz...
2022-08-21 20:57:49.255Z: checking for dot... 
2022-08-21 20:57:49.291Z: no
2022-08-21 20:57:49.320Z: checking for neato... 
2022-08-21 20:57:49.347Z: no
2022-08-21 20:57:49.367Z: checking for twopi... 
2022-08-21 20:57:49.387Z: no
2022-08-21 20:57:49.410Z: configure: no suitable system package found for SPKG graphviz
2022-08-21 20:57:49.432Z: -----------------------------------------------------------------------------
2022-08-21 20:57:49.454Z: Checking whether SageMath should install SPKG gsl...
2022-08-21 20:57:49.475Z: checking whether any of openblas is installed as or will be installed as SPKG... 
2022-08-21 20:57:49.494Z: no
2022-08-21 20:57:49.513Z: checking for gsl >= $2.4... 
2022-08-21 20:57:49.534Z: yes
2022-08-21 20:57:49.554Z: configure: will use system package and not install SPKG gsl
2022-08-21 20:57:49.574Z: checking 32-bit host C ABI... 
2022-08-21 20:57:49.594Z: no
2022-08-21 20:57:49.614Z: checking for grep that handles long lines and -e... 
2022-08-21 20:57:49.632Z: /usr/bin/grep
2022-08-21 20:57:49.653Z: checking for egrep... 
2022-08-21 20:57:49.677Z: /usr/bin/grep -E
2022-08-21 20:57:49.697Z: checking for ELF binary format... 
2022-08-21 20:57:49.717Z: yes
2022-08-21 20:57:49.739Z: checking for the common suffixes of directories in the library search path... 
2022-08-21 20:57:49.760Z: lib,lib,lib64
2022-08-21 20:57:49.787Z: checking for iconv... 
2022-08-21 20:57:49.808Z: yes
2022-08-21 20:57:49.828Z: checking for working iconv... 
2022-08-21 20:57:49.850Z: yes
2022-08-21 20:57:49.875Z: checking whether iconv is compatible with its POSIX signature... 
2022-08-21 20:57:49.903Z: yes
2022-08-21 20:57:49.923Z: -----------------------------------------------------------------------------
2022-08-21 20:57:49.941Z: Checking whether SageMath should install SPKG iconv...
2022-08-21 20:57:49.962Z: configure: will use system package and not install SPKG iconv
2022-08-21 20:57:49.985Z: -----------------------------------------------------------------------------
2022-08-21 20:57:50.006Z: Checking whether SageMath should install SPKG igraph...
2022-08-21 20:57:50.025Z: checking whether any of glpk openblas gmp is installed as or will be installed as SPKG... no
2022-08-21 20:57:50.047Z: checking for igraph >= 0.9.5... 
2022-08-21 20:57:50.067Z: no
2022-08-21 20:57:50.086Z: configure: no suitable system package found for SPKG igraph
2022-08-21 20:57:50.106Z: -----------------------------------------------------------------------------
2022-08-21 20:57:50.126Z: Checking whether SageMath should install SPKG imagemagick...
2022-08-21 20:57:50.145Z: checking for convert... 
2022-08-21 20:57:50.166Z: no
2022-08-21 20:57:50.186Z: configure: no suitable system package found for SPKG imagemagick
2022-08-21 20:57:50.207Z: -----------------------------------------------------------------------------
2022-08-21 20:57:50.227Z: Checking whether SageMath should install SPKG iml...
2022-08-21 20:57:50.247Z: checking whether any of gmp openblas is installed as or will be installed as SPKG... no
2022-08-21 20:57:50.266Z: checking for iml.h... 
2022-08-21 20:57:50.290Z: yes
2022-08-21 20:57:50.310Z: checking for library containing nonsingSolvLlhsMM... 
2022-08-21 20:57:50.330Z: -liml
2022-08-21 20:57:50.349Z: configure: will use system package and not install SPKG iml
2022-08-21 20:57:50.368Z: -----------------------------------------------------------------------------
2022-08-21 20:57:50.387Z: Checking whether SageMath should install SPKG info...
2022-08-21 20:57:50.408Z: checking for info... 
2022-08-21 20:57:50.428Z: no
2022-08-21 20:57:50.447Z: configure: no suitable system package found for SPKG info
2022-08-21 20:57:50.466Z: -----------------------------------------------------------------------------
2022-08-21 20:57:50.485Z: Checking whether SageMath should install SPKG isl...
2022-08-21 20:57:50.504Z: checking whether any of gmp is installed as or will be installed as SPKG... no
2022-08-21 20:57:50.522Z: checking for isl >= 0.20... 
2022-08-21 20:57:50.541Z: no
2022-08-21 20:57:50.560Z: configure: no suitable system package found for SPKG isl
2022-08-21 20:57:50.581Z: -----------------------------------------------------------------------------
2022-08-21 20:57:50.599Z: Checking whether SageMath should install SPKG lcalc...
2022-08-21 20:57:50.618Z: checking whether any of pari is installed as or will be installed as SPKG... no
2022-08-21 20:57:50.636Z: checking for lcalc... 
2022-08-21 20:57:50.655Z: /usr/bin/lcalc
2022-08-21 20:57:50.674Z: checking for lcalc/L.h... 
2022-08-21 20:57:50.697Z: yes
2022-08-21 20:57:50.717Z: checking for double-precision libLfunction >= 2.0.0 with pari support... 
2022-08-21 20:57:52.144Z: found; using lcalc from the system
2022-08-21 20:57:52.177Z: configure: will use system package and not install SPKG lcalc
2022-08-21 20:57:52.199Z: -----------------------------------------------------------------------------
2022-08-21 20:57:52.218Z: Checking whether SageMath should install SPKG libbraiding...
2022-08-21 20:57:52.236Z: checking if we can link against libbraiding... 
2022-08-21 20:57:52.592Z: yes
2022-08-21 20:57:52.616Z: configure: will use system package and not install SPKG libbraiding
2022-08-21 20:57:52.637Z: -----------------------------------------------------------------------------
2022-08-21 20:57:52.657Z: Checking whether SageMath should install SPKG libffi...
2022-08-21 20:57:52.677Z: checking for libffi... 
2022-08-21 20:57:52.710Z: yes
2022-08-21 20:57:52.764Z: configure: will use system package and not install SPKG libffi
2022-08-21 20:57:52.785Z: -----------------------------------------------------------------------------
2022-08-21 20:57:52.808Z: Checking whether SageMath should install SPKG libgd...
2022-08-21 20:57:52.828Z: checking whether any of gcc libpng freetype is installed as or will be installed as SPKG... no
2022-08-21 20:57:52.848Z: checking for gdlib >= 2.1... 
2022-08-21 20:57:52.871Z: yes
2022-08-21 20:57:52.891Z: configure: will use system package and not install SPKG libgd
2022-08-21 20:57:52.911Z: -----------------------------------------------------------------------------
2022-08-21 20:57:52.931Z: Checking whether SageMath should install SPKG libgraphviz...
2022-08-21 20:57:52.951Z: checking for graphviz/cgraph.h... 
2022-08-21 20:57:52.972Z: no
2022-08-21 20:57:52.993Z: configure: no suitable system package found for SPKG libgraphviz
2022-08-21 20:57:53.029Z: -----------------------------------------------------------------------------
2022-08-21 20:57:53.049Z: Checking whether SageMath should install SPKG libhomfly...
2022-08-21 20:57:53.075Z: checking whether any of gc is installed as or will be installed as SPKG... no
2022-08-21 20:57:53.095Z: checking for homfly.h... 
2022-08-21 20:57:53.133Z: yes
2022-08-21 20:57:53.152Z: checking for library containing homfly... 
2022-08-21 20:57:53.178Z: -lhomfly
2022-08-21 20:57:53.198Z: configure: will use system package and not install SPKG libhomfly
2022-08-21 20:57:53.218Z: -----------------------------------------------------------------------------
2022-08-21 20:57:53.239Z: Checking whether SageMath should install SPKG xz...
2022-08-21 20:57:53.260Z: configure: SPKG xz is not required on this system
2022-08-21 20:57:53.284Z: -----------------------------------------------------------------------------
2022-08-21 20:57:53.302Z: Checking whether SageMath should install SPKG liblzma...
2022-08-21 20:57:53.323Z: checking whether any of xz is installed as or will be installed as SPKG... no
2022-08-21 20:57:53.342Z: checking for lzma_raw_decoder in -llzma... 
2022-08-21 20:57:53.364Z: yes
2022-08-21 20:57:53.383Z: checking for lzma.h... 
2022-08-21 20:57:53.407Z: yes
2022-08-21 20:57:53.430Z: configure: will use system package and not install SPKG liblzma
2022-08-21 20:57:53.450Z: -----------------------------------------------------------------------------
2022-08-21 20:57:53.481Z: Checking whether SageMath should install SPKG nauty...
2022-08-21 20:57:53.511Z: checking for geng... 
2022-08-21 20:57:53.535Z: no
2022-08-21 20:57:53.553Z: checking for nauty-geng... /usr/bin/nauty-geng
2022-08-21 20:57:53.577Z: checking for nauty-directg... 
2022-08-21 20:57:53.598Z: /usr/bin/nauty-directg
2022-08-21 20:57:53.617Z: checking for nauty-gentourng... 
2022-08-21 20:57:53.638Z: /usr/bin/nauty-gentourng
2022-08-21 20:57:53.656Z: checking for nauty-geng... 
2022-08-21 20:57:53.675Z: /usr/bin/nauty-geng
2022-08-21 20:57:53.697Z: checking for nauty-genbg... 
2022-08-21 20:57:53.717Z: /usr/bin/nauty-genbg
2022-08-21 20:57:53.737Z: checking for nauty-gentreeg... 
2022-08-21 20:57:53.756Z: /usr/bin/nauty-gentreeg
2022-08-21 20:57:53.776Z: checking for nauty-converseg... 
2022-08-21 20:57:53.794Z: /usr/bin/nauty-converseg
2022-08-21 20:57:53.813Z: configure: will use system package and not install SPKG nauty
2022-08-21 20:57:53.835Z: -----------------------------------------------------------------------------
2022-08-21 20:57:53.857Z: Checking whether SageMath should install SPKG libnauty...
2022-08-21 20:57:53.879Z: checking whether any of nauty is installed as or will be installed as SPKG... no
2022-08-21 20:57:53.901Z: checking for nauty/nauty.h... 
2022-08-21 20:57:53.926Z: no
2022-08-21 20:57:53.946Z: checking for library containing densenauty... 
2022-08-21 20:57:53.965Z: no
2022-08-21 20:57:53.987Z: configure: no suitable system package found for SPKG libnauty
2022-08-21 20:57:54.013Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.037Z: Checking whether SageMath should install SPKG libsemigroups...
2022-08-21 20:57:54.064Z: checking for libsemigroups >= 0.6.7... 
2022-08-21 20:57:54.084Z: no
2022-08-21 20:57:54.104Z: configure: no suitable system package found for SPKG libsemigroups
2022-08-21 20:57:54.123Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.143Z: Checking whether SageMath should install SPKG libxml2...
2022-08-21 20:57:54.162Z: checking for xml2-config... 
2022-08-21 20:57:54.180Z: /usr/bin/xml2-config
2022-08-21 20:57:54.198Z: configure: will use system package and not install SPKG libxml2
2022-08-21 20:57:54.218Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.238Z: Checking whether SageMath should install SPKG m4rie...
2022-08-21 20:57:54.260Z: checking whether any of m4ri is installed as or will be installed as SPKG... no
2022-08-21 20:57:54.282Z: checking for m4rie/m4rie.h... 
2022-08-21 20:57:54.301Z: yes
2022-08-21 20:57:54.321Z: checking for library containing gf2e_init... 
2022-08-21 20:57:54.354Z: -lm4rie
2022-08-21 20:57:54.377Z: configure: will use system package and not install SPKG m4rie
2022-08-21 20:57:54.397Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.421Z: Checking whether SageMath should install SPKG linbox...
2022-08-21 20:57:54.441Z: configure: linbox has already been installed by SageMath
2022-08-21 20:57:54.459Z: 
2022-08-21 20:57:54.480Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.500Z: Checking whether SageMath should install SPKG llvm...
2022-08-21 20:57:54.523Z: configure: will use system package and not install SPKG llvm
2022-08-21 20:57:54.543Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.563Z: Checking whether SageMath should install SPKG lrcalc...
2022-08-21 20:57:54.584Z: configure: lrcalc has already been installed by SageMath
2022-08-21 20:57:54.605Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.625Z: Checking whether SageMath should install SPKG lrslib...
2022-08-21 20:57:54.652Z: checking whether any of gmp flint is installed as or will be installed as SPKG... no
2022-08-21 20:57:54.680Z: checking for lrsnash... 
2022-08-21 20:57:54.700Z: no
2022-08-21 20:57:54.719Z: configure: no suitable system package found for SPKG lrslib
2022-08-21 20:57:54.743Z: -----------------------------------------------------------------------------
2022-08-21 20:57:54.763Z: Checking whether SageMath should install SPKG mpc...
2022-08-21 20:57:54.783Z: checking whether any of mpfr is installed as or will be installed as SPKG... no
2022-08-21 20:57:54.809Z: checking for mpc.h... 
2022-08-21 20:57:54.833Z: yes
2022-08-21 20:57:54.859Z: checking for library containing mpc_cmp_abs... 
2022-08-21 20:57:54.911Z: -lmpc
2022-08-21 20:57:54.954Z: configure: will use system package and not install SPKG mpc
2022-08-21 20:57:54.981Z: using mpc library from the system
2022-08-21 20:57:55.021Z: -----------------------------------------------------------------------------
2022-08-21 20:57:55.044Z: Checking whether SageMath should install SPKG mpfi...
2022-08-21 20:57:55.070Z: checking whether any of mpfr is installed as or will be installed as SPKG... no
2022-08-21 20:57:55.100Z: checking for mpfi.h... 
2022-08-21 20:57:55.132Z: yes
2022-08-21 20:57:55.165Z: checking for library containing mpfi_diam_abs... 
2022-08-21 20:57:55.184Z: -lmpfi
2022-08-21 20:57:55.206Z: checking MPFI version >= 1.5... 
2022-08-21 20:57:55.235Z: yes
2022-08-21 20:57:55.273Z: configure: will use system package and not install SPKG mpfi
2022-08-21 20:57:55.300Z: -----------------------------------------------------------------------------
2022-08-21 20:57:55.324Z: Checking whether SageMath should install SPKG ninja_build...
2022-08-21 20:57:55.358Z: checking for ninja >= 1.7.2... 
2022-08-21 20:57:55.378Z: 
2022-08-21 20:57:55.400Z: configure: no suitable system package found for SPKG ninja_build
2022-08-21 20:57:55.419Z: -----------------------------------------------------------------------------
2022-08-21 20:57:55.450Z: Checking whether SageMath should install SPKG python3...
2022-08-21 20:57:55.469Z: checking whether any of bzip2 liblzma libffi is installed as or will be installed as SPKG... no
2022-08-21 20:57:55.504Z: checking for python3 >= 3.8.0, < 3.11.0 with modules sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip... 
2022-08-21 20:57:55.541Z: checking ... whether /usr/bin/python3 is good... 
2022-08-21 20:57:56.067Z: yes
2022-08-21 20:57:56.087Z: checking for python3 >= 3.8.0, < 3.11.0 with modules sqlite3, ctypes, math, hashlib, crypt, socket, zlib, distutils.core, ssl, ensurepip... /usr/bin/python3
2022-08-21 20:57:56.106Z: configure: will use system package and not install SPKG python3
2022-08-21 20:57:56.125Z: checking whether /usr/bin/python3 is configured to build multiarch extensions... 
2022-08-21 20:57:56.144Z: no
2022-08-21 20:57:56.164Z: checking whether "-march=native" works with the C/C++ compilers configured for building extensions for /usr/bin/python3... 
2022-08-21 20:57:56.576Z: yes
2022-08-21 20:57:56.597Z: checking whether OpenMP works with the C/C++ compilers configured for building extensions for /usr/bin/python3... 
2022-08-21 20:57:57.083Z: yes
2022-08-21 20:57:57.139Z: -----------------------------------------------------------------------------
2022-08-21 20:57:57.160Z: Checking whether SageMath should install SPKG openssl...
2022-08-21 20:57:57.180Z: configure: SPKG openssl is not required on this system
2022-08-21 20:57:57.201Z: -----------------------------------------------------------------------------
2022-08-21 20:57:57.221Z: 
2022-08-21 20:57:57.266Z: Checking whether SageMath should install SPKG palp...
2022-08-21 20:57:57.298Z: 
2022-08-21 20:57:57.318Z: checking for poly.x... 
2022-08-21 20:57:57.339Z: /usr/bin/poly.x
2022-08-21 20:57:57.365Z: checking for poly-4d.x... /usr/bin/poly-4d.x
2022-08-21 20:57:57.388Z: checking for poly-5d.x... 
2022-08-21 20:57:57.428Z: /usr/bin/poly-5d.x
2022-08-21 20:57:57.447Z: 
2022-08-21 20:57:57.473Z: checking for poly-6d.x... 
2022-08-21 20:57:57.495Z: /usr/bin/poly-6d.x
2022-08-21 20:57:57.517Z: 
2022-08-21 20:57:57.552Z: checking for poly-11d.x... 
2022-08-21 20:57:57.588Z: /usr/bin/poly-11d.x
2022-08-21 20:57:57.619Z: 
2022-08-21 20:57:57.660Z: checking for class.x... 
2022-08-21 20:57:57.686Z: /usr/bin/class.x
2022-08-21 20:57:57.707Z: 
2022-08-21 20:57:57.730Z: checking for class-4d.x... 
2022-08-21 20:57:57.753Z: /usr/bin/class-4d.x
2022-08-21 20:57:57.777Z: 
2022-08-21 20:57:57.805Z: checking for class-5d.x... 
2022-08-21 20:57:57.831Z: /usr/bin/class-5d.x
2022-08-21 20:57:57.852Z: 
2022-08-21 20:57:57.874Z: checking for class-6d.x... 
2022-08-21 20:57:57.894Z: /usr/bin/class-6d.x
2022-08-21 20:57:57.915Z: 
2022-08-21 20:57:57.937Z: checking for class-11d.x... 
2022-08-21 20:57:57.958Z: /usr/bin/class-11d.x
2022-08-21 20:57:57.980Z: 
2022-08-21 20:57:58.009Z: checking for nef.x... 
2022-08-21 20:57:58.035Z: /usr/bin/nef.x
2022-08-21 20:57:58.056Z: checking for nef-4d.x... 
2022-08-21 20:57:58.081Z: /usr/bin/nef-4d.x
2022-08-21 20:57:58.123Z: checking for nef-5d.x... 
2022-08-21 20:57:58.143Z: /usr/bin/nef-5d.x
2022-08-21 20:57:58.165Z: checking for nef-6d.x... 
2022-08-21 20:57:58.187Z: /usr/bin/nef-6d.x
2022-08-21 20:57:58.208Z: checking for nef-11d.x... 
2022-08-21 20:57:58.230Z: /usr/bin/nef-11d.x
2022-08-21 20:57:58.251Z: checking for cws.x... 
2022-08-21 20:57:58.271Z: /usr/bin/cws.x
2022-08-21 20:57:58.291Z: checking for cws-4d.x... 
2022-08-21 20:57:58.314Z: /usr/bin/cws-4d.x
2022-08-21 20:57:58.335Z: checking for cws-5d.x... 
2022-08-21 20:57:58.356Z: /usr/bin/cws-5d.x
2022-08-21 20:57:58.379Z: checking for cws-6d.x... 
2022-08-21 20:57:58.405Z: /usr/bin/cws-6d.x
2022-08-21 20:57:58.427Z: checking for cws-11d.x... 
2022-08-21 20:57:58.454Z: /usr/bin/cws-11d.x
2022-08-21 20:57:58.478Z: configure: will use system package and not install SPKG palp
2022-08-21 20:57:58.501Z: -----------------------------------------------------------------------------
2022-08-21 20:57:58.537Z: Checking whether SageMath should install SPKG pandoc...
2022-08-21 20:57:58.573Z: checking for pandoc... 
2022-08-21 20:57:58.605Z: no
2022-08-21 20:57:58.640Z: configure: no suitable system package found for SPKG pandoc
2022-08-21 20:57:58.670Z: -----------------------------------------------------------------------------
2022-08-21 20:57:58.703Z: Checking whether SageMath should install SPKG pari_elldata...
2022-08-21 20:57:58.736Z: checking installing pari? ... 
2022-08-21 20:57:58.766Z: no
2022-08-21 20:57:58.795Z: configure: will use system package and not install SPKG pari_elldata
2022-08-21 20:57:58.830Z: -----------------------------------------------------------------------------
2022-08-21 20:57:58.861Z: Checking whether SageMath should install SPKG pari_galdata...
2022-08-21 20:57:58.897Z: checking installing pari? ... 
2022-08-21 20:57:58.935Z: no
2022-08-21 20:57:58.971Z: configure: will use system package and not install SPKG pari_galdata
2022-08-21 20:57:59.007Z: -----------------------------------------------------------------------------
2022-08-21 20:57:59.042Z: Checking whether SageMath should install SPKG pari_galpol...
2022-08-21 20:57:59.075Z: checking installing pari? ... 
2022-08-21 20:57:59.111Z: no
2022-08-21 20:57:59.141Z: 
2022-08-21 20:57:59.177Z: configure: will use system package and not install SPKG pari_galpol
2022-08-21 20:57:59.209Z: 
2022-08-21 20:57:59.237Z: -----------------------------------------------------------------------------
2022-08-21 20:57:59.269Z: 
2022-08-21 20:57:59.307Z: Checking whether SageMath should install SPKG pari_nftables...
2022-08-21 20:57:59.337Z: 
2022-08-21 20:57:59.371Z: checking installing pari? ... 
2022-08-21 20:57:59.404Z: no
2022-08-21 20:57:59.439Z: configure: Installing nftables should be done by the user,
2022-08-21 20:57:59.470Z: configure: cf. http://pari.math.u-bordeaux1.fr/pub/pari/packages/nftables/README.txt
2022-08-21 20:57:59.506Z: configure: will use system package and not install SPKG pari_nftables
2022-08-21 20:57:59.536Z: -----------------------------------------------------------------------------
2022-08-21 20:57:59.567Z: Checking whether SageMath should install SPKG pari_seadata...
2022-08-21 20:57:59.603Z: checking installing pari? ... 
2022-08-21 20:57:59.634Z: no
2022-08-21 20:57:59.670Z: configure: will use system package and not install SPKG pari_seadata
2022-08-21 20:57:59.716Z: -----------------------------------------------------------------------------
2022-08-21 20:57:59.746Z: Checking whether SageMath should install SPKG pari_seadata_small...
2022-08-21 20:57:59.782Z: checking installing pari? ... 
2022-08-21 20:57:59.808Z: no
2022-08-21 20:57:59.834Z: configure: will use system package and not install SPKG pari_seadata_small
2022-08-21 20:57:59.858Z: -----------------------------------------------------------------------------
2022-08-21 20:57:59.879Z: Checking whether SageMath should install SPKG patch...
2022-08-21 20:57:59.903Z: checking for GNU patch >= 2.7.0... 
2022-08-21 20:57:59.935Z: /usr/bin/patch
2022-08-21 20:57:59.975Z: configure: will use system package and not install SPKG patch
2022-08-21 20:58:00.015Z: -----------------------------------------------------------------------------
2022-08-21 20:58:00.045Z: Checking whether SageMath should install SPKG pcre...
2022-08-21 20:58:00.079Z: checking installing bzip2? ... 
2022-08-21 20:58:00.106Z: no
2022-08-21 20:58:00.130Z: checking for libpcre >= 8.39 libpcreposix libpcrecpp... 
2022-08-21 20:58:00.157Z: yes
2022-08-21 20:58:00.179Z: configure: will use system package and not install SPKG pcre
2022-08-21 20:58:00.199Z: -----------------------------------------------------------------------------
2022-08-21 20:58:00.225Z: Checking whether SageMath should install SPKG pdf2svg...
2022-08-21 20:58:00.252Z: checking for pdf2svg... 
2022-08-21 20:58:00.276Z: no
2022-08-21 20:58:00.299Z: configure: no suitable system package found for SPKG pdf2svg
2022-08-21 20:58:00.323Z: -----------------------------------------------------------------------------
2022-08-21 20:58:00.660Z: Checking whether SageMath should install SPKG perl_cpan_polymake_prereq...
2022-08-21 20:58:00.696Z: checking for perl module XML::Writer... 
2022-08-21 20:58:00.718Z: no
2022-08-21 20:58:00.739Z: checking for perl module XML::LibXML... 
2022-08-21 20:58:00.761Z: no
2022-08-21 20:58:00.782Z: checking for perl module XML::LibXSLT... 
2022-08-21 20:58:00.810Z: no
2022-08-21 20:58:00.833Z: checking for perl module File::Slurp... 
2022-08-21 20:58:00.852Z: no
2022-08-21 20:58:00.873Z: checking for perl module JSON... 
2022-08-21 20:58:00.901Z: no
2022-08-21 20:58:00.929Z: checking for perl module SVG... 
2022-08-21 20:58:00.963Z: no
2022-08-21 20:58:00.985Z: checking for perl module Term::ReadKey... 
2022-08-21 20:58:01.059Z: no
2022-08-21 20:58:01.108Z: configure: no suitable system package found for SPKG perl_cpan_polymake_prereq
2022-08-21 20:58:01.175Z: -----------------------------------------------------------------------------
2022-08-21 20:58:01.194Z: Checking whether SageMath should install SPKG perl_mongodb...
2022-08-21 20:58:01.222Z: checking for perl module MongoDB... 
2022-08-21 20:58:01.245Z: no
2022-08-21 20:58:01.289Z: configure: no suitable system package found for SPKG perl_mongodb
2022-08-21 20:58:01.324Z: -----------------------------------------------------------------------------
2022-08-21 20:58:01.362Z: Checking whether SageMath should install SPKG perl_term_readline_gnu...
2022-08-21 20:58:01.532Z: checking for perl module Term::ReadLine... 
2022-08-21 20:58:01.555Z: ok
2022-08-21 20:58:01.580Z: checking Term::ReadLine module...... 
2022-08-21 20:58:01.599Z: non-GNU
2022-08-21 20:58:01.622Z: configure: no suitable system package found for SPKG perl_term_readline_gnu
2022-08-21 20:58:01.643Z: -----------------------------------------------------------------------------
2022-08-21 20:58:01.663Z: Checking whether SageMath should install SPKG pkgconf...
2022-08-21 20:58:01.696Z: using pkg-config from the system
2022-08-21 20:58:01.716Z: configure: will use system package and not install SPKG pkgconf
2022-08-21 20:58:01.736Z: -----------------------------------------------------------------------------
2022-08-21 20:58:01.757Z: Checking whether SageMath should install SPKG planarity...
2022-08-21 20:58:01.779Z: checking for planarity/planarity.h... 
2022-08-21 20:58:01.803Z: yes
2022-08-21 20:58:01.823Z: checking for gp_InitGraph in -lplanarity... 
2022-08-21 20:58:01.846Z: yes
2022-08-21 20:58:01.866Z: checking for planarity version 3.0 or later... 
2022-08-21 20:58:01.886Z: yes
2022-08-21 20:58:01.906Z: 
2022-08-21 20:58:01.929Z: configure: will use system package and not install SPKG planarity
2022-08-21 20:58:01.949Z: 
2022-08-21 20:58:01.971Z: -----------------------------------------------------------------------------
2022-08-21 20:58:01.990Z: 
2022-08-21 20:58:02.014Z: Checking whether SageMath should install SPKG polymake...
2022-08-21 20:58:02.034Z: 
2022-08-21 20:58:02.057Z: checking for polymake-config >= 3.5... 
2022-08-21 20:58:02.081Z: 
2022-08-21 20:58:02.101Z: configure: no suitable system package found for SPKG polymake
2022-08-21 20:58:02.124Z: 
2022-08-21 20:58:02.155Z: -----------------------------------------------------------------------------
2022-08-21 20:58:02.177Z: 
2022-08-21 20:58:02.198Z: Checking whether SageMath should install SPKG ppl...
2022-08-21 20:58:02.218Z: 
2022-08-21 20:58:02.239Z: checking whether any of gcc glpk gmp is installed as or will be installed as SPKG... 
2022-08-21 20:58:02.276Z: no
2022-08-21 20:58:02.296Z: 
2022-08-21 20:58:02.317Z: checking for ppl-config... 
2022-08-21 20:58:02.342Z: /usr/bin/ppl-config
2022-08-21 20:58:02.364Z: 
2022-08-21 20:58:02.385Z: checking for the Parma Polyhedra Library, version >= 1.2... 
2022-08-21 20:58:02.405Z: yes
2022-08-21 20:58:02.432Z: configure: will use system package and not install SPKG ppl
2022-08-21 20:58:02.452Z: -----------------------------------------------------------------------------
2022-08-21 20:58:02.479Z: Checking whether SageMath should install SPKG primesieve...
2022-08-21 20:58:02.499Z: configure: primesieve has already been installed by SageMath
2022-08-21 20:58:02.519Z: -----------------------------------------------------------------------------
2022-08-21 20:58:02.554Z: Checking whether SageMath should install SPKG primecount...
2022-08-21 20:58:02.575Z: configure: primecount has already been installed by SageMath
2022-08-21 20:58:02.596Z: -----------------------------------------------------------------------------
2022-08-21 20:58:02.617Z: Checking whether SageMath should install SPKG qhull...
2022-08-21 20:58:02.637Z: configure: qhull has already been installed by SageMath
2022-08-21 20:58:02.658Z: -----------------------------------------------------------------------------
2022-08-21 20:58:02.678Z: Checking whether SageMath should install SPKG r...
2022-08-21 20:58:02.698Z: checking whether any of openblas iconv readline bzip2 liblzma pcre curl is installed as or will be installed as SPKG... 
2022-08-21 20:58:02.717Z: no
2022-08-21 20:58:02.738Z: checking for libR >= 3.4.4... 
2022-08-21 20:58:02.762Z: yes
2022-08-21 20:58:02.823Z: checking for R... 
2022-08-21 20:58:02.892Z: /usr/bin/R
2022-08-21 20:58:02.969Z: configure: will use system package and not install SPKG r
2022-08-21 20:58:03.052Z: -----------------------------------------------------------------------------
2022-08-21 20:58:03.082Z: Checking whether SageMath should install SPKG rw...
2022-08-21 20:58:03.150Z: checking for rw.h... 
2022-08-21 20:58:03.213Z: yes
2022-08-21 20:58:03.278Z: checking for library containing calculate_level... 
2022-08-21 20:58:03.325Z: -lrw
2022-08-21 20:58:03.366Z: configure: will use system package and not install SPKG rw
2022-08-21 20:58:03.399Z: -----------------------------------------------------------------------------
2022-08-21 20:58:03.438Z: Checking whether SageMath should install SPKG singular...
2022-08-21 20:58:03.458Z: checking whether any of gmp ntl flint readline mpfr cddlib is installed as or will be installed as SPKG... 
2022-08-21 20:58:03.483Z: no
2022-08-21 20:58:03.507Z: checking for Singular... 
2022-08-21 20:58:03.545Z: /usr/bin/Singular
2022-08-21 20:58:03.570Z: checking for Singular >= 4.2.1... 
2022-08-21 20:58:03.600Z: yes
2022-08-21 20:58:03.621Z: checking that Singular's help is working... 
2022-08-21 20:58:03.642Z: yes
2022-08-21 20:58:03.665Z: checking if we can dlopen()... 
2022-08-21 20:58:03.685Z: yes
2022-08-21 20:58:03.708Z: configure: will use system package and not install SPKG singular
2022-08-21 20:58:03.727Z: -----------------------------------------------------------------------------
2022-08-21 20:58:03.748Z: Checking whether SageMath should install SPKG sqlite...
2022-08-21 20:58:03.783Z: configure: SPKG sqlite is not required on this system
2022-08-21 20:58:03.801Z: -----------------------------------------------------------------------------
2022-08-21 20:58:03.823Z: Checking whether SageMath should install SPKG suitesparse...
2022-08-21 20:58:03.844Z: checking whether any of openblas is installed as or will be installed as SPKG... no
2022-08-21 20:58:03.865Z: checking for library containing cholmod_speye... 
2022-08-21 20:58:03.887Z: -lcholmod
2022-08-21 20:58:03.908Z: checking for library containing umfpack_di_solve... 
2022-08-21 20:58:03.929Z: -lumfpack
2022-08-21 20:58:03.951Z: checking for library containing SuiteSparse_version... 
2022-08-21 20:58:03.976Z: -lsuitesparseconfig
2022-08-21 20:58:03.996Z: checking for suitesparse/SuiteSparse_config.h... 
2022-08-21 20:58:04.017Z: yes
2022-08-21 20:58:04.036Z: checking for suitesparse/amd.h... 
2022-08-21 20:58:04.057Z: yes
2022-08-21 20:58:04.081Z: configure: will use system package and not install SPKG suitesparse
2022-08-21 20:58:04.100Z: -----------------------------------------------------------------------------
2022-08-21 20:58:04.123Z: Checking whether SageMath should install SPKG symmetrica...
2022-08-21 20:58:04.143Z: checking for symmetrica/def.h... 
2022-08-21 20:58:04.165Z: yes
2022-08-21 20:58:04.186Z: checking for library containing zykelind_tetraeder_edges_extended... 
2022-08-21 20:58:04.206Z: -lsymmetrica
2022-08-21 20:58:04.226Z: checking whether we have a properly patched Symmetrica version... 
2022-08-21 20:58:04.247Z: appears to be a well-patched version.
2022-08-21 20:58:04.267Z: configure: will use system package and not install SPKG symmetrica
2022-08-21 20:58:04.286Z: -----------------------------------------------------------------------------
2022-08-21 20:58:04.306Z: Checking whether SageMath should install SPKG sympow...
2022-08-21 20:58:04.328Z: checking for sympow... 
2022-08-21 20:58:04.349Z: /usr/bin/sympow
2022-08-21 20:58:04.371Z: checking whether sympow works well (cf. :trac:30147 and :trac:30633)... 
2022-08-21 20:58:04.395Z: yes; use system sympow
2022-08-21 20:58:04.414Z: configure: will use system package and not install SPKG sympow
2022-08-21 20:58:04.435Z: -----------------------------------------------------------------------------
2022-08-21 20:58:04.454Z: Checking whether SageMath should install SPKG tachyon...
2022-08-21 20:58:04.476Z: checking for tachyon... 
2022-08-21 20:58:04.496Z: /usr/bin/tachyon
2022-08-21 20:58:04.517Z: configure: will use system package and not install SPKG tachyon
2022-08-21 20:58:04.538Z: -----------------------------------------------------------------------------
2022-08-21 20:58:04.558Z: Checking whether SageMath should install SPKG texlive...
2022-08-21 20:58:04.578Z: checking for pdflatex... 
2022-08-21 20:58:04.601Z: no
2022-08-21 20:58:04.620Z: checking for latexmk... 
2022-08-21 20:58:04.640Z: no
2022-08-21 20:58:04.662Z: checking for dvipng... 
2022-08-21 20:58:04.681Z: no
2022-08-21 20:58:04.700Z: checking for latex package fontspec... 
2022-08-21 20:58:04.722Z: no
2022-08-21 20:58:04.743Z: checking for latex package xunicode... 
2022-08-21 20:58:04.774Z: no
2022-08-21 20:58:04.793Z: checking for latex package xltxtra... 
2022-08-21 20:58:04.814Z: no
2022-08-21 20:58:04.833Z: checking for latex package amssymb... 
2022-08-21 20:58:04.853Z: no
2022-08-21 20:58:04.875Z: checking for latex package amsfonts... 
2022-08-21 20:58:04.900Z: no
2022-08-21 20:58:04.926Z: checking for latex package graphicx... no
2022-08-21 20:58:04.947Z: checking for latex package mathrsfs... 
2022-08-21 20:58:04.967Z: no
2022-08-21 20:58:04.987Z: checking for latex package textcomp... 
2022-08-21 20:58:05.009Z: no
2022-08-21 20:58:05.030Z: checking for latex package tikz... 
2022-08-21 20:58:05.049Z: no
2022-08-21 20:58:05.075Z: checking for latex package tikz-qtree... 
2022-08-21 20:58:05.096Z: no
2022-08-21 20:58:05.117Z: checking for latex package iftex... 
2022-08-21 20:58:05.137Z: no
2022-08-21 20:58:05.156Z: checking for latex package tkz-berge... 
2022-08-21 20:58:05.176Z: no
2022-08-21 20:58:05.197Z: checking for latex package tkz-graph... 
2022-08-21 20:58:05.226Z: no
2022-08-21 20:58:05.247Z: checking for latex package xy... 
2022-08-21 20:58:05.271Z: no
2022-08-21 20:58:05.292Z: checking for latex package babel... 
2022-08-21 20:58:05.313Z: no
2022-08-21 20:58:05.332Z: checking for latex package subfigure... 
2022-08-21 20:58:05.355Z: no
2022-08-21 20:58:05.378Z: checking for latex package hyperref... 
2022-08-21 20:58:05.403Z: no
2022-08-21 20:58:05.425Z: checking for latex package hypcap... 
2022-08-21 20:58:05.445Z: no
2022-08-21 20:58:05.464Z: checking for latex package xr... 
2022-08-21 20:58:05.484Z: no
2022-08-21 20:58:05.503Z: checking for latex package tgtermes... 
2022-08-21 20:58:05.523Z: no
2022-08-21 20:58:05.542Z: checking for latex package fncychap... 
2022-08-21 20:58:05.561Z: no
2022-08-21 20:58:05.582Z: configure: no suitable system package found for SPKG texlive
2022-08-21 20:58:05.602Z: -----------------------------------------------------------------------------
2022-08-21 20:58:05.637Z: Checking whether SageMath should install SPKG toml...
2022-08-21 20:58:05.657Z: configure: SPKG toml is not required on this system
2022-08-21 20:58:05.687Z: -----------------------------------------------------------------------------
2022-08-21 20:58:05.706Z: Checking whether SageMath should install SPKG zeromq...
2022-08-21 20:58:05.728Z: checking whether any of gcc is installed as or will be installed as SPKG... no
2022-08-21 20:58:05.748Z: checking for zmq.h... 
2022-08-21 20:58:05.769Z: yes
2022-08-21 20:58:05.789Z: checking for ZMQ version >= 4.2.5... 
2022-08-21 20:58:05.809Z: yes
2022-08-21 20:58:05.829Z: configure: will use system package and not install SPKG zeromq
2022-08-21 20:58:05.848Z: -----------------------------------------------------------------------------
2022-08-21 20:58:05.869Z: Checking whether SageMath should install SPKG zn_poly...
2022-08-21 20:58:05.894Z: checking whether any of gmp is installed as or will be installed as SPKG... 
2022-08-21 20:58:05.914Z: no
2022-08-21 20:58:05.938Z: checking for zn_poly/zn_poly.h... 
2022-08-21 20:58:05.961Z: yes
2022-08-21 20:58:05.983Z: checking for library containing zn_mod_init... 
2022-08-21 20:58:06.004Z: -lzn_poly
2022-08-21 20:58:06.024Z: configure: will use system package and not install SPKG zn_poly
2022-08-21 20:58:06.043Z: ## ----------------------------------------------------------------------- ##
2022-08-21 20:58:06.064Z: ## Build status for each package:                                          ##
2022-08-21 20:58:06.085Z: ## ----------------------------------------------------------------------- ##
2022-08-21 20:58:06.106Z: 4ti2:                           no suitable system package; optional, use "./configure --enable-4ti2" to install SPKG version 1.6.7.p0
2022-08-21 20:58:06.129Z: admcycles:                      optional pip package; use "./sage -i admcycles" to install
2022-08-21 20:58:06.148Z: alabaster:                      standard, SPKG version 0.7.12 is already installed
2022-08-21 20:58:06.173Z: appdirs:                        not required on your platform; SPKG will not be installed
2022-08-21 20:58:06.198Z: appnope:                        standard, SPKG version 0.1.3 is already installed
2022-08-21 20:58:06.224Z: arb:                            using system package; SPKG will not be installed
2022-08-21 20:58:06.246Z: argon2_cffi:                    standard, SPKG version 20.1.0 is already installed
2022-08-21 20:58:06.267Z: asttokens:                      standard, SPKG version 2.0.5 is already installed
2022-08-21 20:58:06.287Z: attrs:                          standard, SPKG version 21.4.0 is already installed
2022-08-21 20:58:06.308Z: awali:                          experimental, use "./configure --enable-awali" to install SPKG version 1.0.2-190218
2022-08-21 20:58:06.328Z: babel:                          standard, SPKG version 2.9.1 is already installed
2022-08-21 20:58:06.359Z: backcall:                       standard, SPKG version 0.2.0 is already installed
2022-08-21 20:58:06.381Z: backports_zoneinfo:             standard, SPKG version 0.2.1 is already installed
2022-08-21 20:58:06.401Z: barvinok:                       optional, use "./configure --enable-barvinok" to install SPKG version 0.41.1
2022-08-21 20:58:06.421Z: beautifulsoup4:                 standard, SPKG version 4.11.1 is already installed
2022-08-21 20:58:06.440Z: beniget:                        standard, SPKG version 0.4.1 is already installed
2022-08-21 20:58:06.462Z: benzene:                        optional, use "./configure --enable-benzene" to install SPKG version 20130630
2022-08-21 20:58:06.485Z: biopython:                      optional pip package; use "./sage -i biopython" to install
2022-08-21 20:58:06.509Z: bleach:                         standard, SPKG version 5.0.0 is already installed
2022-08-21 20:58:06.530Z: bliss:                          optional, use "./configure --enable-bliss" to install SPKG version 0.73+debian-1+sage-2016-08-02.p0
2022-08-21 20:58:06.552Z: boost_cropped:                  using system package; SPKG will not be installed
2022-08-21 20:58:06.572Z: brial:                          using system package; SPKG will not be installed
2022-08-21 20:58:06.593Z: buckygen:                       optional, use "./configure --enable-buckygen" to install SPKG version 1.1
2022-08-21 20:58:06.615Z: bzip2:                          using system package; SPKG will not be installed
2022-08-21 20:58:06.637Z: cbc:                            no suitable system package; optional, use "./configure --enable-cbc" to install SPKG version 2.9.4.p0
2022-08-21 20:58:06.657Z: ccache:                         optional, use "./configure --enable-ccache" to install SPKG version 3.3.4
2022-08-21 20:58:06.676Z: cddlib:                         using system package; SPKG will not be installed
2022-08-21 20:58:06.695Z: certifi:                        standard, SPKG version 2021.10.8 is already installed
2022-08-21 20:58:06.716Z: cffi:                           standard, SPKG version 1.15.0 is already installed
2022-08-21 20:58:06.736Z: charset_normalizer:             standard, SPKG version 2.0.12 is already installed
2022-08-21 20:58:06.757Z: cliquer:                        using system package; SPKG will not be installed
2022-08-21 20:58:06.778Z: cmake:                          using system package; SPKG will not be installed
2022-08-21 20:58:06.801Z: cocoalib:                       experimental, use "./configure --enable-cocoalib" to install SPKG version 0.99564
2022-08-21 20:58:06.825Z: combinatorial_designs:          standard, SPKG version 20140630.p0 is already installed
2022-08-21 20:58:06.846Z: configure:                      base, use "./configure --enable-configure" to install SPKG version a3be8106604ed6a2c1d7d119e67674e3166a6eec
2022-08-21 20:58:06.866Z: conway_polynomials:             standard, SPKG version 0.5 is already installed
2022-08-21 20:58:06.888Z: coxeter3:                       no suitable system package; optional, use "./configure --enable-coxeter3" to install SPKG version 8ac9c71723c8ca57a836d6381aed125261e44e9e.p0
2022-08-21 20:58:06.912Z: cppy:                           standard, SPKG version 1.1.0 is already installed
2022-08-21 20:58:06.935Z: cryptominisat:                  optional, use "./configure --enable-cryptominisat" to install SPKG version 5.8.0
2022-08-21 20:58:06.956Z: csdp:                           optional, use "./configure --enable-csdp" to install SPKG version 6.2.p1
2022-08-21 20:58:06.978Z: cunningham_tables:              optional, use "./configure --enable-cunningham_tables" to install SPKG version 1.0
2022-08-21 20:58:07.000Z: curl:                           using system package; SPKG will not be installed
2022-08-21 20:58:07.022Z: cvxopt:                         standard, SPKG version 1.3.0 is already installed
2022-08-21 20:58:07.050Z: cycler:                         standard, SPKG version 0.11.0 is already installed
2022-08-21 20:58:07.072Z: cylp:                           optional, use "./configure --enable-cylp" to install SPKG version 0.91.4
2022-08-21 20:58:07.095Z: cypari:                         standard, SPKG version 2.1.2 is already installed
2022-08-21 20:58:07.117Z: cysignals:                      standard, SPKG version 1.11.2 is already installed
2022-08-21 20:58:07.137Z: cython:                         standard, SPKG version 0.29.32 is already installed
2022-08-21 20:58:07.160Z: d3js:                           optional, use "./configure --enable-d3js" to install SPKG version 3.4.8
2022-08-21 20:58:07.180Z: database_cremona_ellcurve:      optional, use "./configure --enable-database_cremona_ellcurve" to install SPKG version 20190911
2022-08-21 20:58:07.200Z: database_jones_numfield:        optional, use "./configure --enable-database_jones_numfield" to install SPKG version 4
2022-08-21 20:58:07.221Z: database_knotinfo:              optional, use "./configure --enable-database_knotinfo" to install SPKG version 2021.10.1
2022-08-21 20:58:07.242Z: database_kohel:                 optional, use "./configure --enable-database_kohel" to install SPKG version 20160724
2022-08-21 20:58:07.262Z: database_mutation_class:        optional, use "./configure --enable-database_mutation_class" to install SPKG version 1.0
2022-08-21 20:58:07.283Z: database_odlyzko_zeta:          optional, use "./configure --enable-database_odlyzko_zeta" to install SPKG version 20061209
2022-08-21 20:58:07.303Z: database_stein_watkins:         optional, use "./configure --enable-database_stein_watkins" to install SPKG version 20110713
2022-08-21 20:58:07.325Z: database_stein_watkins_mini:    optional, use "./configure --enable-database_stein_watkins_mini" to install SPKG version 20070827
2022-08-21 20:58:07.344Z: database_symbolic_data:         optional, use "./configure --enable-database_symbolic_data" to install SPKG version 20070206
2022-08-21 20:58:07.370Z: dateutil:                       standard, SPKG version 2.8.2 is already installed
2022-08-21 20:58:07.392Z: debugpy:                        optional, use "./configure --enable-debugpy" to install SPKG version 1.6.0
2022-08-21 20:58:07.413Z: decorator:                      standard, SPKG version 5.1.1 is already installed
2022-08-21 20:58:07.434Z: deformation:                    experimental, use "./configure --enable-deformation" to install SPKG version 20210503
2022-08-21 20:58:07.454Z: defusedxml:                     standard, SPKG version 0.7.1 is already installed
2022-08-21 20:58:07.476Z: deprecation:                    standard, SPKG version 2.1.0 is already installed
2022-08-21 20:58:07.496Z: distlib:                        not required on your platform; SPKG will not be installed
2022-08-21 20:58:07.517Z: docutils:                       standard, SPKG version 0.17.1 is already installed
2022-08-21 20:58:07.537Z: dot2tex:                        optional, use "./configure --enable-dot2tex" to install SPKG version 2.11.3.p0
2022-08-21 20:58:07.556Z: e_antic:                        optional, use "./configure --enable-e_antic" to install SPKG version 0.1.9
2022-08-21 20:58:07.577Z: ecl:                            using system package; SPKG will not be installed
2022-08-21 20:58:07.596Z: eclib:                          SPKG version 20220621 is already installed
2022-08-21 20:58:07.617Z: ecm:                            using system package; SPKG will not be installed
2022-08-21 20:58:07.637Z: editables:                      standard, SPKG version 0.3 is already installed
2022-08-21 20:58:07.660Z: elliptic_curves:                standard, SPKG version 0.8.1 is already installed
2022-08-21 20:58:07.683Z: entrypoints:                    standard, SPKG version 0.4 is already installed
2022-08-21 20:58:07.703Z: executing:                      standard, SPKG version 0.8.3 is already installed
2022-08-21 20:58:07.725Z: fastjsonschema:                 standard, SPKG version 2.15.3 is already installed
2022-08-21 20:58:07.745Z: fflas_ffpack:                   SPKG version 2.4.3.p0 is already installed
2022-08-21 20:58:07.769Z: ffmpeg:                         no suitable system package; optional
2022-08-21 20:58:07.794Z: filelock:                       not required on your platform; SPKG will not be installed
2022-08-21 20:58:07.820Z: flint:                          using system package; SPKG will not be installed
2022-08-21 20:58:07.841Z: flintqs:                        using system package; SPKG will not be installed
2022-08-21 20:58:07.866Z: flit_core:                      standard, SPKG version 3.7.1 is already installed
2022-08-21 20:58:07.888Z: fonttools:                      standard, SPKG version 4.28.4 is already installed
2022-08-21 20:58:07.913Z: fplll:                          SPKG version 5.4.2 is already installed
2022-08-21 20:58:07.933Z: fpylll:                         standard, SPKG version 0.5.7 is already installed
2022-08-21 20:58:07.954Z: freetype:                       using system package; SPKG will not be installed
2022-08-21 20:58:07.974Z: fricas:                         optional, use "./configure --enable-fricas" to install SPKG version 1.3.8.p1
2022-08-21 20:58:07.996Z: frobby:                         optional, use "./configure --enable-frobby" to install SPKG version 0.9.0.p2
2022-08-21 20:58:08.016Z: furo:                           optional pip package; use "./sage -i furo" to install
2022-08-21 20:58:08.036Z: gambit:                         experimental, use "./configure --enable-gambit" to install SPKG version 15.1.1.p0
2022-08-21 20:58:08.058Z: gap:                            standard, SPKG version 4.11.1 is already installed
2022-08-21 20:58:08.078Z: gap3:                           experimental, use "./configure --enable-gap3" to install SPKG version 04jul17
2022-08-21 20:58:08.105Z: gap_jupyter:                    optional, use "./configure --enable-gap_jupyter" to install SPKG version 0.9
2022-08-21 20:58:08.127Z: gap_packages:                   optional, use "./configure --enable-gap_packages" to install SPKG version 4.11.1
2022-08-21 20:58:08.148Z: gast:                           standard, SPKG version 0.5.3 is already installed
2022-08-21 20:58:08.169Z: gc:                             using system package; SPKG will not be installed
2022-08-21 20:58:08.192Z: gcc:                            using system package; SPKG will not be installed
2022-08-21 20:58:08.213Z: gdb:                            experimental, use "./configure --enable-gdb" to install SPKG version 8.2
2022-08-21 20:58:08.234Z: gengetopt:                      using system package; SPKG will not be installed
2022-08-21 20:58:08.257Z: gf2x:                           using system package; SPKG will not be installed
2022-08-21 20:58:08.278Z: gfan:                           using system package; SPKG will not be installed
2022-08-21 20:58:08.305Z: gfortran:                       using system package; SPKG will not be installed
2022-08-21 20:58:08.345Z: giac:                           using system package; SPKG will not be installed
2022-08-21 20:58:08.365Z: git:                            using system package
2022-08-21 20:58:08.385Z: givaro:                         SPKG version 4.1.1 is already installed
2022-08-21 20:58:08.406Z: glpk:                           using system package; SPKG will not be installed
2022-08-21 20:58:08.431Z: glucose:                        optional, use "./configure --enable-glucose" to install SPKG version 4.1
2022-08-21 20:58:08.457Z: gmp:                            using system package; SPKG will not be installed
2022-08-21 20:58:08.477Z: gmpy2:                          standard, SPKG version 2.1.1 is already installed
2022-08-21 20:58:08.498Z: gp2c:                           using system package; SPKG will not be installed
2022-08-21 20:58:08.519Z: graphs:                         standard, SPKG version 20210214.p0 is already installed
2022-08-21 20:58:08.537Z: graphviz:                       no suitable system package; optional
2022-08-21 20:58:08.559Z: gsl:                            using system package; SPKG will not be installed
2022-08-21 20:58:08.585Z: hatchling:                      standard, SPKG version 1.3.1 is already installed
2022-08-21 20:58:08.606Z: html5lib:                       standard, SPKG version 1.1 is already installed
2022-08-21 20:58:08.627Z: iconv:                          using system package; SPKG will not be installed
2022-08-21 20:58:08.646Z: idna:                           standard, SPKG version 3.3 is already installed
2022-08-21 20:58:08.669Z: igraph:                         no suitable system package; optional, use "./configure --enable-igraph" to install SPKG version 0.9.7
2022-08-21 20:58:08.688Z: imagemagick:                    no suitable system package; optional
2022-08-21 20:58:08.710Z: imagesize:                      standard, SPKG version 1.2.0 is already installed
2022-08-21 20:58:08.731Z: iml:                            using system package; SPKG will not be installed
2022-08-21 20:58:08.766Z: importlib_metadata:             standard, SPKG version 4.8.2 is already installed
2022-08-21 20:58:08.829Z: importlib_resources:            standard, SPKG version 5.2.2 is already installed
2022-08-21 20:58:08.850Z: info:                           no suitable system package; optional, use "./configure --enable-info" to install SPKG version 6.8
2022-08-21 20:58:08.872Z: ipykernel:                      standard, SPKG version 6.6.0 is already installed
2022-08-21 20:58:08.892Z: ipympl:                         optional pip package; use "./sage -i ipympl" to install
2022-08-21 20:58:08.912Z: ipython:                        standard, SPKG version 8.4.0 is already installed
2022-08-21 20:58:08.934Z: ipython_genutils:               standard, SPKG version 0.2.0 is already installed
2022-08-21 20:58:08.955Z: ipywidgets:                     standard, SPKG version 7.7.0 is already installed
2022-08-21 20:58:08.978Z: isl:                            no suitable system package; optional, use "./configure --enable-isl" to install SPKG version 0.20
2022-08-21 20:58:09.000Z: jedi:                           standard, SPKG version 0.18.1 is already installed
2022-08-21 20:58:09.026Z: jinja2:                         standard, SPKG version 3.1.2 is already installed
2022-08-21 20:58:09.054Z: jmol:                           standard, SPKG version 14.29.52 is already installed
2022-08-21 20:58:09.088Z: jsonschema:                     standard, SPKG version 4.5.1 is already installed
2022-08-21 20:58:09.124Z: jupymake:                       optional, use "./configure --enable-jupymake" to install SPKG version 0.9
2022-08-21 20:58:09.158Z: jupyter_client:                 standard, SPKG version 7.3.4 is already installed
2022-08-21 20:58:09.184Z: jupyter_core:                   standard, SPKG version 4.10.0 is already installed
2022-08-21 20:58:09.223Z: jupyter_jsmol:                  standard, SPKG version 2022.1.0 is already installed
2022-08-21 20:58:09.259Z: jupyter_packaging:              standard, SPKG version 0.12.2 is already installed
2022-08-21 20:58:09.298Z: jupyter_sphinx:                 standard, SPKG version 0.3.2 is already installed
2022-08-21 20:58:09.329Z: jupyterlab:                     optional pip package; use "./sage -i jupyterlab" to install
2022-08-21 20:58:09.369Z: jupyterlab_pygments:            standard, SPKG version 0.1.2 is already installed
2022-08-21 20:58:09.408Z: jupyterlab_widgets:             optional pip package; use "./sage -i jupyterlab_widgets" to install
2022-08-21 20:58:09.441Z: 
2022-08-21 20:58:09.473Z: kenzo:                          optional, use "./configure --enable-kenzo" to install SPKG version 1.1.10
2022-08-21 20:58:09.498Z: kiwisolver:                     standard, SPKG version 1.3.2 is already installed
2022-08-21 20:58:09.523Z: latte_int:                      optional, use "./configure --enable-latte_int" to install SPKG version 1.7.6
2022-08-21 20:58:09.550Z: lcalc:                          using system package; SPKG will not be installed
2022-08-21 20:58:09.581Z: libatomic_ops:                  using system package; SPKG will not be installed
2022-08-21 20:58:09.605Z: libbraiding:                    using system package; SPKG will not be installed
2022-08-21 20:58:09.638Z: libffi:                         using system package; SPKG will not be installed
2022-08-21 20:58:09.666Z: libgd:                          using system package; SPKG will not be installed
2022-08-21 20:58:09.695Z: libgraphviz:                    no suitable system package; optional
2022-08-21 20:58:09.724Z: libhomfly:                      using system package; SPKG will not be installed
2022-08-21 20:58:09.755Z: liblzma:                        using system package; SPKG will not be installed
2022-08-21 20:58:09.784Z: libnauty:                       no suitable system package; optional, use "./configure --enable-libnauty" to install SPKG version none
2022-08-21 20:58:09.817Z: libogg:                         optional, use "./configure --enable-libogg" to install SPKG version 1.3.1.p0
2022-08-21 20:58:09.846Z: libpng:                         using system package; SPKG will not be installed
2022-08-21 20:58:09.884Z: libsemigroups:                  no suitable system package; optional, use "./configure --enable-libsemigroups" to install SPKG version 1.1.0
2022-08-21 20:58:09.915Z: libtheora:                      experimental, use "./configure --enable-libtheora" to install SPKG version 1.1.1
2022-08-21 20:58:09.942Z: libxml2:                        using system package
2022-08-21 20:58:09.973Z: lidia:                          optional, use "./configure --enable-lidia" to install SPKG version 2.3.0+latte-patches-2019-05-02
2022-08-21 20:58:09.998Z: lie:                            experimental, use "./configure --enable-lie" to install SPKG version 2.2.2
2022-08-21 20:58:10.030Z: linbox:                         SPKG version 1.6.3.p1 is already installed
2022-08-21 20:58:10.063Z: llvm:                           not required on your platform
2022-08-21 20:58:10.085Z: lrcalc:                         SPKG version 2.1 is already installed
2022-08-21 20:58:10.112Z: lrcalc_python:                  standard, SPKG version 2.1 is already installed
2022-08-21 20:58:10.144Z: lrslib:                         no suitable system package; optional, use "./configure --enable-lrslib" to install SPKG version 071b+autotools-2021-07-13
2022-08-21 20:58:10.167Z: m4ri:                           using system package; SPKG will not be installed
2022-08-21 20:58:10.195Z: m4rie:                          using system package; SPKG will not be installed
2022-08-21 20:58:10.230Z: markupsafe:                     standard, SPKG version 2.1.1 is already installed
2022-08-21 20:58:10.254Z: mathics:                        optional, use "./configure --enable-mathics" to install SPKG version 4.0.0
2022-08-21 20:58:10.283Z: mathics_scanner:                optional, use "./configure --enable-mathics_scanner" to install SPKG version 1.2.4
2022-08-21 20:58:10.307Z: mathjax:                        standard, SPKG version 3.2.0 is already installed
2022-08-21 20:58:10.336Z: matplotlib:                     standard, SPKG version 3.5.2 is already installed
2022-08-21 20:58:10.372Z: matplotlib_inline:              standard, SPKG version 0.1.2 is already installed
2022-08-21 20:58:10.409Z: maxima:                         standard, SPKG version 5.45.0.p0 is already installed
2022-08-21 20:58:10.447Z: mcqd:                           optional, use "./configure --enable-mcqd" to install SPKG version 1.0.p0
2022-08-21 20:58:10.477Z: meataxe:                        optional, use "./configure --enable-meataxe" to install SPKG version 1.0.1
2022-08-21 20:58:10.508Z: memory_allocator:               standard, SPKG version 0.1.3 is already installed
2022-08-21 20:58:10.531Z: mistune:                        standard, SPKG version 0.8.4 is already installed
2022-08-21 20:58:10.554Z: modular_decomposition:          experimental, use "./configure --enable-modular_decomposition" to install SPKG version 20100607
2022-08-21 20:58:10.579Z: mpc:                            using system package; SPKG will not be installed
2022-08-21 20:58:10.612Z: mpfi:                           using system package; SPKG will not be installed
2022-08-21 20:58:10.633Z: mpfr:                           using system package; SPKG will not be installed
2022-08-21 20:58:10.665Z: mpfrcx:                         optional, use "./configure --enable-mpfrcx" to install SPKG version 0.5
2022-08-21 20:58:10.691Z: mpmath:                         standard, SPKG version 1.2.1 is already installed
2022-08-21 20:58:10.727Z: nauty:                          using system package; SPKG will not be installed
2022-08-21 20:58:10.757Z: nbclient:                       standard, SPKG version 0.6.4 is already installed
2022-08-21 20:58:10.780Z: nbconvert:                      standard, SPKG version 6.5.0 is already installed
2022-08-21 20:58:10.810Z: nbformat:                       standard, SPKG version 5.4.0 is already installed
2022-08-21 20:58:10.841Z: ncurses:                        using system package; SPKG will not be installed
2022-08-21 20:58:10.864Z: nest_asyncio:                   standard, SPKG version 1.5.5 is already installed
2022-08-21 20:58:10.900Z: networkx:                       standard, SPKG version 2.8.4 is already installed
2022-08-21 20:58:10.937Z: nibabel:                        optional pip package; use "./sage -i nibabel" to install
2022-08-21 20:58:10.970Z: ninja_build:                    no suitable system package; optional, use "./configure --enable-ninja_build" to install SPKG version 1.8.2
2022-08-21 20:58:10.996Z: nodeenv:                        optional pip package; use "./sage -i nodeenv" to install
2022-08-21 20:58:11.019Z: nodejs:                         optional, use "./configure --enable-nodejs" to install SPKG version 12.18.3
2022-08-21 20:58:11.040Z: normaliz:                       optional, use "./configure --enable-normaliz" to install SPKG version 3.8.10
2022-08-21 20:58:11.073Z: notebook:                       standard, SPKG version 6.4.12 is already installed
2022-08-21 20:58:11.097Z: notedown:                       optional, use "./configure --enable-notedown" to install SPKG version 1.5.1
2022-08-21 20:58:11.132Z: ntl:                            using system package; SPKG will not be installed
2022-08-21 20:58:11.171Z: numpy:                          standard, SPKG version 1.22.4 is already installed
2022-08-21 20:58:11.204Z: openblas:                       using system package; SPKG will not be installed
2022-08-21 20:58:11.227Z: openssl:                        not required on your platform; SPKG will not be installed
2022-08-21 20:58:11.265Z: ore_algebra:                    optional pip package; use "./sage -i ore_algebra" to install
2022-08-21 20:58:11.296Z: p_group_cohomology:             optional, use "./configure --enable-p_group_cohomology" to install SPKG version 3.3.2
2022-08-21 20:58:11.334Z: packaging:                      standard, SPKG version 21.3 is already installed
2022-08-21 20:58:11.362Z: palettable:                     optional, use "./configure --enable-palettable" to install SPKG version 3.3.0
2022-08-21 20:58:11.394Z: palp:                           using system package; SPKG will not be installed
2022-08-21 20:58:11.425Z: pandoc:                         no suitable system package; optional
2022-08-21 20:58:11.450Z: pandoc_attributes:              optional, use "./configure --enable-pandoc_attributes" to install SPKG version 8bc82f6d
2022-08-21 20:58:11.478Z: pandocfilters:                  standard, SPKG version 1.5.0 is already installed
2022-08-21 20:58:11.511Z: pari:                           using system package; SPKG will not be installed
2022-08-21 20:58:11.534Z: pari_elldata:                   using system package; SPKG will not be installed
2022-08-21 20:58:11.565Z: pari_galdata:                   using system package; SPKG will not be installed
2022-08-21 20:58:11.596Z: pari_galpol:                    using system package; SPKG will not be installed
2022-08-21 20:58:11.616Z: pari_jupyter:                   optional, use "./configure --enable-pari_jupyter" to install SPKG version 1.4.0
2022-08-21 20:58:11.639Z: pari_nftables:                  using system package; SPKG will not be installed
2022-08-21 20:58:11.658Z: pari_seadata:                   using system package; SPKG will not be installed
2022-08-21 20:58:11.679Z: pari_seadata_small:             using system package; SPKG will not be installed
2022-08-21 20:58:11.702Z: parso:                          standard, SPKG version 0.8.3 is already installed
2022-08-21 20:58:11.721Z: patch:                          using system package; SPKG will not be installed
2022-08-21 20:58:11.741Z: pathspec:                       standard, SPKG version 0.9.0 is already installed
2022-08-21 20:58:11.762Z: pcre:                           using system package; SPKG will not be installed
2022-08-21 20:58:11.781Z: pdf2svg:                        no suitable system package; optional
2022-08-21 20:58:11.802Z: perl_cpan_polymake_prereq:      no suitable system package; optional
2022-08-21 20:58:11.821Z: perl_mongodb:                   no suitable system package; optional
2022-08-21 20:58:11.841Z: perl_term_readline_gnu:         no suitable system package; optional, use "./configure --enable-perl_term_readline_gnu" to install SPKG version 1.35
2022-08-21 20:58:11.861Z: pexpect:                        standard, SPKG version 4.8.0 is already installed
2022-08-21 20:58:11.881Z: phitigra:                       optional pip package; use "./sage -i phitigra" to install
2022-08-21 20:58:11.900Z: pickleshare:                    standard, SPKG version 0.7.5 is already installed
2022-08-21 20:58:11.925Z: pillow:                         standard, SPKG version 9.0.1 is already installed
2022-08-21 20:58:11.944Z: pint:                           optional, use "./configure --enable-pint" to install SPKG version 0.17
2022-08-21 20:58:11.965Z: pip:                            standard, SPKG version 22.1.2 is already installed
2022-08-21 20:58:11.986Z: pkgconf:                        using system package; SPKG will not be installed
2022-08-21 20:58:12.006Z: pkgconfig:                      standard, SPKG version 1.5.5 is already installed
2022-08-21 20:58:12.028Z: planarity:                      using system package; SPKG will not be installed
2022-08-21 20:58:12.047Z: plantri:                        optional, use "./configure --enable-plantri" to install SPKG version 5.3
2022-08-21 20:58:12.069Z: platformdirs:                   standard, SPKG version 2.5.1 is already installed
2022-08-21 20:58:12.088Z: pluggy:                         standard, SPKG version 1.0.0 is already installed
2022-08-21 20:58:12.109Z: ply:                            standard, SPKG version 3.11 is already installed
2022-08-21 20:58:12.129Z: poetry_core:                    standard, SPKG version 1.0.8 is already installed
2022-08-21 20:58:12.150Z: polylib:                        optional, use "./configure --enable-polylib" to install SPKG version 5.22.5
2022-08-21 20:58:12.172Z: polymake:                       no suitable system package; optional, use "./configure --enable-polymake" to install SPKG version 4.6
2022-08-21 20:58:12.191Z: polytopes_db:                   standard, SPKG version 20170220.p0 is already installed
2022-08-21 20:58:12.220Z: polytopes_db_4d:                optional, use "./configure --enable-polytopes_db_4d" to install SPKG version 1.0
2022-08-21 20:58:12.240Z: ppl:                            using system package; SPKG will not be installed
2022-08-21 20:58:12.268Z: pplpy:                          standard, SPKG version 0.8.6 is already installed
2022-08-21 20:58:12.296Z: pplpy_doc:                      standard, SPKG version 0.8.6 is already installed
2022-08-21 20:58:12.353Z: primecount:                     SPKG version 7.4 is already installed
2022-08-21 20:58:12.382Z: primecountpy:                   standard, SPKG version 0.1.0 is already installed
2022-08-21 20:58:12.406Z: primesieve:                     SPKG version 8.0 is already installed
2022-08-21 20:58:12.456Z: prometheus_client:              standard, SPKG version 0.14.1 is already installed
2022-08-21 20:58:12.482Z: prompt_toolkit:                 standard, SPKG version 3.0.24 is already installed
2022-08-21 20:58:12.537Z: ptyprocess:                     standard, SPKG version 0.5.1.p0 is already installed
2022-08-21 20:58:12.578Z: pure_eval:                      standard, SPKG version 0.2.2 is already installed
2022-08-21 20:58:12.636Z: py:                             standard, SPKG version 1.11.0 is already installed
2022-08-21 20:58:12.662Z: pybind11:                       standard, SPKG version 2.9.2 is already installed
2022-08-21 20:58:12.686Z: pybtex:                         optional pip package; use "./sage -i pybtex" to install
2022-08-21 20:58:12.706Z: pycosat:                        optional, use "./configure --enable-pycosat" to install SPKG version 0.6.3
2022-08-21 20:58:12.738Z: 
2022-08-21 20:58:12.771Z: pycparser:                      standard, SPKG version 2.21 is already installed
2022-08-21 20:58:12.801Z: pycryptosat:                    optional, use "./configure --enable-pycryptosat" to install SPKG version 5.8.0
2022-08-21 20:58:12.824Z: pycygwin:                       standard, SPKG version 0.1 is already installed
2022-08-21 20:58:12.862Z: pyflakes:                       optional pip package; use "./sage -i pyflakes" to install
2022-08-21 20:58:12.920Z: pygments:                       standard, SPKG version 2.12.0 is already installed
2022-08-21 20:58:12.974Z: pygraphviz:                     optional pip package; use "./sage -i pygraphviz" to install
2022-08-21 20:58:13.025Z: pynormaliz:                     optional, use "./configure --enable-pynormaliz" to install SPKG version 2.14
2022-08-21 20:58:13.065Z: pyparsing:                      standard, SPKG version 3.0.9 is already installed
2022-08-21 20:58:13.096Z: pyppeteer:                      optional pip package; use "./sage -i pyppeteer" to install
2022-08-21 20:58:13.128Z: pyrsistent:                     standard, SPKG version 0.18.1 is already installed
2022-08-21 20:58:13.179Z: pysingular:                     optional, use "./configure --enable-pysingular" to install SPKG version 0.9.7
2022-08-21 20:58:13.219Z: pytest:                         optional pip package; use "./sage -i pytest" to install
2022-08-21 20:58:13.303Z: pytest_xdist:                   optional pip package; use "./sage -i pytest_xdist" to install
2022-08-21 20:58:13.354Z: python3:                        using system package; SPKG will not be installed
2022-08-21 20:58:13.402Z: python_build:                   optional pip package; use "./sage -i python_build" to install
2022-08-21 20:58:13.438Z: python_igraph:                  optional, use "./configure --enable-python_igraph" to install SPKG version 0.9.9
2022-08-21 20:58:13.502Z: pythran:                        standard, SPKG version 0.11.0 is already installed
2022-08-21 20:58:13.534Z: pytz:                           standard, SPKG version 2021.3 is already installed
2022-08-21 20:58:13.565Z: pytz_deprecation_shim:          standard, SPKG version 0.1.0.post0 is already installed
2022-08-21 20:58:13.609Z: pyx:                            optional pip package; use "./sage -i pyx" to install
2022-08-21 20:58:13.640Z: pyzmq:                          standard, SPKG version 23.2.0 is already installed
2022-08-21 20:58:13.678Z: qepcad:                         experimental, use "./configure --enable-qepcad" to install SPKG version B.1.72
2022-08-21 20:58:13.697Z: qhull:                          SPKG version 2020-src-8.0.2 is already installed
2022-08-21 20:58:13.726Z: r:                              using system package; SPKG will not be installed
2022-08-21 20:58:13.756Z: r_jupyter:                      optional, use "./configure --enable-r_jupyter" to install SPKG version none
2022-08-21 20:58:13.783Z: readline:                       using system package; SPKG will not be installed
2022-08-21 20:58:13.846Z: requests:                       standard, SPKG version 2.28.0 is already installed
2022-08-21 20:58:13.885Z: retrolab:                       optional pip package; use "./sage -i retrolab" to install
2022-08-21 20:58:13.918Z: rpy2:                           standard, SPKG version 3.3.6 is already installed
2022-08-21 20:58:13.955Z: rst2ipynb:                      optional, use "./configure --enable-rst2ipynb" to install SPKG version 0.2.3
2022-08-21 20:58:13.992Z: rubiks:                         optional, use "./configure --enable-rubiks" to install SPKG version 20070912.p21
2022-08-21 20:58:14.036Z: rw:                             using system package; SPKG will not be installed
2022-08-21 20:58:14.099Z: saclib:                         optional, use "./configure --enable-saclib" to install SPKG version 2.2.7
2022-08-21 20:58:14.124Z: sage_conf:                      standard, SPKG version 9.7.beta8 is already installed
2022-08-21 20:58:14.169Z: sage_docbuild:                  standard, SPKG version 9.7.beta8 is already installed
2022-08-21 20:58:14.206Z: sage_flatsurf:                  optional pip package; use "./sage -i sage_flatsurf" to install
2022-08-21 20:58:14.248Z: sage_numerical_backends_coin:   optional, use "./configure --enable-sage_numerical_backends_coin" to install SPKG version 9.0b12
2022-08-21 20:58:14.296Z: sage_numerical_backends_cplex:  optional, use "./configure --enable-sage_numerical_backends_cplex" to install SPKG version 9.0b12
2022-08-21 20:58:14.347Z: sage_numerical_backends_gurobi: optional, use "./configure --enable-sage_numerical_backends_gurobi" to install SPKG version 9.3.1
2022-08-21 20:58:14.382Z: sage_setup:                     standard, SPKG version 9.7.beta8 is already installed
2022-08-21 20:58:14.429Z: sage_sws2rst:                   optional, use "./configure --enable-sage_sws2rst" to install SPKG version 9.7.beta8
2022-08-21 20:58:14.458Z: sagelib:                        standard, SPKG version 9.7.beta8 is already installed
2022-08-21 20:58:14.498Z: sagemath_categories:            experimental, use "./configure --enable-sagemath_categories" to install SPKG version 9.7.beta8
2022-08-21 20:58:14.518Z: sagemath_doc_html:              standard, SPKG is already installed
2022-08-21 20:58:14.555Z: sagemath_doc_pdf:               optional, use "./configure --enable-sagemath_doc_pdf" to install SPKG version none
2022-08-21 20:58:14.598Z: sagemath_environment:           experimental, use "./configure --enable-sagemath_environment" to install SPKG version 9.7.beta8
2022-08-21 20:58:14.656Z: sagemath_objects:               experimental, use "./configure --enable-sagemath_objects" to install SPKG version 9.7.beta8
2022-08-21 20:58:14.719Z: sagemath_repl:                  experimental, use "./configure --enable-sagemath_repl" to install SPKG version 9.7.beta8
2022-08-21 20:58:14.984Z: sagenb_export:                  standard, SPKG version 3.3 is already installed
2022-08-21 20:58:15.014Z: sagetex:                        standard, SPKG version 3.5 is already installed
2022-08-21 20:58:15.042Z: scipoptsuite:                   experimental, use "./configure --enable-scipoptsuite" to install SPKG version 5.0.1
2022-08-21 20:58:15.063Z: scipy:                          standard, SPKG version 1.8.1 is already installed
2022-08-21 20:58:15.089Z: send2trash:                     standard, SPKG version 1.8.0 is already installed
2022-08-21 20:58:15.115Z: setuptools:                     standard, SPKG version 63.2.0 is already installed
2022-08-21 20:58:15.135Z: setuptools_scm:                 standard, SPKG version 6.3.2 is already installed
2022-08-21 20:58:15.158Z: setuptools_scm_git_archive:     standard, SPKG version 1.1 is already installed
2022-08-21 20:58:15.194Z: setuptools_wheel:               standard, SPKG version 63.2.0 is already installed
2022-08-21 20:58:15.243Z: simplegeneric:                  standard, SPKG version 0.8.1.p0 is already installed
2022-08-21 20:58:15.263Z: singular:                       using system package; SPKG will not be installed
2022-08-21 20:58:15.283Z: singular_jupyter:               optional, use "./configure --enable-singular_jupyter" to install SPKG version 0.9.7
2022-08-21 20:58:15.310Z: sirocco:                        optional, use "./configure --enable-sirocco" to install SPKG version 2.1.0
2022-08-21 20:58:15.466Z: six:                            standard, SPKG version 1.16.0 is already installed
2022-08-21 20:58:15.543Z: slabbe:                         optional pip package; use "./sage -i slabbe" to install
2022-08-21 20:58:15.567Z: snappy:                         optional pip package; use "./sage -i snappy" to install
2022-08-21 20:58:15.598Z: snowballstemmer:                standard, SPKG version 2.2.0 is already installed
2022-08-21 20:58:15.627Z: soupsieve:                      standard, SPKG version 2.3.2.post1 is already installed
2022-08-21 20:58:15.736Z: sphinx:                         standard, SPKG version 4.4.0 is already installed
2022-08-21 20:58:15.791Z: sphinxcontrib_applehelp:        standard, SPKG version 1.0.2 is already installed
2022-08-21 20:58:15.852Z: sphinxcontrib_devhelp:          standard, SPKG version 1.0.2 is already installed
2022-08-21 20:58:15.964Z: sphinxcontrib_htmlhelp:         standard, SPKG version 2.0.0 is already installed
2022-08-21 20:58:16.044Z: sphinxcontrib_jsmath:           standard, SPKG version 1.0.1 is already installed
2022-08-21 20:58:16.094Z: sphinxcontrib_qthelp:           standard, SPKG version 1.0.3 is already installed
2022-08-21 20:58:16.151Z: sphinxcontrib_serializinghtml:  standard, SPKG version 1.1.5 is already installed
2022-08-21 20:58:16.173Z: sphinxcontrib_websupport:       standard, SPKG version 1.2.1 is already installed
2022-08-21 20:58:16.217Z: sqlalchemy:                     optional pip package; use "./sage -i sqlalchemy" to install
2022-08-21 20:58:16.238Z: sqlite:                         not required on your platform; SPKG will not be installed
2022-08-21 20:58:16.263Z: stack_data:                     standard, SPKG version 0.3.0 is already installed
2022-08-21 20:58:16.298Z: suitesparse:                    using system package; SPKG will not be installed
2022-08-21 20:58:16.336Z: surf:                           experimental, use "./configure --enable-surf" to install SPKG version 1.0.6-gcc6
2022-08-21 20:58:16.385Z: surface_dynamics:               optional pip package; use "./sage -i surface_dynamics" to install
2022-08-21 20:58:16.434Z: symengine:                      optional, use "./configure --enable-symengine" to install SPKG version 0.8.1
2022-08-21 20:58:16.463Z: symengine_py:                   optional, use "./configure --enable-symengine_py" to install SPKG version 0.8.1.p0
2022-08-21 20:58:16.508Z: symmetrica:                     using system package; SPKG will not be installed
2022-08-21 20:58:16.574Z: sympow:                         using system package; SPKG will not be installed
2022-08-21 20:58:16.616Z: sympy:                          standard, SPKG version 1.10.1 is already installed
2022-08-21 20:58:16.666Z: tachyon:                        using system package; SPKG will not be installed
2022-08-21 20:58:16.690Z: tdlib:                          optional, use "./configure --enable-tdlib" to install SPKG version 0.3.1.p0
2022-08-21 20:58:16.733Z: terminado:                      standard, SPKG version 0.12.1 is already installed
2022-08-21 20:58:16.768Z: texlive:                        no suitable system package; optional, use "./configure --enable-texlive" to install SPKG version none
2022-08-21 20:58:16.799Z: texttable:                      optional, use "./configure --enable-texttable" to install SPKG version 1.6.4
2022-08-21 20:58:16.833Z: threejs:                        standard, SPKG version r122.p0 is already installed
2022-08-21 20:58:16.859Z: tides:                          optional, use "./configure --enable-tides" to install SPKG version 2.0.p0
2022-08-21 20:58:16.889Z: tinycss2:                       standard, SPKG version 1.1.1 is already installed
2022-08-21 20:58:16.928Z: toml:                           not required on your platform; SPKG will not be installed
2022-08-21 20:58:16.972Z: tomli:                          standard, SPKG version 2.0.1 is already installed
2022-08-21 20:58:17.003Z: tomlkit:                        standard, SPKG version 0.11.0 is already installed
2022-08-21 20:58:17.063Z: topcom:                         optional, use "./configure --enable-topcom" to install SPKG version 0.17.7
2022-08-21 20:58:17.148Z: tornado:                        standard, SPKG version 6.1 is already installed
2022-08-21 20:58:17.207Z: tox:                            using system package; SPKG will not be installed
2022-08-21 20:58:17.288Z: traitlets:                      standard, SPKG version 5.3.0 is already installed
2022-08-21 20:58:17.351Z: typing_extensions:              standard, SPKG version 3.10.0.0 is already installed
2022-08-21 20:58:17.405Z: tzdata:                         standard, SPKG version 2022.1 is already installed
2022-08-21 20:58:17.476Z: tzlocal:                        standard, SPKG version 4.2 is already installed
2022-08-21 20:58:17.506Z: urllib3:                        standard, SPKG version 1.26.9 is already installed
2022-08-21 20:58:17.547Z: valgrind:                       experimental, use "./configure --enable-valgrind" to install SPKG version 3.14.0
2022-08-21 20:58:17.582Z: vcversioner:                    standard, SPKG version 2.16.0.0.p0 is already installed
2022-08-21 20:58:17.644Z: virtualenv:                     not required on your platform; SPKG will not be installed
2022-08-21 20:58:17.679Z: wcwidth:                        standard, SPKG version 0.2.5 is already installed
2022-08-21 20:58:17.704Z: webencodings:                   standard, SPKG version 0.5.1 is already installed
2022-08-21 20:58:17.748Z: wheel:                          standard, SPKG version 0.37.1 is already installed
2022-08-21 20:58:17.777Z: widgetsnbextension:             standard, SPKG version 3.6.1 is already installed
2022-08-21 20:58:17.813Z: xz:                             not required on your platform; SPKG will not be installed
2022-08-21 20:58:17.873Z: zeromq:                         using system package; SPKG will not be installed
2022-08-21 20:58:17.929Z: zipp:                           standard, SPKG version 3.8.0 is already installed
2022-08-21 20:58:17.971Z: zlib:                           using system package; SPKG will not be installed
2022-08-21 20:58:18.029Z: zn_poly:                        using system package; SPKG will not be installed
2022-08-21 20:58:18.083Z: checking that generated files are newer than configure... 
2022-08-21 20:58:18.108Z: done
2022-08-21 20:58:18.126Z: configure: creating ./config.status
2022-08-21 20:58:18.147Z: 
2022-08-21 20:58:18.192Z: config.status: creating build/make/Makefile-auto
2022-08-21 20:58:18.222Z: config.status: creating build/make/Makefile
2022-08-21 20:58:18.256Z: config.status: creating src/bin/sage-env-config
2022-08-21 20:58:18.296Z: config.status: creating src/bin/sage-src-env-config
2022-08-21 20:58:18.355Z: config.status: creating build/bin/sage-build-env-config
2022-08-21 20:58:18.403Z: config.status: creating pkgs/sage-conf/_sage_conf/_conf.py
2022-08-21 20:58:18.463Z: config.status: executing depfiles commands
2022-08-21 20:58:18.541Z: config.status: executing mkdirs commands
2022-08-21 20:58:18.608Z: config.status: creating directory /workspaces/sagetrac-mirror/logs/pkgs
2022-08-21 20:58:18.637Z: config.status: creating directory /sage/local
2022-08-21 20:58:18.663Z: config.status: creating directory /sage/local/bin
2022-08-21 20:58:18.691Z: config.status: creating directory /sage/local/etc
2022-08-21 20:58:18.720Z: config.status: creating directory /sage/local/include
2022-08-21 20:58:18.766Z: config.status: creating directory /sage/local/lib
2022-08-21 20:58:18.826Z: config.status: creating directory /sage/local/lib/pkgconfig
2022-08-21 20:58:18.861Z: config.status: creating directory /sage/local/share
2022-08-21 20:58:18.896Z: config.status: creating directory /sage/local/var/lib/sage/installed
2022-08-21 20:58:18.935Z: config.status: executing links commands
2022-08-21 20:58:18.957Z: config.status: creating convenience symlink prefix -> /sage/local
2022-08-21 20:58:18.979Z: config.status: creating convenience symlink venv -> /sage/local/var/lib/sage/venv-python3.10
2022-08-21 20:58:19.021Z: configure:
2022-08-21 20:58:19.044Z: 
2022-08-21 20:58:19.065Z:     notice: the following SPKGs did not find equivalent system packages:
2022-08-21 20:58:19.099Z: 
2022-08-21 20:58:19.155Z:           4ti2 _recommended cbc coxeter3 ffmpeg graphviz igraph imagemagick info isl libgraphviz libnauty libsemigroups lrslib ninja_build pandoc pdf2svg perl_cpan_polymake_prereq perl_mongodb perl_term_readline_gnu polymake texlive
2022-08-21 20:58:19.176Z:         
2022-08-21 20:58:19.196Z: checking for the package system in use... 
2022-08-21 20:58:19.225Z: debian
2022-08-21 20:58:19.253Z: configure:
2022-08-21 20:58:19.299Z: 
2022-08-21 20:58:19.332Z:     hint: installing the following system packages, if not
2022-08-21 20:58:19.354Z:     already present, may provide additional optional features:
2022-08-21 20:58:19.380Z: 
2022-08-21 20:58:19.417Z:       $ sudo apt-get update 
2022-08-21 20:58:19.440Z:       $ sudo apt-get install  4ti2 default-jdk libavdevice-dev coinor-cbc coinor-libcbc-dev ffmpeg graphviz libigraph-dev imagemagick texinfo libisl-dev libgraphviz-dev libnauty-dev lrslib ninja-build pandoc pdf2svg libxml-libxslt-perl libxml-writer-perl libxml2-dev libperl-dev libfile-slurp-perl libjson-perl libsvg-perl libterm-readkey-perl libterm-readline-gnu-perl libmongodb-perl libterm-readline-gnu-perl polymake libpolymake-dev texlive-latex-extra texlive-xetex latexmk dvipng tex-gyre texlive-fonts-recommended texlive-lang-cyrillic texlive-lang-english texlive-lang-european texlive-lang-french texlive-lang-german texlive-lang-italian texlive-lang-japanese texlive-lang-polish texlive-lang-portuguese texlive-lang-spanish
2022-08-21 20:58:19.464Z: 
2022-08-21 20:58:19.497Z: configure:
2022-08-21 20:58:19.520Z: 
2022-08-21 20:58:19.539Z:     hint: After installation, re-run configure using:
2022-08-21 20:58:19.571Z: 
2022-08-21 20:58:19.593Z:       $ ./config.status --recheck && ./config.status
2022-08-21 20:58:19.612Z:                 
2022-08-21 20:58:19.638Z: + make build V=0
2022-08-21 20:58:19.664Z: make -j4 build/make/Makefile --stop
2022-08-21 20:58:19.687Z: make[1]: Entering directory '/workspaces/sagetrac-mirror'
2022-08-21 20:58:19.708Z: make[1]: 'build/make/Makefile' is up to date.
2022-08-21 20:58:19.732Z: make[1]: Leaving directory '/workspaces/sagetrac-mirror'
2022-08-21 20:58:19.762Z: build/bin/sage-logger \
2022-08-21 20:58:19.784Z: 	"cd build/make && ./install 'base-toolchain'" logs/install.log
2022-08-21 20:58:19.812Z: make[1]: Entering directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:19.834Z: make[1]: Leaving directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:19.865Z: *** ALL ENVIRONMENT VARIABLES BEFORE BUILD: ***
2022-08-21 20:58:19.896Z: CLOUDENV_ENVIRONMENT_ID=75b767f1-bd2c-4d7a-a730-32bf5dd7e9b6
2022-08-21 20:58:19.922Z: CODESPACES=true
2022-08-21 20:58:20.030Z: CODESPACE_NAME=tobiasdiez-sagemath-sagetrac-mirror-7w7r4j5prvhwprr
2022-08-21 20:58:20.064Z: ContainerVersion=12
2022-08-21 20:58:20.134Z: GITHUB_API_URL=https://api.github.com
2022-08-21 20:58:20.187Z: GITHUB_CODESPACE_TOKEN=******
2022-08-21 20:58:20.207Z: GITHUB_GRAPHQL_URL=https://api.github.com/graphql
2022-08-21 20:58:20.231Z: GITHUB_REPOSITORY=sagemath/sagetrac-mirror
2022-08-21 20:58:20.251Z: GITHUB_SERVER_URL=https://github.com
2022-08-21 20:58:20.273Z: GITHUB_TOKEN=******
2022-08-21 20:58:20.292Z: GITHUB_USER=tobiasdiez
2022-08-21 20:58:20.314Z: HOME=/root
2022-08-21 20:58:20.335Z: HOSTNAME=codespaces-8b0542
2022-08-21 20:58:20.355Z: INTERNAL_VSCS_TARGET_URL=https://westeurope.online.visualstudio.com
2022-08-21 20:58:20.375Z: LS_COLORS=
2022-08-21 20:58:20.398Z: MAKE=make -j4
2022-08-21 20:58:20.419Z: MAKEFLAGS= -- V=0 V=1
2022-08-21 20:58:20.442Z: MAKELEVEL=1
2022-08-21 20:58:20.462Z: MAKEOVERRIDES=${-*-command-variables-*-}
2022-08-21 20:58:20.483Z: MAKE_TERMERR=/dev/pts/0
2022-08-21 20:58:20.504Z: MAKE_TERMOUT=/dev/pts/0
2022-08-21 20:58:20.524Z: MFLAGS=
2022-08-21 20:58:20.543Z: OLDPWD=/workspaces/sagetrac-mirror
2022-08-21 20:58:20.563Z: PACKAGES= libprimesieve-dev python3 libpython3-dev python3-distutils python3-venv libmpfr-dev fflas-ffpack libreadline-dev libfplll-dev libncurses5-dev libm4rie-dev xz-utils liblzma-dev libbz2-dev bzip2 openssl libssl-dev lcalc liblfunction-dev xz-utils gfortran cliquer libcliquer-dev libgsl-dev pkg-config libsymmetrica2-dev patch libbraiding-dev librw-dev libm4ri-dev libgc-dev libgiac-dev xcas gfan curl libcurl4-openssl-dev libgf2x-dev palp libbrial-dev libbrial-groebner-dev libgivaro-dev libqhull-dev libntl-dev liblinbox-dev libzmq3-dev libflint-arb-dev pari-gp2c libpari-dev pari-doc pari-elldata pari-galdata pari-galpol pari-seadata libcdd-dev libcdd-tools libboost-dev libfreetype6-dev libz-dev libatomic-ops-dev cmake libopenblas-dev libplanarity-dev planarity libec-dev eclib-tools singular singular-doc libsingular4-dev tachyon libgd-dev libsqlite3-dev sqlite3 liblrcalc-dev libppl-dev ppl-dev gengetopt libhomfly-dev libgmp-dev sympow libiml-dev gmp-ecm libecm-dev libpcre3-dev nauty libsuitesparse-dev gcc g++ libmpfi-dev libflint-dev libmpc-dev libffi-dev flintqs ecl r-base-dev r-cran-lattice binutils make m4 perl python3 tar bc gcc g++ ca-certificates libzn-poly-dev tox glpk-utils libglpk-dev gettext autoconf automake libtool pkg-config
2022-08-21 20:58:20.585Z: PATH=/workspaces/sagetrac-mirror/build/bin:/workspaces/sagetrac-mirror/src/bin:/sage/local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
2022-08-21 20:58:20.606Z: PWD=/workspaces/sagetrac-mirror/build/make
2022-08-21 20:58:20.645Z: PYTHONPATH=/sage/local
2022-08-21 20:58:20.686Z: RepositoryName=sagetrac-mirror
2022-08-21 20:58:20.705Z: SAGE_CHECK=warn
2022-08-21 20:58:20.725Z: SAGE_CHECK_PACKAGES=!cython,!r,!python3,!gap,!cysignals,!linbox,!git,!ppl,!cmake,!rpy2,!sage_sws2rst
2022-08-21 20:58:20.747Z: SAGE_ENV_CONFIG_SOURCED=1
2022-08-21 20:58:20.767Z: SAGE_LOCAL=/sage/local
2022-08-21 20:58:20.787Z: SAGE_LOGFILE=logs/install.log
2022-08-21 20:58:20.807Z: SAGE_LOGS=/workspaces/sagetrac-mirror/logs/pkgs
2022-08-21 20:58:20.828Z: SAGE_NUM_THREADS=4
2022-08-21 20:58:20.848Z: SAGE_NUM_THREADS_PARALLEL=4
2022-08-21 20:58:20.867Z: SAGE_ORIG_PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
2022-08-21 20:58:20.887Z: SAGE_ORIG_PATH_SET=True
2022-08-21 20:58:20.905Z: SAGE_PKGCONFIG=/sage/local/lib/pkgconfig
2022-08-21 20:58:20.933Z: SAGE_ROOT=/workspaces/sagetrac-mirror
2022-08-21 20:58:20.952Z: SAGE_SHARE=/sage/local/share
2022-08-21 20:58:20.980Z: SAGE_SILENT_BUILD=yes
2022-08-21 20:58:21.003Z: SAGE_SRC=/workspaces/sagetrac-mirror/src
2022-08-21 20:58:21.052Z: SHELL_LOGGED_IN=true
2022-08-21 20:58:21.100Z: SHLVL=2
2022-08-21 20:58:21.153Z: TERM=xterm
2022-08-21 20:58:21.173Z: V=0
2022-08-21 20:58:21.211Z: _=/usr/bin/env
2022-08-21 20:58:21.255Z: ***********************************************
2022-08-21 20:58:21.279Z: make[1]: Entering directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:21.326Z: make --no-print-directory toolchain
2022-08-21 20:58:21.348Z: make[2]: Nothing to be done for 'toolchain'.
2022-08-21 20:58:21.387Z: make[1]: Leaving directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:21.409Z: 
2022-08-21 20:58:21.435Z: real	0m0.064s
2022-08-21 20:58:21.456Z: user	0m0.064s
2022-08-21 20:58:21.493Z: sys	0m0.000s
2022-08-21 20:58:21.552Z: SAGE_CHECK=warn, so scanning the log files. This may take a few seconds.
2022-08-21 20:58:21.579Z: Sage build/upgrade complete!
2022-08-21 20:58:21.621Z: make -j4 all-build
2022-08-21 20:58:21.674Z: make[1]: Entering directory '/workspaces/sagetrac-mirror'
2022-08-21 20:58:21.697Z: make -j4 build/make/Makefile --stop
2022-08-21 20:58:21.736Z: make[2]: Entering directory '/workspaces/sagetrac-mirror'
2022-08-21 20:58:21.769Z: make[2]: warning: -j4 forced in submake: resetting jobserver mode.
2022-08-21 20:58:21.792Z: make[2]: 'build/make/Makefile' is up to date.
2022-08-21 20:58:21.821Z: make[2]: Leaving directory '/workspaces/sagetrac-mirror'
2022-08-21 20:58:21.847Z: build/bin/sage-logger \
2022-08-21 20:58:21.880Z: 	"cd build/make && ./install 'all-build'" logs/install.log
2022-08-21 20:58:21.911Z: make[2]: Entering directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:21.971Z: make[2]: warning: -j4 forced in submake: resetting jobserver mode.
2022-08-21 20:58:22.000Z: make[2]: Leaving directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:22.025Z: 
2022-08-21 20:58:22.047Z: *** ALL ENVIRONMENT VARIABLES BEFORE BUILD: ***
2022-08-21 20:58:22.068Z: CLOUDENV_ENVIRONMENT_ID=75b767f1-bd2c-4d7a-a730-32bf5dd7e9b6
2022-08-21 20:58:22.087Z: CODESPACES=true
2022-08-21 20:58:22.124Z: CODESPACE_NAME=tobiasdiez-sagemath-sagetrac-mirror-7w7r4j5prvhwprr
2022-08-21 20:58:22.144Z: ContainerVersion=12
2022-08-21 20:58:22.181Z: GITHUB_API_URL=https://api.github.com
2022-08-21 20:58:22.209Z: GITHUB_CODESPACE_TOKEN=******
2022-08-21 20:58:22.244Z: GITHUB_GRAPHQL_URL=https://api.github.com/graphql
2022-08-21 20:58:22.270Z: GITHUB_REPOSITORY=sagemath/sagetrac-mirror
2022-08-21 20:58:22.309Z: GITHUB_SERVER_URL=https://github.com
2022-08-21 20:58:22.348Z: GITHUB_TOKEN=******
2022-08-21 20:58:22.397Z: GITHUB_USER=tobiasdiez
2022-08-21 20:58:22.435Z: HOME=/root
2022-08-21 20:58:22.472Z: HOSTNAME=codespaces-8b0542
2022-08-21 20:58:22.492Z: INTERNAL_VSCS_TARGET_URL=https://westeurope.online.visualstudio.com
2022-08-21 20:58:22.513Z: LS_COLORS=
2022-08-21 20:58:22.535Z: MAKE=make -j4
2022-08-21 20:58:22.557Z: MAKEFLAGS=w -j4 --jobserver-auth=3,4 -- V=0 V=1
2022-08-21 20:58:22.576Z: MAKELEVEL=2
2022-08-21 20:58:22.596Z: MAKEOVERRIDES=${-*-command-variables-*-}
2022-08-21 20:58:22.616Z: MAKE_TERMERR=/dev/pts/0
2022-08-21 20:58:22.641Z: MAKE_TERMOUT=/dev/pts/0
2022-08-21 20:58:22.661Z: MFLAGS=-w -j4 --jobserver-auth=3,4
2022-08-21 20:58:22.679Z: OLDPWD=/workspaces/sagetrac-mirror
2022-08-21 20:58:22.700Z: PACKAGES= libprimesieve-dev python3 libpython3-dev python3-distutils python3-venv libmpfr-dev fflas-ffpack libreadline-dev libfplll-dev libncurses5-dev libm4rie-dev xz-utils liblzma-dev libbz2-dev bzip2 openssl libssl-dev lcalc liblfunction-dev xz-utils gfortran cliquer libcliquer-dev libgsl-dev pkg-config libsymmetrica2-dev patch libbraiding-dev librw-dev libm4ri-dev libgc-dev libgiac-dev xcas gfan curl libcurl4-openssl-dev libgf2x-dev palp libbrial-dev libbrial-groebner-dev libgivaro-dev libqhull-dev libntl-dev liblinbox-dev libzmq3-dev libflint-arb-dev pari-gp2c libpari-dev pari-doc pari-elldata pari-galdata pari-galpol pari-seadata libcdd-dev libcdd-tools libboost-dev libfreetype6-dev libz-dev libatomic-ops-dev cmake libopenblas-dev libplanarity-dev planarity libec-dev eclib-tools singular singular-doc libsingular4-dev tachyon libgd-dev libsqlite3-dev sqlite3 liblrcalc-dev libppl-dev ppl-dev gengetopt libhomfly-dev libgmp-dev sympow libiml-dev gmp-ecm libecm-dev libpcre3-dev nauty libsuitesparse-dev gcc g++ libmpfi-dev libflint-dev libmpc-dev libffi-dev flintqs ecl r-base-dev r-cran-lattice binutils make m4 perl python3 tar bc gcc g++ ca-certificates libzn-poly-dev tox glpk-utils libglpk-dev gettext autoconf automake libtool pkg-config
2022-08-21 20:58:22.720Z: PATH=/workspaces/sagetrac-mirror/build/bin:/workspaces/sagetrac-mirror/src/bin:/sage/local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
2022-08-21 20:58:22.743Z: PWD=/workspaces/sagetrac-mirror/build/make
2022-08-21 20:58:22.762Z: PYTHONPATH=/sage/local
2022-08-21 20:58:22.782Z: RepositoryName=sagetrac-mirror
2022-08-21 20:58:22.803Z: SAGE_CHECK=warn
2022-08-21 20:58:22.823Z: SAGE_CHECK_PACKAGES=!cython,!r,!python3,!gap,!cysignals,!linbox,!git,!ppl,!cmake,!rpy2,!sage_sws2rst
2022-08-21 20:58:22.843Z: SAGE_ENV_CONFIG_SOURCED=1
2022-08-21 20:58:22.863Z: SAGE_LOCAL=/sage/local
2022-08-21 20:58:22.882Z: SAGE_LOGFILE=logs/install.log
2022-08-21 20:58:22.901Z: SAGE_LOGS=/workspaces/sagetrac-mirror/logs/pkgs
2022-08-21 20:58:22.922Z: SAGE_NUM_THREADS=4
2022-08-21 20:58:22.942Z: SAGE_NUM_THREADS_PARALLEL=4
2022-08-21 20:58:22.961Z: SAGE_ORIG_PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
2022-08-21 20:58:22.983Z: SAGE_ORIG_PATH_SET=True
2022-08-21 20:58:23.005Z: SAGE_PKGCONFIG=/sage/local/lib/pkgconfig
2022-08-21 20:58:23.035Z: SAGE_ROOT=/workspaces/sagetrac-mirror
2022-08-21 20:58:23.055Z: SAGE_SHARE=/sage/local/share
2022-08-21 20:58:23.074Z: SAGE_SILENT_BUILD=yes
2022-08-21 20:58:23.093Z: SAGE_SRC=/workspaces/sagetrac-mirror/src
2022-08-21 20:58:23.113Z: SHELL_LOGGED_IN=true
2022-08-21 20:58:23.140Z: SHLVL=2
2022-08-21 20:58:23.160Z: TERM=xterm
2022-08-21 20:58:23.180Z: V=0
2022-08-21 20:58:23.200Z: _=/usr/bin/env
2022-08-21 20:58:23.220Z: ***********************************************
2022-08-21 20:58:23.239Z: make[2]: Entering directory '/workspaces/sagetrac-mirror/build/make'
2022-08-21 20:58:23.258Z: 
2022-08-21 20:58:23.277Z: make[2]: warning: -j4 forced in submake: resetting jobserver mode.
2022-08-21 20:58:23.298Z: make --no-print-directory /sage/local/var/lib/sage/installed/.dummy
2022-08-21 20:58:23.324Z: make[3]: '/sage/local/var/lib/sage/installed/.dummy' is up to date.
2022-08-21 20:58:23.345Z: make --no-print-directory /sage/local/var/lib/sage/installed/.dummy
2022-08-21 20:58:23.367Z: make[3]: '/sage/local/var/lib/sage/installed/.dummy' is up to date.
2022-08-21 20:58:23.386Z: make --no-print-directory /sage/local/var/lib/sage/installed/.dummy
2022-08-21 20:58:23.409Z: make[3]: '/sage/local/var/lib/sage/installed/.dummy' is up to date.
2022-08-21 20:58:23.456Z: make --no-print-directory /sage/local/var/lib/sage/installed/.dummy
2022-08-21 20:58:23.485Z: make[3]: '/sage/local/var/lib/sage/installed/.dummy' is up to date.
2022-08-21 20:58:23.505Z: make --no-print-directory all-sage
2022-08-21 20:58:23.525Z: make --no-print-directory pytest-no-deps
2022-08-21 20:58:23.545Z: make --no-print-directory sage_conf-SAGE_VENV-no-deps
2022-08-21 20:58:23.567Z: make --no-print-directory sage_setup-SAGE_VENV-no-deps
2022-08-21 20:58:23.587Z: 
2022-08-21 20:58:23.612Z: sage-logger -p 'sage --pip install -r "/workspaces/sagetrac-mirror/build/pkgs/pytest/requirements.txt"' '/workspaces/sagetrac-mirror/logs/pkgs/pytest.log'
2022-08-21 20:58:23.636Z: [pytest] installing. Log file: /workspaces/sagetrac-mirror/logs/pkgs/pytest.log
2022-08-21 20:58:23.661Z: 
2022-08-21 20:58:23.685Z: [sage_conf-9.7.beta8] installing. Log file: /workspaces/sagetrac-mirror/logs/pkgs/sage_conf-9.7.beta8.log
2022-08-21 20:58:23.704Z: 
2022-08-21 20:58:23.731Z: [sage_setup-9.7.beta8] installing. Log file: /workspaces/sagetrac-mirror/logs/pkgs/sage_setup-9.7.beta8.log
2022-08-21 20:58:23.753Z:   [pytest] successfully installed.
2022-08-21 20:58:26.672Z:   [sage_conf-9.7.beta8] successfully installed.
2022-08-21 20:58:27.719Z:   [sage_setup-9.7.beta8] successfully installed.
2022-08-21 20:58:27.753Z: make --no-print-directory sagelib-SAGE_VENV-no-deps
2022-08-21 20:58:27.777Z: 
2022-08-21 20:58:27.796Z: [sagelib-9.7.beta8] installing. Log file: /workspaces/sagetrac-mirror/logs/pkgs/sagelib-9.7.beta8.log

comment:287 in reply to:  286 Changed 6 weeks ago by Matthias Köppe

Replying to gh-tobiasdiez:

There is only one portability config as of now.

But we document what users can do - namely make new configs by editing. The Dockerfile is designed that it does not have to be modified. So it would be a bad practice if we have to tell the user to make a copy.

Its still not completely working:

Tobias, again -- the work on Codespaces should please go to a follow-up ticket. You said you don't have time to work on it. And it's not actionable for us.

The present ticket has a clear scope, has been thoroughly tested and documented.

comment:288 Changed 6 weeks ago by Matthias Köppe

Description: modified (diff)

comment:289 Changed 6 weeks ago by Matthias Köppe

I've opened #34403 for this work.

comment:290 Changed 6 weeks ago by git

Commit: 59f4ac12b1b7c2dffe85d8ce1a9bca22d74f2c0d37eb95dcb3e68c19092c38cb49c9a75c5da35154

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

comment:291 Changed 6 weeks ago by Matthias Köppe

Status: needs_workpositive_review

I've reset the branch to the reviewed version.

comment:292 Changed 6 weeks ago by git

Commit: 37eb95dcb3e68c19092c38cb49c9a75c5da35154d5610b15885f79d8554c1d307759e8431c11bd1c
Status: positive_reviewneeds_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

d5610b1Edit: prefer symlink

comment:293 Changed 6 weeks ago by Kwankyu Lee

Status: needs_reviewpositive_review

comment:294 Changed 6 weeks ago by Matthias Köppe

OK

comment:295 Changed 6 weeks ago by Tobias Diez

Status: positive_reviewneeds_work

Sorry Matthias, but the original version of the code was working well with codespaces. I'm happy you further worked on it, but it's not fair that you introduce issues with codespaces and then say "I don't care, lets fix them in a follow up ticket". And this is not for the sake of codespaces, but as I said above microsoft treats the codespaces as the defacto standard; so if its not working there then vscode will likely break in the future as well (and it will not work with other providers, such as devcontainer cli and gitpod). In fact, the vscode team works on using the same cli as codespaces, see https://github.com/microsoft/vscode-remote-release/issues/6859 and https://github.com/microsoft/vscode-remote-release/issues/7033.

So what about deleting the portability dockerfile completely, and simply specifying the image in the devcontainer? Since the dockerfile is simply forwarding to the github image anyway, this should suffice and be quicker. Moreover, can we use a different "target" that doesn't include the sage source code?

Finally, the names of the "post" scripts need to be changed and the docs changed to reflect the recent changes of "onCreateCommand" etc.

comment:296 in reply to:  295 Changed 6 weeks ago by Kwankyu Lee

Replying to gh-tobiasdiez:

... as I said above microsoft treats the codespaces as the defacto standard; so if its not working there then vscode will likely break in the future as well (and it will not work with other providers, such as devcontainer cli and gitpod). In fact, the vscode team works on using the same cli as codespaces,

Would you comment on: https://trac.sagemath.org/ticket/34403#comment:3 ?

comment:297 in reply to:  295 Changed 6 weeks ago by Matthias Köppe

Replying to gh-tobiasdiez:

Sorry Matthias, but the original version of the code was working well with codespaces. I'm happy you further worked on it, but it's not fair that you introduce issues with codespaces and then say "I don't care, lets fix them in a follow up ticket".

I've set the scope of the ticket to be actionable. Work on codespaces is not actionable for me. You want to support them, you do the work on the follow-up ticket.

comment:298 Changed 6 weeks ago by git

Commit: d5610b15885f79d8554c1d307759e8431c11bd1c179406f61466f123f95ab578dd179ed37ec6b456

Branch pushed to git repo; I updated commit sha1. New commits:

179406fsrc/doc/en/developer/portability_testing.rst: Update references to devcontainer ...Command

comment:299 in reply to:  295 Changed 6 weeks ago by Matthias Köppe

Replying to gh-tobiasdiez:

So what about deleting the portability dockerfile completely

It's there as preparation for the following improvement (which is waiting for #29536):

  • always pull FROM the build stage -with-system-packages
  • then COPY the Sage SAGE_LOCAL (but not the old Sage source tree) from the requested build stage such as the default -with-targets

This creates a smaller version of the container image.

Last edited 6 weeks ago by Matthias Köppe (previous) (diff)

comment:300 Changed 6 weeks ago by Matthias Köppe

Description: modified (diff)

comment:301 Changed 6 weeks ago by git

Commit: 179406f61466f123f95ab578dd179ed37ec6b4564affef24a703a5c9f2cd7dfc008637b57e04dade

Branch pushed to git repo; I updated commit sha1. New commits:

4affef2.devcontainer/onCreate.sh, portability-updateContent.sh: Rename from post_create.sh, portability-post_start.sh

comment:302 in reply to:  295 Changed 6 weeks ago by Matthias Köppe

Replying to gh-tobiasdiez:

the names of the "post" scripts need to be changed and the docs changed to reflect the recent changes of "onCreateCommand" etc.

Thanks for catching this. Done now.

comment:303 Changed 6 weeks ago by Matthias Köppe

Status: needs_workneeds_review

comment:304 Changed 6 weeks ago by Kwankyu Lee

Status: needs_reviewpositive_review

Simple renaming. Positive again.

comment:305 Changed 5 weeks ago by Volker Braun

Branch: public/build/devcontainer4affef24a703a5c9f2cd7dfc008637b57e04dade
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.