Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3314 closed defect (fixed)

[with patch, Positive review] dsage.setup() add_default_client broken

Reported by: yi Owned by: yi
Priority: major Milestone: sage-3.0.3
Component: dsage Keywords: editor_gfurnish
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

twisted changed it's conch interface and I forgot to toString the pubkey object in some instances.

Attachments (1)

3314_default_users.patch (1.3 KB) - added by yi 9 years ago.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by yi

comment:1 Changed 9 years ago by yi

  • Summary changed from dsage.setup() add_default_client broken to [with patch, needs review] dsage.setup() add_default_client broken

comment:2 Changed 9 years ago by mabshoff

  • Milestone set to sage-3.0.3

comment:3 Changed 9 years ago by mabshoff

  • Component changed from Cygwin to dsage
  • Owner changed from mabshoff to yi

comment:4 Changed 9 years ago by craigcitro

  • Keywords editor_gfurnish added

comment:5 Changed 9 years ago by gfurnish

  • Summary changed from [with patch, needs review] dsage.setup() add_default_client broken to [with patch, Negative review] dsage.setup() add_default_client broken

DSage is completely broken in 3.0.2 and 3.0.3!!!!! Make me some patches so that I can actually run dsage.

comment:6 Changed 9 years ago by mabshoff

DSage is not completely broken in Sage 3.0.2 with the patch applied and in 3.3.0.rc0. If you make claims like that you should back them up with details.

Cheers,

Michael

comment:7 Changed 9 years ago by gfurnish

If you do not have an existing known good .sage directory with existing dsage materials from some previous version (unknown), dsage is completely broken.

comment:8 Changed 9 years ago by mabshoff

Ok, the bug is the following *after* deleting the dsage directory in DOT_SAGE:

mabshoff@sage:/scratch/mabshoff/release-cycle/sage-3.0.3.rc0$ ./sage
----------------------------------------------------------------------
| SAGE Version 3.0.3.rc0, Release Date: 2008-06-16                   |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------

sage: dsage.setup()
==================================================
Generating public/private key pair for authentication...
Your key will be stored in /home/mabshoff/.sage/dsage/dsage_key
Just hit enter when prompted for a passphrase
==================================================
<SNIP>
sage: dsage.start_all()
Spawned twistd -d /home/mabshoff/.sage/dsage --pidfile=server.pid --logfile=/home/mabshoff/.sage/dsage/server.log -y dsage_server.tac (pid = 26784)

Spawned python /scratch/mabshoff/release-cycle/sage-3.0.3.rc0/local/bin/dsage_worker.py -s localhost -p 8087 -u mabshoff -w 2 --poll 1.0 -l 0 -f /home/mabshoff/.sage/dsage/worker.log --privkey=/home/mabshoff/.sage/dsage/dsage_key --pubkey=/home/mabshoff/.sage/dsage/dsage_key.pub --priority=20 --ssl --noblock (pid = 26801)

Not connected.
sage: 

The DSage server log says:

2008-06-16 17:08:52-0700 [-] Log opened.
2008-06-16 17:08:52-0700 [-] twistd 8.0.1 (/scratch/mabshoff/release-cycle/sage-3.0.3.rc0/local/bin/python 2.5.2) starting up
2008-06-16 17:08:52-0700 [-] reactor class: <class 'twisted.internet.selectreactor.SelectReactor'>
2008-06-16 17:08:52-0700 [-] twisted.spread.pb.PBServerFactory starting on 8087
2008-06-16 17:08:52-0700 [-] Starting factory <twisted.spread.pb.PBServerFactory instance at 0x2b54f6e88998>
2008-06-16 17:08:52-0700 [-] twisted.web2.channel.http.HTTPFactory starting on 8088
2008-06-16 17:08:52-0700 [-] Starting factory <twisted.web2.channel.http.HTTPFactory instance at 0x2b54f6e88e60>
2008-06-16 17:08:52-0700 [Broker,1,127.0.0.1] <client:'mabshoff'> connected
2008-06-16 17:08:53-0700 [Broker,2,127.0.0.1] <unauthenticated_worker:'Anonymous'> connected
2008-06-16 17:12:03-0700 [Broker,1,127.0.0.1] <client:'mabshoff'> disconnected
2008-06-16 17:12:03-0700 [Broker,2,127.0.0.1] <unauthenticated_worker:'Anonymous'> disconnected

Cheers,

Michael

comment:9 Changed 9 years ago by yi

Michael, Gary, did you test this after applying the patch I posted?

comment:10 Changed 9 years ago by yi

Ok. I tried this with 3.0.3rc0 after applying both #3312 and #3314 and can't repro this.

comment:11 Changed 9 years ago by gfurnish

  • Summary changed from [with patch, Negative review] dsage.setup() add_default_client broken to [with patch, Positive review] dsage.setup() add_default_client broken

comment:12 Changed 9 years ago by was

  • Resolution set to fixed
  • Status changed from new to closed

comment:13 Changed 9 years ago by mabshoff

  • Milestone changed from sage-3.0.4 to sage-3.0.3

Merged in Sage 3.0.3.final

Note: See TracTickets for help on using tickets.