Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#32982 closed defect (duplicate)

Completely split primes sometimes gives wrong answer

Reported by: Maarten Derickx Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Samuel Lelièvre)

sage: x = polygen(QQ)
sage: f = x^3 - x^2 + 2*x + 8
sage: K.<a> = NumberField(f)
sage: K.completely_split_primes(80)
[59, 73, 79]
sage: len((2*K).factor())
3

Since len((2*K).factor()) == 3 we should expect 2 to show up in the list of completely split primes.

Change History (5)

comment:1 Changed 10 months ago by Maarten Derickx

Component: PLEASE CHANGEnumber fields
Type: PLEASE CHANGEdefect

comment:2 Changed 10 months ago by Dave Morris

Is this a duplicate of #28113?

comment:3 Changed 10 months ago by Maarten Derickx

Milestone: sage-9.5sage-duplicate/invalid/wontfix
Status: newneeds_review

yep, thanks for pointing me to that one

comment:4 Changed 10 months ago by Maarten Derickx

Resolution: duplicate
Status: needs_reviewclosed

comment:5 Changed 10 months ago by Samuel Lelièvre

Description: modified (diff)
Note: See TracTickets for help on using tickets.