Opened 13 years ago

Closed 13 years ago

#3296 closed defect (duplicate)

polymake spkg needs "CDDLIB_VERSION='094b.p2" in spkg-install

Reported by: mhampton Owned by: mabshoff
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: polymake, cddlib
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The short summary describes both the problem and solution. I could post a new spkg but its almost easier to change that one line.

Change History (3)

comment:1 Changed 13 years ago by mabshoff

  • Milestone set to sage-3.0.3

Instead of patching polymake each time cddlib changes you should use the following construct:

spkg/standard$ ./newest_version cddlib
cddlib-094b.p2

That way it keeps working ;)

Cheers,

Michael

comment:2 Changed 13 years ago by mabshoff

  • Status changed from new to assigned

The same applies to the gmp, too. Either way, the polymake spkg-install is a mess. In fact the polymake.spkg violates a copious amount of other rules. So while I am at it I might as well update the the polymake 2.3 release.

Thoughts?

Cheers,

Michael

comment:3 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.1.1 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from assigned to closed

#3640 will shortly have a working polymake.spkg, so I am closing this as a duplicate.

Cheers,

Michael

Note: See TracTickets for help on using tickets.