Opened 13 years ago

Closed 13 years ago

#3265 closed defect (duplicate)

some doctests leave files in $SAGE_ROOT/devel/sage

Reported by: mabshoff Owned by: failure
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Some doctests [likely notebook related] leave files in $SAGE_ROOT/devel/sage:

hg status
? sage/server/docs-0.html
? sage/server/docs-1.html
? sage/server/docs-2.html
? sage/server/notebook/a.txt

This is problematic for two reasons:

  • temp files should be written to SAGE_TESTDIR since that is guaranteed to be writable, i.e. when you run doctests on an install that is not owned by the current user
  • it leaves crap in the default tree ;)

Cheers,

Michael

Change History (2)

comment:1 Changed 13 years ago by mabshoff

Mmmh, with the proto patch from #3267 the "sage/server/docs-X.html" files are no longer created.

Cheers,

Michael

comment:2 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.0.3 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #3412.

Cheers,

Michael

Note: See TracTickets for help on using tickets.