Changes between Version 2 and Version 6 of Ticket #32580


Ignore:
Timestamp:
09/28/21 17:53:38 (9 months ago)
Author:
mkoeppe
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #32580

    • Property Cc dimpase mjo jhpalmieri added
  • Ticket #32580 – Description

    v2 v6  
    1 We should update `build/pkgs/openssl/spkg-configure.m4` to detect this.
     1Following [[https://www.python.org/dev/peps/pep-0644/ PEP 644]], python requires OpenSSL 1.1.1 or newer. This was planned to be included in Python 3.10, but apparently Python 3.9.7 (the version of our spkg after #32443) has already broken compatibility with some older openssl releases. For example `ubuntu-trusty` uses 1.0.1f.
    22https://github.com/sagemath/sage/runs/3712854824?check_suite_focus=true
    33
     
    1717                 ^~~~~~~~~~~
    1818}}}
     19
     20We should update `build/pkgs/openssl/spkg-configure.m4` to detect that we have a suitable version. Currently there is no version check whatsoever.
     21
     22