#31903 closed defect (fixed)

Build errors in padic_relaxed_element

Reported by: mkoeppe Owned by:
Priority: blocker Milestone: sage-9.4
Component: padics Keywords:
Cc: dimpase, caruso, roed, vbraun Merged in:
Authors: Matthias Koeppe Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: e568e3b (Commits, GitHub, GitLab) Commit: e568e3b2885a96b2008b43bcf1986501ede3447d
Dependencies: Stopgaps:

Status badges

Description

9.4.beta0 fails to build:

https://github.com/sagemath/sage/runs/2670399286?check_suite_focus=true

  [sagelib-9.4.beta0]   building 'sage.rings.padics.padic_relaxed_element' extension
  [sagelib-9.4.beta0]   Executing 1 command (using 1 thread)
  [sagelib-9.4.beta0]   [1/1] gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -Wno-unused -O2 -g -march=native -O2 -g -march=native -fPIC -I./sage/cpython -I./sage/libs/flint -Isage/libs/flint -I/sage/build/pkgs/sagelib/src -I/sage/local/include/python3.9 -I/sage/local/lib/python3.9/site-packages/numpy/core/include -Ibuild/cythonized -I/sage/local/include/python3.9 -c build/cythonized/sage/rings/padics/padic_relaxed_element.c -o build/temp.linux-x86_64-3.9/build/cythonized/sage/rings/padics/padic_relaxed_element.o -fno-strict-aliasing -DCYTHON_CLINE_IN_TRACEBACK=1 -std=c99
  [sagelib-9.4.beta0]   build/cythonized/sage/rings/padics/padic_relaxed_element.c:5174:60: fatal error: sage/libs/linkages/padics/relaxed/flint_helper.c: No such file or directory

Change History (11)

comment:1 Changed 13 months ago by mkoeppe

I think __init__.py is missing in the new directory libs/linkages/padics/relaxed, so it is not recognized as a package directory

comment:2 Changed 13 months ago by mkoeppe

Actually I think the problem is that flint_helper.c was not added as an exception to .gitignore, so all Docker-based builds (which use .dockerignore -> .gitignore) are broken

comment:3 Changed 13 months ago by mkoeppe

  • Branch set to u/mkoeppe/build_errors_in_padic_relaxed_element

comment:4 Changed 13 months ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Commit set to e568e3b2885a96b2008b43bcf1986501ede3447d

New commits:

d5a33desrc/sage/libs/linkages/padics/relaxed/__init__.py: New
e568e3b.gitignore: Add exception for a non-generated .c file

comment:5 Changed 13 months ago by mkoeppe

  • Reviewers set to https://github.com/mkoeppe/sage/actions/runs/904504331

comment:6 follow-up: Changed 13 months ago by roed

I'm fine with this fix, but I'm not sure how to parse the output of https://github.com/mkoeppe/sage/actions/runs/904504331. It seems to have various numpy failures but not the failure reported in this ticket. Will all of the jobs eventually finish there?

comment:7 Changed 13 months ago by dimpase

  • Status changed from new to needs_review

probably what's tested has more stuff in than just this branch.

comment:8 in reply to: ↑ 6 Changed 13 months ago by mkoeppe

Replying to roed:

I'm fine with this fix, but I'm not sure how to parse the output of https://github.com/mkoeppe/sage/actions/runs/904504331. It seems to have various numpy failures but not the failure reported in this ticket. Will all of the jobs eventually finish there?

This GH Actions run used the branch from this ticket together with the one from #31008, numpy upgrade.

The failures reported on the present ticket are fixed by the branch.

Ready for review

comment:9 Changed 13 months ago by vbraun

  • Status changed from needs_review to positive_review

comment:10 Changed 13 months ago by vbraun

  • Reviewers changed from https://github.com/mkoeppe/sage/actions/runs/904504331 to Volker Braun

comment:11 Changed 13 months ago by vbraun

  • Branch changed from u/mkoeppe/build_errors_in_padic_relaxed_element to e568e3b2885a96b2008b43bcf1986501ede3447d
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.