#31847 closed defect (invalid)

Fix rich output of LatexExpr in Jupyter

Reported by: rjbarker Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: show, sage.repl.rich_output.pretty_print
Cc: egourgoulhon, klee, slelievre Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by slelievre)

Up to Sage 9.2, show(...), alias for sage.repl.rich_output.pretty_print(...), formats LatexExpr correctly in Jupyter.

In Sage 9.3 it is broken, as illustrated by:

sage: sage.repl.rich_output.pretty_print(LatexExpr(r"\frac{x}{y}"))
sage: show(LatexExpr(r"\frac{x}{y}"))

Screenshots reproducing the defect in CoCalc are attached to this ticket.

Attachments (2)

SageMath9.2.jpg (49.8 KB) - added by rjbarker 15 months ago.
SageMath9.3.jpg (78.3 KB) - added by rjbarker 15 months ago.

Download all attachments as: .zip

Change History (9)

Changed 15 months ago by rjbarker

Changed 15 months ago by rjbarker

comment:1 Changed 15 months ago by rjbarker

  • Authors set to rjbarker

comment:2 Changed 15 months ago by rjbarker

  • Authors rjbarker deleted

comment:3 Changed 15 months ago by slelievre

  • Cc egourgoulhon klee slelievre added
  • Description modified (diff)
  • Keywords show sage.repl.rich_output.pretty_print added; show() sage.repl.rich_output.pretty_print() removed
  • Summary changed from "show()" does not display LatexExpr in jupyter as of sage 9.3 to Fix rich output of LatexExpr in Jupyter

Maybe the changes in #31536 cause this change in display?

comment:4 follow-up: Changed 15 months ago by slelievre

Possibly a duplicate of #31629.

comment:5 in reply to: ↑ 4 Changed 15 months ago by klee

  • Milestone changed from sage-9.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Replying to slelievre:

Possibly a duplicate of #31629.

Yes. Fixed by the patch in #31629.

comment:6 Changed 15 months ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

comment:7 Changed 14 months ago by mkoeppe

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.