Opened 15 months ago

Last modified 4 months ago

#31761 new defect

Stop loading all installed GAP packages — at Initial Version

Reported by: arojas Owned by:
Priority: major Milestone: sage-9.7
Component: packages: standard Keywords:
Cc: dimpase Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On a fresh run of the GAP interface, Sage caches a GAP workspace which loads every single GAP package on the system. While this might be OK with Sage's trimmed-down version of gap_packages, if using a system GAP install with all optional packages installed this can take a massive amount of memory (~1GB with all packages included in the 4.11.1 tarball), which in many casses surpasses the default gap_memory_pool_size value, causing crashes. This will become a common issue once #29644 is merged.

Possible solutions: 1) Don't preload packages in Sage and let GAP load its default list of packages 2) Load a hardcoded list of packages (such as those installed by the gap and gap_packages spkg's)

Change History (0)

Note: See TracTickets for help on using tickets.