Opened 6 months ago

Closed 4 months ago

#31704 closed defect (fixed)

Remove Python 2 compatibility from manifolds

Reported by: gh-mjungmath Owned by:
Priority: major Milestone: sage-9.4
Component: manifolds Keywords:
Cc: egourgoulhon, tscrim Merged in:
Authors: Eric Gourgoulhon Reviewers: Michael Jung
Report Upstream: N/A Work issues:
Branch: b027f2d (Commits, GitHub, GitLab) Commit: b027f2d1a4bb09b93e72c6c97f2ab739ddafd70c
Dependencies: Stopgaps:

Status badges

Description

Currently, the manifolds code has still things like

__nonzero__ = __bool__  # For Python2 compatibility

which should be removed by now.

Change History (6)

comment:1 Changed 6 months ago by egourgoulhon

  • Authors set to Eric Gourgoulhon
  • Branch set to public/manifolds/remove_python2_compatibility-31704
  • Commit set to 0aefe529a51100b5870194aeb767e3cc7a2cade5
  • Status changed from new to needs_review
  • Type changed from task to defect

Thanks for catching this. Here we go...


New commits:

0aefe52Remove __nonzero__ from manifolds

comment:2 follow-up: Changed 6 months ago by gh-mjungmath

  • Reviewers set to Michael Jung
  • Status changed from needs_review to positive_review

LGTM. Morally green patchbot. The cause of that pyflakes error is in line 1507 of free_module_tensor.py:

if basis is None: basis = self._fmodule._def_basis

Should we fix this in another ticket just to get rid of this annoying error whenever we play around with free_module_tensor.py...?

comment:3 Changed 6 months ago by git

  • Commit changed from 0aefe529a51100b5870194aeb767e3cc7a2cade5 to b027f2d1a4bb09b93e72c6c97f2ab739ddafd70c
  • Status changed from positive_review to needs_review

Branch pushed to git repo; I updated commit sha1 and set ticket back to needs_review. New commits:

b027f2dCorrect pycodestyle error

comment:4 in reply to: ↑ 2 Changed 6 months ago by egourgoulhon

Replying to gh-mjungmath:

LGTM. Morally green patchbot. The cause of that pyflakes error is in line 1507 of free_module_tensor.py:

if basis is None: basis = self._fmodule._def_basis

Should we fix this in another ticket just to get rid of this annoying error whenever we play around with free_module_tensor.py...?

You're right; let's fix it here (cf. the latest commit).

comment:5 Changed 6 months ago by gh-mjungmath

  • Status changed from needs_review to positive_review

Morally green. LGTM.

comment:6 Changed 4 months ago by vbraun

  • Branch changed from public/manifolds/remove_python2_compatibility-31704 to b027f2d1a4bb09b93e72c6c97f2ab739ddafd70c
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.