Opened 16 months ago

Closed 16 months ago

Last modified 15 months ago

#31638 closed enhancement (fixed)

Add mention of Culler's app to install docs for macOS

Reported by: dunfield Owned by:
Priority: blocker Milestone: sage-9.3
Component: documentation Keywords:
Cc: slelievre, kcrisman, culler, mgoerner, mkoeppe, vbraun Merged in:
Authors: Nathan Dunfield Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: d45298a (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

Status badges

Description

Marc Culler has a new binary distribution of Sage for macOS that is fully signed and notarized, eliminating the many problems with the current official Sage binary caused by Apple's gatekeeper antimalware protections.

This ticket adds a reference to this distribution in the install docs. It is related to #31000.

https://github.com/3-manifolds/Sage_macOS/releases

Change History (10)

comment:1 Changed 16 months ago by dunfield

  • Branch set to u/dunfield/culler_macOS_app
  • Commit set to 492b2d67e0e9d45d196e5b1d7e34c598af3624a8

Initial version of English language docs. Because the old "app" version is going away in 9.3, I also updated the install instructions for the official binaries.

What do people think?


New commits:

492b2d6Initial draft

comment:2 Changed 16 months ago by vdelecroix

  • Cc vbraun added

Shouldn't this app be the preferred way to install on MacOS? I mean shouldn't it appear first?

To my mind it is mandatory to make them available on the mirrors.

@Volker: could we have it for 9.3?

comment:3 Changed 16 months ago by mkoeppe

  • Authors changed from dunfield to Nathan Dunfield
  • Priority changed from major to blocker

comment:4 Changed 16 months ago by mkoeppe

  • Branch changed from u/dunfield/culler_macOS_app to u/mkoeppe/culler_macOS_app

comment:5 Changed 16 months ago by mkoeppe

  • Commit changed from 492b2d67e0e9d45d196e5b1d7e34c598af3624a8 to d45298ae2089a2c5e984e845435a2613ff6048f3
  • Reviewers set to Matthias Koeppe
  • Status changed from new to needs_review

New commits:

d45298asrc/doc/en/installation/binary.rst: Fix typos

comment:6 Changed 16 months ago by mkoeppe

  • Status changed from needs_review to positive_review

I've set it to "blocker", we definitely need this change for 9.3

comment:7 Changed 16 months ago by dunfield

comment:8 Changed 16 months ago by vbraun

  • Branch changed from u/mkoeppe/culler_macOS_app to d45298ae2089a2c5e984e845435a2613ff6048f3
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:9 follow-up: Changed 15 months ago by slelievre

  • Commit d45298ae2089a2c5e984e845435a2613ff6048f3 deleted

Needs a follow-up ticket in view of this discussion:

comment:10 in reply to: ↑ 9 Changed 15 months ago by vdelecroix

Replying to slelievre:

Needs a follow-up ticket in view of this discussion:

The procedure is described here https://doc.sagemath.org/html/en/developer/index.html

Note: See TracTickets for help on using tickets.