Opened 19 months ago

Closed 4 weeks ago

#31522 closed defect (invalid)

GH Actions: tox-optional.yml: Remove misleading error messages regarding optional script packages

Reported by: Matthias Köppe Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: porting Keywords:
Cc: gh-kliem, John Palmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #31163 Stopgaps:

Status badges

Description

For example on ubuntu-trusty-maximal (https://github.com/mkoeppe/sage/runs/2135025659), configure correctly finds system perl_cpan_polymake_prereq but then tests whether SPKG perl_cpan_polymake_prereq can be installed (it gives an error - by design).

This can be distracting in the GH Action logs.

Change History (7)

comment:1 Changed 19 months ago by Matthias Köppe

A possible fix would be through #31163

comment:2 Changed 18 months ago by Matthias Köppe

Milestone: sage-9.3sage-9.4

Sage development has entered the release candidate phase for 9.3. Setting a new milestone for this ticket based on a cursory review of ticket status, priority, and last modification date.

comment:3 Changed 14 months ago by Matthias Köppe

Milestone: sage-9.4sage-9.5

comment:4 Changed 12 months ago by Matthias Köppe

Dependencies: #31163
Milestone: sage-9.5sage-duplicate/invalid/wontfix
Status: newneeds_review

Taken care of by #31163

comment:5 Changed 7 weeks ago by Matthias Köppe

Cc: John Palmieri added

comment:6 Changed 7 weeks ago by John Palmieri

Status: needs_reviewpositive_review

comment:7 Changed 4 weeks ago by Matthias Köppe

Resolution: invalid
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.