Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#31447 closed defect (duplicate)

list_plot labels don't indicate exponential notation by default

Reported by: DavidLowry Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords: list_plot, plot
Cc: slelievre Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The plotting snippet list_plot([2**n for n in range(100)]) shows a plot that is almost right, except that the y-labels are incorrect. They show 1, 2, ... instead of something like 1e30, 2e30.

This might have to do with #30176, updating matplotlib to 3.3, and the different behavior of OldScalarFormatter and ScalarFormatter in matplotlib, but I'm not sure.

This was pointed out to me by Tom Hulse.

Change History (3)

comment:1 Changed 6 weeks ago by slelievre

  • Cc slelievre added
  • Milestone changed from sage-9.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Possibly a duplicate of #30983. Give positive review if you think so.

That ticket links to reports on Ask Sage, where some workarounds are provided.

comment:2 Changed 6 weeks ago by DavidLowry

  • Status changed from needs_review to positive_review

I agree that this is a duplicate of #30983. Thank you for catching that!

comment:3 Changed 6 weeks ago by slelievre

  • Resolution set to duplicate
  • Status changed from positive_review to closed

Thanks for the report and code snippet. Happy to review a fix to #30983.

Last edited 6 weeks ago by slelievre (previous) (diff)
Note: See TracTickets for help on using tickets.