#31252 closed defect (fixed)

Suppress message "WARNING: You are using pip version 20.2.3; however, version 20.3.3 is available."

Reported by: mkoeppe Owned by:
Priority: minor Milestone: sage-9.3
Component: build Keywords: quiet
Cc: slelievre, jhpalmieri Merged in:
Authors: Matthias Koeppe Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: c555b30 (Commits, GitHub, GitLab) Commit: c555b30332188d252a8ffa63a731deff2d377ac9
Dependencies: Stopgaps:

Status badges

Description (last modified by mkoeppe)

Using --disable-pip-version-check

Change History (9)

comment:1 Changed 18 months ago by mkoeppe

  • Description modified (diff)

comment:2 Changed 18 months ago by mkoeppe

  • Branch set to u/mkoeppe/suppress_message__warning__you_are_using_pip_version_20_2_3__however__version_20_3_3_is_available__

comment:3 Changed 18 months ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Cc slelievre jhpalmieri added
  • Commit set to c555b30332188d252a8ffa63a731deff2d377ac9
  • Keywords quiet added

New commits:

c555b30src/bin/sage (--pip): Use --disable-pip-version-check

comment:4 Changed 17 months ago by mkoeppe

  • Status changed from new to needs_review

comment:5 follow-up: Changed 17 months ago by jhpalmieri

Is it worth also making this change in build/bin also? (sage-dist-helpers, sage-pip-install, sage-pip-uninstall, sage-print-system-package-command)

comment:6 in reply to: ↑ 5 Changed 17 months ago by mkoeppe

Replying to jhpalmieri:

Is it worth also making this change in build/bin also? (sage-dist-helpers, sage-pip-install, sage-pip-uninstall,

These pip calls already use --no-index, which implies --disable-pip-version-check.

sage-print-system-package-command)

I don't think we should change this one: The output is (mostly) for informing/educating users, and it is better if we show the simplest possible command line there.

comment:7 Changed 17 months ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

Okay, looks good to me. Works as advertised and I don't see any downside, as long as we keep our pip reasonably up to date. (The warning serves as a reminder to update it, so we are losing that.)

comment:8 Changed 17 months ago by mkoeppe

Thanks!

comment:9 Changed 16 months ago by vbraun

  • Branch changed from u/mkoeppe/suppress_message__warning__you_are_using_pip_version_20_2_3__however__version_20_3_3_is_available__ to c555b30332188d252a8ffa63a731deff2d377ac9
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.