Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#31192 closed defect (fixed)

Installation manual: Fix documentation of python prerequisite (sage-bootstrap-python)

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.3
Component: documentation Keywords:
Cc: jhpalmieri, gh-tobiasdiez, dimpase Merged in:
Authors: Tobias Diez, Matthias Koeppe Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: 4265656 (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

GitHub link to the corresponding issue

Description

(split out from #30551)

sage-bootstrap-python which has much wider range of supported python versions, including Python >= 2.6 and Python >= 3.4 - according to build/tox.ini.

Change History (10)

comment:1 Changed 2 years ago by gh-tobiasdiez

What is wrong with the current description? If an old Python is installed, then sage bootstrap downloads and (locally) installs a new python, right? This seems to be a huge enough workaround to justify the terminology "deprecated" (which implies that it does work, but is no longer recommended). Or do you mean something else?

comment:2 Changed 2 years ago by mkoeppe

Branch: u/mkoeppe/installation_manual__fix_documentation_of_python_prerequisite__sage_bootstrap_python_

comment:3 Changed 2 years ago by mkoeppe

Authors: Tobias Diez, Matthias Koeppe
Cc: dimpase added
Commit: 4265656ad2a431317d70e1e8df665ceb097d1e8f
Status: newneeds_review

New commits:

4265656src/doc/en/installation/source.rst: Fix documentation of python prerequisite (sage-bootstrap-python)

comment:4 Changed 2 years ago by dimpase

is Python 2.6 actually tested to work? IMHO asking for 2.7 is fine.

comment:5 Changed 2 years ago by gh-tobiasdiez

This part of the documentation is for "normal" users right? Then maybe the reference to sage-bootstrap-python is more confusing than helpful for the target group. Personally, I would also add a "Version 3.7 or later is recommended".

Last edited 2 years ago by gh-tobiasdiez (previous) (diff)

comment:6 Changed 2 years ago by jhpalmieri

I think the phrasing is okay: I think it makes it clear that it is a technical term and people can freely ignore it. I haven't actually tested to see whether Python 2.6 will work, but I think we should merge this. Any objections?

comment:7 Changed 2 years ago by dimpase

Reviewers: Dima Pasechnik
Status: needs_reviewpositive_review

ok, fine

comment:8 Changed 2 years ago by mkoeppe

Thanks.

comment:9 Changed 2 years ago by vbraun

Branch: u/mkoeppe/installation_manual__fix_documentation_of_python_prerequisite__sage_bootstrap_python_4265656ad2a431317d70e1e8df665ceb097d1e8f
Resolution: fixed
Status: positive_reviewclosed

comment:10 Changed 2 years ago by mkoeppe

Commit: 4265656ad2a431317d70e1e8df665ceb097d1e8f

Follow-up in #20023

Note: See TracTickets for help on using tickets.