Opened 13 months ago

Closed 8 months ago

#31179 closed enhancement (fixed)

Add package ipympl - Makes interactive features of matplotlib available also in JupyterLab

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.4
Component: packages: optional Keywords:
Cc: egourgoulhon, gh-jcamp0x2a, dunfield, culler, slelievre, charpent Merged in:
Authors: Matthias Koeppe Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 3621bc4 (Commits, GitHub, GitLab) Commit: 3621bc414a228f7009200b7c03194f79559cd5c7
Dependencies: Stopgaps:

Status badges

Description (last modified by mkoeppe)

ipympl provides %matplotlib widget, which works in both the Jupyter notebook and JupyterLab.

https://github.com/matplotlib/ipympl

Change History (9)

comment:1 Changed 13 months ago by dunfield

A minor clarification: The classic Jupyter notebook has built-in support for live matplotlib interaction through the %matplotlib notebook magic command, but this matplotlib backend does not work in JupyterLab. The ipympl package provides %matplotlib widget which works with both versions of Jupyter.

comment:2 Changed 13 months ago by mkoeppe

  • Summary changed from Add package ipympl - interactive features of matplotlib in the Jupyter notebook and in JupyterLab to Add package ipympl - Makes interactive features of matplotlib available also in JupyterLab

comment:3 Changed 11 months ago by mkoeppe

  • Branch set to u/mkoeppe/add_package_ipympl___makes_interactive_features_of_matplotlib_available_also_in_jupyterlab

comment:4 Changed 11 months ago by git

  • Commit set to 3621bc414a228f7009200b7c03194f79559cd5c7

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

3621bc4build/pkgs/ipympl/dependencies: Add jupyter_packaging, make jupyterlab an optional dependency

comment:5 Changed 11 months ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Description modified (diff)
  • Status changed from new to needs_review

comment:6 Changed 10 months ago by mkoeppe

  • Milestone changed from sage-9.3 to sage-9.4

Moving this ticket to 9.4, as it seems unlikely that it will be merged in 9.3, which is in the release candidate stage

comment:7 Changed 9 months ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

LGTM.

comment:8 Changed 9 months ago by mkoeppe

Thank you.

comment:9 Changed 8 months ago by vbraun

  • Branch changed from u/mkoeppe/add_package_ipympl___makes_interactive_features_of_matplotlib_available_also_in_jupyterlab to 3621bc414a228f7009200b7c03194f79559cd5c7
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.