Opened 13 years ago

Closed 12 years ago

#3086 closed defect (duplicate)

Update R to the 2.9.2 release and split off rpy.spkg

Reported by: mabshoff Owned by: jason
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: jason Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jason)

  • R 2.9.2 is out, so let's upgrade.
  • Evaluate using rpy2, which is a lower-level interface between R and python. Make rpy2 its own spkg.

Change History (7)

comment:1 Changed 13 years ago by mabshoff

  • Status changed from new to assigned

R 2.6.1 is also broken on FC3:

gcc -std=gnu99 -I. -I../../src/include -I../../src/include -I/usr/local/include -DHAVE_CONFIG_H   -fpic  -I/root/sage-3.0/lo
cal/include -L/root/sage-3.0/local/lib/  -c signrank.c -o signrank.o
make[5]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/nmath'
make[4]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/nmath'
make[4]: Entering directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/unix'
config.status: creating src/unix/Makefile
make[4]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/unix'
make[4]: Entering directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/unix'
make[5]: Entering directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/unix'
making dynload.d from dynload.c
making edit.d from edit.c
making stubs.d from stubs.c
making system.d from system.c
making sys-unix.d from sys-unix.c
making sys-std.d from sys-std.c
sys-std.c:401:33: readline/readline.h: No such file or directory
sys-std.c:431:32: readline/history.h: No such file or directory
make[5]: *** [sys-std.d] Error 1
make[5]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/unix'
make[4]: *** [R] Error 2
make[4]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src/unix'
make[3]: *** [R] Error 1
make[3]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src/src'
make[2]: *** [R] Error 1
make[2]: Leaving directory `/root/sage-3.0/spkg/build/r-2.6.1.p15/src'
Error building R.

This is most likely cause by R not using Sage's readline. There is a similar issue with R not picking Sage's libpng, so fix both issues when updating to R 2.7.

Cheers,

Michael

comment:2 Changed 13 years ago by mabshoff

See also #3011 about the related RHOME issue.

Cheers,

Michael

comment:3 Changed 12 years ago by jason

  • Cc jason added
  • Description modified (diff)
  • Owner changed from mabshoff to jason
  • Status changed from assigned to new
  • Summary changed from Update R to the 2.7 release and split off rpy.spkg to Update R to the 2.9.2 release and split off rpy.spkg

comment:4 Changed 12 years ago by jason

Also, R has its own C interface---I think rpy2 is using it, but if not, it might make sense for us to just write a Cython wrapper around the C interface.

comment:5 Changed 12 years ago by jason

My draft of an updated R and rpy2 spkg is at http://sage.math.washington.edu/home/jason/r-2.9.2.spkg. There are unchecked-in changes in the spkg, and I just ignored a bunch of old patches to R because I wasn't sure they applied anymore, so the spkg is not finished.

comment:6 Changed 12 years ago by jason

See #6972 for a continuation of the updated spkg above.

comment:7 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as a duplicate of #6972.

Note: See TracTickets for help on using tickets.