Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#30780 closed enhancement (fixed)

sage_setup: Separate installing and cleaning

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.3
Component: build Keywords:
Cc: gh-tobiasdiez, dimpase, jhpalmieri Merged in:
Authors: Matthias Koeppe Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: ad9402f (Commits, GitHub, GitLab) Commit:
Dependencies: #30779 Stopgaps:

Status badges

Description

This is preparation for #28925.

Change History (11)

comment:1 Changed 22 months ago by mkoeppe

  • Type changed from PLEASE CHANGE to enhancement

comment:2 Changed 22 months ago by mkoeppe

  • Branch set to u/mkoeppe/sage_setup__separate_installing_and_cleaning

comment:3 Changed 22 months ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Commit set to 9b9562827f92371c91109fc62380fecf7af8f65d
  • Status changed from new to needs_review

New commits:

4f56517Duplicate src/setup.py
7980130Merge branch 't/30779/duplicate_src_setup_py' into t/30780/sage_setup__separate_installing_and_cleaning
9b95628sage_setup.command.sage_install.sage_install: Rename to sage_install_and_clean, update use it in build/pkgs/sagelib/src/setup.py; refactor through new class sage_install

comment:4 Changed 22 months ago by mkoeppe

  • Cc gh-tobiasdiez added

comment:5 Changed 22 months ago by git

  • Commit changed from 9b9562827f92371c91109fc62380fecf7af8f65d to ad9402f606204d6dd9a454b9b055bed63247d97a

Branch pushed to git repo; I updated commit sha1. New commits:

ad9402fsage_setup.command.sage_install: Fixup: Remove cleaning code (moved to sage_install_and_clean)

comment:6 Changed 21 months ago by mkoeppe

  • Cc dimpase jhpalmieri added

comment:7 Changed 21 months ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

ok

comment:8 Changed 21 months ago by mkoeppe

Thanks

comment:9 Changed 21 months ago by vbraun

  • Branch changed from u/mkoeppe/sage_setup__separate_installing_and_cleaning to ad9402f606204d6dd9a454b9b055bed63247d97a
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:10 Changed 21 months ago by embray

  • Commit ad9402f606204d6dd9a454b9b055bed63247d97a deleted

Why did this include a whole entire duplicate of setup.py?

comment:11 Changed 21 months ago by mkoeppe

The duplication was done in #30779, a dependency of this ticket. This is preparing for Tobias Diez's work for editable installs (setup.py develop) in #30371 out of src/ and the work in #29705 regarding modularization, which is taking place in build/pkgs/sagelib/src. At some point they will be reconciled again, but for the time being it simplifies development to keep the two copies separate.

Note: See TracTickets for help on using tickets.