Changes between Version 4 and Version 6 of Ticket #30560


Ignore:
Timestamp:
Sep 13, 2020, 7:13:02 PM (2 years ago)
Author:
Matthias Köppe
Comment:

Found a simpler solution than the previously discussed SAGE_TOOLCHAIN business. Needs review


New commits:

0c394cabuild/pkgs/python3/dependencies: Make openssl a dependency if it is enabled

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #30560

    • Property Status changed from new to needs_review
    • Property Authors changed from to Matthias Koeppe
    • Property Summary changed from Build optional package openssl as part of SAGE_TOOLCHAIN to Make openssl an optional dependency of python3
    • Property Branch changed from to u/mkoeppe/build_optional_package_openssl_as_part_of_sage_toolchain
    • Property Commit changed from to 0c394ca0885c02944fba5b3472c5bd7f9a3c274d
  • Ticket #30560 – Description

    v4 v6  
    11As discussed in #30556, if `openssl` is enabled using `--enable-openssl` and neither `openssl` nor `python3` are available as system packages, this makes sure that `openssl` is built before `python3`.
    22
    3 If system openssl is found via #30557, then `--enable-openssl` does not trigger building openssl. Use `--enable-openssl --without-system-openssl` if this is desired.
     3If system openssl is found via #30557, then `--enable-openssl` does NOT trigger building openssl. Use `--enable-openssl --without-system-openssl` if this is desired.
    44