Opened 11 months ago

Closed 9 months ago

#30545 closed defect (fixed)

A 1-dimensional polytope has no edge

Reported by: vpilaud Owned by:
Priority: minor Milestone: sage-9.3
Component: geometry Keywords: polytopes
Cc: jipilab, chapoton, gh-kliem Merged in:
Authors: Frédéric Chapoton Reviewers: Samuel Lelièvre
Report Upstream: N/A Work issues:
Branch: 4c3016a (Commits, GitHub, GitLab) Commit: 4c3016a60af07b5bbb5cf0b1f3e161cfdb648895
Dependencies: Stopgaps:

Status badges

Description (last modified by slelievre)

The graph of a polytope used to be constructed in the method graph using pairs of vertices satisfying common inequalities of the inequalities list, which did not work in dimension 1:

In Sage 9.0:

sage: polytopes.simplex(1).graph().edges()
[]

This has since been fixed.

This ticket adds a doctest.

Change History (13)

comment:1 Changed 11 months ago by chapoton

  • Cc jipilab chapoton gh-kliem added; labbe@… chapoton@… removed
  • Milestone changed from sage-9.2 to sage-9.3

comment:2 Changed 11 months ago by chapoton

Vincent, tu utilises quelle version de sage ? Ca marche pour moi dans la version 9.2.beta12.

sage: polytopes.simplex(1).graph().edges()                                      
[(A vertex at (0, 1), A vertex at (1, 0), None)]
Last edited 11 months ago by chapoton (previous) (diff)

comment:3 Changed 11 months ago by gh-kliem

I cannot reproduce this either.

comment:4 Changed 11 months ago by dimpase

by the way, I see bouncing emails from trac to vinc.pilaud@... (they seem to be notifications on this ticket).

Please alert vpilaud.

Yours, postmaster :-)

Last edited 11 months ago by dimpase (previous) (diff)

comment:5 Changed 11 months ago by vpilaud

I had that on version 9.0 and was too lazy to update. So nevermind. I took the opportunity to update my email address on track.

comment:6 Changed 11 months ago by slelievre

  • Milestone changed from sage-9.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_info

Two ways to solve this ticket:

  • add a doctest for that (is there already one?)
  • or set to duplicate/invalid/wontfix

comment:7 Changed 11 months ago by slelievre

Cheap ways to check whether something is fixed in a more recent Sage version than you have:

  • The main CoCalc instance has a lot of Sage versions installed, including the last few stable versions, and usually a recent enough development version.

This can help decide whether to upgrade.

comment:8 Changed 11 months ago by chapoton

  • Authors set to Frédéric Chapoton
  • Branch set to u/chapoton/30545
  • Commit set to 4c3016a60af07b5bbb5cf0b1f3e161cfdb648895
  • Status changed from needs_info to needs_review

Here is a doctest


New commits:

4c3016aadd a check for the vertex graph af the line-segment polytope

comment:9 Changed 11 months ago by slelievre

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-9.2
  • Status changed from needs_review to positive_review

Thanks!

comment:10 Changed 11 months ago by slelievre

  • Description modified (diff)
  • Reviewers set to Samuel Lelièvre

comment:11 Changed 11 months ago by vpilaud

Thanks Samuel and Frédéric for the links and resolution of the ticket.

comment:12 Changed 9 months ago by mkoeppe

  • Milestone changed from sage-9.2 to sage-9.3

comment:13 Changed 9 months ago by vbraun

  • Branch changed from u/chapoton/30545 to 4c3016a60af07b5bbb5cf0b1f3e161cfdb648895
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.