#30346 closed defect (fixed)

Exception for the unknot in Homfly-PT polynomial

Reported by: soehms Owned by:
Priority: major Milestone: sage-9.3
Component: algebraic topology Keywords: link, knot, homfly
Cc: mmarco Merged in:
Authors: Sebastian Oehms Reviewers: Samuel Lelièvre
Report Upstream: N/A Work issues:
Branch: da6e768 (Commits, GitHub, GitLab) Commit: da6e768ffde18db3137a0cde1ee23aed08debec8
Dependencies: Stopgaps:

Status badges

Description (last modified by slelievre)

Define the trivial link:

sage: L = Link([]); L                                                                                                                                                                                
Link with 1 component represented by 0 crossings

Before this ticket:

sage: L.homfly_polynomial()            
Traceback (most recent call last):
...
SignalError: Bus error

After this ticket:

sage: L.homfly_polynomial()            
1

Change History (10)

comment:1 Changed 22 months ago by soehms

  • Branch set to u/soehms/homfly_unknot

comment:2 Changed 22 months ago by soehms

  • Authors set to Sebastian Oehms
  • Cc mmarco added
  • Commit set to da6e768ffde18db3137a0cde1ee23aed08debec8
  • Status changed from new to needs_review

New commits:

da6e76830346: initial version

comment:3 follow-up: Changed 22 months ago by mmarco

Thanks for catching this. It would need a doctest.

Also, the unknot (or rather, the trivial diagram) is such a special case that i wouldn't be surprised if other methods also failed with it. It would be worth checking more carefully.

comment:4 in reply to: ↑ 3 Changed 22 months ago by soehms

Replying to mmarco:

Thanks for catching this. It would need a doctest.

What further doctest do you mean?

Also, the unknot (or rather, the trivial diagram) is such a special case that i wouldn't be surprised if other methods also failed with it. It would be worth checking more carefully.

I will pay attention to that during my further development of the KnotInfo? package!

comment:5 Changed 21 months ago by slelievre

  • Description modified (diff)
  • Reviewers set to Samuel Lelièvre
  • Status changed from needs_review to positive_review

Thanks!

comment:6 Changed 21 months ago by vbraun

  • Status changed from positive_review to needs_work
[dochtml] [knots    ] /home/release/Sage/local/lib/python3.8/site-packages/sage/knots/link.py:docstring of sage.knots.link.Link:95: WARNING: Exception occurred in plotting link-3
[dochtml] [knots    ]  from /home/release/Sage/src/doc/en/reference/knots/sage/knots/link.rst:
[dochtml] [knots    ] Traceback (most recent call last):
[dochtml] [knots    ]   File "/home/release/Sage/local/lib/python3.8/site-packages/matplotlib/sphinxext/plot_directive.py", line 472, in run_code
[dochtml] [knots    ]     exec(code, ns)
[dochtml] [knots    ]   File "<string>", line 2, in <module>
[dochtml] [knots    ]   File "sage/structure/parent.pyx", line 900, in sage.structure.parent.Parent.__call__ (build/cythonized/sage/structure/parent.c:9337)
[dochtml] [knots    ]     return mor._call_(x)
[dochtml] [knots    ]   File "sage/structure/coerce_maps.pyx", line 161, in sage.structure.coerce_maps.DefaultConvertMap_unique._call_ (build/cythonized/sage/structure/coerce_maps.c:4623)
[dochtml] [knots    ]     raise
[dochtml] [knots    ]   File "sage/structure/coerce_maps.pyx", line 156, in sage.structure.coerce_maps.DefaultConvertMap_unique._call_ (build/cythonized/sage/structure/coerce_maps.c:4515)
[dochtml] [knots    ]     return C._element_constructor(x)
[dochtml] [knots    ]   File "/home/release/Sage/local/lib/python3.8/site-packages/sage/groups/braid.py", line 1581, in _element_constructor_
[dochtml] [knots    ]     return self.element_class(self, x)
[dochtml] [knots    ]   File "/home/release/Sage/local/lib/python3.8/site-packages/sage/groups/finitely_presented.py", line 236, in __init__
[dochtml] [knots    ]     fp_family = parent.gap().Identity().FamilyObj()
[dochtml] [knots    ]   File "sage/libs/gap/element.pyx", line 2679, in sage.libs.gap.element.GapElement_MethodProxy.__call__ (build/cythonized/sage/libs/gap/element.c:20845)
[dochtml] [knots    ]     return GapElement_Function.__call__(self, self.first_argument)
[dochtml] [knots    ]   File "sage/libs/gap/element.pyx", line 2525, in sage.libs.gap.element.GapElement_Function.__call__ (build/cythonized/sage/libs/gap/element.c:19781)
[dochtml] [knots    ]     sig_on()
[dochtml] [knots    ] sage.libs.gap.util.GAPError: Error, no method found! Error, no 2nd choice method found for `OneMutable' on 1 arguments
[dochtml] [knots    ] /home/release/Sage/local/lib/python3.8/site-packages/sage/knots/link.py:docstring of sage.knots.link.Link:108: WARNING: Exception occurred in plotting link-4

comment:7 Changed 20 months ago by dimpase

this branch applied over the branch of #29314 does fix the problem. I didn't test it without #29314.

comment:8 Changed 19 months ago by mkoeppe

  • Milestone changed from sage-9.2 to sage-9.3

comment:9 Changed 18 months ago by soehms

  • Status changed from needs_work to positive_review

I cannot reproduce this error and I completely don't understand how this could be caused by the changes of that ticket which don't use braid groups.

It looks very similar to me as the issue I reported in this comment and which I detected on all of my facilities as an interference between the upgrade of the Gap version and the cysignals package (see comment 76 and 96 of #29314)

So lets have a try with that again!

comment:10 Changed 18 months ago by vbraun

  • Branch changed from u/soehms/homfly_unknot to da6e768ffde18db3137a0cde1ee23aed08debec8
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.