Opened 8 months ago

Closed 7 months ago

#30264 closed enhancement (duplicate)

Upgrade: CryptoMiniSat 5.8.0

Reported by: slelievre Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: upgrade, cryptominisat
Cc: mkoeppe, slelievre Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This is to upgrade to CryptoMiniSat 5.8.0, released 2020-07-06.

Release notes for the versions since 5.6.8 (current in Sage):

5.8.0

Massive new release! Many-many improvements:

  • Gauss-Jordan elimination is enabled by default
  • Target Phases ("Stable Polarities") are used
  • CCAnr SLS solver is enabled and is set to work by default
  • Hybrid variable branching heuristics
  • Many-many speed improvements
  • Better DIMACS parsing to work for other systems
  • Made to work with new ApproxMC and UniGen

5.7.1

  • Removing LSIDS, as it was interfering with performance.

5.7.0

  • Improved parameters
  • Hybrid branching strategies
  • and much more

Previous upgrade:

  • #27319: Upgrade to Cryptominisat 5.6.8 -- merged in Sage 8.9.beta2

Change History (2)

comment:1 Changed 8 months ago by slelievre

  • Cc mkoeppe added
  • Milestone changed from sage-9.2 to sage-duplicate/invalid/wontfix

Duplicate of #25374.

comment:2 Changed 7 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.