Opened 2 years ago

Closed 23 months ago

#30262 closed enhancement (fixed)

Update e-antic to 0.1.8

Reported by: mkoeppe Owned by:
Priority: critical Milestone: sage-9.2
Component: packages: optional Keywords:
Cc: vdelecroix, Winfried, jipilab, gh-kliem, dimpase Merged in:
Authors: Matthias Koeppe Reviewers: Jonathan Kliem
Report Upstream: N/A Work issues:
Branch: 0882611 (Commits, GitHub, GitLab) Commit: 08826113448fa5a5e2c76571fe3575764c22936a
Dependencies: Stopgaps:

Status badges

Change History (19)

comment:1 Changed 2 years ago by mkoeppe

  • Branch set to u/mkoeppe/update_e_antic_to_0_1_8

comment:2 Changed 2 years ago by mkoeppe

  • Cc dimpase added
  • Commit set to 6e9191ac44608e4c582f263e7e2a2168af270b94

New commits:

6e9191abuild/pkgs/e_antic: Update to 0.1.8

comment:3 Changed 2 years ago by dimpase

  • Description modified (diff)

there is a wrong http://ftp.kaist.ac.kr/sage/spkg/upstream/e_antic/e-antic-0.1.8.tar.gz - found on attempt to install. So the tarball https://www.labri.fr/perso/vdelecro/e-antic/e-antic-0.1.8.tar.gz has to be manually downloaded.

comment:4 Changed 2 years ago by mkoeppe

Weird?

comment:5 Changed 2 years ago by mkoeppe

Looks like some server misconfiguration:

$ wget http://ftp.kaist.ac.kr/sage/spkg/upstream/e_antic/e-antic-0.1.8.tar.gz
--2020-07-31 18:44:09--  http://ftp.kaist.ac.kr/sage/spkg/upstream/e_antic/e-antic-0.1.8.tar.gz
Resolving ftp.kaist.ac.kr (ftp.kaist.ac.kr)... 99.84.238.93, 99.84.238.129, 99.84.238.27, ...
Connecting to ftp.kaist.ac.kr (ftp.kaist.ac.kr)|99.84.238.93|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://ftp.kaist.ac.kr/sage/spkg/upstream/e_antic/e-antic-0.1.8.tar.gz [following]
--2020-07-31 18:44:09--  https://ftp.kaist.ac.kr/sage/spkg/upstream/e_antic/e-antic-0.1.8.tar.gz
Connecting to ftp.kaist.ac.kr (ftp.kaist.ac.kr)|99.84.238.93|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 992 [text/html]

comment:6 Changed 2 years ago by mkoeppe

I have asked this mirror to be removed - https://github.com/sagemath/website/issues/200

comment:7 follow-up: Changed 2 years ago by kcrisman

That is weird that KAIST would not be interested in hosting Sage any more. Do we have any contact info? I know someone there, though I do not think he uses Sage nor their web servers, but I could ask him to poke around.

comment:8 in reply to: ↑ 7 Changed 2 years ago by slelievre

Replying to kcrisman:

That is weird that KAIST would not be interested in hosting Sage any more.

It's nothing Sage-specific: the KAIST mirror is down: https://ftp.kaist.ac.kr currently says

Service On Maintenance

We are conducting server checks to stabilize the system and improve performance. SPARCS server team is working hard(roll roll) to fix the problem.

We apologize for the inconvenience.

Let's discuss mirror at https://github.com/sagemath/website/issues/200 and e-antic update here.

comment:9 Changed 2 years ago by mkoeppe

The problem is that they are delivering this error message with HTTP status 200 OK - which is wrong

comment:10 Changed 2 years ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Status changed from new to needs_review

comment:11 Changed 2 years ago by dimpase

are these GH actions with ./configure --enable-e_antic ?

comment:12 Changed 2 years ago by mkoeppe

The workflow titled "Test optional packages with tox" runs the optional packages. It's right next to the one I linked, at https://github.com/mkoeppe/sage/actions/runs/191867540

comment:13 Changed 23 months ago by git

  • Commit changed from 6e9191ac44608e4c582f263e7e2a2168af270b94 to 08826113448fa5a5e2c76571fe3575764c22936a

Branch pushed to git repo; I updated commit sha1. New commits:

0882611Merge tag '9.2.beta7' into t/30262/update_e_antic_to_0_1_8

comment:14 Changed 23 months ago by mkoeppe

  • Reviewers set to https://github.com/mkoeppe/sage/actions/runs/201953190

Another test run, this time just this ticket.

comment:15 Changed 23 months ago by gh-kliem

  • Reviewers changed from https://github.com/mkoeppe/sage/actions/runs/201953190 to https://github.com/mkoeppe/sage/actions/runs/201953190, Jonathan Kliem
  • Status changed from needs_review to positive_review

LGTM. It doesn't seem to break normaliz, which is all that we use it for. According to https://github.com/mkoeppe/sage/actions/runs/201953190 the installation also works, not just for me.

comment:16 Changed 23 months ago by mkoeppe

Thank you!

comment:17 Changed 23 months ago by mkoeppe

  • Priority changed from major to critical

comment:18 Changed 23 months ago by mkoeppe

  • Reviewers changed from https://github.com/mkoeppe/sage/actions/runs/201953190, Jonathan Kliem to Jonathan Kliem

comment:19 Changed 23 months ago by vbraun

  • Branch changed from u/mkoeppe/update_e_antic_to_0_1_8 to 08826113448fa5a5e2c76571fe3575764c22936a
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.