Opened 2 years ago

Last modified 5 months ago

#30207 closed enhancement

Deprecate sage.misc.dist.install_scripts — at Initial Version

Reported by: Matthias Köppe Owned by:
Priority: major Milestone: sage-9.7
Component: build Keywords: sd111
Cc: Emmanuel Charpentier, John Palmieri, Julian Rüth Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This function does not belong into sagelib. If it is still needed at all, it should become a script in sage-the-distribution.

install_scripts is also mentioned in one place in the sage installation guide, src/doc/en/installation/source.rst. While updating that, also https://doc.sagemath.org/html/en/installation/source.html#installation-in-a-multiuser-environment should be updated.

https://groups.google.com/d/msg/sage-devel/M6S1bL_qU3Y/twdtVp0rBgAJ

Change History (0)

Note: See TracTickets for help on using tickets.