Opened 9 months ago

Closed 8 months ago

#30205 closed defect (duplicate)

More error checking for CombinatorialFreeModule.monomial

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: tscrim Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: F = CombinatorialFreeModule(QQ, ['a', 'b', 'c'])
sage: F.monomial('a')
B['a']
sage: F.monomial(0)
B[0]
sage: F.monomial('hmmm?')
B['hmmm?']

Change History (4)

comment:1 Changed 9 months ago by tscrim

Duplicate of #18750.

comment:2 Changed 9 months ago by mkoeppe

  • Milestone changed from sage-9.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:3 Changed 9 months ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

comment:4 Changed 8 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.