#30131 closed defect (fixed)

2 internet doctests failing in bibd.py

Reported by: slabbe Owned by:
Priority: major Milestone: sage-9.2
Component: doctest coverage Keywords:
Cc: Merged in:
Authors: Frédéric Chapoton Reviewers: Sébastien Labbé, Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: 8cf4741 (Commits, GitHub, GitLab) Commit: 8cf4741dde5f5efd8c5283f61d98e5d903db7f20
Dependencies: Stopgaps:

Status badges

Description (last modified by slabbe)

With 9.2.beta4,

sage -t --optional=sage,internet src/sage/combinat/designs/bibd.py

gives

sage -t --long src/sage/combinat/designs/bibd.py
**********************************************************************
File "src/sage/combinat/designs/bibd.py", line 109, in sage.combinat.designs.bibd.balanced_incomplete_block_design
Failed example:
    B                                                              # optional - internet
Expected:
    Incidence structure with 66 points and 143 blocks
Got:
    (66,6,1)-Balanced Incomplete Block Design
**********************************************************************
File "src/sage/combinat/designs/bibd.py", line 113, in sage.combinat.designs.bibd.balanced_incomplete_block_design
Failed example:
    designs.balanced_incomplete_block_design(66, 6, 1, use_LJCR=True)  # optional - internet
Expected:
    Incidence structure with 66 points and 143 blocks
Got:
    (66,6,1)-Balanced Incomplete Block Design
**********************************************************************
1 item had failures:
   2 of  26 in sage.combinat.designs.bibd.balanced_incomplete_block_design
    0 tests not run because we ran out of time
    [120 tests, 2 failures, 5.32 s]

Change History (8)

comment:1 Changed 22 months ago by slabbe

  • Description modified (diff)

comment:2 Changed 22 months ago by chapoton

  • Authors set to Frédéric Chapoton
  • Branch set to u/chapoton/30131
  • Commit set to 8cf4741dde5f5efd8c5283f61d98e5d903db7f20
  • Status changed from new to needs_review

done


New commits:

8cf4741fix optional internet doctests in bibd

comment:3 Changed 22 months ago by slabbe

  • Reviewers set to Sébastien Labbé
  • Status changed from needs_review to positive_review

Doctests fixed. html doc builds okay.

comment:4 Changed 22 months ago by gh-Ivo-Maffei

I think this ticket is a duplicate of #30107. I merged this in that ticket as there was a merge conflict.

comment:5 Changed 22 months ago by dimpase

should this be moved to duplicate/invalid Milestone then?

comment:6 Changed 22 months ago by slabbe

no, since #30107 is now based on #30131.

comment:7 Changed 22 months ago by dimpase

  • Reviewers changed from Sébastien Labbé to Sébastien Labbé, Dima Pasechnik

OK, thanks.

comment:8 Changed 22 months ago by vbraun

  • Branch changed from u/chapoton/30131 to 8cf4741dde5f5efd8c5283f61d98e5d903db7f20
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.