#30127 closed defect (fixed)

cygwin-minimal: pip-20.1.1 fails to install

Reported by: mkoeppe Owned by:
Priority: critical Milestone: sage-9.2
Component: porting: Cygwin Keywords:
Cc: embray, slelievre, dimpase Merged in:
Authors: Matthias Koeppe Reviewers: Dima Pasechnik
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: bc8c54f (Commits, GitHub, GitLab) Commit: bc8c54f91dbb84d3487d5d3359a7a3a4a7861f08
Dependencies: Stopgaps:

Status badges

Description

https://github.com/sagemath/sage/runs/862451271

  [pip-20.1.1]     File "/cygdrive/d/a/sage/sage/local/var/tmp/sage/build/pip-20.1.1/src/src/pip/_vendor/urllib3/__init__.py", line 7, in <module>
  [pip-20.1.1]       from .connectionpool import HTTPConnectionPool, HTTPSConnectionPool, connection_from_url
  [pip-20.1.1]     File "/cygdrive/d/a/sage/sage/local/var/tmp/sage/build/pip-20.1.1/src/src/pip/_vendor/urllib3/connectionpool.py", line 29, in <module>
  [pip-20.1.1]       from .connection import (
  [pip-20.1.1]     File "/cygdrive/d/a/sage/sage/local/var/tmp/sage/build/pip-20.1.1/src/src/pip/_vendor/urllib3/connection.py", line 68, in <module>
  [pip-20.1.1]       class HTTPConnection(_HTTPConnection, object):
  [pip-20.1.1]     File "/cygdrive/d/a/sage/sage/local/var/tmp/sage/build/pip-20.1.1/src/src/pip/_vendor/urllib3/connection.py", line 96, in HTTPConnection
  [pip-20.1.1]       default_socket_options = [(socket.IPPROTO_TCP, socket.TCP_NODELAY, 1)]
  [pip-20.1.1]   AttributeError: module 'socket' has no attribute 'TCP_NODELAY'

The install on cygwin-standard works fine.

Change History (21)

comment:1 Changed 15 months ago by slelievre

Note that pip 20.2 was released.

comment:3 Changed 15 months ago by mkoeppe

  • Branch set to u/mkoeppe/cygwin_minimal__pip_20_1_1_fails_to_install

comment:4 Changed 15 months ago by mkoeppe

  • Branch u/mkoeppe/cygwin_minimal__pip_20_1_1_fails_to_install deleted

comment:5 Changed 15 months ago by mkoeppe

  • Branch set to u/mkoeppe/cygwin_minimal__pip_20_1_1_fails_to_install
  • Commit set to 91f21f629cb8267e3b1ca28919e6471752db4e19

New commits:

a22b6aebuild/pkgs/pip: Update to 20.2.1
91f21f6build/pkgs/setuptools: Update to 49.2.1

comment:7 Changed 15 months ago by mkoeppe

Should probably look at the python3 build log on this system.

comment:8 Changed 15 months ago by mkoeppe

The same error also with pip 20.1.1 and python3 3.8.5 from #27754.

comment:9 Changed 15 months ago by mkoeppe

Apparently caused by a recent change in the Cygwin headers: https://bugs.python.org/issue41374

comment:10 Changed 15 months ago by git

  • Commit changed from 91f21f629cb8267e3b1ca28919e6471752db4e19 to bc8c54f91dbb84d3487d5d3359a7a3a4a7861f08

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

bc8c54fbuild/pkgs/python3/patches/cygwin-socket-tcpnodelay-21649.patch: New

comment:11 Changed 15 months ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Report Upstream changed from N/A to Fixed upstream, but not in a stable release.

comment:13 Changed 15 months ago by mkoeppe

  • Status changed from new to needs_review

comment:14 Changed 15 months ago by mkoeppe

This worked, as can be seen in https://github.com/mkoeppe/sage/runs/959927471

Needs review

comment:15 Changed 15 months ago by mkoeppe

  • Reviewers set to https://github.com/mkoeppe/sage/runs/959927471

comment:16 Changed 15 months ago by mkoeppe

  • Reviewers changed from https://github.com/mkoeppe/sage/runs/959927471 to https://github.com/mkoeppe/sage/runs/959927471, ...

comment:17 Changed 15 months ago by mkoeppe

  • Cc dimpase added

Let's get this in please

comment:18 Changed 15 months ago by dimpase

  • Reviewers changed from https://github.com/mkoeppe/sage/runs/959927471, ... to https://github.com/mkoeppe/sage/runs/959927471, Dima Pasechnik

comment:19 Changed 15 months ago by dimpase

  • Status changed from needs_review to positive_review

lgtm

comment:20 Changed 15 months ago by mkoeppe

  • Reviewers changed from https://github.com/mkoeppe/sage/runs/959927471, Dima Pasechnik to Dima Pasechnik

Thanks!

comment:21 Changed 14 months ago by vbraun

  • Branch changed from u/mkoeppe/cygwin_minimal__pip_20_1_1_fails_to_install to bc8c54f91dbb84d3487d5d3359a7a3a4a7861f08
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.