#29965 closed enhancement (fixed)

Make graphs doctests ready for random seeds

Reported by: gh-kliem Owned by:
Priority: major Milestone: sage-9.2
Component: doctest framework Keywords:
Cc: Merged in:
Authors: Jonathan Kliem Reviewers: David Coudert
Report Upstream: N/A Work issues:
Branch: e8a9a90 (Commits, GitHub, GitLab) Commit: e8a9a90e00ceae17caaee1956fb0ddc4ed3fe3f0
Dependencies: #29962, #29958 Stopgaps:

Status badges

Description

This ticket makes

sage -t --long --random-seed=n src/sage/graphs/

pass for different values n than just 0.

Change History (18)

comment:1 Changed 16 months ago by gh-kliem

  • Branch set to public/29965
  • Commit set to 3f85d3460e2fb9886b6dfc11cd242d0ea6360646
  • Status changed from new to needs_review

New commits:

da1c6bestart from a "random" random seed for doctesting
b7b836dmake random seed reproducible
eedbe5edocument random_seed
998b1b9default random seed 0 for now
1d7b00edash instead of underscore for command line options
964588fmake graphs ready for fuzz doctests
3f85d34failing doctest due to missing sort

comment:2 Changed 16 months ago by gh-kliem

  • Dependencies set to #29962

comment:3 Changed 16 months ago by git

  • Commit changed from 3f85d3460e2fb9886b6dfc11cd242d0ea6360646 to 7dd4282a757c72d42a428d86c56094f280de6195

Branch pushed to git repo; I updated commit sha1. New commits:

7dd4282bug in connectivity

comment:4 Changed 16 months ago by gh-kliem

  • Branch changed from public/29965 to public/29965-reb
  • Commit 7dd4282a757c72d42a428d86c56094f280de6195 deleted

comment:5 Changed 16 months ago by git

  • Commit set to 57a3302c3cbbbeb7f50c3f9dc315056c3e078ba8

Branch pushed to git repo; I updated commit sha1. New commits:

da1c6bestart from a "random" random seed for doctesting
b7b836dmake random seed reproducible
eedbe5edocument random_seed
998b1b9default random seed 0 for now
1d7b00edash instead of underscore for command line options
b3ea6efMerge branch 'public/29962' of git://trac.sagemath.org/sage into public/29965-reb
89d6bccmake graphs ready for fuzz doctests
7dc9cd5failing doctest due to missing sort
57a3302bug in connectivity

comment:6 Changed 16 months ago by git

  • Commit changed from 57a3302c3cbbbeb7f50c3f9dc315056c3e078ba8 to e9204fa7187f5550c11bf352ef30a2163561848a

Branch pushed to git repo; I updated commit sha1. New commits:

e9204faimprovements of random tests

comment:7 Changed 16 months ago by dcoudert

in sage/graphs/connectivity.pyx, you added # known bug, but the issue is fixed in #29958.

in sage/graphs/generators/random.py it might be better to do

-    EXAMPLES: We show the edge list of a random graph with 3 backbone
+    EXAMPLES:
+
+    We check a random graph with 12 backbone
     nodes and probabilities `p = 0.7` and `q = 0.3`::

comment:8 Changed 16 months ago by gh-kliem

  • Dependencies changed from #29962 to #29962, #29958

comment:9 Changed 16 months ago by git

  • Commit changed from e9204fa7187f5550c11bf352ef30a2163561848a to f770315dab737fc7ec5da57248bdab0260e418df

Branch pushed to git repo; I updated commit sha1. New commits:

07ce116trac #29958: fix
5b46764Merge branch 'public/graphs/29958_sap' of git://trac.sagemath.org/sage into public/29965-reb
5d0b277remove known bug for fixed bug
f770315improved documentation style

comment:10 Changed 16 months ago by dcoudert

  • Reviewers set to David Coudert
  • Status changed from needs_review to positive_review

LGTM.

comment:11 Changed 16 months ago by gh-kliem

Thank you.

comment:12 Changed 16 months ago by gh-kliem

  • Status changed from positive_review to needs_work

Merge conflict.

comment:13 Changed 16 months ago by gh-kliem

  • Status changed from needs_work to needs_review

Fixed merge conflict.

comment:14 Changed 16 months ago by gh-kliem

  • Branch changed from public/29965-reb to public/29965-reb2
  • Commit changed from f770315dab737fc7ec5da57248bdab0260e418df to e8a9a90e00ceae17caaee1956fb0ddc4ed3fe3f0

New commits:

b31e2d5Merge branch 'public/29962' of git://trac.sagemath.org/sage into public/29962-reb
2f30dd9small fixes
b62f781doctests do not start from a random seed by default yet
1d99129fix merge conflict
e8a9a90merged in public/29965-reb

comment:15 Changed 16 months ago by dcoudert

  • Status changed from needs_review to positive_review

Successfully tested over 9.2.beta5.

comment:16 Changed 16 months ago by gh-kliem

Thanks again.

comment:17 Changed 16 months ago by vbraun

  • Status changed from positive_review to needs_work

Merge conflict

comment:18 Changed 16 months ago by vbraun

  • Branch changed from public/29965-reb2 to e8a9a90e00ceae17caaee1956fb0ddc4ed3fe3f0
  • Resolution set to fixed
  • Status changed from needs_work to closed
Note: See TracTickets for help on using tickets.