Opened 10 months ago

Closed 9 months ago

#29861 closed enhancement (fixed)

Upgrade Cython to 0.29.21

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.2
Component: packages: standard Keywords: upgrade, cython
Cc: isuruf, nbruin, fbissey, dimpase, arojas, jhpalmieri Merged in:
Authors: Matthias Koeppe Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: c24d109 (Commits, GitHub, GitLab) Commit: c24d109199a68d09b138b3a29436704b9532fb39
Dependencies: #29867 Stopgaps:

Status badges

Description (last modified by mkoeppe)

We upgrade Cython to 0.29.21

(https://github.com/cython/cython/blob/master/CHANGES.rst#02921-2020-07-09)

This is supposed to fix many bugs compared to our current 0.29.17, but a bug reported with the new version (https://groups.google.com/g/sage-devel/c/ij0ulNf7ZuI/m/qF0AlS9IBgAJ):

$sage -c 1+1
SageMath version 9.1, Release Date: 2020-05-20
Traceback (most recent call last):
  File "/home/conda/feedstock_root/build_artifacts/sagelib_1592119926566/_test_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehol/bin/sage-eval", line 4, in <module>
    from sage.all import *
  File "/home/conda/feedstock_root/build_artifacts/sagelib_1592119926566/_test_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehol/lib/python3.6/site-packages/sage/all.py", line 117, in <module>
    import sage.misc.lazy_import
  File "sage/misc/lazy_import.pyx", line 1, in init sage.misc.lazy_import (build/cythonized/sage/misc/lazy_import.c:10174)
AttributeError: type object 'sage.misc.lazy_import.LazyImport' has no attribute '__div__'

Previous update:

  • #29480 - Upgrade Cython to 0.29.17 (merged in 9.2.beta1)

Change History (17)

comment:1 Changed 10 months ago by mkoeppe

  • Description modified (diff)

comment:2 Changed 10 months ago by dimpase

  • Cc arojas added

apparently the cause for this is already found.

This works for me with no apparent issues:

https://aur.archlinux.org/cgit/aur.git/tree/sagemath-cython-0.29.20.patch?h=sagemath-git

comment:3 Changed 10 months ago by arojas

  • Dependencies set to #29867

comment:4 Changed 10 months ago by slelievre

  • Keywords upgrade cython added

comment:5 Changed 9 months ago by mkoeppe

0.29.21 is out. Needed by numpy branches master, maintenance/1.19.x

comment:6 Changed 9 months ago by mkoeppe

  • Description modified (diff)
  • Summary changed from Upgrade Cython to 0.29.20 to Upgrade Cython to 0.29.21

comment:7 Changed 9 months ago by mkoeppe

  • Branch set to u/mkoeppe/upgrade_cython_to_0_29_20

comment:8 Changed 9 months ago by mkoeppe

  • Commit set to c24d109199a68d09b138b3a29436704b9532fb39

Tests with 0.29.21 run at https://github.com/mkoeppe/sage/actions/runs/169380426


New commits:

c24d109build/pkgs/cython: Updatt to 0.29.21

comment:9 Changed 9 months ago by mkoeppe

  • Description modified (diff)

comment:10 Changed 9 months ago by mkoeppe

  • Authors set to Matthias Koeppe

comment:11 Changed 9 months ago by mkoeppe

  • Cc jhpalmieri added

comment:12 Changed 9 months ago by mkoeppe

  • Status changed from new to needs_review

comment:13 Changed 9 months ago by mkoeppe

Tests look clean. Needs review

comment:14 Changed 9 months ago by jhpalmieri

Works for me on OS X, seems to be needed for #27754.

comment:15 Changed 9 months ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

lgtm

comment:16 Changed 9 months ago by mkoeppe

Thanks!

comment:17 Changed 9 months ago by vbraun

  • Branch changed from u/mkoeppe/upgrade_cython_to_0_29_20 to c24d109199a68d09b138b3a29436704b9532fb39
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.