Opened 2 years ago

Closed 23 months ago

#29851 closed defect (fixed)

tox.ini: debian-bullseye, -sid have Python3.8 instead of 3.7

Reported by: gh-cduston44 Owned by:
Priority: minor Milestone: sage-9.2
Component: porting Keywords:
Cc: dimpase, gh-kliem Merged in:
Authors: Matthias Koeppe Reviewers: Jonathan Kliem
Report Upstream: N/A Work issues:
Branch: 1e7becc (Commits, GitHub, GitLab) Commit: 1e7becc551c3bad53ce67fa8457c5c3d977cad71
Dependencies: Stopgaps:

Status badges

Description

As per the wiki, running

build/bin/write-dockerfile.sh debian "@(standard|optional)" > Dockerfile

Generates a Dockerfile, but running the dockerfile fails because Debian (at least) comes with Python3.8, not 3.7. This can be fixed by changing the file build/pkgs/python3/distros/debian.txt, but I don't know if that will have unexpected consequences.

Change History (11)

comment:1 Changed 2 years ago by mkoeppe

Yes, this will have to be changed when we support Python 3.8 (#27754). At the moment, we only accept Python 3.7.x in configure; ticket #29033 adds Python 3.6.x support.

comment:2 Changed 2 years ago by mkoeppe

Also, see the flag IGNORE_MISSING_SYSTEM_PACKAGES in tox.ini, which we use both for too old versions of the distribution that don't have all packages, and for too new versions of the distribution, such as ubuntu-focal.

comment:3 Changed 2 years ago by mkoeppe

  • Summary changed from write-dockerfile.sh: Debian has Python3.8 instead of 3.7 to tox.ini: debian-bullseye, -sid have Python3.8 instead of 3.7

comment:4 Changed 2 years ago by mkoeppe

  • Branch set to u/mkoeppe/tox_ini__debian_bullseye___sid_have_python3_8_instead_of_3_7

comment:5 Changed 2 years ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Commit set to 1e7becc551c3bad53ce67fa8457c5c3d977cad71
  • Status changed from new to needs_review

New commits:

1e7becctox.ini [debian-buster, -sid]: IGNORE_MISSING_SYSTEM_PACKAGES=yes because of libpython3.7-dev

comment:6 Changed 2 years ago by mkoeppe

  • Cc dimpase gh-kliem added

comment:7 Changed 2 years ago by gh-kliem

  • Reviewers set to Jonathan Kliem

I already noticed the problem. So what this does it just make the workflow go through, even though it coulnd't install python3.7. It will later find out that no suitable python can be found and install python3.7 for sage.

comment:8 Changed 2 years ago by mkoeppe

That's right. Best we can do before we get to Python 3.8 compatibility in #27754, which seems to have stalled

comment:9 Changed 2 years ago by gh-kliem

  • Status changed from needs_review to positive_review

comment:10 Changed 2 years ago by mkoeppe

Thanks!

comment:11 Changed 23 months ago by vbraun

  • Branch changed from u/mkoeppe/tox_ini__debian_bullseye___sid_have_python3_8_instead_of_3_7 to 1e7becc551c3bad53ce67fa8457c5c3d977cad71
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.