Opened 2 years ago

Last modified 2 years ago

#29774 closed enhancement

Ignore jedi deprecation warnings — at Version 2

Reported by: arojas Owned by:
Priority: major Milestone: sage-9.2
Component: user interface Keywords:
Cc: Merged in:
Authors: Antonio Rojas Reviewers:
Report Upstream: N/A Work issues:
Branch: u/arojas/ignore_jedi_deprecation_warnings (Commits, GitHub, GitLab) Commit: 791bb94dc489931990c2875cdb413788c3009143
Dependencies: Stopgaps:

Status badges

Description (last modified by arojas)

ipython 7 throws lots of deprecation warnings on tab completion when using jedi>=0.16. A warning is emmitted for every item in the autocompletion list, so this can even make Sage crash if the list is long. Hide these warnings by default.

Change History (2)

comment:1 Changed 2 years ago by arojas

  • Branch set to u/arojas/ignore_jedi_deprecation_warnings

comment:2 Changed 2 years ago by arojas

  • Authors set to Antonio Rojas
  • Commit set to 791bb94dc489931990c2875cdb413788c3009143
  • Component changed from PLEASE CHANGE to user interface
  • Description modified (diff)
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to enhancement

New commits:

791bb94Ignore jedi deprecation warnings
Note: See TracTickets for help on using tickets.