Opened 5 months ago

Closed 4 months ago

#29755 closed defect (worksforme)

Multiprocessing in tensor computations does not work under macOS

Reported by: egourgoulhon Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: performance Keywords: multiprocessing, parallelization, macOS
Cc: Merged in:
Authors: Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Multiprocessing, as implemented in differential geometry computations via

sage: Parallelism().set(nproc=8)

does not work under macOS. This has been reported by many users, a recent report being https://groups.google.com/d/msg/sage-support/0RsGgb3lmZg/zNTMFLH9AQAJ

Note there is no issue within the doctest framework, i.e. the doctests involving parallel computations implemented in src/sage/manifolds/differentiable and src/sage/tensor/modules are passed on macOS machines.

Change History (7)

comment:1 follow-up: Changed 5 months ago by dimpase

it is not clear how to see that it is broken. Could you point at a doctest that doesn't work at the Sage prompt?

comment:2 in reply to: ↑ 1 Changed 5 months ago by egourgoulhon

Replying to dimpase:

it is not clear how to see that it is broken. Could you point at a doctest that doesn't work at the Sage prompt?

For instance, the doctest about the parallelization of the Lie derivative, a short version of which is

sage: M = Manifold(2, 'M')
sage: X.<x,y> = M.chart()
sage: v = M.vector_field(-y, x)
sage: w = M.one_form(y^2*sin(x), x^3*cos(y))
sage: Parallelism().set(nproc=2)
sage: w.lie_derivative(v).display()
(-y^3*cos(x) + x^3*cos(y) + 2*x*y*sin(x)) dx 
 + (-x^4*sin(y) - 3*x^2*y*cos(y) - y^2*sin(x)) dy

comment:3 Changed 5 months ago by egourgoulhon

The OP at https://groups.google.com/d/msg/sage-support/0RsGgb3lmZg/WNxT_rzNAwAJ says that the problem is fixed in Sage 9.1. Dima, can you confirm this? (sorry I don't have any macOS computer at hand...). If yes, we may close this ticket.

comment:4 follow-up: Changed 5 months ago by dimpase

  • Milestone changed from sage-9.2 to sage-duplicate/invalid/wontfix
  • Reviewers set to Dima Pasechnik
  • Status changed from new to needs_review

works for me on macOS and Sage 9.2.beta0

comment:5 Changed 5 months ago by dimpase

  • Status changed from needs_review to positive_review

comment:6 in reply to: ↑ 4 Changed 5 months ago by egourgoulhon

Replying to dimpase:

works for me on macOS and Sage 9.2.beta0

Thank you Dima!

comment:7 Changed 4 months ago by chapoton

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.