#29753 closed defect (invalid)

Build fails on Python 3.5.2

Reported by: vbraun Owned by:
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers: Jonathan Kliem
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

[sagelib-9.1] ************************************************************************
[sagelib-9.1] Traceback (most recent call last):
[sagelib-9.1]   File "setup.py", line 73, in <module>
[sagelib-9.1]     from sage_setup.find import find_extra_files
[sagelib-9.1]   File "/var/lib/buildbot/slave/sage2_git/build/src/sage_setup/find.py", line 15, in <module>
[sagelib-9.1]     import importlib.machinery
[sagelib-9.1] ImportError: No module named machinery
[sagelib-9.1] ************************************************************************
[sagelib-9.1] Error building the Sage library
[sagelib-9.1] ************************************************************************

Change History (16)

comment:1 Changed 12 months ago by mkoeppe

What code is invoking this? Please post config.log

comment:2 Changed 12 months ago by mkoeppe

In particular, please clarify what you mean by building "on Python 3.5.2" in light of my explanation in https://groups.google.com/d/msg/sage-devel/fgsSsJmVVXo/n2BQBSaBAAAJ

comment:3 Changed 12 months ago by mkoeppe

  • Priority changed from major to blocker
  • Status changed from new to needs_info

comment:4 follow-up: Changed 12 months ago by gh-kliem

You probably already found out: This is caused by #27472.

I see this error on the standard-python2-gcc_spkg tests.

E.g. https://github.com/kliem/sage-test-27122/runs/722743058

comment:5 in reply to: ↑ 4 Changed 12 months ago by mkoeppe

Replying to gh-kliem:

You probably already found out: This is caused by #27472.

Could you elaborate? I don't understand this ticket, and unfortunately it seems that Volker does not see my requests for more information.

comment:6 Changed 12 months ago by gh-kliem

Sorry, this has nothing to do with #27472. The line 15 in sage_setup/find.py it is complaining about was added in #28000 (remove python2 support from sage lib).

To me it looks like this also removed python2 support for building sage, which was not the plan I believe (I think the agreement was that python2 may still be used to build sage). The module importlib.machinery just doesn't exist in python2 and hence the error.

I think the title of this ticket here is not correct as it appears to have nothing to do with python 3.5.2. It appears that the kucalc buildbot just doesn't have python3 installed. It should then in the build process automatically install python3, but it doesn't even get there.

comment:7 Changed 12 months ago by mkoeppe

But why would sage_setup/find.py be invoked using system python2?

comment:8 Changed 12 months ago by gh-kliem

That's pretty much the first thing it runs. So apparently rejecting python2 wasn't very successful. E.g. it tries to install scipy before python3, which doesn't look like it did really reject the wrong system python.

comment:9 Changed 12 months ago by mkoeppe

Are you referring to a build --with-python=2?

comment:10 Changed 12 months ago by mkoeppe

That is being removed in 9.2.

comment:11 Changed 12 months ago by gh-kliem

I'm refering to the github testrun ubuntu-bionic, standard-python2-gcc_spkg (and likewise all ... standard-python2-gcc_spkg).

To my understanding this tries to install sage on a system, where all standard packages are installed but not python3 (instead python2). Is this correct?

comment:12 Changed 12 months ago by mkoeppe

No, the factor python2 means that ./configure --with-python=2 is called. And that is scheduled to be removed in 9.2 (the removal of this option is done in #29669).

comment:13 Changed 12 months ago by gh-kliem

Ok. Using this option the build fails exactly as in the description of this ticket.

comment:14 Changed 12 months ago by mkoeppe

  • Milestone changed from sage-9.2 to sage-duplicate/invalid/wontfix
  • Status changed from needs_info to needs_review

OK, then let's assume that this is also what Volker meant. Marking it as invalid.

comment:15 Changed 12 months ago by gh-kliem

  • Reviewers set to Jonathan Kliem
  • Status changed from needs_review to positive_review

I agree, this import error really shouldn't happen in python 3.5.2, see https://docs.python.org/3.5/library/importlib.html. The module is present in 3.5.2 and an import error implies that not python 3.5.2 was used but probably some python2.

comment:16 Changed 11 months ago by chapoton

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.