#29742 closed defect (duplicate)

is_unit() fails for power-series-ring element: O(t^0)

Reported by: gh-n-vi Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords: power series, is_unit
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by gh-kliem)

Duplicate of #29743.

Using version 9.1 of sage, is_unit() fails for the element O(t0) of a power-series ring.
The bug does not depend on the base of the power-series. It occurs since is_unit() attempts to access the 0'th coefficient of the series, which does not exist in the special case of O(t0), resulting in an Index Error.
Example:

Change History (2)

comment:1 Changed 11 months ago by gh-kliem

  • Description modified (diff)
  • Milestone changed from sage-9.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:2 Changed 11 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.