#29463 closed defect (duplicate)

homebrew-macos-standard: Fix Fortran-related doctest errors

Reported by: mkoeppe Owned by:
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: porting Keywords:
Cc: jhpalmieri, isuruf, dimpase Merged in:
Authors: Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

From #29451:

https://github.com/mkoeppe/sage/runs/559191935

----------------------------------------------------------------------
sage -t src/sage/interfaces/gap.py  # 1 doctest failed
sage -t src/sage/misc/inline_fortran.py  # 3 doctests failed
sage -t src/sage/misc/persist.pyx  # 2 doctests failed
sage -t src/sage/repl/ipython_extension.py  # 4 doctests failed
----------------------------------------------------------------------
      File "/Users/runner/runners/2.165.2/work/sage/sage/.tox/local-homebrew-macos-standard/local/lib/python3.7/site-packages/sage/misc/inline_fortran.py", line 194, in eval
        "failed to compile Fortran code:\n{}".format(exc.output))
    RuntimeError: failed to compile Fortran code:
    b'Could not locate executable g++ -std=gnu++11 -pthread -bundle -undefined dynamic_lookup\nIn file included from /var/folders/24/8k48jl6d249_n_qfxwsl6xvm0000gn/T/tmpjff9tknw/src.macosx-10.15-x86_64-3.7/fortran_modulemodule.c:16:\nIn file included from /var/folders/24/8k48jl6d249_n_qfxwsl6xvm0000gn/T/tmpjff9tknw/src.macosx-10.15-x86_64-3.7/fortranobject.h:13:\nIn file included from 

To reproduce (with #29417):

 tox -e local-homebrew-macos-standard -- ptest 

Change History (12)

comment:1 Changed 12 months ago by mkoeppe

Should check if the fix in #29408 fixes any of these too.

comment:3 follow-up: Changed 12 months ago by jhpalmieri

The fix in #29408 works at least with the OS X Python installation. When I say "works," I mean that all tests pass. I did, however, twice see a dialog box saying "Python quit unexpectedly."

I will also try with Homebrew's Python.

comment:4 Changed 12 months ago by jhpalmieri

Same behavior with Homebrew's Python. So if #29408 gets a positive review, we can close this.

comment:5 in reply to: ↑ 3 Changed 12 months ago by mkoeppe

Replying to jhpalmieri:

The fix in #29408 works at least with the OS X Python installation. When I say "works," I mean that all tests pass. I did, however, twice see a dialog box saying "Python quit unexpectedly."

Yes, I have seen this too on my machine. My guess is that we have some tests that crash some python process deliberately

comment:6 Changed 12 months ago by jhpalmieri

Oh, yes, that makes sense.

comment:7 Changed 12 months ago by mkoeppe

  • Priority changed from critical to blocker

comment:8 Changed 12 months ago by mkoeppe

Still present on 9.1.rc0 because #29408 is not merged

comment:9 Changed 12 months ago by jhpalmieri

Can now be closed, I think.

comment:10 Changed 12 months ago by mkoeppe

  • Milestone changed from sage-9.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:11 Changed 12 months ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

comment:12 Changed 11 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.