#29443 closed enhancement (fixed)

Update scipy to 1.2.3 (last release supporting py2)

Reported by: mkoeppe Owned by:
Priority: blocker Milestone: sage-9.1
Component: packages: standard Keywords:
Cc: fbissey, dimpase, isuruf, vbraun Merged in:
Authors: Matthias Koeppe Reviewers: Thierry Monteil
Report Upstream: N/A Work issues:
Branch: ce38504 (Commits, GitHub, GitLab) Commit: ce385048292a40246f1f36f897222491ca5d2f00
Dependencies: Stopgaps:

Status badges

Change History (12)

comment:1 Changed 19 months ago by mkoeppe

  • Cc fbissey dimpase isuruf added

comment:2 Changed 19 months ago by mkoeppe

  • Branch set to u/mkoeppe/update_scipy_to_1_2_3__last_release_supporting_py2_

comment:3 Changed 19 months ago by fbissey

  • Commit set to ce385048292a40246f1f36f897222491ca5d2f00

From 1.2.0 to 1.2.3, there shouldn't be any issues. The ticket for dealing with issues in 1.4+ is already in so I would be surprised if there was any new problems.


New commits:

ce38504Update scipy to 1.2.3

comment:4 Changed 19 months ago by mkoeppe

comment:5 Changed 19 months ago by mkoeppe

  • Status changed from new to needs_review

comment:6 Changed 18 months ago by mkoeppe

  • Milestone changed from sage-9.1 to sage-9.2

comment:7 Changed 18 months ago by tmonteil

  • Description modified (diff)

comment:8 Changed 18 months ago by tmonteil

  • Reviewers set to Thierry Monteil
  • Status changed from needs_review to positive_review

In case this could be merged before 9.1.

comment:9 Changed 18 months ago by tmonteil

Shall we set this to blocker, since 9.1 will be the last version supporting Python 2 ?

comment:10 Changed 18 months ago by dimpase

  • Cc vbraun added
  • Milestone changed from sage-9.2 to sage-9.1
  • Priority changed from major to blocker

Volker, this only makes sense to merge in 9.1 - for 9.2 we should go to a newer Python3-only version.

comment:11 Changed 18 months ago by mkoeppe

I would support this to increase the expected shelf life of 9.1

comment:12 Changed 18 months ago by vbraun

  • Branch changed from u/mkoeppe/update_scipy_to_1_2_3__last_release_supporting_py2_ to ce385048292a40246f1f36f897222491ca5d2f00
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.