#29388 closed task (duplicate)

prototype to make fast_callable accepts numpy arrays of floating points

Reported by: gh-unicorn-io Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords: GSOC Prototype
Cc: vdelecroix Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by vdelecroix)

This ticket is regarding the prototype I am proposing to sage math for the project Fast evaluation of symbolic expressions.

The objective is to make the following work

sage: import numpy as np
sage: x = SR.var('x')
sage: f = cos(x) + 3 * sin(x)**2
sage: g = fast_callable(f, vars=['x'], domain=RDF)
sage: a = np.array([0.1, 0.3, 0.4], dtype=float)
sage: g(a)    # currently raises a TypeError
array([1.0249043 , 1.21733307, 1.37600093])

Change History (7)

comment:1 Changed 17 months ago by gh-unicorn-io

I need a little clarity regarding the following points,

  • I am slightly unclear about the project goals/ Major contributions section, can you please briefly describe the idea behind it.

P.S. i would also love to contribute in Diameter, radius, eccentricities, and distances what should I be doing to get in contact with other mentors?

comment:2 Changed 17 months ago by vdelecroix

Tickets are to propose and discuss changes to SageMath. Not to discuss the content of GSoC. For the latter, do use the mailing list https://groups.google.com/forum/#!forum/sage-gsoc

comment:3 Changed 17 months ago by vdelecroix

  • Component changed from PLEASE CHANGE to symbolics
  • Description modified (diff)

I updated the description.

comment:4 Changed 17 months ago by vdelecroix

  • Description modified (diff)

comment:5 Changed 17 months ago by gh-DaveWitteMorris

  • Milestone changed from sage-9.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This seems to be a duplicate of #29235.

comment:6 Changed 17 months ago by vdelecroix

  • Authors gh-unicorn-io deleted
  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

It indeed is. I forgot that I already opened one.

comment:7 Changed 17 months ago by vdelecroix

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.