Opened 6 months ago

Closed 6 months ago

#29378 closed enhancement (fixed)

Update OpenBLAS to 0.3.9 - fixes build error of iml on fedora-32-standard

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.1
Component: packages: standard Keywords:
Cc: dimpase, vbraun, jpflori, tmonteil, embray, gh-timokau, jhpalmieri, zimmerma, gh-mwageringel, mjo, fbissey Merged in:
Authors: Matthias Koeppe Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: 1238ca7 (Commits) Commit: 1238ca7944479e49be3a07194ac047f3864e8b5e
Dependencies: Stopgaps:

Description (last modified by mkoeppe)

0.3.9 was released in Feb 2020. https://github.com/xianyi/OpenBLAS/releases

The upgrade fixes the build error of iml on fedora-32-standard, caused by our openblas installation of 0.3.6 being underlinked (details - see #29393).

The upstream tarball URL is in checksums.ini. To test the update on this branch: Use make SAGE_SPKG="sage-spkg -o" openblas; this will download the new upstream package automatically.

Related tickets:

  • Previous update: #27847 openblas 0.3.6
  • #29088 Fix BLAS-related installation errors on various systems
  • #28768 another openblas build failure
  • #28731 openblas sometimes fails its testsuite on OS X
  • #28008 Linking OpenBLAS wrong on OSX
  • #22179 Improve SAGE_FAT_BINARY for openblas
  • #29170 Fix R installation errors related to gfortran
  • #22006 CBC tries to use system's blas at runtime which creates an error
  • #22822 openblas from Cygwin's package deadloops after fork
  • #26000 sage with 64 bit openblas

Change History (9)

comment:1 Changed 6 months ago by mkoeppe

  • Branch set to u/mkoeppe/upgrade_openblas_0.3.9

comment:2 Changed 6 months ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Commit set to 1238ca7944479e49be3a07194ac047f3864e8b5e

New commits:

1238ca7Update openblas to 0.3.9, add upstream_url

comment:4 Changed 6 months ago by mkoeppe

The update by itself does not fix the errors of the type reported in #29170.

On archlinux-latest-minimal (https://github.com/mkoeppe/sage/runs/522730107):

cc -I. -I../../src/include -I../../src/include  -DHAVE_CONFIG_H   -fopenmp -fpic  -g -O2   -c integrate.c -o integrate.o
In file included from ../../src/include/R_ext/Applic.h:41,
                 from integrate.c:33:
../../src/include/R_ext/BLAS.h:103:55: error: expected declaration specifiers or '...' before ')' token
  103 |   const double *beta, double *y, const int *incy FCLEN);
      |                                                       ^

comment:5 Changed 6 months ago by mkoeppe

  • Description modified (diff)
  • Status changed from new to needs_review
  • Summary changed from Update OpenBLAS to 0.3.9 to Update OpenBLAS to 0.3.9 - fixes build error of iml on fedora-32-standard

comment:6 Changed 6 months ago by mkoeppe

Tests ran at https://github.com/mkoeppe/sage/actions/runs/64126739

Fixes fedora-32-standard openblas build, and no problems on other platforms with this update. Needs review

comment:7 Changed 6 months ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

lgtm (we still don't know from GH Actions whether tests pass on MacOS, but I suppose it is now for the bots)

comment:8 Changed 6 months ago by mkoeppe

Thanks!

I did the macOS test on my machine. The test didn't go through on GitHub because of #29418

comment:9 Changed 6 months ago by vbraun

  • Branch changed from u/mkoeppe/upgrade_openblas_0.3.9 to 1238ca7944479e49be3a07194ac047f3864e8b5e
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.