Opened 11 years ago

Closed 11 years ago

#2935 closed defect (invalid)

notebook: internal server error sage-3.0.alpha5

Reported by: jsp Owned by: boothby
Priority: blocker Milestone: sage-3.0.2
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Trying to delete some old worksheets, this happened:

[jaap@paix sage-3.0.alpha5]$ ./sage
----------------------------------------------------------------------
| SAGE Version 3.0.alpha5, Release Date: 2008-04-15                  |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------


sage: notebook()
The notebook files are stored in: /home/jaap/.sage//sage_notebook
Port 8000 is already in use.
Trying next port...
****************************************************
*                                                  *
* Open your web browser to https://localhost:8001  *
*                                                  *
****************************************************
There is an admin account.  If you do not remember the password,
quit the notebook and type notebook(reset=True).
Removing stale pidfile /home/jaap/.sage/sage_notebook/twistd.pd
2008-04-15 19:54:17+0200 [-] Log opened.
2008-04-15 19:54:17+0200 [-] twistd 8.0.1 (/home/jaap/downloads/sage-3.0.alpha5/local/bin/python 2.5.1) starting up
2008-04-15 19:54:17+0200 [-] reactor class: <class 'twisted.internet.selectreactor.SelectReactor'>
2008-04-15 19:54:17+0200 [-] twisted.web2.channel.http.HTTPFactory starting on 8001
2008-04-15 19:54:17+0200 [-] Starting factory <twisted.web2.channel.http.HTTPFactory instance at 0xa6cdc4c>
2008-04-15 19:55:24+0200 [HTTPChannel,3,127.0.0.1] /home/jaap/downloads/sage-3.0.alpha5/local/lib/python2.5/site-packages/twisted/internet/defer.py:262: exceptions.DeprecationWarning: Don't pass strings (like 'Bad token') to failure.Failure (replacing with a DefaultException).
2008-04-15 19:55:24+0200 [HTTPChannel,3,127.0.0.1] Exception rendering:
2008-04-15 19:55:24+0200 [HTTPChannel,3,127.0.0.1] Unhandled Error
        Traceback (most recent call last):
        Failure: twisted.python.failure.DefaultException: Bad token


}}

Jaap

Change History (15)

comment:1 follow-up: Changed 11 years ago by mabshoff

Well, there already seems to be a notebook running on port 8000, so could that have something to do with that? Can you check and report back?

Do we support more than one notebook running from the same Sage instance?

Cheers,

Michael

comment:2 in reply to: ↑ 1 Changed 11 years ago by jsp

Replying to mabshoff:

Well, there already seems to be a notebook running on port 8000, so could that have something to do with that? Can you check and report back?

No, this is not the case. No notebook on port 8000.

Do we support more than one notebook running from the same Sage instance?

I don't think so. I would love to have the possibility to run more notebooks from different versions of sage!

Jaap

Cheers,

Michael

comment:3 Changed 11 years ago by was

Neither tom nor I can replicate this.

Could you try with a fresh NOTEBOOK directory? E.g.,

sage: notebook(directory = 'foo')

william

comment:4 Changed 11 years ago by jsp

Let me tell what I did a few minutes ago.

I created a worksheet 'test' with sage-2.11, saved it and quit.

Started the notebook under sage-3.0.alpha5, selected 'test' and clicked on delete.

With the error mentioned above :(

Worksheets created with earlier versions and with alpha5 don't give this error!

Jaap

comment:5 Changed 11 years ago by jsp

Follow up: selecting an old ws and clicking on 'Archive' cased the same error here.

comment:6 follow-up: Changed 11 years ago by jsp

I reproduced this failure on a different machine Fedora 8, 32 bits with a ws made under sage-2.11. using Firefox-2.0.0.13.

Narrowing(?) this down: I get the same failure under sage-2.11 :(

Starting the notebook and selecting nothing(!) clicking on Archive or Delete gives the internal server error. Both on Fedora 7 and 8.

Jaap

comment:7 in reply to: ↑ 6 Changed 11 years ago by jsp

Replying to jsp:

I reproduced this failure on a different machine Fedora 8, 32 bits with a ws made under sage-2.11. using Firefox-2.0.0.13.

Narrowing(?) this down: I get the same failure under sage-2.11 :(

Starting the notebook and selecting nothing(!) clicking on Archive or Delete gives the internal server error. Both on Fedora 7 and 8.

Jaap

Even with sage-2.10.4, just clicking in the overview on Delete:

[jaap@paix sage-2.10.4]$ ./sage
----------------------------------------------------------------------
| SAGE Version 2.10.4, Release Date: 2008-03-16                      |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------


sage: notebook()
The notebook files are stored in: /home/jaap/.sage//sage_notebook
Port 8000 is already in use.
Trying next port...
****************************************************
*                                                  *
* Open your web browser to https://localhost:8001  *
*                                                  *
****************************************************
There is an admin account.  If you do not remember the password,
quit the notebook and type notebook(reset=True).
Removing stale pidfile /home/jaap/.sage/sage_notebook/twistd.pd
2008/04/17 23:11 +0200 [-] Log opened.
2008/04/17 23:11 +0200 [-] twistd 2.5.0 (/home/jaap/downloads/sage-2.10.4/local/bin/python 2.5.1) starting up
2008/04/17 23:11 +0200 [-] reactor class: <class 'twisted.internet.selectreactor.SelectReactor'>
2008/04/17 23:11 +0200 [-] Loading sage_notebook/twistedconf.tac...
2008/04/17 23:12 +0200 [-] Loaded.
2008/04/17 23:12 +0200 [-] twisted.web2.channel.http.HTTPFactory starting on 8001
2008/04/17 23:12 +0200 [-] Starting factory <twisted.web2.channel.http.HTTPFactory instance at 0x8b9082c>
2008/04/17 23:12 +0200 [HTTPChannel,1,127.0.0.1] /home/jaap/downloads/sage-2.10.4/local/lib/python2.5/site-packages/twisted/internet/defer.py:259: exceptions.DeprecationWarning: Don't pass strings (like 'Bad token') to failure.Failure (replacing with a DefaultException).
2008/04/17 23:12 +0200 [HTTPChannel,1,127.0.0.1] Exception rendering:
2008/04/17 23:12 +0200 [HTTPChannel,1,127.0.0.1] Unhandled Error
        Traceback (most recent call last):
        Failure: twisted.python.failure.DefaultException: Bad token




So I'm flabbergasted

Jaap

comment:8 Changed 11 years ago by jsp

This issue seems to be introduced with sage-2.10.1.

In sage-2.9 clicking on the Archive button gives a warning.

I put up some screen shots here: http://sage.math.washington.edu/home/jsp/screenshots/s1/

Jaap

comment:9 follow-up: Changed 11 years ago by mabshoff

  • Milestone changed from sage-3.0.1 to sage-3.0

Could this have something to do with encoding? Jaap: what is the locale you use?

Cheers,

Michael

comment:10 in reply to: ↑ 9 Changed 11 years ago by jsp

Replying to mabshoff:

Could this have something to do with encoding? Jaap: what is the locale you use?

Cheers,

Michael

Don't think so. My Fedora install is just English (American). I do not use any localization.

Jaap

comment:11 Changed 11 years ago by was

Can anybody but Jaap replicate this problem?

comment:12 Changed 11 years ago by was

  • Milestone changed from sage-3.0 to sage-3.0.1

comment:13 Changed 11 years ago by jsp

How about this:

William Stein wrote:
>
> 
> Please do
>    sage: hg_sage.pull()
> 
> then
> 
>    sage -br
> 
> and try that test again

Something strange was going on with the notebook(), but
after hg_sage.pull() and ./sage -br the notebook
starts in Firefox with still the problem I have reported in trac #2935.

But when I start firefox by hand:  https://localhost:8001/
everything seems to work!

Jaap


comment:14 Changed 11 years ago by jsp

Once again this is what I do now to avoid the error:

Start the notebook in sage-3.0.

Close the notebook tab in firefox.

Connect to https://localhost:8001/

Now I have a notebook running in which I can Archive en Delete worksheets.

Jaap

comment:15 Changed 11 years ago by was

  • Resolution set to invalid
  • Status changed from new to closed

Since nobody else can replicate this, and it could just be some weird cookie corruption on Jaap's computer (or a weird firefox bug), I'm closing this as invalid.

Note: See TracTickets for help on using tickets.