Opened 2 years ago

Closed 2 years ago

#29300 closed defect (fixed)

Latte test failure

Reported by: vbraun Owned by:
Priority: major Milestone: sage-9.1
Component: packages: optional Keywords: random_fail
Cc: slabbe, gh-kliem Merged in:
Authors: Sébastien Labbé Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 2f36788 (Commits, GitHub, GitLab) Commit: 2f36788f5606d6c325adf0dd46b019895b1d253d
Dependencies: #29200 Stopgaps:

Status badges

Description

I'm hitting this now, though there seems to be no change that caused it. Possibly random:

**********************************************************************
File "src/sage/interfaces/latte.py", line 70, in sage.interfaces.latte.count
Failed example:
    print(count(cddin, **opts))  # optional - latte_int
Expected:
    x[0]^2*x[1]^(-2)*x[2]^(-2)/((1-x[1])*(1-x[2])*(1-x[0]^(-1)))
     + x[0]^(-2)*x[1]^(-2)*x[2]^(-2)/((1-x[1])*(1-x[2])*(1-x[0]))
     + x[0]^2*x[1]^(-2)*x[2]^2/((1-x[1])*(1-x[0]^(-1))*(1-x[2]^(-1)))
     + x[0]^(-2)*x[1]^(-2)*x[2]^2/((1-x[1])*(1-x[0])*(1-x[2]^(-1)))
     + x[0]^2*x[1]^2*x[2]^(-2)/((1-x[2])*(1-x[0]^(-1))*(1-x[1]^(-1)))
     + x[0]^(-2)*x[1]^2*x[2]^(-2)/((1-x[2])*(1-x[0])*(1-x[1]^(-1)))
     + x[0]^2*x[1]^2*x[2]^2/((1-x[0]^(-1))*(1-x[1]^(-1))*(1-x[2]^(-1)))
     + x[0]^(-2)*x[1]^2*x[2]^2/((1-x[0])*(1-x[1]^(-1))*(1-x[2]^(-1)))
Got:
    x[0]^2*x[1]^(-2)*x[2]^(-2)/((1-x[1])*(1-x[2])*(1-x[0]^(-1)))
     + x[0]^(-2)*x[1]^(-2)*x[2]^(-2)/((1-x[1])*(1-x[2])*(1-x[0]))
     + x[0]^2*x[1]^(-2)*x[2]^2/((1-x[1])*(1-x[2]^(-1))*(1-x[0]^(-1)))
     + x[0]^(-2)*x[1]^(-2)*x[2]^2/((1-x[1])*(1-x[0])*(1-x[2]^(-1)))
     + x[0]^2*x[1]^2*x[2]^(-2)/((1-x[2])*(1-x[1]^(-1))*(1-x[0]^(-1)))
     + x[0]^(-2)*x[1]^2*x[2]^(-2)/((1-x[2])*(1-x[0])*(1-x[1]^(-1)))
     + x[0]^2*x[1]^2*x[2]^2/((1-x[2]^(-1))*(1-x[1]^(-1))*(1-x[0]^(-1)))
     + x[0]^(-2)*x[1]^2*x[2]^2/((1-x[0])*(1-x[2]^(-1))*(1-x[1]^(-1)))
    <BLANKLINE>
**********************************************************************
1 item had failures:
   1 of  19 in sage.interfaces.latte.count
    [58 tests, 1 failure, 0.80 s]
----------------------------------------------------------------------
sage -t --long src/sage/interfaces/latte.py  # 1 doctest failed
----------------------------------------------------------------------

Change History (5)

comment:1 Changed 2 years ago by slabbe

I confirm this issue was caused by #29200. Dilation of polytopes changed the ordering of their representation and few lines above in src/sage/interfaces/latte.py, the polytope is created by dilation:

   sage: P = 2 * polytopes.cube()
Last edited 2 years ago by slabbe (previous) (diff)

comment:2 Changed 2 years ago by slabbe

  • Authors set to Sébastien Labbé
  • Branch set to u/slabbe/29300
  • Commit set to 2f36788f5606d6c325adf0dd46b019895b1d253d
  • Dependencies set to 29200
  • Status changed from new to needs_review

New commits:

2f3678829300: fix latte doctest after #29200

comment:3 Changed 2 years ago by slabbe

  • Dependencies changed from 29200 to #29200

comment:4 Changed 2 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:5 Changed 2 years ago by vbraun

  • Branch changed from u/slabbe/29300 to 2f36788f5606d6c325adf0dd46b019895b1d253d
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.