#29197 closed defect (fixed)

mcqd needs an update of spkg-install

Reported by: dimpase Owned by:
Priority: critical Milestone: sage-9.1
Component: packages: optional Keywords:
Cc: dcoudert Merged in:
Authors: Dima Pasechnik Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 123fa16 (Commits, GitHub, GitLab) Commit: 123fa16ed135e6349f8605b19c43a281c07778cc
Dependencies: Stopgaps:

Status badges

Description

otherwise rebuilding Sage 9.1.beta4 with mcqd installed fails at it.

Change History (17)

comment:1 Changed 22 months ago by dcoudert

  • Cc dcoudert added

comment:2 Changed 22 months ago by dimpase

  • Authors set to Dima Pasechnik
  • Branch set to u/dimpase/packages/mcqdfix
  • Commit set to 6dbca5f8f94ac9e224c5a8343f6a1d979d00f6ee
  • Status changed from new to needs_review
  • Summary changed from mcqd needs legacy_uninstall, and an update of spkg-install to mcqd needs an update of spkg-install

please test on MacOS in particular

It would also be interesting to find out whether the new upstream gitlab repo for the package has any updates (and then we should apply thhem).

comment:3 Changed 22 months ago by dcoudert

I tried on my linux computer and it seems that it fixes the problem (compilation no longer complaining).

I tried on my macOS laptop, but I had to install mcqd first, so it's not a good test. Someone else should try, or tell me which sequence of operation I have to do.

comment:4 Changed 22 months ago by jhpalmieri

The branch doesn't touch any files related to mcqd. Am I missing something?

comment:5 Changed 22 months ago by dimpase

try cloning it. it seems that trac is confused.

comment:6 Changed 22 months ago by git

  • Commit changed from 6dbca5f8f94ac9e224c5a8343f6a1d979d00f6ee to 8151f552f1ff2d7020aa6b7f2c652e268b7443f6

Branch pushed to git repo; I updated commit sha1. New commits:

8151f55add -fPIC, update upstream website

comment:7 Changed 22 months ago by dimpase

oops, sorry. now the branch is right

comment:8 Changed 22 months ago by jhpalmieri

I can't reproduce any problem with OS X: I took 9.1.beta3, installed mcqd, then did git trac pull develop to get to 9.1.beta4. make succeeded.

make also succeeded with the branch here, and so did ./sage -f mcqd, so it didn't break anything. Is there any reason to bump up the package patch-level?

comment:9 Changed 22 months ago by dimpase

It could be that MacOS just doesn't need -fPIC.

While we're at it, it's good to understand whether mcqd was updated after out release. I'll take a look now.

comment:10 Changed 22 months ago by dimpase

no, it's the same, only README has changed (becoming README.md, and getting a bit longer).

comment:11 Changed 20 months ago by mkoeppe

  • Status changed from needs_review to needs_work

Error confirmed on debian-stretch-standard-python2 (https://github.com/mkoeppe/sage/runs/584777841)

Needs rebase.

comment:12 Changed 20 months ago by git

  • Commit changed from 8151f552f1ff2d7020aa6b7f2c652e268b7443f6 to 123fa16ed135e6349f8605b19c43a281c07778cc

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

123fa16add -fPIC, update upstream website

comment:13 Changed 20 months ago by dimpase

  • Status changed from needs_work to needs_review

comment:14 Changed 20 months ago by mkoeppe

Thanks! I'll test this

comment:15 Changed 20 months ago by mkoeppe

  • Reviewers set to Matthias Koeppe

comment:16 Changed 20 months ago by mkoeppe

  • Status changed from needs_review to positive_review

Installation seems to work well. https://github.com/mkoeppe/sage/runs/589959544

comment:17 Changed 20 months ago by vbraun

  • Branch changed from u/dimpase/packages/mcqdfix to 123fa16ed135e6349f8605b19c43a281c07778cc
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.