Changes between Version 29 and Version 30 of Ticket #29170


Ignore:
Timestamp:
03/22/20 17:11:39 (6 months ago)
Author:
dimpase
Comment:

ok, it works.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #29170

    • Property Status changed from needs_review to positive_review
    • Property Reviewers changed from to Dima Pasechnik
    • Property Summary changed from Fix R installation errors related to gfortran to Fix R installation errors related to gfortran, or downgrade R to "experimental"
  • Ticket #29170 – Description

    v29 v30  
    1 The R spkg does not build from source on many major platforms including ubuntu-bionic-minimal, ubuntu-eoan/focal-minimal, debian-buster/bullseye/sid-minimal, linuxmint-19.3-minimal, archlinux-latest-minimal.
    2 
    3 On these systems, we use a system gcc with our gfortran 9.2.0.
    4 
    51As reported
    62- for 9.0.rc1 in https://groups.google.com/d/msg/sage-release/YaedKjwMhzc/d44U0MM3BwAJ
     
    84- for 9.1.beta8 in https://groups.google.com/d/msg/sage-release/eMQIlhglN98/bTwDGD9HBQAJ
    95
    10 The present ticket works around a failure in R's configure script.
     6https://developer.r-project.org/Blog/public/2019/05/15/gfortran-issues-with-lapack/index.html
    117
    12 Related:
    13 - https://developer.r-project.org/Blog/public/2019/05/15/gfortran-issues-with-lapack/index.html
    14